Werte differenziert nach Monat zählen

Moderator: ModerationP

Werte differenziert nach Monat zählen

Beitragvon C98 » 27. Sep 2021, 11:37

Moin zusammen,

ich arbeite derzeit an einer Tabelle in der die Einträge in Spalte H zähle, die doppelten Werte allerdings dabei nicht mitzähle. Dies geschieht über die folgende Formel:

Code: Alles auswählen
=SUMMENPRODUKT(('Blatt 1'!H9:H1000<>"")/ZÄHLENWENN('Blatt 1'!H9:H1000;'Blatt 1'!H9:H1000&""))


Da ich nun allerdings gerne nach dem Monat differenzieren würde der in Spalte A steht ohne den Bereich auf jeden Monat einzeln anzupassen, wollte ich gerne fragen wie ich dies am besten in den Code mit einbaue, da ich selbst nicht weitergekommen bin.

Ich freue mich auf eure Rückmeldungen!

VG

C
C98
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 28
Registriert: 04. Feb 2021, 09:15

Re: Werte differenziert nach Monat zählen

Beitragvon GMG-CC » 27. Sep 2021, 11:46

Moin,
=> PivotTable?
Gruß
Günther (bekennender Power Query-Enthusiast) :!:

Excel-ist-sexy!
Wenn du keine Excel-Version angegeben hast, gehe ich von >=Excel 2016 aus.
Hilfe zur Selbsthilfe, nicht Komplettlösungen für den kommerziellen Einsatz und das "natürlich" gratis!
Benutzeravatar
GMG-CC
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 4902
Registriert: 12. Nov 2011, 23:17
Wohnort: Geesthacht bei Hamburg

Re: Werte differenziert nach Monat zählen

Beitragvon steve1da » 27. Sep 2021, 11:51

Hola,

schau mal hier:
https://www.herber.de/excelformeln/page ... ungen.html
Die Monatsbedingung wäre dann an Stelle von
Code: Alles auswählen
(A1:A10=4)
einfach
Code: Alles auswählen
(Monat(A1:A10)=1)
für den Januar zB.
Gruß,
steve1da
Benutzeravatar
steve1da
Moderator
 
Beiträge: 31670
Registriert: 24. Sep 2003, 10:54

Re: Werte differenziert nach Monat zählen

Beitragvon slowboarder » 27. Sep 2021, 12:00

HI
im Prinzip so.
ich gehe mal davon aus, das in Spalte A der Monat als Zahl von 1-12 bzw als echter Text mit Monatsnamen steht.

Code: Alles auswählen
=Summe(Wenn(A9:A1000="Januar";Wenn(H9:H1000<>"";1/ZählenWenns(A9:A1000;"Januar";H9:H1000;H9:H1000))))


in Excel älter 365 ist hier immer der Matrixformelabschluss erforderlich (STRG+SHIFT+ENTER)
wegen dem WENN auch bei der Verwendung von Summenprodukt.
das Wenn ist hier erforderlich, um den DIV/0-Fehler zu vermeiden.

wenn du die Auswertung wie bereits vorgeschlagen mit der PIVOT-Tabelle machen willst, musst du allerdings beim Erstellen der PIVOT den Haken bei "Dem Datenmodell diese Daten hinzufügen" setzen.
nur dann bekommst du die Auswerteoption "Diskrete Anzahl" (ganz unten) um Dupliaktfrei zählen zu können.

Gruß Daniel
slowboarder
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 28553
Registriert: 18. Apr 2009, 13:33

Re: Werte differenziert nach Monat zählen

Beitragvon C98 » 27. Sep 2021, 14:28

Moin zusammen,

vielen Dank für eure ganzen Rückmeldungen. Habe mich für die Version von Daniel entschieden, funktioniert perfekt! :)
C98
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 28
Registriert: 04. Feb 2021, 09:15


Zurück zu Excel Forum (provisorisch)

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste