Teilergebnis 109 nach Spalten

Moderator: ModerationP

Teilergebnis 109 nach Spalten

Beitragvon Gast » 24. Sep 2021, 15:22

Hallo Zusammen,

ich möchte ein Teilergebnis nach Spalten haben, hiervon werden immer wieder welche gruppiert und ausgeblendet.

Beispiel : Zeile 4 / Spalten A-M

=Teilergebnis(109;A4:M4)

Die Spalten A-D werden durch die Gruppierung ausgeblendet. Nun soll die Formel nur noch die Spalten E4-M$ addieren.
Nur leider klappt es horizontal nicht mit der Formel :(

Hat einer von Euch eine Idee ?

Gruß
Marco
Gast
 

Re: Teilergebnis 109 nach Spalten

Beitragvon Der Ratlose » 24. Sep 2021, 17:58

Hallo,

versuche mal diese Formel:

Code: Alles auswählen
=SUMME(INDIREKT(LINKS(TEIL(INFO("Ursprung");4;9);3)&RECHTS(TEIL(INFO("Ursprung");4;9);1)+3):M4)



Bei Änderung des Bildschirmausschnittes muss man mit F9 eine Neuberechnung durchführen!!!


https://www.herber.de/excelformeln/page ... hnitt.html


Nachtrag: es geht auch kürzer:

Code: Alles auswählen
=SUMME(INDIREKT(TEIL(INFO("Ursprung");4;3)&4):M4)


Bei Änderung des Bildschirmausschnittes muss man mit F9 eine Neuberechnung durchführen!!!



Der Ratlose
Der Ratlose
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 250
Registriert: 03. Feb 2021, 23:20

Re: Teilergebnis 109 nach Spalten

Beitragvon Flotter Feger » 25. Sep 2021, 21:54

Hallo,

tolle Formel ... Info kannte ich bisher nicht ... Danke für's Zeigen.

Allerdings hat die Lösung einen riesen Nachteil.
Sind die Spalten A:D ausgeblendet und E ist die erste sichtbare Spalte im Tabellenbereich, rechnet die Formel korrekt.
Scrollt man aber weiter nach rechts, und F ist die erste Spalte, die am linken Rand sichtbar ist, beginnt der Summenbereich erst da.
Es wird also nur F4:M4 berechnet und nicht E4:M4, wie eigentlich gedacht.
Außerdem funktioniert die Formel nicht mit gruppierten Spalten, wie es der TO erwähnt hat.
Und blendet man Zeile 4 aus, wird munter weiter berechnet, obwohl das Ergebnis eigentlich 0 sein müsste.

Eine andere Formellösung, habe ich aber auch nicht. Nur etwas per UDF ... also VBA ... und es ist auch nicht von mir.
Code: Alles auswählen
Function XSUMME(WorkRng As Range) As Double
'Update 20130907 SumVisible - Kutools für Excel
'https://de.extendoffice.com
Dim rng As Range
Dim total As Double
Application.Volatile
For Each rng In WorkRng
    If rng.Rows.Hidden = False And rng.Columns.Hidden = False Then
        total = total + rng.Value
    End If
Next
XSUMME = total
End Function

Formel: =XSUMME(A4:M4)
Auch hier nach händischem Ausblenden/Änderung der Spalten die F9 Taste drücken.
Änderungen durch Gruppierungen, berechnet die Formel eigenständig.

Sabina
Benutzeravatar
Flotter Feger
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 3259
Registriert: 24. Okt 2016, 16:40

Re: Teilergebnis 109 nach Spalten

Beitragvon {Boris} » 26. Sep 2021, 09:06

Hi,

ohne VBA gibt es noch den Workaround, die Spalten mit ZELLE("Breite"...) zu prüfen.
Schreibe dazu in eine freie Zeile der Spalte A (in meinem Beispiel: Zeile 3) die Formel

=ZELLE("Breite";A4)>0

und kopier sie rüber bis Spalte M.

Die dazugehörige Summenformel lautet dann:

=SUMMEWENN(A3:M3;WAHR;A4:M4)

Nachteil: Das reine Ausblenden der Spalten löst keine Neuberechnung der Formel aus. Diese muss mit F9 manuell angestoßen werden.
Grüße Boris
Benutzeravatar
{Boris}
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 1662
Registriert: 14. Okt 2007, 10:16
Wohnort: Düsseldorf

Re: Teilergebnis 109 nach Spalten

Beitragvon Gast » 26. Sep 2021, 10:15

@Boris:
DEG Metro Stars?
Gast
 

Re: Teilergebnis 109 nach Spalten

Beitragvon {Boris} » 26. Sep 2021, 13:30

@Boris:
DEG Metro Stars?


?!?
Grüße Boris
Benutzeravatar
{Boris}
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 1662
Registriert: 14. Okt 2007, 10:16
Wohnort: Düsseldorf


Zurück zu Excel Forum (provisorisch)

Wer ist online?

Mitglieder in diesem Forum: DaPeif und 17 Gäste