sverweis Probleme

Moderator: ModerationP

sverweis Probleme

Beitragvon Jo.Ba » 15. Sep 2021, 00:52

Hallo,

ich habe mir eine Datei gebastelt und möchte es per sverweis sie noch weiter bearbeiten.

Doch es funktioniert so wie ich es möchte.
In den Zellen B104, B105, B106, schreibe ich die vorgaben, doch es wird vermischt.

Formel Beispiel: =SVERWEIS($B104;$B$3:$I$100;2;WAHR)

Kann es sich jemand ansehe, und schauen was ich falsch gemacht habe.

Danke
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Jo.Ba
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 31
Registriert: 12. Mai 2015, 22:12

Re: sverweis Probleme

Beitragvon slowboarder » 15. Sep 2021, 00:55

Hi
Ich hab grad beim Öffen der Datei Probleme, aber ich vermute mal, die Liste ist nicht sortiert und du solltest FALSCH statt WAHR verwenden.

Gruß Daniel
slowboarder
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 28452
Registriert: 18. Apr 2009, 13:33

Re: sverweis Probleme

Beitragvon shift-del » 15. Sep 2021, 01:17

Moin

Oder so:
Code: Alles auswählen
=FILTER(C3:I46;B3:B46=B104)
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Benutzeravatar
shift-del
Moderator
 
Beiträge: 21685
Registriert: 25. Jan 2009, 22:54
Wohnort: Ehemaliges Fabrikgelände

Re: sverweis Probleme

Beitragvon HKindler » 15. Sep 2021, 08:28

Hi,

FILTER() ist mit Sicherheit die schönste Lösung. Und die Vermutung von Daniel ist korrekt. Aber ich würde hier keinen SVERWEIS verwenden, da du Werte aus 7 Spalten holen willst. Daher wäre es besser in einer Hilfszellen mit VERGLEICH die Zeile zu ermitteln und dann die Daten mit INDEX zu holen:
A104: =VERGLEICH($B104;$B$3:$B$100;0)
C104: =INDEX(C$3:C$100;$A104)

Die Formeln kannst du so beliebig ziehen (also A nach unten und C nach rechts und unten).
Gruß,
Helmut

----------------------------
Windows 10 Enterprise (64 Bit) / Office 365 ProPlus (32 Bit)
Benutzeravatar
HKindler
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 6308
Registriert: 04. Jul 2013, 09:02
Wohnort: Schwarzwald

Re: sverweis Probleme

Beitragvon Jo.Ba » 15. Sep 2021, 11:18

shift-del hat geschrieben:Moin

Oder so:
Code: Alles auswählen
=FILTER(C3:I46;B3:B46=B104)


ich bekomme bei diese Formel eine Fehlermeldung "Diese Funktion ist ungültig"
Hat es vielleicht mit meine Office Version zu tun? Ich habe MS Office Pro Plus 2019
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Jo.Ba
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 31
Registriert: 12. Mai 2015, 22:12

Re: sverweis Probleme

Beitragvon steve1da » 15. Sep 2021, 11:23

FILTER() gibt es erst am Excel365.
Aber die Lösung steht ja schon hier im Thread (und übrigens bekommt man die Lösung auch, wenn man den Betreff einfach mal googlet).
Benutzeravatar
steve1da
Moderator
 
Beiträge: 31562
Registriert: 24. Sep 2003, 10:54

Re: sverweis Probleme

Beitragvon Jo.Ba » 15. Sep 2021, 11:42

slowboarder hat geschrieben:Hi
Ich hab grad beim Öffen der Datei Probleme, aber ich vermute mal, die Liste ist nicht sortiert und du solltest FALSCH statt WAHR verwenden.

Gruß Daniel



Danke, mit FALSCH funktioniert meine sverweis Formel
Jo.Ba
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 31
Registriert: 12. Mai 2015, 22:12

Re: sverweis Probleme

Beitragvon Jo.Ba » 15. Sep 2021, 11:44

HKindler hat geschrieben:Hi,

FILTER() ist mit Sicherheit die schönste Lösung. Und die Vermutung von Daniel ist korrekt. Aber ich würde hier keinen SVERWEIS verwenden, da du Werte aus 7 Spalten holen willst. Daher wäre es besser in einer Hilfszellen mit VERGLEICH die Zeile zu ermitteln und dann die Daten mit INDEX zu holen:
A104: =VERGLEICH($B104;$B$3:$B$100;0)
C104: =INDEX(C$3:C$100;$A104)

Die Formeln kannst du so beliebig ziehen (also A nach unten und C nach rechts und unten).


Danke, auch mit den Hilfszellen funktioniert es.

Verständnis frage: Was ist der Vorteil davon?
Zuletzt geändert von Jo.Ba am 15. Sep 2021, 11:46, insgesamt 1-mal geändert.
Jo.Ba
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 31
Registriert: 12. Mai 2015, 22:12

Re: sverweis Probleme

Beitragvon Jo.Ba » 15. Sep 2021, 11:45

steve1da hat geschrieben:FILTER() gibt es erst am Excel365.
Aber die Lösung steht ja schon hier im Thread (und übrigens bekommt man die Lösung auch, wenn man den Betreff einfach mal googlet).



Danke für den Hinweis, ich war diese am Testen.
Jo.Ba
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 31
Registriert: 12. Mai 2015, 22:12

Re: sverweis Probleme

Beitragvon slowboarder » 15. Sep 2021, 12:26

Jo.Ba hat geschrieben:Danke, auch mit den Hilfszellen funktioniert es.
Verständnis frage: Was ist der Vorteil davon?


Das benötigt weniger Rechenzeit.
a) Excel berechnet eine Formel dann neu, wenn sich ein Wert einer Zelle, den diese Formel verwendet, ändert.
Die Formel wird nicht neu berechnet, wenn ihr Ergebnis weiterverwendet wird.
b) Das Zeitaufwendige beim SVerweis ist die Suche nach dem Eintrag.
wenn du also zu einem Eintrag die nächsten sieben Spalten aus der Tabelle benötigst und du machst das mit sieben SVerweisen, muss Excel sieben mal suchen
machst du das mit der Hilfsspalte mit Vergleich und dann sieben Formeln mit Index und Referenz auf diese Hilfsspalte, muss nur die Formel mit Vergleich in der Hilfsspalte aktiv suchen, die restlichen sieben Formeln mit Index verwenden dann dieses Ergebnis und greifen direkt auf die Werte zu was ratzfatz geht.
Daher ist das mit der Hilfsspalte dann entsprechend schneller (bei sieben Spaltenwerten sieben mal)
Ist die zu durchsuchende Liste nur klein, ist das natürlich egal, aber wenn eine Liste mit mehreren tausend Einträgen unsortiert ist und du den SVerweis mit 4. Parameter = FALSCH anwenden musst, dann ist das deutlich spürbar.

Gruß Daniel
slowboarder
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 28452
Registriert: 18. Apr 2009, 13:33

Re: sverweis Probleme

Beitragvon HKindler » 15. Sep 2021, 12:44

Hi,

und ergänzend: du kannst die INDEX-Formel problemlos nach rechts ziehen, zumindest wenn du die $-Zeichen so wie oben setzt. Bei einer SVERWEIS-Formel wird es etwas umständlicher, zumindest so, wie du sie verwendet hast: =SVERWEIS($B104;$B$3:$I$100;2;FALSCH) Hier muss beim Ziehen die 2 angepasst werden. Man könnte auch dies ziehbar machen: =SVERWEIS($B104;$B$3:$I$100;SPALTE(2:2);FALSCH)

Weiterer Vorteil von INDEX/VERGLEICH: Man kann auch Ergebnisse links von der Suchspalte zurück geben oder auch immer z.B. 2 Zeilen tiefer. Man ist einfach flexibler.
Gruß,
Helmut

----------------------------
Windows 10 Enterprise (64 Bit) / Office 365 ProPlus (32 Bit)
Benutzeravatar
HKindler
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 6308
Registriert: 04. Jul 2013, 09:02
Wohnort: Schwarzwald


Zurück zu Excel Forum (provisorisch)

Wer ist online?

Mitglieder in diesem Forum: daNorbert, Excelneuling83 und 33 Gäste