Seite 1 von 1

SVERWEIS in Wertgruppen

BeitragVerfasst: 14. Sep 2021, 11:13
von Tolados
Hallo zusammen,

ich stehe gerade etwas auf dem Schlauch. Ich habe eine Liste
Wertgruppe Preis
bis 25.000 € 300,00 €
bis 50.000 € 400,00 €
bis 75.000 € 500,00 €
bis 100.000 € 650,00 €

nun möchte ich in einer Formel, wenn ich z.B. 25.500 € eingebe, dass dann als Ergebnis 400 € und nicht 300 € zurückgegeben wird.
Geht das mit Bordmitteln oder brauche ich dafür VBA?

Vielen Dank schonmal vorab!

Re: SVERWEIS in Wertgruppen

BeitragVerfasst: 14. Sep 2021, 11:22
von Boris71
Hi,

änder die Wertgruppen in ab

Also A1:B5:

Code: Alles auswählen
Ab      Preis
0       300
25001   400
50001   500
75001   650


Dazu Suchwert in E2:

=SVERWEIS(E2;A2:B5;2)

VG, Boris

Re: SVERWEIS in Wertgruppen

BeitragVerfasst: 14. Sep 2021, 11:23
von slowboarder
Hi

Das geht problemlos mit dem SVerweis mit 4. Parameter = Wahr.
Allerdings müssen in der ersten Spalte nicht die BIS-Werte stehen, sondern die AB-Werte, also immer der kleinste Wert, ab dem diese Zeile als Ergebnis verwendet werden soll:

00.001 | 300
25.001 | 400
50.001 | 500

Usw.

Re: SVERWEIS in Wertgruppen

BeitragVerfasst: 14. Sep 2021, 11:56
von Tolados
ohje, was bin ich doch für ein Schaf.... da hätte ich auch mal selbst drauf kommen können.
Vielen Dank Euch beiden!