Kürzere/ optimiertere Formel möglich?

Moderator: ModerationP

Kürzere/ optimiertere Formel möglich?

Beitragvon sven8219 » 13. Sep 2021, 10:13

Hallo zusammen,

ich habe eine Auswertung in der in Spalte D der Name mit B4 übereinstimmen soll zudem muss in Spalte A das Datum mit E3 stimmen und dann kommt der Knackpunkt.
Es muss noch Spalte M geprüft werden ob der Text "ok" oder "nok" beinhaltet und entsprechend eine 1 oder eine 0 ausgeben. Ist gar kein Wert vorhanden soll es leer bleiben.
Ich habe das über eine große WENN Formel gelöst, suche aber etwas kürzeres, da es eine große Datenbank ist. Vielleicht hab ihr ja eine gute Alternative :)

Code: Alles auswählen
=WENN(ZÄHLENWENNS(Testergebnisse!$D:$D;LINKS($B$4;FINDEN(",";$B$4)-1);Testergebnisse!$A:$A;E3;Testergebnisse!$M:$M;"ok");1;WENN(ZÄHLENWENNS(Testergebnisse!$D:$D;LINKS($B$4;FINDEN(",";$B$4)-1);Testergebnisse!$A:$A;E3;Testergebnisse!$M:$M;"nok");0;""))


Danke euch


Gruß
Sven
Gruß
Sven
sven8219
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 199
Registriert: 12. Nov 2011, 20:21

Re: Kürzere/ optimiertere Formel möglich?

Beitragvon Der Steuerfuzzi » 13. Sep 2021, 10:54

Hallo,

eine Beispieldatei wäre hilfreich.
Viele Grüße
Michael
Benutzeravatar
Der Steuerfuzzi
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 3920
Registriert: 25. Mär 2013, 13:28

Re: Kürzere/ optimiertere Formel möglich?

Beitragvon slowboarder » 13. Sep 2021, 12:06

Hi
als Formel etwas kürzer, aber obs wirklich weniger Rechenaufwand bedeutet, weiß ich nicht:

=WAHL(1+SUMMENPRODUKT((ZÄHLENWENNS(Testergebnisse!$D:$D;LINKS($B$4;FINDEN(",";$B$4)-1);Testergebnisse!$A:$A;E3;Testergebnisse!$M:$M;{"ok";"nok"})>0)*{1;2});"";1;0;"beides")

ist denn die Kombination aus Datum und Name eindeutig?
oder kann das mehrfach vorkommen, so das "ok" und "nok" gleichzeitig vorkommen können?

Gruß Daniel
slowboarder
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 28453
Registriert: 18. Apr 2009, 13:33

Re: Kürzere/ optimiertere Formel möglich?

Beitragvon sven8219 » 13. Sep 2021, 12:14

Hallo Daniel,

es gibt IMMER nur eines der drei Optionen:
ok, nok oder der Name Name taucht nicht auf, dann leer.
Gruß
Sven
sven8219
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 199
Registriert: 12. Nov 2011, 20:21

Re: Kürzere/ optimiertere Formel möglich?

Beitragvon slowboarder » 13. Sep 2021, 12:22

ok, wenn das nicht vorkommt, kannst du meine Formel verwenden.
falls es doch mal passiert, bekommst du einen entsprechenden Hinweis.
Gruß Daniel
slowboarder
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 28453
Registriert: 18. Apr 2009, 13:33


Zurück zu Excel Forum (provisorisch)

Wer ist online?

Mitglieder in diesem Forum: Klaus-Dieter und 20 Gäste