Index; Zählenwenn; Vergleich

Moderator: ModerationP

Index; Zählenwenn; Vergleich

Beitragvon EChaos » 18. Okt 2021, 16:01

Hallo liebe Community,

ich habe hier schon sehr oft die beste Lösung für mein Problem gefunden. Aber nun komme ich einfach nicht mehr weiter und die stundenlange Suche hat mich nichts außer Zeit und Nerven gekostet :D
Oder ich stehe einfach nur auf dem Schlauch :(

Folgende Herausforderung:
Sobald ein Name auftaucht soll in der Zelle die Anzahl der Einträge zum Namen >0 stehen!
Zufrieden bin ich schon, wenn es das Ergebnis aus der ersten Tabelle ausgibt. Glücklicher wäre ich, wenn es aus beiden Tabellen das Ergebnis ausgeben könnte ohne die Zwischensumme zu berücksichtigen :)

s. Anhang

Vielen Dank für eure Hilfe!

Gruss EChaos
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
EChaos
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 5
Registriert: 18. Okt 2021, 15:43

Re: Index; Zählenwenn; Vergleich

Beitragvon Der Ratlose » 18. Okt 2021, 17:40

Hallo,

in I2

Code: Alles auswählen
=ZÄHLENWENN(B2:B12;">0")-1




Der Ratlose
Der Ratlose
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 275
Registriert: 03. Feb 2021, 23:20

Re: Index; Zählenwenn; Vergleich

Beitragvon EChaos » 18. Okt 2021, 18:23

Danke, das ist nicht was ich suche und die Zwischensumme in Zeile 7 wird damit mitgezählt.
EChaos
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 5
Registriert: 18. Okt 2021, 15:43

Re: Index; Zählenwenn; Vergleich

Beitragvon Der Ratlose » 18. Okt 2021, 18:31

Hier ohne B7...


Code: Alles auswählen
=ZÄHLENWENN(B2:B6;">0") + ZÄHLENWENN(B8:B12;">0")




Der Ratlose
Der Ratlose
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 275
Registriert: 03. Feb 2021, 23:20

Re: Index; Zählenwenn; Vergleich

Beitragvon Der Ratlose » 18. Okt 2021, 18:33

Danke, das ist nicht was ich suche und die Zwischensumme in Zeile 7 wird damit mitgezählt.



Durch -1 wird die Zeile 7 wieder abgezogen...



Der Ratlose
Der Ratlose
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 275
Registriert: 03. Feb 2021, 23:20

Re: Index; Zählenwenn; Vergleich

Beitragvon EChaos » 18. Okt 2021, 19:06

Hi Der Ratlose,

das liegt dem schon Nahe. Die Namen sind aber nicht fix. Bedeutet, wenn ich in H1 den Namen auf Name 2 ändere soll er mir das Ergebnis aus der Spalte C ausgeben.
Kannst du mir hier ein Tipp geben?

Vielen Dank :)
EChaos
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 5
Registriert: 18. Okt 2021, 15:43

Re: Index; Zählenwenn; Vergleich

Beitragvon Der Ratlose » 18. Okt 2021, 22:19

Hallo,

dann versuche mal diese Formel...

Code: Alles auswählen
=SUMME((B2:D12>0)*(B1:D1=H2))-1



Auch hier wird wieder Zeile 7 mitgezählt und anschließend abgezogen...



Der Ratlose
Der Ratlose
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 275
Registriert: 03. Feb 2021, 23:20

Re: Index; Zählenwenn; Vergleich

Beitragvon shift-del » 18. Okt 2021, 22:23

Moin

Code: Alles auswählen
=ZÄHLENWENN(INDEX($B$2:$D$13;0;VERGLEICH(H2;$B$1:$D$1;0));">0")-2

Index: Check!
Zählenwenn: Check!
Vergleich: Check!


Warum verwendest du nicht eine vernünftige Datenstruktur ohne Kreuztabelle und Zwischensummen?
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Benutzeravatar
shift-del
Moderator
 
Beiträge: 21712
Registriert: 25. Jan 2009, 22:54
Wohnort: Ehemaliges Fabrikgelände

Re: Index; Zählenwenn; Vergleich

Beitragvon GMG-CC » 18. Okt 2021, 22:41

Moin,
wenn es immer 6er-Blöcke sind ist das ganz gut handelbar…
Gruß
Günther (bekennender Power Query-Enthusiast) :!:

Excel-ist-sexy!
Wenn du keine Excel-Version angegeben hast, gehe ich von >=Excel 2016 aus.
Hilfe zur Selbsthilfe, nicht Komplettlösungen für den kommerziellen Einsatz und das "natürlich" gratis!
Benutzeravatar
GMG-CC
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 4902
Registriert: 12. Nov 2011, 23:17
Wohnort: Geesthacht bei Hamburg

Re: Index; Zählenwenn; Vergleich

Beitragvon EChaos » 19. Okt 2021, 10:03

Perfekt shift-del, genau das habe ich gesucht. Im Moment kann ich damit weiterarbeiten - VIELEN DANK!

Danke auch an alle anderen - Super Forum!
EChaos
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 5
Registriert: 18. Okt 2021, 15:43

Re: Index; Zählenwenn; Vergleich

Beitragvon slowboarder » 19. Okt 2021, 11:03

Hi

Andere Variante:
Wenn die Zwischensummen nur für die Anzeige benötigt werden, dann gib diese als Text aus :
In B7 und den anderen Zwischenzeiten: =Summe(B2:B6)&""
Das ZählennWenn mit ">0" ignoriert dann diese Texte.
Die passende Spalte dann wie schon gezeigt mit Index und Vergleich:
I2: =ZÄHLENWENN(INDEX($B:$D;0;VERGLEICH(H2;$B$1:$D$1;0));">0")

Noch ne Variante um die ZwischenZeilen auszuschließen:
Normalerweise ist ja auch die Spalte A mit Texten gefüllt und da steht dann sowas drin wie "Zwischenergebnis"
Je nachdem was da drin steht, könntes du dann über ZählenWenns diese Zeilen ignorieren.
I2: =ZÄHLENWENNS($A:$A;"<>Zwischen*";INDEX($B:$D;0;VERGLEICH(H2;$B$1:$D$1;0));">0")

Alles zu zählen was größer 0 ist und dann pauschal die Anzahl der Zwischenzeiten abzuziehen, halte ich für gefährlich. Das führt zu einem falschen Ergebnis, wenn mal in einem Block alle Werte 0 sind. Dann wäre auch die Zwischensumme 0 und würde nicht gezählt.

Gruß Daniel
slowboarder
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 28553
Registriert: 18. Apr 2009, 13:33

Re: Index; Zählenwenn; Vergleich

Beitragvon PIVPQ » 19. Okt 2021, 18:46

Hallo

Noch eine Alternativ Variante ohne Formel mit PQ
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Viele Grüße
PIVPQ
PIVPQ
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 133
Registriert: 19. Dez 2020, 15:11

Re: Index; Zählenwenn; Vergleich

Beitragvon Der Ratlose » 19. Okt 2021, 18:59

Hallo

Noch eine Alternativ Variante ohne Formel mit PQ


Kannst du bitte den Unsinn mit "ohne Formel mit PQ" lassen???

Oder willst du wirklich behaupten, das

Code: Alles auswählen
= Excel.CurrentWorkbook(){[Name="Tabelle1"]}[Content]

Code: Alles auswählen
= Table.SelectRows(Source, each ([Spalte1] = null))

Code: Alles auswählen
= Table.RemoveColumns(#"Filtered Rows",{"Spalte1", "Name 1", "Name 3"})

Code: Alles auswählen
= Table.AddColumn(#"Removed Columns", "Benutzerdefiniert", each if [Name 2] <> 0 then 1 else null)

Code: Alles auswählen
= List.Sum(#"Added Conditional Column"[Benutzerdefiniert])

Code: Alles auswählen
= #table(1, {{#"Calculated Sum"}})

Code: Alles auswählen
= Table.RenameColumns(#"Converted to Table",{{"Column1", "Name 2"}})

Code: Alles auswählen
= Table.UnpivotOtherColumns(#"Renamed Columns", {}, "Attribut", "Wert")


das keine Formeln sind???


Der Ratlose,

das liegt dem schon Nahe. Die Namen sind aber nicht fix. Bedeutet, wenn ich in H1 den Namen auf Name 2 ändere soll er mir das Ergebnis aus der Spalte C ausgeben.
Kannst du mir hier ein Tipp geben?

Vielen Dank :)




Wo kann er das bei dir ändern???



Der Ratlose
Der Ratlose
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 275
Registriert: 03. Feb 2021, 23:20

Re: Index; Zählenwenn; Vergleich

Beitragvon DerHoepp » 19. Okt 2021, 19:50

Moin,
ich war zwar nicht direkt angesprochen, aber:
Der Ratlose hat geschrieben:das keine Formeln sind???

Ja. PowerQuery M ist eine eigene Sprache und hat mit Formeln eher nix zu tun. Das Konzept ist grundlegend anders. Es geht darum Daten zu Extrahieren, in eine ordentliche Form Überzuleiten um diese danach in Excel zu laden.
Der Ratlose hat geschrieben:Wo kann er das bei dir ändern???

Indem er statt Table.RemoveColumns Table.SelectColumns mit der beizubehaltenden Spalte verwendet.

Viele Grüße
derHöpp
DerHoepp
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 9841
Registriert: 14. Mai 2013, 11:08

Re: Index; Zählenwenn; Vergleich

Beitragvon Der Ratlose » 19. Okt 2021, 20:14

Hallo,

eine ordentliche Form Überzuleiten


um nicht das "böse" Wort >>Formel<< zu verwenden.... nur, wenn man die Formel nicht händisch eingibt, heißt es nicht, das es keine Formel ist...


beizubehaltenden Spalte verwendet


dann kann er auch gleich die Daten so stehen lassen und nicht erst noch ändern...



Der Ratlose
Der Ratlose
Im Profil kannst Du frei den Rang ändern
 
Beiträge: 275
Registriert: 03. Feb 2021, 23:20

Nächste

Zurück zu Excel Forum (provisorisch)

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 33 Gäste