Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Die Suche hat 2194 Ergebnisse ergeben.
Seite 89 von 147 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7 ... 86, 87, 88, 89, 90, 91, 92 ... 141, 142, 143, 144, 145, 146, 147  Weiter
Index
Autor Nachricht
  Thema: Problem mit Makro Code ? Blinkende Zeile 
werni

Antworten: 2
Aufrufe: 171

BeitragForum: Excel Hilfe   Verfasst am: 21. Mai 2011, 20:53   Titel: AW: Problem mit Makro Code ? Blinkende Zeile Version: Office 2007
Hallo Wind

Versuch es mal mit diesen Codes und der Bedingten Formatierung.

Microsoft Excel Objekt DieseArbeitsmappeOption Explicit Private Sub Workbook_Activate() Start End Sub Private Sub Workbook_BeforeClose(Cancel As Boolean) Stoppen End Sub Private Sub Workbook_Deactivate() Stoppen End Sub Code eingefügt mit

Modul TaktgeberOption Explicit Private UhrAktiv As Boolean Dim lngI As Long Public Sub Start() UhrAktiv = True MSchleife End Sub Public Sub MSchleife() Code eingefügt mit

Arbeitsblatt mit dem Namen 'Tabelle1' ABCDEFGHIJ1Z32xxxxxxxxyyyyyyyzzzz6   2A31xxxxxxxxyyyyyyyzzzz3   3B11xxxxxxxxyyyyyyyzzzz1   4C11xxxxxxxxyyyyyyyzzzz1   5D13xxxxxxxxyyyyyyyzzzz3   6E20xxxxxxxxyyyyyyyzzzz0   7F31xxxxxxxxyyyyyyyzzzz3   8G39xxxxxxxxyyyyyyyzzzz27   9H47xxxxxxxxyyyyyyyzzzz28   10I58xxxxxxxxyyyyyyyzzzz40   ZelleFormelG1=B1*C1G2=B2*C2G3=B3*C3G4=B4*C4G5=B5*C ...
  Thema: mischen von zahlen/buchstaben in argumenten 
werni

Antworten: 14
Aufrufe: 760

BeitragForum: Excel Formate   Verfasst am: 21. Mai 2011, 15:36   Titel: AW: mischen von zahlen/buchstaben in argumenten Version: Office 2003
Hallo Dennis

Stimmt. Sad
Habe gerade noch festgestellt, dass in meiner Formel noch ein Schreibfehler steckt, was bei deiner Formel nicht passieren kann. Habe 317 anstatt 173 geschrieben.

Dann ist deine auch viel kürzer.

Gruss werni
  Thema: Text in Textfeld bei Überschneidung ausblenden 
werni

Antworten: 1
Aufrufe: 389

BeitragForum: Excel Hilfe   Verfasst am: 21. Mai 2011, 14:17   Titel: AW: Text in Textfeld bei Überschneidung ausblenden Version: Office 2007
Hallo Nooky

In den Eigeschaften des Textfeldes:
MaxLength (die Anzahl Zeichen eingeben)

z.B. MaxLength 10 (es können nicht mehr als 10 Zeichen eingegeben werden)

Gruss werni
  Thema: mischen von zahlen/buchstaben in argumenten 
werni

Antworten: 14
Aufrufe: 760

BeitragForum: Excel Formate   Verfasst am: 21. Mai 2011, 14:03   Titel: AW: mischen von zahlen/buchstaben in argumenten Version: Office 2003
Hallo Max

In hundert Jahren hast du das auch gelernt. Razz

Gruss werni
  Thema: Sicherungskopie bestimmter Tabellen... 
werni

Antworten: 13
Aufrufe: 169

BeitragForum: Excel VBA (Makros)   Verfasst am: 21. Mai 2011, 14:00   Titel: AW: Sicherungskopie bestimmter Tabellen... Version: Office 2003
Hallo Matthi

Wo speicherst du die Kopie hin? In dasselbe Verzeichnis wie die Datei, aus der du kopierst? Was hast du denn unter xPfad eingegeben? Stimmen die Verzeichnisse? Hast du auch am ende von xPfad auch einen Backslash eingegeben?

Meine Glaskugel ist in der Reinigung, darum kann ich nicht auf deinen PC schauen. Razz

Gruss werni
  Thema: mischen von zahlen/buchstaben in argumenten 
werni

Antworten: 14
Aufrufe: 760

BeitragForum: Excel Formate   Verfasst am: 21. Mai 2011, 13:45   Titel: AW: mischen von zahlen/buchstaben in argumenten Version: Office 2003
Hallo Max

Diese Formel:

Arbeitsblatt mit dem Namen 'Tabelle1' B192052ZelleFormelB19=ZÄHLENWENN(B$5:B$18;"P")*188+ZÄHLENWENN(B$5:B$18;"M")*212+ZÄHLENWENN(B$5:B$18;"F")*317+ZÄHLENWENN(B$5:B$18;"C")*77+SUMME(B5:B18)Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Gruss werni
  Thema: Sicherungskopie bestimmter Tabellen... 
werni

Antworten: 13
Aufrufe: 169

BeitragForum: Excel VBA (Makros)   Verfasst am: 21. Mai 2011, 13:31   Titel: AW: Sicherungskopie bestimmter Tabellen... Version: Office 2003
Hallo Matthi

Natürlich geht das auch. Wenn nur eine Tabelle, dann ...
Sheets("Abrechnung").Copy

Wenn mehrere, dann ...
Sheets(Array("Abrechnung", "Statistik")).Copy

Tabellenname natürlich anpassen.

Sub SicherungsKopie()
xPfad = ActiveWorkbook.Path & "\Ablage\" 'Wohin speichern?
xDateiNam="SicherungsKopie.xls"
Sheets("Abrechnung").Copy ' Kopiert das Blatt (Blätter) in eine neue Arbeitsmappe
Application.DisplayAlerts = False
ActiveWorkbook.SaveAs Filename:=xPfad & xDateiNam
ActiveWindow.Close 'Schliesst die kopierte/gespeicherte Arbeitsmappe
End sub

Diesen Code kannst du z.B. anwenden beim schliessen der Datei, oder bevor speichern.

Anpassungen an dein System nicht vergessen!

Gruss werni
  Thema: Sicherungskopie bestimmter Tabellen... 
werni

Antworten: 13
Aufrufe: 169

BeitragForum: Excel VBA (Makros)   Verfasst am: 21. Mai 2011, 12:40   Titel: AW: Sicherungskopie bestimmter Tabellen... Version: Office 2003
Hallo Matthi

Gerade heute morgen ......

http://www.office-loesung.de/ftopic460618_0_0_asc.php

Gruss werni
  Thema: mischen von zahlen/buchstaben in argumenten 
werni

Antworten: 14
Aufrufe: 760

BeitragForum: Excel Formate   Verfasst am: 21. Mai 2011, 12:36   Titel: AW: mischen von zahlen/buchstaben in argumenten Version: Office 2003
Hallo mue

Ich weiss jetzt nicht ob dieses Resultat stimmt. Der letzte Summenprodukt-Abschnitt
rechnet die Menge von Spalte B mal die Menge von Spalte C.

In Zelle C19 steht dann diese Formel

Arbeitsblatt mit dem Namen 'Tabelle1' ABCD3PAYLOAD COMPUTATION4OccupantsWArmMoment/1005SEAT 1/PICP131246.286SEAT 2/SICP131246.287SEAT 3F202.51350.34238SEAT 4M202.51429.32129SEAT 5F260.5450.66510SEAT 6M260.5552.2611SEAT 7M295.5626.4612SEAT 8C295.5227.53513SEAT 9F323.79560.156714NOSE074015REAR5414.620.7316REF. CENTER4167.326.692817EVAPO. CAB.3156.294.688718RH CHART C.0150.91019PAYLOAD 5313.963721.4117ZelleFormelD5=WENN(B5="P";188)*C5/100D6=WENN(B6="P";188)*C6/100D7=WENN(B7="M";212;WENN(B7="F";173;WENN(B7="C";77)))*C7/100D8=WENN(B8="M";212;WENN(B8="F";173;WENN(B8="C";77)))*C8/100D9=WENN(B9="M";212;WENN(B9="F";173;WENN(B9="C";77)))*C9/100D10=WENN(B10="M";212;WENN(B10="F ...
  Thema: Excel-Datei ändern, speichern, sichern - alles in einem? 
werni

Antworten: 2
Aufrufe: 793

BeitragForum: Excel VBA (Makros)   Verfasst am: 21. Mai 2011, 07:37   Titel: AW: Excel-Datei ändern, speichern, sichern - alles in einem? Version: Office 2003
Hallo Klaus

sollte noch im Datei-Namen den Zusatz „….#0001“ bekommen
Dazu musst du auf einer Tabelle deiner Arbeitsmappe eine Zelle zur Verfügung stellen (weiter zählen), die nach jedem speichern um 1 erhöht wird. Diese Variante erstellt bei jedem speichern ein neue Arbeitsmappe. Also pro Tag 20 mal speichern ergibt pro Tag 20 Arbeitsmappen.

Variante 1:

Private Sub Workbook_BeforeSave(ByVal SaveAsUI As Boolean, Cancel As Boolean)
xName = Left(ActiveWorkbook.Name, Len(ActiveWorkbook.Name) - 4)
CopyPfad = "G:\Kopien\" 'Pfad und Ordner anpassen
CopyName = xName & " #" & Format(Tabelle1.

Du könntest auch den Zusatz, anstatt 00001 etc., mit Datum YYMMDD versehen. Dazu würde die Zelle zum weiter zählen wegfallen. Und es gäbe pro Tag nur noch 1 neue Arbeitsmappe.

Variante 2:

Private Sub Workbook_BeforeSave(ByVal SaveAsUI As Boolean, Cancel As Boolean)
xName = Left(ActiveWorkbook.Name, Len(ActiveWorkbook.Name) - 4)
CopyPf ...
  Thema: AVERAGE in Formel (vba) gibt Laufzeitfehler 1004 
werni

Antworten: 4
Aufrufe: 800

BeitragForum: Excel Hilfe   Verfasst am: 20. Mai 2011, 21:20   Titel: AW: AVERAGE in Formel (vba) gibt Laufzeitfehler 1004 Version: Office 2007
Hallo

Das stimmt. In der Formel brauchst du keinen Punkt vor Cells

Gruss werni
  Thema: AVERAGE in Formel (vba) gibt Laufzeitfehler 1004 
werni

Antworten: 4
Aufrufe: 800

BeitragForum: Excel Hilfe   Verfasst am: 20. Mai 2011, 21:13   Titel: AW: AVERAGE in Formel (vba) gibt Laufzeitfehler 1004 Version: Office 2007
Hallo Shane

Müsste das nicht so heissen? Könnte sein!

Cells(letztezeile, j + 28)

anstatt:
Cells(letztezeile, 28 + j)

Nimm auch den Punkt weg:
"=AVERAGE(.Range(.Cells(4, 28 + j), .Cells(letztezeile, 28 + j)))"

Gruss werni
  Thema: mischen von zahlen/buchstaben in argumenten 
werni

Antworten: 14
Aufrufe: 760

BeitragForum: Excel Formate   Verfasst am: 20. Mai 2011, 21:00   Titel: AW: mischen von zahlen/buchstaben in argumenten Version: Office 2003
Hallo mue

Ein Bild (*.jpg, -*.bmp etc.) ist nicht das wahre.

Entweder eine Tabelle.xls oder mit einer Tabellen Darstellung
http://www.office-loesung.de/ftopic383163

Ansonsten müssten die Helfer die Tabellen nachbauen was eigentlich niemand gerne macht.

Gruss werni
  Thema: mischen von zahlen/buchstaben in argumenten 
werni

Antworten: 14
Aufrufe: 760

BeitragForum: Excel Formate   Verfasst am: 20. Mai 2011, 19:10   Titel: AW: mischen von zahlen/buchstaben in argumenten Version: Office 2003
Hallo mue

Hilfe ist möglich, wenn genau definiert ist, was der Hilferufende wirklich möchte. Meistens ist es so, dass man zuerst mal beginnt zu rätseln, was, wie, wo und warum. Darum hilft meisten eine Arbeitsmappe, in der man den Aufbau und das Was-möchte-er-(sie)-den sehen und begreifen kann.

Aus deinem Beschrieb bin leider nicht schlau geworden.


Anleitung zum Hochladen von Dateien. (Anmeldung erforderlich)
http://www.office-loesung.de/ftopic126638

Tabellen im Forum darstellen:
http://www.office-loesung.de/ftopic383163

Gruss werni
  Thema: Namen(Hinterlegte Namen soll aus andere Zelle gezogen werden 
werni

Antworten: 8
Aufrufe: 260

BeitragForum: Excel Formeln   Verfasst am: 20. Mai 2011, 15:56   Titel: AW: Namen(Hinterlegte Namen soll aus andere Zelle gezogen we Version: Office 2003
Hallo Hadulla

Arbeitsblatt mit dem Namen 'Tabelle2' ABCD1Knoblauch10 12   23   34   4NameBezugKnoblauch=Tabelle2!$D$1:$D$4ZelleFormelB1=SUMME(INDIREKT(A1))Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Gruss werni
 
Seite 89 von 147 Gehe zu Seite Zurück  1, 2, 3, 4, 5, 6, 7 ... 86, 87, 88, 89, 90, 91, 92 ... 141, 142, 143, 144, 145, 146, 147  Weiter
Gehe zu:  
Alle Zeiten sind
GMT + 1 Stunde

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Excel-Formeln