Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Leere KK
zurück: Anzeigen einer Spalte von Bedingung abhängig machen!? weiter: 2 Spalten zusammenfassen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
retep
Kennst'n Wayne?


Verfasst am:
21. Jul 2006, 11:15
Rufname:
Wohnort: Inzwischen hier und da!

Leere KK - Leere KK

Nach oben
       

Hallo,

ich habe eine verknüpfte Excel Tabelle (tbl1) in Access angelegt und übertrage diese Daten bei Bedarf in eine extra Tabelle in Access (tbl2). In tbl1 und tbl2 befinden sich Spalten mit KK (Datentyp Ja/Nein).
In tbl1 werden die Werte, die in Excel "FALSCH" sind als "Nein" angezeigt. Bei den Zellen wo in Excel "WAHR" steht, bekomme ich in tbl1 "#Zahl!".

Das heisst in tbl2 habe ich nur leere KK! Woher kommt diese "#Zahl!" Angabe in der verknüpften Tabelle (tbl1)???
steffen0815
VBA-Programmierer


Verfasst am:
21. Jul 2006, 13:29
Rufname:


AW: Leere KK - AW: Leere KK

Nach oben
       

Hallo,
also vereinfacht gesagt erscheint in Access '#Zahl!', wenn Access den Wert nicht in den vorgegebenen Felddatentyp konvertieren kann. Welcher Felddatentyp vorgegeben wird entscheidet Access (und das oft falsch)

Was das Problem in deinem speziellen Fall ist, lässt sich aus der Ferne schwer beurteilen.
Als Erstes kannst du kontrollieren, ob in der verknüpften Tabelle die Spalte auch als "Ja/Nein" definiert ist.

Als Zweites würde ich mal versuchen eine AC-Tabelle mit "Ja/Nein"-Feldern nach Excel zu exportiren und dann mi AC zu verknüpfen.

_________________
Gruß Steffen
retep
Kennst'n Wayne?


Verfasst am:
24. Jul 2006, 09:48
Rufname:
Wohnort: Inzwischen hier und da!

AW: Leere KK - AW: Leere KK

Nach oben
       

Nun das Problem ist ja, dass der Feldtyp in der verknüpften Tabelle "Text" ist. Aber ich kann den auch nicht ändern, weil ich doch in einer verknüpften Tabelle keine Änderungen vornehmen kann?!

Da liegt wohl auch mein Problem!
jens05
Moderator


Verfasst am:
24. Jul 2006, 09:54
Rufname:
Wohnort: ~~~~~

AW: Leere KK - AW: Leere KK

Nach oben
       

Hallo,
schau mal, ob dir dieser Beitrag hilft. ACC: "#Zahl!" erscheint in eingebunden Excel Arbeitsblättern

_________________
mfg jens05 Wink
retep
Kennst'n Wayne?


Verfasst am:
26. Jul 2006, 08:05
Rufname:
Wohnort: Inzwischen hier und da!

AW: Leere KK - AW: Leere KK

Nach oben
       

Naja, leider hilft es nicht wirklich, denn der Beitrag handelt ja von gemischten Feldern. Bei mir ist ja das Problem, dass ich "WAHR" und "FALSCH" in Excel eintrage und lediglich möchte, dass KK mit bzw ohne Hacken in Access erscheinen!

Noch jemand eine Idee?
SGast
Gast


Verfasst am:
26. Jul 2006, 09:05
Rufname:

AW: Leere KK - AW: Leere KK

Nach oben
       

Hallo,
Steffen0815 hat folgendes geschrieben:
Als Zweites würde ich mal versuchen eine AC-Tabelle mit "Ja/Nein"-Feldern nach Excel zu exportieren und dann mi AC zu verknüpfen.
Du solltest die Ursache finden, warum die Excelspalte nicht als Ja/Nein - Feld angebunden ist.

Ich kann mir auch nicht so richtig vorstellen, das in einer als Text formatierten Spalte "'#Zahl!'" erscheint.

Gruß Steffen
retep
Kennst'n Wayne?


Verfasst am:
26. Jul 2006, 14:48
Rufname:
Wohnort: Inzwischen hier und da!

AW: Leere KK - AW: Leere KK

Nach oben
       

Also gut, in der verknüpften Tabelle steht jeweils "Wahr" bzw "Falsch" so wie in der original Excel-Tabelle!
Aber in der Access Tabelle in die die Daten der verknüpften Tabelle übertragen werden, bleiben alle KK leer!

Das wird wohl irgendwie damit zusammenhängen, dass in der verknüpften Tabelle der Feldtyp automatisch auf "Text" gestellt wird und in der anderen Access Tabelle ist dieses Feld "Ja/Nein" formatiert!!!

Soll heissen, diese "#Zahl!" Anzeige ist verschwunden, trotzdem sind die "wahren" Werte in den KK NICHT angehakt!
SGast
Gast


Verfasst am:
26. Jul 2006, 16:19
Rufname:


AW: Leere KK - AW: Leere KK

Nach oben
       

Hallo,
solang in der verknüpften Tabelle als Typ Text steht, wird es wohl nicht funktionieren.
Versuch doch die Exceltabelle nochmal neu zu verknüpfen.
Sollte wider Erwarten eine Verknüpfung nur über Text möglich sein, kann man beim Übertragen eine Umwandlung des Formates vornehmen:
Code:
INSERT INTO AccTab ( JaNeinFeld )
SELECT IIf([JaNeinFeld]="Wahr",True,False) AS Ausdr1
FROM   ExcelTab;

Gruß Steffen
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Access Tabellen & Abfragen: Leere Datensatzfelder machen Fehler beim zurücksetzen 9 Xia0 409 03. Dez 2009, 16:46
Xia0 Leere Datensatzfelder machen Fehler beim zurücksetzen
Keine neuen Beiträge Access Tabellen & Abfragen: Leere Felder mit Wert 0 befüllen, Aktualisierungsabfrage? 12 Gast 2043 01. Nov 2009, 14:43
RIGA Leere Felder mit Wert 0 befüllen, Aktualisierungsabfrage?
Keine neuen Beiträge Access Tabellen & Abfragen: leere Tabelle 44MB groß?! 4 Schokomonster 394 16. Okt 2009, 16:38
Schokomonster leere Tabelle 44MB groß?!
Keine neuen Beiträge Access Tabellen & Abfragen: Abfrage: leere Felder werden nicht angezeigt 2 Gast 908 25. März 2009, 18:25
Gast Abfrage: leere Felder werden nicht angezeigt
Keine neuen Beiträge Access Tabellen & Abfragen: Leere Felder mit ausgeben? 1 Gast 604 21. Feb 2009, 23:35
Thomas2007 Leere Felder mit ausgeben?
Keine neuen Beiträge Access Tabellen & Abfragen: Abfrageergebnis bezieht leere Zellen nicht mit ein 13 Grango 800 10. Dez 2008, 17:42
Willi Wipp Abfrageergebnis bezieht leere Zellen nicht mit ein
Keine neuen Beiträge Access Tabellen & Abfragen: Abfrage nach wenn Datumsfeld nur volle anzeigen leere nicht 3 adamth 1629 22. Jul 2008, 18:28
KlausMz Abfrage nach wenn Datumsfeld nur volle anzeigen leere nicht
Keine neuen Beiträge Access Tabellen & Abfragen: Kreutztabellenabfrage Leere Felder mit 0 füllen 4 Feuerpferd 3241 22. Apr 2008, 12:40
Feuerpferd Kreutztabellenabfrage Leere Felder mit 0 füllen
Keine neuen Beiträge Access Tabellen & Abfragen: leere Felder durch kleinsten Wert ersetzen 16 Kathrin_bcn 2823 03. März 2008, 18:06
Kathrin_bcn leere Felder durch kleinsten Wert ersetzen
Keine neuen Beiträge Access Tabellen & Abfragen: Leere Zellen anzeigen 2 Babsi_Acc 707 03. Aug 2007, 13:41
Willi Wipp Leere Zellen anzeigen
Keine neuen Beiträge Access Tabellen & Abfragen: Erstellen von Tabellen - Leere Zeichenfolge zulassen 7 M.o.C. 2859 17. Jul 2007, 00:27
Rhett Erstellen von Tabellen - Leere Zeichenfolge zulassen
Keine neuen Beiträge Access Tabellen & Abfragen: Abfrageverknüpfung verweist auf teils leere Felder 17 spidermanni 1854 16. Apr 2007, 17:27
spidermanni Abfrageverknüpfung verweist auf teils leere Felder
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Excel-Formeln