Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Kurtaxe berechnen unter Berücksichtigung der Saison
zurück: SVerweis mit mehreren Ausgabewerten? weiter: Dringend Hilfe... Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
KlausKraus
Gast


Verfasst am:
31. März 2006, 19:37
Rufname:

Kurtaxe berechnen unter Berücksichtigung der Saison - Kurtaxe berechnen unter Berücksichtigung der Saison

Nach oben
       

Hallo nochmals an die Genies unter Euch,

nach "meinem" Riesenerfolg von gerade, hier noch eine Herausforderung:

Für die Berechnung der Kurtaxe sind Saisonzeiten zu beachten - der Tagessatz kann also während des Urlaubs wechseln. Die Kurzaxe ist je Übernachtung zu zahlen (und nicht je Tag).

Hier ein Beispiel:

Preisliste:
Vom Bis Taxe
01.01.2006 14.05.2006 0,00 €
15.05.2006 14.06.2006 0,90 €
15.06.2006 31.08.2006 1,80 €
01.09.2006 15.09.2006 0,90 €
16.09.2006 31.12.2006 0,00 €

Mietzeitraum
10.06.2006 24.06.2006

Kurtaxe
21,60 € (4x0,90 + 10x1,80)

Wenn Ihr hier auch eine Lösung für mich parat habt, ist mein Wochenende geretten.

Nochmals vielen Dank für Eure Mühe!!!

Gruß
Klaus
ae
Mein Name ist Ente


Verfasst am:
31. März 2006, 20:23
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg


AW: Kurtaxe berechnen unter Berücksichtigung der Saison - AW: Kurtaxe berechnen unter Berücksichtigung der Saison

Nach oben
       

Hallo Klaus,
in der "Raucherpause" mal ein Ansatz zum weiter dran basteln

Ungetestet und einfach als Anregung

Tabelle3
 ABCDEF
10BisTaxe   
201.01.200614.05.20060  
315.05.200614.06.20060,9  
415.06.200631.08.20061,8  
501.09.200615.09.20060,9  
616.09.200631.12.20060  
7      
8      
9      
10  Hilfszelle 1Hilfszelle 2Hilfszelle 3 
11von10.06.20060,93,004,00        3,60 €
12bis24.06.20061,85,0010,00       18,00 €
13            21,60 €
Formeln der Tabelle
C11 : =SVERWEIS(B11;$A$1:$C$6;3)
D11 : =VERGLEICH(B11;$A$1:$A$6;1)
E11 : =ABS(B11-INDIREKT("b"&VERGLEICH(B11;$A$1:$A$6;1)))
F11 : =SVERWEIS(B11;$A$1:$C$6;3)*E11
C12 : =SVERWEIS(B12;$A$1:$C$6;3)
D12 : =VERGLEICH(B12;$A$1:$A$6;1)+1
E12 : =ABS(INDIREKT("a"&VERGLEICH(B12;$A$1:$A$6;1))-B12)+1
F12 : =SVERWEIS(B12;$A$1:$C$6;3)*E12
F13 : =SUMME(F11:F12)
 

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
ransi
Für den Hausgebrauch reicht's..


Verfasst am:
31. März 2006, 20:25
Rufname:
Wohnort: Im schönen Weserbergland

AW: Kurtaxe berechnen unter Berücksichtigung der Saison - AW: Kurtaxe berechnen unter Berücksichtigung der Saison

Nach oben
       

Hallo klaus

wenn du dich entschliessen könntest deine Liste anders aufzubauen wirds einfach:

 
 ABCDE
101.01.20060 von bis
202.01.20060 10.06.200624.06.2006
303.01.20060   
404.01.20060 21,60 € 
505.01.20060   
606.01.20060   
707.01.20060   
Formeln der Tabelle
D4 : =SUMMEWENN(A1:A365;">" &D2;B1:B365)-SUMMEWENN(A1:A365;">"&E2;B1:B365)
 


in A1:A365 stehen die Tage des Jahres und in B1:B365 die dazugehörigen Kurtaxen.


ransi
KlausKraus
Gast


Verfasst am:
01. Apr 2006, 11:50
Rufname:

AW: Kurtaxe berechnen unter Berücksichtigung der Saison - AW: Kurtaxe berechnen unter Berücksichtigung der Saison

Nach oben
       

Moin ransi,

Deine Lösung ist im Aufbau einfach und funktioniert auch. Dafür schon mal vielen herzlichen Dank.

Moin Ente,

Deine Lösung gefällt mir besser, da sie komprimierter und einfacher bei Änderungen anzupassen ist. Nur bekomme ich das leider nicht auf meine Tabelle übertragen.

Wenn ich Deine Tabelle 1:1 übernehme, klappt es. Die Daten sind bei mir aber in anderen Zellen (begint also nicht bei A1, da das bereits mit anderen Dingen belegt ist auf die von anderen Tabellen zugegriffen wird.).

Ich habe alles Mögliche versucht, kenne verstehe aber Deine Formeln nur zum Teil. Es wäre super, wenn Du mir folgendes beantworten kannst:

1. Was macht genau die Formel in E11; insb. was soll die Zeichenkette ("b"&VERGLEICH...

2. Mein Ergebnis in N10 ist 38808. Wieso??? (Meine Tabelle ist aufgebaut wie Deine, nur dass Deine bei A1 mit "0" beginnt und meine bei M2.

3. Wozu sind die Hilfszellen 2? Auf die Ergebnisse wir nirgends zugegriffen.

Nochmals 1.000 Dank vorab.

Gruß
Klaus
ae
Mein Name ist Ente


Verfasst am:
01. Apr 2006, 12:46
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

Re: AW: Kurtaxe berechnen unter Berücksichtigung der Saison - Re: AW: Kurtaxe berechnen unter Berücksichtigung der Saison

Nach oben
       

KlausKraus - 01. Apr 2006, 09:50 hat folgendes geschrieben:

1. Was macht genau die Formel in E11; insb. was soll die Zeichenkette ("b"&VERGLEICH...

Die indirekt braucht eine Zeile und eine Spalte - Die zeile wird über Vergleich ermittelt und die Spalte ist von vorneherein bekannt - in diesem Fall B
Da die Zeile in Abhängigkeit des Ergebnisses varieren kann setze ich sie mit dem &-Zeichen zusammen.

Zitat:

2. Mein Ergebnis in N10 ist 38808. Wieso??? (Meine Tabelle ist aufgebaut wie Deine, nur dass Deine bei A1 mit "0" beginnt und meine bei M2.


Wenn Du deine Tabellenzelle N10 statt als Zahl als Datum formatierst wird es richtig.
Excel beginnt seine Datumsrechnung am 1.1.1900 mit der Zahl 1 und setzt den Zähler für jeden Tag eins höher
38808 entspricht also dem 01.04.2006

Zitat:

3. Wozu sind die Hilfszellen 2? Auf die Ergebnisse wir nirgends zugegriffen.

Nochmals 1.000 Dank vorab.

Gruß
Klaus


Die Hilfszellen dienten mir nur als Kopiervorlage und für die einzelnen Teilschritte - als älteres Semester schaffe ich solche geistigen Klimmzüge nimmer in einem Schritt Razz
Die Teilergebnisse der Hilfszellen kannst also getrost ignorieren.

Solltest es nicht angepasst bekommen poste mal deinen exakten Tabellenaufbau hier -
Am besten mit dem Jeanietool
http://www.office-loesung.de/ftopic30676_0_0_asc.php

Zur Lösung von ransi -

Für meinen Geschmack ist die beser als meine -
Das Auslagern der Jahresdaten geht ja ratzfatz -
Die Tabelle ist in 2 Minuten erstellt -
Und sein Lösungsweg über die Subtraktion der beiden summewenn einfach genial oder genial einfach -

Beim Jahreswechsel oder Wechsel der Tarife, oder...... ist die für jeden Exceluser einfach nach zu pflegen und zu verstehen!

Soll nicht heissen ich helfe dir nicht beim Anpassen, aber ich tendiere da sehr stark zu ransis Lösung !

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
KlausKraus
Gast


Verfasst am:
01. Apr 2006, 20:15
Rufname:


AW: Kurtaxe berechnen unter Berücksichtigung der Saison - AW: Kurtaxe berechnen unter Berücksichtigung der Saison

Nach oben
       

Idea Razz Idea Razz Idea Razz Idea Razz Idea Razz Idea
Andresas, Du bist ein Genie. Nun habe ich alles nachvollziehen (und sogar kapieren!) können. Diese neuen Excel-Erkenntnisse werden mir noch viel halfen, denn ich hatte schon öfter Probleme mit Tabellen, wo ich mit den "neuen" Funktionen Vergleich und Indirekt sehr weiter kommen werde.

Danke für Deine Hilfe.

Gruß
Klaus
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: SUMME einer Zeile mit VBA berechnen 7 Klausi 10623 27. Feb 2006, 14:10
Klausi SUMME einer Zeile mit VBA berechnen
Keine neuen Beiträge Excel Formeln: Verteilung berechnen 4 Coward 1288 27. Feb 2006, 13:28
Coward Verteilung berechnen
Keine neuen Beiträge Excel Formeln: Eine von zwei Zellen eingeben, andere berechnen 5 elf99 1010 10. Feb 2006, 11:42
fridgenep Eine von zwei Zellen eingeben, andere berechnen
Keine neuen Beiträge Excel Formeln: Zahlen zusammenfassen ohne sie zu berechnen 11 Neuling1000 1805 21. Dez 2005, 14:17
Neuling1000 Zahlen zusammenfassen ohne sie zu berechnen
Keine neuen Beiträge Excel Formeln: Arbeitszeit berechnen 1 keksi 1830 11. Nov 2005, 22:45
Tobias113 Arbeitszeit berechnen
Keine neuen Beiträge Excel Formeln: Summe für einen bestimmten Bereich berechnen? 6 bruce 2852 07. Nov 2005, 20:14
Gast Summe für einen bestimmten Bereich berechnen?
Keine neuen Beiträge Excel Formeln: Überstunden berechnen 1 Kaya001 2122 07. Aug 2005, 18:35
ae Überstunden berechnen
Keine neuen Beiträge Excel Formeln: Preise berechnen 2 excelflasche 1010 18. Mai 2005, 08:19
excelflasche Preise berechnen
Keine neuen Beiträge Excel Formeln: Übernachtungen berechnen 2 PRB 4054 28. Feb 2005, 00:22
PRB Übernachtungen berechnen
Keine neuen Beiträge Excel Formeln: Zeitdauer abzüglich Nachtzeit und Wochenende berechnen 1 sia 2216 19. Feb 2005, 13:59
Jeanie Zeitdauer abzüglich Nachtzeit und Wochenende berechnen
Keine neuen Beiträge Excel Formeln: Alter berechnen - Excel Version 97 11 Sita 6078 15. Feb 2005, 14:42
Sita Alter berechnen - Excel Version 97
Keine neuen Beiträge Excel Formeln: Stunden in bestimmtem Zeitraum berechnen 16 twistx 3443 22. Jan 2005, 02:20
xyzdef Stunden in bestimmtem Zeitraum berechnen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML CSS