Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
daten in anderer tabelle suchen und einsetzen
zurück: Speicherschutz weiter: Text in Excel formatieren Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Gast



Verfasst am:
13. Feb 2006, 16:05
Rufname:

daten in anderer tabelle suchen und einsetzen - daten in anderer tabelle suchen und einsetzen

Nach oben
       

Hi Smile

ich habe hier ein kleines Problem, dessen Lösung mir nicht einfallen will.

Was ich bisher habe:
Code:

=WENN(SVERWEIS('Import-txt'!A2;'produkt'!A$1:A$50000;1;1)='Import-txt'!A2;1;)


Wenn also der Wert in Spalte A übereinstimmt (Artikelnummer) druckt er mir eine 1 (für wahr) sonst eine 0 (für falsch).

Was ich aber WILL ist, daß er mir statt der 0 oder 1 einen Wert aus der gesuchten Spalte der Tabelle produkt übernimmt (Artikelname in Spalte B).

Bin für alle Tipps offen Smile
Hübi
Es gibt immer bessere Lösungen, als meine.


Verfasst am:
13. Feb 2006, 17:12
Rufname: Hübi (selten Herbert)
Wohnort: Strausberg


AW: daten in anderer tabelle suchen und einsetzen - AW: daten in anderer tabelle suchen und einsetzen

Nach oben
       

Hi,

ich verstehe den Sinn der Wenn() nicht so recht. Embarassed
Könnte aber so klappen
=SVERWEIS('Import-txt'!A2;'produkt'!A$1:A$50000;2;0)

_________________
Gruß Hübi
[Tipps getestet mit Win XP Prof. SP-2, Office 2000 Premium SP3 / Office 2003 Prof. SP3 / Office Professional 2007 SP1]
Gast



Verfasst am:
13. Feb 2006, 17:27
Rufname:

AW: daten in anderer tabelle suchen und einsetzen - AW: daten in anderer tabelle suchen und einsetzen

Nach oben
       

Servus,

Wenn ich diese Formel verwende bekomm ich einen #bezug!

Was sagt der ;2; aus? Das er aus Spalte 2 den Wert liefern soll?
Gast



Verfasst am:
13. Feb 2006, 17:31
Rufname:

AW: daten in anderer tabelle suchen und einsetzen - AW: daten in anderer tabelle suchen und einsetzen

Nach oben
       

Gelöst - danke:

Folgendes war noch zu tun:

Die Matrix muß nicht nur die zu durchsuchende Spalte (A) beinhalten, sondern auch die Spalte B um die Lösung retourzugeben. Somit:

=SVERWEIS('Import-txt'!A2;'produkt'!A$1:B$50000;2;0)
Hübi
Es gibt immer bessere Lösungen, als meine.


Verfasst am:
13. Feb 2006, 17:33
Rufname: Hübi (selten Herbert)
Wohnort: Strausberg


AW: daten in anderer tabelle suchen und einsetzen - AW: daten in anderer tabelle suchen und einsetzen

Nach oben
       

Hi

sorry, hatte nicht richtig gelesen.
So sollte es gehen
=SVERWEIS('Import-txt'!A2;'produkt'!A$1:B$50000;2;0)
Zitat:
Was sagt der ;2; aus? Das er aus Spalte 2 den Wert liefern soll?

Ja, genau so ist es.

_________________
Gruß Hübi
[Tipps getestet mit Win XP Prof. SP-2, Office 2000 Premium SP3 / Office 2003 Prof. SP3 / Office Professional 2007 SP1]
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Vernünftige Darstellung von Daten in einem Diagramm! 39 Axis_Sonnenflieger 5443 07. Dez 2004, 12:25
Axis_Sonnenflieger Vernünftige Darstellung von Daten in einem Diagramm!
Keine neuen Beiträge Excel Formeln: Suchen eines Wertes in einer Zeile 1 AxelChris 1731 25. Nov 2004, 17:25
Patrick0705 Suchen eines Wertes in einer Zeile
Keine neuen Beiträge Excel Formeln: Wert aus einer anderen Tabelle holen 2 =KB=Shorty 4867 17. Nov 2004, 21:22
=KB=Shorty Wert aus einer anderen Tabelle holen
Keine neuen Beiträge Excel Formeln: Anzahl bei 2 Bedingungen aus Tabelle berechnen 6 Satanico 1723 21. Okt 2004, 14:48
Satanico Anzahl bei 2 Bedingungen aus Tabelle berechnen
Keine neuen Beiträge Excel Formeln: Funktion: Identische Inhalt einer Zelle in Tabelle 1 und 2 4 luki 4202 09. Sep 2004, 18:20
Gast Funktion: Identische Inhalt einer Zelle in Tabelle 1 und 2
Keine neuen Beiträge Excel Formeln: Gleiche Einträge in Tabelle nummerich aufzählen 1 sauer 483 02. Sep 2004, 09:11
ae Gleiche Einträge in Tabelle nummerich aufzählen
Keine neuen Beiträge Excel Formeln: Frage... (suchen und löschen) 2 fs-racing 695 01. Sep 2004, 12:13
fs-racing Frage...  (suchen und löschen)
Keine neuen Beiträge Excel Formeln: aus Tabelle auslesen und vergleichen 1 wiedenmann 2805 12. Aug 2004, 13:42
Arnim aus Tabelle auslesen und vergleichen
Keine neuen Beiträge Excel Formeln: Tabelle einer Internetseite auslesen 1 Andy_beginner 1931 14. Jul 2004, 23:19
Manfred Bartak Tabelle einer Internetseite auslesen
Keine neuen Beiträge Excel Formeln: Kst.daten in einen Tabellenblatt zusammenfassen ...sverweis? 7 Memo 4623 05. Jul 2004, 12:05
Memo Kst.daten in einen Tabellenblatt zusammenfassen ...sverweis?
Keine neuen Beiträge Excel Formeln: EXCEL97: Zahl anhand von Text suchen? 1 Gast 821 04. Jun 2004, 20:02
Arnim EXCEL97: Zahl anhand von Text suchen?
Keine neuen Beiträge Excel Formeln: 2 Tabellen vergleichen und Werte in zweiter Tabelle ergänzen 2 Gast 1218 14. Apr 2004, 15:39
Gast 2 Tabellen vergleichen und Werte in zweiter Tabelle ergänzen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML CSS