Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Wie Mittelwert wenn Monat=1 berechnen? (beantwortet)
zurück: Kopfzerbrechen mit Zeitrechnung weiter: Zinseszinsformel in Berechnung Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
MET
Im Profil kannst Du frei den Rang ändern


Verfasst am:
13. Feb 2006, 10:22
Rufname:

Wie Mittelwert wenn Monat=1 berechnen? (beantwortet) - Wie Mittelwert wenn Monat=1 berechnen? (beantwortet)

Nach oben
       

Habe in einer Spalte Zellen im Datmsformat und in einer anderen Spalte Zahlen von denen ich den Mittelwert (und den Median) berechnen möchte. Versuchte es erst einmal mit Summewenn Monat(.:.)=1 (um nachher durch Zählenwenn zu dividieren) aber schon dies funktionierte nicht. Kann mir jemand auf die Sprünge helfen? Gibt es vielleicht sogar einen direkten Ansatz mit Mittelwert (bzw. Median)? Danke.

Zuletzt bearbeitet von MET am 21. Feb 2006, 18:24, insgesamt 3-mal bearbeitet
ae
Mein Name ist Ente


Verfasst am:
13. Feb 2006, 10:41
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg


AW: Wie Mittelwert wenn Monat=1 berechnen? - AW: Wie Mittelwert wenn Monat=1 berechnen?

Nach oben
       

Hallo,
geht bestimmt auch einfacher - aber so müsste es auch passen

Tabelle1
 ABCDE
101.01.2006100  120
218.01.2006120   
324.01.2006140   
421.02.2006160   
510.03.2006180   
627.03.2006200   
713.04.2006220   
830.04.2006240   
917.05.2006260   
10     
Formeln der Tabelle
E1 : =SUMMENPRODUKT((MONAT(A1:A9)=1)*(B1:B9))/SUMMENPRODUKT((MONAT(A1:A9)=1)*1)
 

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
rainberg
Excel-Anwender


Verfasst am:
13. Feb 2006, 11:12
Rufname:

AW: Wie Mittelwert wenn Monat=1 berechnen? - AW: Wie Mittelwert wenn Monat=1 berechnen?

Nach oben
       

Hallo MET,

anbei meine Alternative

Tabelle1
 ABCDE
101.01.2006105 MW132
218.01.2006121 Median121
324.01.2006170   
421.02.2006160   
510.03.2006180   
627.03.2006200   
713.04.2006220   
830.04.2006240   
917.05.2006260   
Formeln der Tabelle
E1 : {=MITTELWERT(WENN(MONAT(A1:A9)=1;B1:B9))}
E2 : {=MEDIAN(WENN(MONAT(A1:A9)=1;B1:B9))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
MET
Im Profil kannst Du frei den Rang ändern


Verfasst am:
13. Feb 2006, 11:38
Rufname:

AW: Wie Mittelwert wenn Monat=1 berechnen? - AW: Wie Mittelwert wenn Monat=1 berechnen?

Nach oben
       

Danke Andreas, dies funktioniert für den Mittelwert. Die erhaltenen Resultate haben mir jedoch gezeigt, dass die Daten der einzelnen Monate separat zu behandeln sind bzw. die Daten der einzelnen Monate in separate Blätter übertragen werden müssen. Der Mittelwert und der Median können dort dann wieder ganz normal berechnet werden...
MET
Im Profil kannst Du frei den Rang ändern


Verfasst am:
13. Feb 2006, 11:50
Rufname:


AW: Wie Mittelwert wenn Monat=1 berechnen? - AW: Wie Mittelwert wenn Monat=1 berechnen?

Nach oben
       

Hallo Rainer

Danke, das ist wirklich die Lösung wie es gemacht werden müsste... Habe damit jetzt mindestens herausgefunden, dass die Daten nicht symmetrisch verteilt sind. Muss all die Daten jetzt doch nach Monaten aufsplitten. Resultiert in etwas mehr Arbeit als ich hoffte...

Gruss MET
MET
Im Profil kannst Du frei den Rang ändern


Verfasst am:
21. Feb 2006, 14:11
Rufname:

AW: Wie Mittelwert wenn Monat=1 berechnen? - AW: Wie Mittelwert wenn Monat=1 berechnen?

Nach oben
       

Muss dieses Thema nochmals angehen, dies jetzt mit Datensätzen unterschiedlicher Länge. Im Beispiel von Rainer ist die Anzahl der in der Spalte vorhandenen Daten bekannt, nämlich 9.

Habe folgende Varianten probiert, beide gehen jedoch nicht:

{=MITTELWERT(WENN(MONAT(A:A)=1;B:B))}
liefert: #ZAHL!

Nehme ich einen Bereich, der grösser ist, also z.B:
{=MITTELWERT(WENN(MONAT(A1:A50000)=1;B1:B50000))}
dann stimmt das Resultat nicht mehr, es resultiert ein viel kleinerer Wert als mit der genauen Angabe des Bereichs.

Gibt es eine Lösung, wenn die Grösse des Bereichs beispielsweise mit ZÄHLENWENN bestimmt wird? Oder, irgendwelche andere Vorschläge?

Danke.

Nachtrag: Habe es jetzt auch noch mit dem Summenprodukt versucht. Bei grossen Bereichen liefert dies aber #WERT!

Hinweis: Der Datenbereich kann schon über ein paar "ig" tausend Zellen umfassen.
rainberg
Excel-Anwender


Verfasst am:
21. Feb 2006, 15:44
Rufname:

AW: Wie Mittelwert wenn Monat=1 berechnen? - AW: Wie Mittelwert wenn Monat=1 berechnen?

Nach oben
       

Hallo MET,

mach's so

Tabelle1
 ABCDE
101.01.2006105 MW132
218.01.2006121 Median121
324.01.2006170   
421.02.2006160   
510.03.2006180   
627.03.2006200   
713.04.2006220   
830.04.2006240   
917.05.2006260   
Formeln der Tabelle
E1 : {=MITTELWERT(WENN(MONAT(INDIREKT("A1:A"&ANZAHL(A:A)))=1;INDIREKT("B1:B"&ANZAHL(A:A))))}
E2 : {=MEDIAN(WENN(MONAT(INDIREKT("A1:A"&ANZAHL(A:A)))=1;INDIREKT("B1:B"&ANZAHL(A:A))))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
MET
Im Profil kannst Du frei den Rang ändern


Verfasst am:
21. Feb 2006, 16:15
Rufname:

AW: Wie Mittelwert wenn Monat=1 berechnen? - AW: Wie Mittelwert wenn Monat=1 berechnen?

Nach oben
       

Danke Rainer für die rasche Antwort. Werde es gleich ausprobieren.

Habe inzwischen noch weiter probiert und folgendes festgestellt:
Mit {=MITTELWERT(WENN(MONAT(A1:A50000)=1;B1:B50000))} ist das Resultat nur für den Monat=1 nicht richtig, bei den anderen Monaten stimmt der Wert. Das Problem liegt bei den Leerzellen. Excel setzt für die Leerzelle den Monat ebenfalls =1.

Ein weiterer Versuch mit
{=MITTELWERT(WENN(UND(MONAT(A1:A50000)=1;JAHR(A1:A50000)>1900);B1:B50000))} liefert als Resultat nur 0. (Hinweis: Excel liefert für eine Leerzelle das Jahr 1900.)

Hoffe, dass es jetzt mit Deinem Vorschlag hinkommt. Nochmals "Dankeschön".
rainberg
Excel-Anwender


Verfasst am:
21. Feb 2006, 17:03
Rufname:

AW: Wie Mittelwert wenn Monat=1 berechnen? - AW: Wie Mittelwert wenn Monat=1 berechnen?

Nach oben
       

Hallo MET,

diese Formel geht auch
Code:
{=MITTELWERT(WENN(MONAT(A1:A50000)=1;B1:B50000))}


nur musst du wegen der leeren Zellen ein weiteres Kriterium hinzufügen, da diese sonst dem Januar zugerechnet werden.

So wäre es richtig:
Code:
{=MITTELWERT(WENN((MONAT(A1:A50000)=1)*(A1:A50000<>"");B1:B50000))}


Folgendes Beispiel sollte dir das "WARUM" erklären.

Tabelle1
 AB
121.01.20061
212.06.24806
323.03.20063
4 1
5 1
Formeln der Tabelle
B1 : =MONAT(A1)
B2 : =MONAT(A2)
B3 : =MONAT(A3)
B4 : =MONAT(A4)
B5 : =MONAT(A5)
 
MET
Im Profil kannst Du frei den Rang ändern


Verfasst am:
21. Feb 2006, 18:23
Rufname:

AW: Wie Mittelwert wenn Monat=1 berechnen? - AW: Wie Mittelwert wenn Monat=1 berechnen?

Nach oben
       

Hallo Rainer

Das mit dem Januar hatte ich vorher ja eben rausgefunden ...

Die Version mit INDIREKT funktioniert bis auf eine einzige Ausnahme. Teste mit einem Datensatz der zu jeder von etwas mehr als 14'000 Datum/Zeitangaben (=14'000 Excel-Zeilen) jeweils verschiedene Messwerte enthält. Von 3 dieser Messwerte bestimme ich für jeden der 12 Monate den Mittelwert und den Median. Bei einem dieser Messwerte liefert mir jedoch diese INDIREKT-Version für den Mittelwert und den Median ein #NV. Benutze ich anstelle der INDIREKT-Formel eine der anderen Versionen liefert mir Excel das Resultat. Hatte mir mehrmals die betreffenden Bereiche im Datensatz angeschaut, konnte aber nichts besonderes feststellen. Werde deshalb die Auswertung auf die letzte von Dir vorgeschlagene Version abändern. Wegen dem festen Datenbereich ist diese nicht ganz so 'elegant' wie die INDIRECT-Lösung, sie scheint aber stabiler zu funktionieren.

Nochmals vielen Dank für Deine Hilfe

Gruss MET
rainberg
Excel-Anwender


Verfasst am:
21. Feb 2006, 19:39
Rufname:

AW: Wie Mittelwert wenn Monat=1 berechnen? (beantwortet) - AW: Wie Mittelwert wenn Monat=1 berechnen? (beantwortet)

Nach oben
       

Hallo MET,

die INDIREKT-Version funktioniert selbstverständlich stabil, nur vermute ich, du verwendest Spaltenüberschriften ohne die Formel angepasst zu haben.
Tabelle2
 ABCDE
1DatumWerte   
201.01.2006105 MW132
318.01.2006121 Median121
424.01.2006170   
521.02.2006160   
610.03.2006180   
727.03.2006200   
813.04.2006220   
930.04.2006240   
1017.05.2006260   
Formeln der Tabelle
E2 : {=MITTELWERT(WENN(MONAT(INDIREKT("A2:A"&ANZAHL(A:A)))=1;INDIREKT("B2:B"&ANZAHL(A:A))))}
E3 : {=MEDIAN(WENN(MONAT(INDIREKT("A2:A"&ANZAHL(A:A)))=1;INDIREKT("B2:B"&ANZAHL(A:A))))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
MET
Im Profil kannst Du frei den Rang ändern


Verfasst am:
21. Feb 2006, 20:23
Rufname:

AW: Wie Mittelwert wenn Monat=1 berechnen? (beantwortet) - AW: Wie Mittelwert wenn Monat=1 berechnen? (beantwortet)

Nach oben
       

Daran kann's nicht liegen. Habe für den Test extra alle Überschriften entfernt. Wie gesagt, bei den anderen beiden Messwerten gibt es keine Probleme und die fraglichen Daten hatte ich noch durchgeschaut und nichts feststellen können; hatte auch die Spalten nochmals formatiert (Datum und Zahl), aber nichts half...
rainberg
Excel-Anwender


Verfasst am:
21. Feb 2006, 20:35
Rufname:


AW: Wie Mittelwert wenn Monat=1 berechnen? (beantwortet) - AW: Wie Mittelwert wenn Monat=1 berechnen? (beantwortet)

Nach oben
       

Hallo MET,

dann bleibt noch die Frage, ob du nur die Texte der Überschriften gelöscht hast oder die kompletten Zellen?

Was sonst an deine Werten nicht stimmt kann ich leider nicht sehen, deshalb schließe ich hiermit meine Hilfestellung.

Jedenfalls arbeiten meine Formeln mit 20000 Testzeilen bei mir einwandfrei.
Der einzige Wermutstropfen, die Berechnungen benötigen viel Zeit, was allerdings durch die Verwendung von Matrixformeln begründet ist.
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Überstunden berechnen 1 Kaya001 2122 07. Aug 2005, 18:35
ae Überstunden berechnen
Keine neuen Beiträge Excel Formeln: Zeit und Stunden berechnen 2 power-user 4051 03. Aug 2005, 22:20
power-user Zeit und Stunden berechnen
Keine neuen Beiträge Excel Formeln: Preise berechnen 2 excelflasche 1010 18. Mai 2005, 08:19
excelflasche Preise berechnen
Keine neuen Beiträge Excel Formeln: Stunden berechnen 4 Blacksmithtwo 3129 25. Apr 2005, 17:18
Leeza Stunden berechnen
Keine neuen Beiträge Excel Formeln: Zuschläge berechnen 7 leer 3509 21. Feb 2005, 22:41
ae Zuschläge berechnen
Keine neuen Beiträge Excel Formeln: Zeitdauer abzüglich Nachtzeit und Wochenende berechnen 1 sia 2216 19. Feb 2005, 13:59
Jeanie Zeitdauer abzüglich Nachtzeit und Wochenende berechnen
Keine neuen Beiträge Excel Formeln: Formel um die Wahrscheinlichkeit einer Menge zu berechnen 1 Martin209 881 22. Dez 2004, 07:34
xpecidy Formel um die Wahrscheinlichkeit einer Menge zu berechnen
Keine neuen Beiträge Excel Formeln: Pausenzeiten dynamisch berechnen und anzeigen 8 acki-bm 2213 07. Dez 2004, 18:19
Sanne Pausenzeiten dynamisch berechnen und anzeigen
Keine neuen Beiträge Excel Formeln: Wieviele Tage hat der Monat X? 2 Kaischi 15472 07. Dez 2004, 01:27
Kaischi Wieviele Tage hat der Monat X?
Keine neuen Beiträge Excel Formeln: Anzahl bei 2 Bedingungen aus Tabelle berechnen 6 Satanico 1723 21. Okt 2004, 14:48
Satanico Anzahl bei 2 Bedingungen aus Tabelle berechnen
Keine neuen Beiträge Excel Formeln: Mittelwert aus mehr als 30 Argumenten berechnen 9 wirrwarr 1180 15. Okt 2004, 16:01
Arnim Mittelwert aus mehr als 30 Argumenten berechnen
Keine neuen Beiträge Excel Formeln: Dienstaltersstufe berechnen 2 linuxskipper 6971 19. Sep 2004, 17:00
linuxskipper Dienstaltersstufe berechnen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft-Excel Diagramme