Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
SummeWenn mit Array
Gehe zu Seite 1, 2  Weiter
zurück: Zellenwerte in bestimmten Abstand untereinander ausgeben weiter: Excel Intervall Mittelwert Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
rantanpläne
Im Profil kannst Du frei den Rang ändern


Verfasst am:
30. Apr 2014, 10:36
Rufname:

SummeWenn mit Array - SummeWenn mit Array

Nach oben
       Version: Office 2010

Hallo!

Ich bin völlig neu hier im Forum und gespannt ob mir jemand bei diesem Problem weiterhelfen kann.

Ich würde gerne eine Lösung ohne extra Spalten finden die mir folgendes berechnet:

die Summe jener Werte aus einer Spalte, deren Werte durch Werte einer Nachbarspalte dividiert kleiner als ein bestimmter Wert sind. Also zB wie unten: die Summe aller Werte in der Spalte 2 ist 47. Ich möchte jedoch auch die Zahl 8 errechnet haben (2+3+3), weil für die ersten drei Zeilen die Bedingung zutrifft, dass die Zahl aus Spalte 2 dividiert mit der Zahl aus Spalte 1 kleiner als das Kriterium 15 ist.

30% 2
50% 3
50% 3
50% 8
50% 8
90% 18
50% 8
47
Gesuchtes Ergebnis: 8
Kriterium 15

Bin für jede Hilfe in dieser Sacher sehr dankbar!

Liebe Grüße!
YDKJ
Im Profil kannst Du frei den Rang ändern


Verfasst am:
30. Apr 2014, 11:04
Rufname:

AW: SummeWenn mit Array - AW: SummeWenn mit Array

Nach oben
       Version: Office 2010

Hallo,

meinst du das so?
 AB
130%2
250%3
350%3
450%8
550%8
690%18
750%8
8  
9Summe50
10Gesuchtes Ergebnis8
11Kriterium15

ZelleFormatWert
A10%0,3
A20%0,5
A30%0,5
A40%0,5
A50%0,5
A60%0,9
A70%0,5

ZelleFormel
B9=SUMME(B1:B7)
B10=SUMMENPRODUKT(((B1:B7/A1:A7)<B11)*B1:B7)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Gruß

_________________
Einfach ist immer das, was man kann.
Und: «Einer muss sich immer plagen, entweder der Autor oder der Leser.» Wolf Schneider, 2010
rantanpläne
Im Profil kannst Du frei den Rang ändern


Verfasst am:
30. Apr 2014, 11:16
Rufname:

AW: SummeWenn mit Array - AW: SummeWenn mit Array

Nach oben
       Version: Office 2010

Hi YDKJ!

Vielen Dank für deinen Lösungsvorschlag! Nur klappt der bei mir aus irgendeinem Grund nicht (#Wert!)... Irgendeine Idee warum?

Danke jedenfalls!
rantanpläne
Im Profil kannst Du frei den Rang ändern


Verfasst am:
30. Apr 2014, 11:20
Rufname:

AW: SummeWenn mit Array - AW: SummeWenn mit Array

Nach oben
       Version: Office 2010

Bin grad draufgekommen warums nicht klappt: bei mir gibt's auch leere Zellen, die in der Formel ignoriert werden müssten... Sonst klappt die Formel perfekt vielen Dank dir!!
rantanpläne
Im Profil kannst Du frei den Rang ändern


Verfasst am:
30. Apr 2014, 12:05
Rufname:

AW: SummeWenn mit Array - AW: SummeWenn mit Array

Nach oben
       Version: Office 2010

Hallo nochmal!

Leider ist die Suche nach einer Formel, die wie oben von YDKJ funktioniert, aber leere Zellen in beiden Spalten ignoriert gar nicht so simpel, wie meine Recherche ergeben hat...

Wie immer bin ich für Vorschläge sehr dankbar!

LG
rantanpläne
Im Profil kannst Du frei den Rang ändern


Verfasst am:
30. Apr 2014, 12:52
Rufname:

AW: SummeWenn mit Array - AW: SummeWenn mit Array

Nach oben
       Version: Office 2010

Ich bin mit meinem Latein mittlerweile bei dieser nicht funktionierenden Formel (inspiriert von YDJK) angelangt um zu versuchen leere Zellen (Formeln sind enthalten) zu ignorieren:

=SUMMENPRODUKT(((B1:B8/A1:A8)<15)*(B1:B8<>0))

Leider mit dem Resultat: #Wert!

Vielleicht habt ihr da draußen einen Ansatz der funktioniert?

LG
steve1da
Moderator


Verfasst am:
30. Apr 2014, 12:57
Rufname:

AW: SummeWenn mit Array - AW: SummeWenn mit Array

Nach oben
       Version: Office 2010

Hola,

#WERT bedeutet, dass entweder in einem der Bereich #WERT steht, oder aber TEXT.

Gruß,
steve1da[/list]
rantanpläne
Im Profil kannst Du frei den Rang ändern


Verfasst am:
30. Apr 2014, 13:08
Rufname:

AW: SummeWenn mit Array - AW: SummeWenn mit Array

Nach oben
       Version: Office 2010

Hi steve1da, danke für deine Antwort!

In der Formelauswertung bekomm ich den Fehler #Wert in der Funktion SUMMENPRODUKT bei den leeren Zellen, welche selbst über eine Formel bestimmt den Wert "" zugewiesen bekommen.

Mein Versuch in der SUMMENPRODUKT Formel die 0 mit "" zu ersetzen hat leider auch nix gebracht (vgl. unten)

=SUMMENPRODUKT(((B1:B8/A1:A8)<15)*(B1:B8<>""))
FCH
Im Profil kannst Du frei den Rang ändern


Verfasst am:
30. Apr 2014, 13:29
Rufname: Jürgen

AW: SummeWenn mit Array - AW: SummeWenn mit Array

Nach oben
       Version: Office 2010

Hi,

versuche mal das:

Arbeitsblatt mit dem Namen 'Tabelle4'
 AB
125%2
225% 
325%2
425%4
510%2
625%0
725%2
8  
9Summe50
10Gesuchtes Ergebnis10
11Kriterium15

ZelleFormel
B2=WENN(C2=1;1;"")
B10=SUMMENPRODUKT((A1:A7>B11/100)*(B1:B7<>"");B1:B7)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Gruß
Jürgen
rantanpläne
Im Profil kannst Du frei den Rang ändern


Verfasst am:
30. Apr 2014, 13:57
Rufname:

AW: SummeWenn mit Array - AW: SummeWenn mit Array

Nach oben
       Version: Office 2010

Hi Jürgen!

Danke für deinen Vorschlag!

Wenn ich deine Formel für meine Bedürfnisse anpasse komm ich zum gewünschten Ergebnis, allerdings nur wenn B2 in deinem Beispiel keine Formel enthält und wirklich "leer" ist. Sonst gibt's wieder einen #Wert- Fehler.

Hier meine angepasste Formel für dein Zahlenbeispiel:

=SUMMENPRODUKT((B1:B7/A1:A7<B11)*(B1:B7<>"");B1:B7)

LG
Gast



Verfasst am:
30. Apr 2014, 14:35
Rufname:

AW: SummeWenn mit Array - AW: SummeWenn mit Array

Nach oben
       Version: Office 2010

Hallo,


eine Division ""/x funktioniert in Excel nicht, deshalb der Fehler #Wert! Kann man mit der Formelauswertung nachprüfen:

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
130%2
250%3
350%3
450%8
550% 
690%18
750%8
8  
9Summe42
10Gesuchtes Ergebnis8
11Kriterium15

ZelleFormel
B5=WENN(C5="";"";C7)
B9=SUMME(B1:B7)
B10{=SUMMENPRODUKT((WENN(ISTZAHL(B1:B7);B1:B7;0)/A1:A7<B11)*1;B1:B7)}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Ansonsten solltest Du statt "" als Formelergebnis eine 0 erzeugen, dann funktioniert Deine Formel:

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
130%2
250%3
350%3
450%8
550%0
690%18
750%8
8  
9Summe42
10Gesuchtes Ergebnis8
11Kriterium15

ZelleFormel
B5=WENN(C5="";0;C7)
B9=SUMME(B1:B7)
B10=SUMMENPRODUKT((B1:B7/A1:A7<B11)*1;B1:B7)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Gruß

elg
rantanpläne
Im Profil kannst Du frei den Rang ändern


Verfasst am:
30. Apr 2014, 15:17
Rufname:

AW: SummeWenn mit Array - AW: SummeWenn mit Array

Nach oben
       Version: Office 2010

Hi elg!

Danke für deine Hilfe!

Das Problem ist nur, dass in der Spalte A auch eine Leere Zelle bzw 0 vorkommen kann. Das führt dann zu einem #DIV/0 Fehler.

LG
lupo1
Tüftler und {}-Sympathisant


Verfasst am:
30. Apr 2014, 15:37
Rufname:

Umformung, weg mit der Division ;) - Umformung, weg mit der Division ;)

Nach oben
       Version: Office 2010

B10: =SUMMENPRODUKT(--(B1:B7<B11*A1:A7);B1:B7)
_________________
MfG Lupo - 11.10.2012-> {MSO 2000 SP3;Win 7} - 28.02.2013-> {MSO 2010;Win 8.1} (beide vorhanden)
rantanpläne
Im Profil kannst Du frei den Rang ändern


Verfasst am:
30. Apr 2014, 15:53
Rufname:

AW: SummeWenn mit Array - AW: SummeWenn mit Array

Nach oben
       Version: Office 2010

Wahnsinn!! Vielen Dank Lupo1! So hat's mit 0-Werten (anstelle von "") funktioniert!! Und das mit zwei -- in der Formel... wie soll man nur da drauf kommen!!??

Danke jedenfalls an alle Mitwirkenden! Bin total happy!! Very Happy

Liebe Grüße
lupo1
Tüftler und {}-Sympathisant


Verfasst am:
30. Apr 2014, 16:17
Rufname:

AW: SummeWenn mit Array - AW: SummeWenn mit Array

Nach oben
       Version: Office 2010

--TEXT() entspricht TEXT()*1 oder TEXT()+0 - reine Typumwandlung. Da *1 zu unauffällig wirkt, das -- einem jedoch sofort ins Auge springt und sofort auch "WARUM", ziehe ich -- vor.

"" ist eine Krankheit. Ein Mittel gibt es dafür in diesem Forum nicht.

_________________
MfG Lupo - 11.10.2012-> {MSO 2000 SP3;Win 7} - 28.02.2013-> {MSO 2010;Win 8.1} (beide vorhanden)
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Gehe zu Seite 1, 2  Weiter
Diese Seite Freunden empfehlen

Seite 1 von 2
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Monat() und Summewenn() 8 Hippi4v2a 14620 04. Jul 2006, 07:59
Hippi4v2a Monat() und Summewenn()
Keine neuen Beiträge Excel Formeln: summewenn mit kleiner, gleich einer variblen zelle 4 doc77 17883 29. Jun 2006, 11:51
tom_r summewenn mit kleiner, gleich einer variblen zelle
Keine neuen Beiträge Excel Formeln: SummeWenn 1 maximum 582 18. März 2006, 18:30
ae SummeWenn
Keine neuen Beiträge Excel Formeln: Summewenn mit 2 Bedingungen 8 Stepps13 3906 10. März 2006, 12:36
Stepps13 Summewenn mit 2 Bedingungen
Keine neuen Beiträge Excel Formeln: summewenn 7 yoogula777 976 08. März 2006, 09:27
yoogula777 summewenn
Keine neuen Beiträge Excel Formeln: SUMMEWENN - Problem ? 3 FrankH. 1083 16. Feb 2006, 11:53
FrankH. SUMMEWENN - Problem ?
Keine neuen Beiträge Excel Formeln: Summewenn mit mehreren Suchkriterien 2 schneemann79 10089 20. Jan 2006, 11:17
schneemann79 Summewenn mit mehreren Suchkriterien
Keine neuen Beiträge Excel Formeln: SUMMEWENN mit 2 Bedingungen 3 Diana007 591 10. Jan 2006, 15:13
Diana007 SUMMEWENN mit 2 Bedingungen
Keine neuen Beiträge Excel Formeln: Summewenn bei Filter anwenden. 6 watchguard 2117 09. Jan 2006, 19:23
fridgenep Summewenn bei Filter anwenden.
Keine neuen Beiträge Excel Formeln: Summewenn/dbsumme Brauche formel für add. einzelner Monate 4 CBR900RR 1297 15. Okt 2005, 14:17
CBR900RR Summewenn/dbsumme Brauche formel für add. einzelner Monate
Keine neuen Beiträge Excel Formeln: SUMMEWENN mit Suchkriterium Datum;Datum nach jeder Zeile +1? 4 homer_134 3721 20. Sep 2005, 23:48
homer_134 SUMMEWENN mit Suchkriterium Datum;Datum nach jeder Zeile +1?
Keine neuen Beiträge Excel Formeln: SummeWenn 11 Dog 976 13. Sep 2005, 13:43
fridgenep SummeWenn
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Project