Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Zellen mit Datum älter heute kopieren
zurück: Zelleninhalt auf String überprüfen weiter: Uhrzeiten erechnen und summe bilden Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
FzumD
Gast


Verfasst am:
29. Apr 2014, 15:20
Rufname:

Zellen mit Datum älter heute kopieren - Zellen mit Datum älter heute kopieren

Nach oben
       Version: Office 2010

Grüßt euch ihr Lieben,
ich mal wieder.

Erstmal möchte ich kurz auf folgenden Thread verweisen.

Ich habe nämlich ein ähnliches Problem.
<Peter> hat hier einen Lösungsansatz vorgeschlagen, welchen ich aufgegriffen habe.
Problem hierbei allerdings: Ich suche nicht nach einem Wort sondern ich möchte aus einer Tabelle mit dieser Formel Daten beziehen, deren Termin älter als HEUTE() ist.

Das heißt ich habe eine Tabelle in etwa so:
(tut mir leid, kann leider euer tolles Jeanie-Tool gerade nicht nutzen)

Tabelle 1

Artikelnummer Name Termin
0815 Blech 28.04.14
11880 Stahl 06.08.14
6969 Holz 03.03.14
4247 Fleisch 05.12.13


Und möchte nun in einem neuen Tabellenblatt die Zeilen deren Termin älter als heute (29.04.14) auflisten.

Geht mit der von mir abgewandelten Formel:

Tabelle 2
A1=

{=WENN(ZEILE(Tabelle1!1:1)>ZÄHLENWENN(Tabelle1!$B:$B;"<"&HEUTE());"";INDEX(Tabelle1!A:A;KKLEINSTE(WENN(Tabelle1!$B$1:$B$10="<"&HEUTE();ZEILE(Tabelle1!$1:$10));ZEILE(A1))))}


Meine Frage: Habe ich etwas übersehen? Geht das überhaupt auf die Weise?
Bzw. kann ich überhaupt sagen, "Lese mir alle Zeilen in denen ein Datum älter heute" aus?
Bin für jedwede Idee und Hilfe offen, stehe gerade etwas auf dem Schlauch.
Filtern nach Datum und gefilterte Zeilen kopieren fiel mir noch ein, könnte aber sehr umständlich werden, glaube ich.

Ich hoffe ich konnte mein Problem verständlich darlegen und jemand kann mir helfen. Danke schonmal!

Einen schönen Tag noch,
Flat
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
29. Apr 2014, 17:00
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände

AW: Zellen mit Datum älter heute kopieren - AW: Zellen mit Datum älter heute kopieren

Nach oben
       Version: Office 2010

Hi

Ändere mal diesen Teil
Tabelle1!$B$1:$B$10="<"&HEUTE()
in
Tabelle1!$B$1:$B$10<HEUTE()

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
FzumD
Gast


Verfasst am:
30. Apr 2014, 11:51
Rufname:

AW: Zellen mit Datum älter heute kopieren - AW: Zellen mit Datum älter heute kopieren

Nach oben
       Version: Office 2010

Hallo shift-del!

Danke, das war wohl der Fehler in der Formel.
Bei dem genannten Beispiel funktioniert das so auch (abgesehen davon, dass sich natürlich auf C bezogen werden muss nicht wie in der genannten Formel auf B, Fehler meinerseits), aber in meiner großen komplexen Tabelle, für die ich die Formel brauche, steht dann mit der Formel nur in der obersten Zeile überall eine 0 und darunter ist alles leer Sad

Gruß,
Flat
steve1da
Moderator


Verfasst am:
30. Apr 2014, 11:54
Rufname:

AW: Zellen mit Datum älter heute kopieren - AW: Zellen mit Datum älter heute kopieren

Nach oben
       Version: Office 2010

Hola,

da wir deine Tabelle nicht sehen, können wir nur raten. Sieht das so aus?

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFG
1ArtikelnummerNameTermin   815
2815Blech28.04.2014   6969
311880Stahl06.08.2014   4247
46969Holz03.03.2014   0
54247Fleisch05.12.2013   0
6       

ZelleFormel
G1{=WENNFEHLER(INDEX(Tabelle1!A:A;KKLEINSTE(WENN(Tabelle1!$C$1:$C$10<HEUTE();ZEILE(Tabelle1!$1:$10));ZEILE(A1)));"")}
G2{=WENNFEHLER(INDEX(Tabelle1!A:A;KKLEINSTE(WENN(Tabelle1!$C$1:$C$10<HEUTE();ZEILE(Tabelle1!$1:$10));ZEILE(A2)));"")}
G3{=WENNFEHLER(INDEX(Tabelle1!A:A;KKLEINSTE(WENN(Tabelle1!$C$1:$C$10<HEUTE();ZEILE(Tabelle1!$1:$10));ZEILE(A3)));"")}
G4{=WENNFEHLER(INDEX(Tabelle1!A:A;KKLEINSTE(WENN(Tabelle1!$C$1:$C$10<HEUTE();ZEILE(Tabelle1!$1:$10));ZEILE(A4)));"")}
G5{=WENNFEHLER(INDEX(Tabelle1!A:A;KKLEINSTE(WENN(Tabelle1!$C$1:$C$10<HEUTE();ZEILE(Tabelle1!$1:$10));ZEILE(A5)));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Sind die Daten auch wirklich kleiner als HEUTE()?

Gruß,
steve1da
FzumD
Excel-Tausendsassa


Verfasst am:
30. Apr 2014, 12:36
Rufname: Flat

AW: Zellen mit Datum älter heute kopieren - AW: Zellen mit Datum älter heute kopieren

Nach oben
       Version: Office 2010

(so, erstmal offiziell angemeldet)

Hey steve!

Bin schon gerade dabei das ganze mal als kleine vereinfachte Excel-Datei zu schreiben und dann hochzuladen, dann sieht man das am besten, denke ich.

Kann man bei euch direkt ins Forum excel-Dateien hochladen? Oder muss das über nen Hoster hochgeladen sein?

Gruß, Flat
steve1da
Moderator


Verfasst am:
30. Apr 2014, 12:55
Rufname:

AW: Zellen mit Datum älter heute kopieren - AW: Zellen mit Datum älter heute kopieren

Nach oben
       Version: Office 2010

Sowohl als auch Wink

http://www.office-loesung.de/ftopic126638 (Anleitung zum Hochladen von Dateien, Anmeldung erforderlich)
alternativ zB bei www.file-upload.net
FzumD
Excel-Tausendsassa


Verfasst am:
30. Apr 2014, 13:15
Rufname: Flat

AW: Zellen mit Datum älter heute kopieren - AW: Zellen mit Datum älter heute kopieren

Nach oben
       Version: Office 2010

Date anhängen will grad nicht so richtig funktionieren, daher über nen Filehoster Very Happy

Beispiel.zip downloaden

So sieht die Tabelle aus, etwas kürzer gehalten als das Original. Das Original geht über ca. 150 Zeilen. und auch noch über paar mehr Spalten
Die anderen Tabellenblätter zeigen wie ich die Formel angewendet habe und schließlich wie ich dachte, dass es am Ende eigentlich aussieht.


Kurz und knapp ausgedrückt möchte ich eigentlich nur eine Tabelle/Textdatei/whatever, in der ich sehe, welcher Auftrag bei welchem Arbeitsgang überfällig (also älter als heute) ist. Die Beachtung der Termine des ersten Arbeitsgangs würde hier schon reichen (= Spalte M), weiter hinten vorkommende Termine können auch vernachlässigt werden...
Und ich dachte, auf diese Weise funktioniert das, aber so ganz...

Gruß,
Flat
steve1da
Moderator


Verfasst am:
30. Apr 2014, 13:28
Rufname:

AW: Zellen mit Datum älter heute kopieren - AW: Zellen mit Datum älter heute kopieren

Nach oben
       Version: Office 2010

Das Problem an der Sache ist, du hast in Spalte M auch leere Zellen, die werten Datumsmäßig als 0 angesehen und sind automatisch kleiner als Heute. Die würden also auch mit ausgegeben werden. Als kleiner Workaround, schreibe in Daten, Zelle R5 folgende Formel:

Code:
=WENN(UND(M5<HEUTE();M5<>"");"x";"")


Die ziehst du nach unten.

Als Vorstellung dann:

Arbeitsblatt mit dem Namen 'Vorstellung'
 GHIJK
103/35801000schneiden03.03.2014
205/3584110bestschneiden15.02.2014
303/3591200bestschneiden12.11.2013
403/359560bestschneiden15.04.2014

ZelleFormel
G1{=WENNFEHLER(INDEX(Daten!$I$5:$I$99;KKLEINSTE(WENN(Daten!R$5:R$99="x";ZEILE($1:$95));ZEILE(A1)));"")}
H1{=WENNFEHLER(INDEX(Daten!$J$5:$J$99;KKLEINSTE(WENN(Daten!R$5:R$99="x";ZEILE($1:$95));ZEILE(A1)));"")}
I1{=WENNFEHLER(INDEX(Daten!$K$5:$K$99;KKLEINSTE(WENN(Daten!R$5:R$99="x";ZEILE($1:$95));ZEILE(A1)));"")}
J1{=WENNFEHLER(INDEX(Daten!$L$5:$L$99;KKLEINSTE(WENN(Daten!R$5:R$99="x";ZEILE($1:$95));ZEILE(A1)));"")}
K1{=WENNFEHLER(INDEX(Daten!$M$5:$M$99;KKLEINSTE(WENN(Daten!R$5:R$99="x";ZEILE($1:$95));ZEILE(A1)));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
FzumD
Excel-Tausendsassa


Verfasst am:
30. Apr 2014, 13:50
Rufname: Flat

Re: AW: Zellen mit Datum älter heute kopieren - Re: AW: Zellen mit Datum älter heute kopieren

Nach oben
       Version: Office 2010

steve1da - 30. Apr 2014, 13:28 hat folgendes geschrieben:
Das Problem an der Sache ist, du hast in Spalte M auch leere Zellen, die werten Datumsmäßig als 0 angesehen


Da hab ich überhaupt nicht dran gedacht. Immer diese Sache mit den Bäumen vor lauter Wald. Rolling Eyes
Dein Workaround löst das ganze natürlich noch eleganter. Ich denke damit wirds hinhauen.
Vielen vielen Dank, melde mich bestimmt die Tage nochmal, wie's funktioniert.

Schönen Feiertag wünsch ich!

MfG,
Flat
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: zusammengesetzten Hyperlink kopieren 4 Seppo110 570 07. Sep 2004, 12:22
Seppo110 zusammengesetzten Hyperlink kopieren
Keine neuen Beiträge Excel Formeln: Prüfung, ob in bestimmten Zellen Daten eingetragen wurden 2 AlPa 2490 12. Aug 2004, 15:59
lala Prüfung, ob in bestimmten Zellen Daten eingetragen wurden
Keine neuen Beiträge Excel Formeln: Felder ausfüllen nur bis aktuellem Datum 4 Salazar 906 12. Aug 2004, 15:53
fl618 Felder ausfüllen nur bis aktuellem Datum
Keine neuen Beiträge Excel Formeln: Auswahlmenü in einzelnen Zellen erstellen 5 Big_Daddy17 4515 29. Jul 2004, 11:56
ae Auswahlmenü in einzelnen Zellen erstellen
Keine neuen Beiträge Excel Formeln: Bei SVERWEIS wird die Matrix mit hochgezählt, beim kopieren. 1 MariaMagda 1606 28. Jul 2004, 14:14
Thomas Ramel Bei SVERWEIS wird die Matrix mit hochgezählt, beim kopieren.
Keine neuen Beiträge Excel Formeln: Zellen verknüpfen 2 lochohneboden 1994 22. Jul 2004, 12:35
lochohneboden Zellen verknüpfen
Keine neuen Beiträge Excel Formeln: ANZAHL in einer bestimmten Schriftfarbe formatierter Zellen 12 curious 1933 21. Jun 2004, 13:56
Gast ANZAHL in einer bestimmten Schriftfarbe formatierter Zellen
Keine neuen Beiträge Excel Formeln: Bitte um Hilfe Heute ist nicht mein Tag!! 4 Tommyboy 482 26. Mai 2004, 14:11
Tommyboy Bitte um Hilfe Heute ist nicht mein Tag!!
Keine neuen Beiträge Excel Formeln: Mittelwert über Zellen in denen auch 0 stehen kann 3 pkegelking 484 18. Mai 2004, 10:57
pkegelking Mittelwert über Zellen in denen auch 0 stehen kann
Keine neuen Beiträge Excel Formeln: =Heute() durch ein Makro reinschreiben lassen 1 clemimausi 675 14. Mai 2004, 11:38
Kuwe =Heute() durch ein Makro reinschreiben lassen
Keine neuen Beiträge Excel Formeln: Aktuelles Datum soll in einer Zelle farbig markiert werden 7 Moustee 2511 01. Mai 2004, 19:55
Gast Aktuelles Datum soll in einer Zelle farbig markiert werden
Keine neuen Beiträge Excel Formeln: Gültigkeitsregel für Datum anwenden? 4 Brandlife 1308 19. Apr 2004, 18:53
Brandlife Gültigkeitsregel für Datum anwenden?
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: JavaScript