Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl aus
zurück: Stunden raussuchen und addieren weiter: Tabelle mit mehreren/flexiblen Auswahlfeldern auszählen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Offen Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Kuschelmonster
Excel-Erfahrener (ohne VBA)


Verfasst am:
23. Apr 2014, 22:54
Rufname:
Wohnort: Hamburg

SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl aus - SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl aus

Nach oben
       Version: Office 2007

Hi zusammen,

mit der Formel
Zitat:
{=INDEX(A:A;KKLEINSTE(WENN(B$1:B$99="x";ZEILE($1:$99));1))}

aus dem Beitrag http://www.excelformeln.de/formeln.html?welcher=28 konnte ich die Formel erstellen. Jedoch bei der Zweiten Formel (für das nächste Ergebniss)
Zitat:

{=INDEX(A:A;KKLEINSTE(WENN(B$1:B$99="x";ZEILE($1:$99));2))}
bekomme ich die Fehlermeldung #Zahl.

Hier findet Ihr die Auswertung.
In der Spalte Kommentar habe ich bisher die gebuchte Menge aus gewertet und einen Kommentartext entworfen der dann in der anderen Tabelle entsprechend ausgegeben wird.
In Spalte AD sollte sich der Kommentar aus AB (so denke ich) wiederholen.
In Spalte AE wollte ich einen zweiten Kommentar erzeugen, usw. (Hier ist auch der Fehler #Zahl)
Darüber hinaus kann ich nicht herausfinden warum das erste Ergebniss nicht das aus AB ist.

Ich gehen von bis zu 3 dopplungen aus. Und möchte aus diesen Kommentaren einen Gesamtkommentar erstellen. Dieser wird dann in Tabelle Scope... ausgegeben. (siehe 2 Tabelle)

Wie in dem Beispiel zu sehen habe ich die mehrfachen Suchergebnisse farbig hinterlegt. So wie auch die Ergebnisse die in AD, AE, AF dann hintereinander stehen sollen.

Arbeitsblatt mit dem Namen 'Transportaufträge Erstkom'
 ABCEIKPQWXYZAAABACADAEAF
1SchlüsselKA/PosTA-NummerMaterialVonplatzQSTypNachplatzSollmenge VonAMEErst.datSollmenge NachSollmenge RückKommentar    
410/1225740105200111966122574074AA01A@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz10001036906151,000ST25.11.20131,0000,00025.11.2013 TA über Menge 1 ST erzeugt 07.04.2014 TA über Menge 1 ST erzeugt#ZAHL!#ZAHL!
510/1225740105200142369122574074AA01A@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz10001036906154,000ST31.01.20144,0000,00031.01.2014 TA über Menge 4 ST erzeugt 07.04.2014 TA über Menge 1 ST erzeugt#ZAHL! 
610/1225740105200142369122574052DA11A@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz10001036906151,000ST31.01.20141,0000,00031.01.2014 TA über Menge 1 ST erzeugt 07.04.2014 TA über Menge 1 ST erzeugt#ZAHL! 
13820/1225740205200111968122574074AA01A@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz10001036906141,000ST25.11.20131,0000,00025.11.2013 TA über Menge 1 ST erzeugt    
13920/1225740205200142964122574074AA01A@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz10001036906142,000ST03.02.20142,0000,00003.02.2014 TA über Menge 2 ST erzeugt    

ZelleFormel
A4=B4&"/"&E4
AB4=Y4&" TA über Menge "&Z4&" "&X4&" erzeugt"
AD4=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A4;ZEILE('Scope VPS'!$6:$2749));1))
AE4=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A4;ZEILE('Scope VPS'!$6:$2749));2))
AF4=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A4;ZEILE('Scope VPS'!$6:$2749));3))
A5=B5&"/"&E5
AB5=Y5&" TA über Menge "&Z5&" "&X5&" erzeugt"
AD5=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A5;ZEILE('Scope VPS'!$6:$2749));1))
AE5=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A5;ZEILE('Scope VPS'!$6:$2749));2))
A6=B6&"/"&E6
AB6=Y6&" TA über Menge "&Z6&" "&X6&" erzeugt"
AD6=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A6;ZEILE('Scope VPS'!$6:$2749));1))
AE6=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A6;ZEILE('Scope VPS'!$6:$2749));2))
A138=B138&"/"&E138
AB138=Y138&" TA über Menge "&Z138&" "&X138&" erzeugt"
A139=B139&"/"&E139
AB139=Y139&" TA über Menge "&Z139&" "&X139&" erzeugt"
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Tabelle in der der Gesammtkommentar (aus allen 3 Kommentaren ausgegeben werden soll)
Arbeitsblatt mit dem Namen 'Scope VPS'
ABCDEHIJMNOPQRS
12910Endmontage103401A1237055ICI9237#PLACARD "STOWAGE S21";90X28MMZS11ST10.04.201411 10/123705507.04.2014 TA über Menge 1 ST erzeugt
13010Endmontage103401A1238197103401-01-002#PLATEZS11ST10.04.201411 10/123819707.04.2014 TA über Menge 1 ST erzeugt
13110Endmontage103401A1238341A20133-7#LATCHZS12ST10.04.201422 10/123834107.04.2014 TA über Menge 1 ST erzeugt
13210Endmontage103401A1238394103403-07-013#PLATEZS12ST10.04.201422 10/123839407.04.2014 TA über Menge 2 ST erzeugt
13310Endmontage103401A1238637103400-01-017#SHROUD;Mat.: 3.3535ZS11ST10.04.201411 10/123863707.04.2014 TA über Menge 1 ST erzeugt
13410Endmontage103401A1238642103404-01-041#PLATE;Mat.: 3.3535ZS12ST10.04.201422 10/123864207.04.2014 TA über Menge 2 ST erzeugt

ZelleFormel
P129=WENN(I129<=O129;"";"fehlt")
R129=A129&"/"&D129
S129=WENNFEHLER(SVERWEIS(R129;'Transportaufträge Erstkom'!$A$2:$AB$1300;28;0);"möglicherweise kein Bestand")
P130=WENN(I130<=O130;"";"fehlt")
R130=A130&"/"&D130
S130=WENNFEHLER(SVERWEIS(R130;'Transportaufträge Erstkom'!$A$2:$AB$1300;28;0);"möglicherweise kein Bestand")
P131=WENN(I131<=O131;"";"fehlt")
R131=A131&"/"&D131
S131=WENNFEHLER(SVERWEIS(R131;'Transportaufträge Erstkom'!$A$2:$AB$1300;28;0);"möglicherweise kein Bestand")
P132=WENN(I132<=O132;"";"fehlt")
R132=A132&"/"&D132
S132=WENNFEHLER(SVERWEIS(R132;'Transportaufträge Erstkom'!$A$2:$AB$1300;28;0);"möglicherweise kein Bestand")
P133=WENN(I133<=O133;"";"fehlt")
R133=A133&"/"&D133
S133=WENNFEHLER(SVERWEIS(R133;'Transportaufträge Erstkom'!$A$2:$AB$1300;28;0);"möglicherweise kein Bestand")
P134=WENN(I134<=O134;"";"fehlt")
R134=A134&"/"&D134
S134=WENNFEHLER(SVERWEIS(R134;'Transportaufträge Erstkom'!$A$2:$AB$1300;28;0);"möglicherweise kein Bestand")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gast



Verfasst am:
23. Apr 2014, 23:46
Rufname:

AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a - AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a

Nach oben
       Version: Office 2007

Hi!

Ohne jetzt auf weiteres geachtet zu haben: Du hast die Formel nicht als Matrixformel (Strg+Shift+Enter) eingegeben!
Kuschelmonster
Excel-Erfahrener (ohne VBA)


Verfasst am:
24. Apr 2014, 00:10
Rufname:
Wohnort: Hamburg

AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a - AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a

Nach oben
       Version: Office 2007

Ich habe den Corsour in die Zelle gestelt und die Zellen mit Strg+Shift + Enter abgeschloßen
Warum die Geschweiften Klammern nicht angezeigt werden ist mir nicht klar.

Kann es sein das Matrixformeln in freigegeben Tabellen nicht laufen?

Arbeitsblatt mit dem Namen 'Transportaufträge Erstkom'
 ABCEIKPQWXYZAAABACADAEAF
1SchlüsselKA/PosTA-NummerMaterialVonplatzQSTypNachplatzSollmenge VonAMEErst.datSollmenge NachSollmenge RückKommentar    
410/1225740105200111966122574074AA01A@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz10001036906151,000ST25.11.20131,0000,00025.11.2013 TA über Menge 1 ST erzeugt 07.04.2014 TA über Menge 1 ST erzeugt#ZAHL!#ZAHL!
510/1225740105200142369122574074AA01A@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz10001036906154,000ST31.01.20144,0000,00031.01.2014 TA über Menge 4 ST erzeugt 07.04.2014 TA über Menge 1 ST erzeugt#ZAHL!#ZAHL!
610/1225740105200142369122574052DA11A@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz10001036906151,000ST31.01.20141,0000,00031.01.2014 TA über Menge 1 ST erzeugt 07.04.2014 TA über Menge 1 ST erzeugt#ZAHL!#ZAHL!
13820/1225740205200111968122574074AA01A@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz10001036906141,000ST25.11.20131,0000,00025.11.2013 TA über Menge 1 ST erzeugt 07.04.2014 TA über Menge 4 ST erzeugt#ZAHL!#ZAHL!
13920/1225740205200142964122574074AA01A@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz10001036906142,000ST03.02.20142,0000,00003.02.2014 TA über Menge 2 ST erzeugt 07.04.2014 TA über Menge 4 ST erzeugt#ZAHL!#ZAHL!

ZelleFormel
A4=B4&"/"&E4
AB4=Y4&" TA über Menge "&Z4&" "&X4&" erzeugt"
AD4{=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A4;ZEILE('Scope VPS'!$6:$2749));1))}
AE4{=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A4;ZEILE('Scope VPS'!$6:$2749));2))}
AF4{=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A4;ZEILE('Scope VPS'!$6:$2749));3))}
A5=B5&"/"&E5
AB5=Y5&" TA über Menge "&Z5&" "&X5&" erzeugt"
AD5{=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A5;ZEILE('Scope VPS'!$6:$2749));1))}
AE5{=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A5;ZEILE('Scope VPS'!$6:$2749));2))}
AF5{=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A5;ZEILE('Scope VPS'!$6:$2749));3))}
A6=B6&"/"&E6
AB6=Y6&" TA über Menge "&Z6&" "&X6&" erzeugt"
AD6{=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A6;ZEILE('Scope VPS'!$6:$2749));1))}
AE6{=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A6;ZEILE('Scope VPS'!$6:$2749));2))}
AF6{=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A6;ZEILE('Scope VPS'!$6:$2749));3))}
A138=B138&"/"&E138
AB138=Y138&" TA über Menge "&Z138&" "&X138&" erzeugt"
AD138{=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A138;ZEILE('Scope VPS'!$6:$2749));1))}
AE138{=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A138;ZEILE('Scope VPS'!$6:$2749));2))}
AF138{=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A138;ZEILE('Scope VPS'!$6:$2749));3))}
A139=B139&"/"&E139
AB139=Y139&" TA über Menge "&Z139&" "&X139&" erzeugt"
AD139{=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A139;ZEILE('Scope VPS'!$6:$2749));1))}
AE139{=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A139;ZEILE('Scope VPS'!$6:$2749));2))}
AF139{=INDEX('Transportaufträge Erstkom'!$AB$2:$AB$1280;KKLEINSTE(WENN('Scope VPS'!$R$6:$R$2749='Transportaufträge Erstkom'!A139;ZEILE('Scope VPS'!$6:$2749));3))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


nach der Rücknahme der Freigabe.
Kuschelmonster
Excel-Erfahrener (ohne VBA)


Verfasst am:
24. Apr 2014, 20:43
Rufname:
Wohnort: Hamburg

AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a - AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a

Nach oben
       Version: Office 2007

Auch nach dem ich die Matrix mit Strg+Shift+Enter abgeschloßen habe hat sich nicht verändert.
Im ersten Fund wird die Falsche Ausgabe erzeugt.
Im zweiten und dritten fund kommt der Fehler.

Zum bessern Verständniss habe ich die beispielhafen Funde 1 bis 3 und die Ausgaben 1 bis 3 zusätzlich in "Transportaufträge Erstkom" kommentiert.



Beispieltabelle 3 Fund.xlsx
 Beschreibung:

Download
 Dateiname:  Beispieltabelle 3 Fund.xlsx
 Dateigröße:  600.57 KB
 Heruntergeladen:  7 mal

shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
25. Apr 2014, 06:27
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände

AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a - AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a

Nach oben
       Version: Office 2007

Hallo Kuschelmonster

Ich vermute du möchtest so etwas.
Ob das Sinn macht lasse ich mal offen.
 ACADAEAFAGAH
225.11.2013_TA_über_Menge_1_ST_erzeugt25.11.2013 TA über Menge 1 ST erzeugt    

ZelleFormel
AC2=GLÄTTEN(WECHSELN(WECHSELN(VERKETTEN(AD2;"#";AE2;"#";AF2;"#";AG2);" ";"_");"#";" "))
AD2{=WENNFEHLER(INDEX($AB:$AB;KKLEINSTE(WENN($A$2:$A$1280=$A2;ZEILE($A$2:$A$1280));SPALTEN($AD2:AD2)));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


 S
5DSM

Kommentar DSM
607.04.2014_TA_über_Menge_2_ST_erzeugt

ZelleFormel
S6=WENNFEHLER(INDEX('Transportaufträge Erstkom'!AC:AC;VERGLEICH(R6;'Transportaufträge Erstkom'!A:A;0));"möglicherweise kein Bestand")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Kuschelmonster
Excel-Erfahrener (ohne VBA)


Verfasst am:
25. Apr 2014, 20:41
Rufname:
Wohnort: Hamburg

AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a - AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a

Nach oben
       Version: Office 2007

Nein das Verketten ist nicht mein Problem.

Da der SVerweis immer nur den 1 Fund ausgibt habe ich die Formel mit dem Index verwendt.
Doch ich stelle fest das der Erste Fund nicht zu stimmen scheint.
Und der zweite Fund und dritte Fund haben den Fehler #Zahl
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
26. Apr 2014, 01:06
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände

AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a - AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a

Nach oben
       Version: Office 2007

Hi

Zitat:
Doch ich stelle fest das der Erste Fund nicht zu stimmen scheint.
Und der zweite Fund und dritte Fund haben den Fehler #Zahl

Warum soll das erste Ergebnis nicht stimmen?
Und in den Folge-Zellen steht "" und nicht #ZAHL!.

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Kuschelmonster
Excel-Erfahrener (ohne VBA)


Verfasst am:
26. Apr 2014, 23:07
Rufname:
Wohnort: Hamburg

AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a - AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a

Nach oben
       Version: Office 2007

Schaue ich in die Tabelle "Arbeitsblatt mit dem Namen 'Transportaufträge Erstkom'"

dann sehe ich orange Markiert 3 Spalten.
Im ersten steht ein anderer als in der gelben Spalte Links daneben.
Dies ist mit normalem SVerweis der erste Fund.
In den zwei Spalten rechts neben der ersten orangen Spalte sehe ich die Fehler #Zahl
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
26. Apr 2014, 23:18
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände

AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a - AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a

Nach oben
       Version: Office 2007

Hi

Wozu mache ich hier eigentlich Formelvorschläge?

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Kuschelmonster
Excel-Erfahrener (ohne VBA)


Verfasst am:
27. Apr 2014, 14:34
Rufname:
Wohnort: Hamburg

AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a - AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a

Nach oben
       Version: Office 2007

Die Fehler sind nicht mehr zu sehen wie in Deinem Beispiel aber ich möchte das die drei Funde neben einander in den Spalten AD, AE, AF ausgegebe werden.
Dann kann ich in Spalte AB die drei über
Code:
=AD&" / "&"AE&" / "&AF
als Gesammtkommentar zusammenfassen.

Im Moment wird mit den (Unterstrichen) immer noch nur der 1 Fund angezeigt.
Und das versuche ich zu ändern.

schönen Sonntag,
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
27. Apr 2014, 15:16
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände

AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a - AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a

Nach oben
       Version: Office 2007

Hi

Hast du schon mal probiert die Formel in AD2 nach rechts zu kopieren?

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
BoskoBiati
Im Profil kannst Du frei den Rang ändern


Verfasst am:
27. Apr 2014, 15:49
Rufname: Bosko

AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a - AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Zahl a

Nach oben
       Version: Office 2007

Hallo,

und warum eigentlich nicht gleich so:

Code:
=WENN(ZÄHLENWENN($A$1:$A2;$A2)>1;"";Y2&" TA über Menge "&SUMMENPRODUKT(($A$2:$A$2780=$A2)*1;$Z$2:$Z$2780)&X2&" erzeugt")


für AB2

_________________
Gruß

Bosko

Ich würde mich freuen zu erfahren, ob ich helfen konnte.
Kuschelmonster
Excel-Erfahrener (ohne VBA)


Verfasst am:
27. Apr 2014, 17:22
Rufname:
Wohnort: Hamburg

Re: AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Za - Re: AW: SVerweis mit mehreren funden. 2 und 3 Fund geben #Za

Nach oben
       Version: Office 2007

BoskoBiati - 27. Apr 2014, 15:49 hat folgendes geschrieben:
Hallo,

und warum eigentlich nicht gleich so:

Code:
=WENN(ZÄHLENWENN($A$1:$A2;$A2)>1;"";Y2&" TA über Menge "&SUMMENPRODUKT(($A$2:$A$2780=$A2)*1;$Z$2:$Z$2780)&X2&" erzeugt")


für AB2


danke BoskoBiati das ist eine tolle Möglichkeit.
Und so
Code:
=WENN(ZÄHLENWENN($AA$1:$AA4;$AA4)>1;"";X4&" "&ZÄHLENWENN($AA$1:$AA$2780;$AA4)&"TA über Menge "&SUMMENPRODUKT(($AA$2:$AA$2780=$AA4)*1;$Y$2:$Y$2780)&W4&" erzeugt; SAP-Auto")

kann ich auch noch sehen wieviele TAs notwenig waren.
Doch in einer Weiterentwicklung parallelen Weiterentwicklung des Kommentars hatte ich auch unterschieden zwischen dem Inhalt in Spalte (Spaltenüberschrift) QS-Status unterschieden.

=WENN(R6="@5B\QEntnahme und Transport quit.@ Entnahme und Transport quit.";X6&" TA entstanden, ausgelagert";WENN(R6="@5C\Qkeine Quittierung erfolgt@ keine Quittierung erfolgt";X6&" TA entstanden, Quittierung offen";"Test"))

Habt Ihr eine Idee die auf die einfachere Lösung von BoskoBiati aufsetzt.

Ein Ergebniss stelle ich mir in etwa so vor.
Zitat:
Datum: 1TA über 4 Stück erzeugt, gebucht / 2TA über 2 Stück erzeugt, Quittierung offen

Ich habe nur keine Ahnung wo ich diese Unterscheidung einarbeiten muss.
Kuschelmonster
Excel-Erfahrener (ohne VBA)


Verfasst am:
30. Apr 2014, 05:58
Rufname:
Wohnort: Hamburg

Funde 2 und 3 mit der Trennung - - Funde 2 und 3 mit der Trennung -

Nach oben
       Version: Office 2007

Hallo,

nachdem ich auf die Möglichkeit in 2007 mehrere Kriterien mit Zählenwenns zu verbinden. Habe ich für die Anzahl in der von mir gewünschten Ausgabe folgendes Entwickelt.

(In Spalte AB die von BoskoBiat vorgeschlagene Variante. In den Spalten AC und AD (grün hinterlegt) die mit der Trennung weiterentwickelten Varianten

Leider brauche ich für die Trennung in "Entnahme" und "keine Quittierung" Kriterium in Spalte R noch eine Hilfe für die Menge.
Wie erwähnt für die Anzahl der TA habe ich "ZÄHLENWENNS" verwendet.
Für die Menge wird Summewenns vorgeschlagen.
Doch in dem Vorschlag von BoskoBiati wird Summenprodukt vorgeschlagen.
Da hackt es ich bin nicht sicher wie ich das umstricken muss. Muss ich SUMMEWENNS verwenden. Oder gibt es auch SUMMENPRODUKTS ab 2007?


Arbeitsblatt mit dem Namen 'Transportaufträge Erstkom'
 ABDEFGHIJKLMNOPQRSTUVWXYZAAABACAD
1472052001710911241412  00601GB03A1@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz@5F\QLeer@ Leer0005  1000103636005 @5B\QEntnahme und Transport quit.@ Entnahme und Transport quit.   1,000ST28.03.20141,0000,00020/124141228.03.2014 3TA über Menge 4ST erzeugt; SAP-Auto28.03.2014 2TA über Menge 4ST ausgelagert; SAP-Auto28.03.2014 1TA über Menge 4ST erzeugt, Quittierung offen; SAP-Auto
1622052001710941241412  00601GB03A1@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz@5F\QLeer@ Leer0005  1000103767401 @5B\QEntnahme und Transport quit.@ Entnahme und Transport quit.   1,000ST28.03.20141,0000,00020/1241412   
2682052001755881241412  00601GB03A1@5F\QLeer@ Leer@5F\QLeer@ Leer0005  1000103644794 @5C\Qkeine Quittierung erfolgt@ keine Quittierung erfolgt   2,000ST07.04.20142,0000,00020/1241412   
2903052001711001241412  00601GB03A1@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz@5F\QLeer@ Leer0005  1000103636006 @5B\QEntnahme und Transport quit.@ Entnahme und Transport quit.   1,000ST28.03.20141,0000,00030/124141228.03.2014 2TA über Menge 2ST erzeugt; SAP-Auto  
3053052001711031241412  00601GB03A1@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz@5F\QLeer@ Leer0005  1000103636057 @5B\QEntnahme und Transport quit.@ Entnahme und Transport quit.   1,000ST28.03.20141,0000,00030/1241412   
5815052001711141241412  00601GB03A1@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz@5F\QLeer@ Leer0005  1000103636058 @5B\QEntnahme und Transport quit.@ Entnahme und Transport quit.   2,000ST28.03.20142,0000,00050/124141228.03.2014 2TA über Menge 3ST erzeugt; SAP-Auto  
6865052001756021241412  00601GB03A1@5F\QLeer@ Leer@5F\QLeer@ Leer0005  1000103644795 @5C\Qkeine Quittierung erfolgt@ keine Quittierung erfolgt   1,000ST07.04.20141,0000,00050/1241412   
7066052001711211241412  00601GB03A1@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz@5F\QLeer@ Leer0005  1000103636007 @5B\QEntnahme und Transport quit.@ Entnahme und Transport quit.   2,000ST28.03.20142,0000,00060/124141228.03.2014 2TA über Menge 3ST erzeugt; SAP-Auto  
8096052001756121241412  00601GB03A1@5F\QLeer@ Leer@5F\QLeer@ Leer0005  1000103644796 @5C\Qkeine Quittierung erfolgt@ keine Quittierung erfolgt   1,000ST07.04.20141,0000,00060/1241412   
8307052001711281241412  00601GB03A1@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz@5F\QLeer@ Leer0005  1000103636008 @5B\QEntnahme und Transport quit.@ Entnahme und Transport quit.   1,000ST28.03.20141,0000,00070/124141228.03.2014 3TA über Menge 4ST erzeugt; SAP-Auto  
8457052001711311241412  00601GB03A1@20\QQuittiert ohne Differenz@ Quittiert ohne Differenz@5F\QLeer@ Leer0005  1000103636059 @5B\QEntnahme und Transport quit.@ Entnahme und Transport quit.   1,000ST28.03.20141,0000,00070/1241412   
9507052001756291241412  00601GB03A1@5F\QLeer@ Leer@5F\QLeer@ Leer0005  1000103643365 @5C\Qkeine Quittierung erfolgt@ keine Quittierung erfolgt   2,000ST07.04.20142,0000,00070/1241412   

ZelleFormel
AA147=A147&"/"&D147
AB147=WENN(ZÄHLENWENN($AA$1:$AA147;$AA147)>1;"";X147&" "&ZÄHLENWENN($AA$1:$AA$2780;$AA147)&"TA über Menge "&SUMMENPRODUKT(($AA$2:$AA$2780=$AA147)*1;$Y$2:$Y$2780)&W147&" erzeugt; SAP-Auto")
AC147=WENN(ZÄHLENWENN($AA$1:$AA147;$AA147)>1;"";X147&" "&ZÄHLENWENNS($AA$1:$AA$2780;$AA147;$R$1:$R$2780;"*Entnahme und Transport quit*")&"TA über Menge "&SUMMENPRODUKT(($AA$2:$AA$2780=$AA147)*1;$Y$2:$Y$2780)&W147&" ausgelagert; SAP-Auto")
AD147=WENN(ZÄHLENWENN($AA$1:$AA147;$AA147)>1;"";X147&" "&ZÄHLENWENNS($AA$1:$AA$2780;$AA147;$R$1:$R$2780;"*keine Quittierung erfolgt*")&"TA über Menge "&SUMMENPRODUKT(($AA$2:$AA$2780=$AA147)*1;$Y$2:$Y$2780)&W147&" erzeugt, Quittierung offen; SAP-Auto")
AA162=A162&"/"&D162
AB162=WENN(ZÄHLENWENN($AA$1:$AA162;$AA162)>1;"";X162&" "&ZÄHLENWENN($AA$1:$AA$2780;$AA162)&"TA über Menge "&SUMMENPRODUKT(($AA$2:$AA$2780=$AA162)*1;$Y$2:$Y$2780)&W162&" erzeugt; SAP-Auto")
AA268=A268&"/"&D268
AB268=WENN(ZÄHLENWENN($AA$1:$AA268;$AA268)>1;"";X268&" "&ZÄHLENWENN($AA$1:$AA$2780;$AA268)&"TA über Menge "&SUMMENPRODUKT(($AA$2:$AA$2780=$AA268)*1;$Y$2:$Y$2780)&W268&" erzeugt; SAP-Auto")
AA290=A290&"/"&D290
AB290=WENN(ZÄHLENWENN($AA$1:$AA290;$AA290)>1;"";X290&" "&ZÄHLENWENN($AA$1:$AA$2780;$AA290)&"TA über Menge "&SUMMENPRODUKT(($AA$2:$AA$2780=$AA290)*1;$Y$2:$Y$2780)&W290&" erzeugt; SAP-Auto")
AA305=A305&"/"&D305
AB305=WENN(ZÄHLENWENN($AA$1:$AA305;$AA305)>1;"";X305&" "&ZÄHLENWENN($AA$1:$AA$2780;$AA305)&"TA über Menge "&SUMMENPRODUKT(($AA$2:$AA$2780=$AA305)*1;$Y$2:$Y$2780)&W305&" erzeugt; SAP-Auto")
AA581=A581&"/"&D581
AB581=WENN(ZÄHLENWENN($AA$1:$AA581;$AA581)>1;"";X581&" "&ZÄHLENWENN($AA$1:$AA$2780;$AA581)&"TA über Menge "&SUMMENPRODUKT(($AA$2:$AA$2780=$AA581)*1;$Y$2:$Y$2780)&W581&" erzeugt; SAP-Auto")
AA686=A686&"/"&D686
AB686=WENN(ZÄHLENWENN($AA$1:$AA686;$AA686)>1;"";X686&" "&ZÄHLENWENN($AA$1:$AA$2780;$AA686)&"TA über Menge "&SUMMENPRODUKT(($AA$2:$AA$2780=$AA686)*1;$Y$2:$Y$2780)&W686&" erzeugt; SAP-Auto")
AA706=A706&"/"&D706
AB706=WENN(ZÄHLENWENN($AA$1:$AA706;$AA706)>1;"";X706&" "&ZÄHLENWENN($AA$1:$AA$2780;$AA706)&"TA über Menge "&SUMMENPRODUKT(($AA$2:$AA$2780=$AA706)*1;$Y$2:$Y$2780)&W706&" erzeugt; SAP-Auto")
AA809=A809&"/"&D809
AB809=WENN(ZÄHLENWENN($AA$1:$AA809;$AA809)>1;"";X809&" "&ZÄHLENWENN($AA$1:$AA$2780;$AA809)&"TA über Menge "&SUMMENPRODUKT(($AA$2:$AA$2780=$AA809)*1;$Y$2:$Y$2780)&W809&" erzeugt; SAP-Auto")
AA830=A830&"/"&D830
AB830=WENN(ZÄHLENWENN($AA$1:$AA830;$AA830)>1;"";X830&" "&ZÄHLENWENN($AA$1:$AA$2780;$AA830)&"TA über Menge "&SUMMENPRODUKT(($AA$2:$AA$2780=$AA830)*1;$Y$2:$Y$2780)&W830&" erzeugt; SAP-Auto")
AA845=A845&"/"&D845
AB845=WENN(ZÄHLENWENN($AA$1:$AA845;$AA845)>1;"";X845&" "&ZÄHLENWENN($AA$1:$AA$2780;$AA845)&"TA über Menge "&SUMMENPRODUKT(($AA$2:$AA$2780=$AA845)*1;$Y$2:$Y$2780)&W845&" erzeugt; SAP-Auto")
AA950=A950&"/"&D950
AB950=WENN(ZÄHLENWENN($AA$1:$AA950;$AA950)>1;"";X950&" "&ZÄHLENWENN($AA$1:$AA$2780;$AA950)&"TA über Menge "&SUMMENPRODUKT(($AA$2:$AA$2780=$AA950)*1;$Y$2:$Y$2780)&W950&" erzeugt; SAP-Auto")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Vergleich mit SVERWEIS und WENN 4 Marc 3124 27. Sep 2004, 12:44
Marc Vergleich mit SVERWEIS und WENN
Keine neuen Beiträge Excel Formeln: Tabellendaten mit SVERWEIS vergleichen 7 Gast 6039 19. Sep 2004, 00:45
fl618 Tabellendaten mit SVERWEIS vergleichen
Keine neuen Beiträge Excel Formeln: Fehler in Formel mit "WENN" und "SVERWEIS&quo 1 Peter VBA 885 14. Sep 2004, 17:21
fl618 Fehler in Formel mit "WENN" und "SVERWEIS&quo
Keine neuen Beiträge Excel Formeln: Probleme mit sverweis und vergleich 4 Gast 1891 07. Sep 2004, 15:08
fl618 Probleme mit sverweis und vergleich
Keine neuen Beiträge Excel Formeln: Hilfe! Wenn..Dann mit mehreren Dann-Werten 4 Nina81 803 25. Aug 2004, 11:51
Nina81 Hilfe! Wenn..Dann mit mehreren Dann-Werten
Keine neuen Beiträge Excel Formeln: komplizierte Zählung mit mehreren Faktoren 14 SeRo 875 23. Aug 2004, 12:33
ae komplizierte Zählung mit mehreren Faktoren
Keine neuen Beiträge Excel Formeln: Problem mit Sverweis 2 Bernett22 1279 03. Aug 2004, 12:21
Bernett22 Problem mit Sverweis
Keine neuen Beiträge Excel Formeln: Bei SVERWEIS wird die Matrix mit hochgezählt, beim kopieren. 1 MariaMagda 1606 28. Jul 2004, 14:14
Thomas Ramel Bei SVERWEIS wird die Matrix mit hochgezählt, beim kopieren.
Keine neuen Beiträge Excel Formeln: Excel 2000: Kombination von SVERWEIS und BEREICH.VERSCHIEBEN 2 cosmic 2710 21. Jul 2004, 13:56
cosmic Excel 2000: Kombination von SVERWEIS und BEREICH.VERSCHIEBEN
Keine neuen Beiträge Excel Formeln: SVERWEIS - Problem! 7 Takahara1974 2092 09. Jul 2004, 15:49
Arnim SVERWEIS - Problem!
Keine neuen Beiträge Excel Formeln: Kst.daten in einen Tabellenblatt zusammenfassen ...sverweis? 7 Memo 4623 05. Jul 2004, 12:05
Memo Kst.daten in einen Tabellenblatt zusammenfassen ...sverweis?
Keine neuen Beiträge Excel Formeln: Zahl im Textformat mit 0 ergänzen 2 WaterMan 808 05. Jul 2004, 10:02
WaterMan Zahl im Textformat mit 0 ergänzen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Word Serienbriefe