Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Autoausfüllen: Laufrahmen jede 5. Zeile ohne Abstand
zurück: Tage in Jahre und Monate umrechnen weiter: Wenn formel bei Stunden lohn Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
DomSta
Im Profil kannst Du frei den Rang ändern


Verfasst am:
12. Feb 2014, 18:06
Rufname:
Wohnort: Augsburg

Autoausfüllen: Laufrahmen jede 5. Zeile ohne Abstand - Autoausfüllen: Laufrahmen jede 5. Zeile ohne Abstand

Nach oben
       Version: Office 2010

Hallo zusammen,

ich würde mir gerne mein Leben beim einfügen von Verknüpfungen erleichtern und hoffe, dass ihr mir weiter helfen könnt.

Hier mein Problem:

Ich möchte beim ziehen des Laufrahmens nach unten nur jeden 5. Wert pro Zeile ausgegeben bekommen.

Das Beispiel:

Auf "Blatt 1" habe ich "Warennamen"(B10) die zu unterschiedlichen Preisen verkauft werden(C10-C14)
(B15) folgt ein weiterer Warennamen, (B20) der nächste, (B25) der nächste usw.
Jetzt möchte ich in "Blatt 2" eine Liste erstellen auf der alle "Warennamen" unterinander erscheinen. Ich würde gerne darauf verzichten jede Zeile einzeln zu verknüpfen.
Da ich viele dieser Fälle zu bearbeiten habe benötige ich dringend eine Möglichkeit der Erleichterung.

Vielen Dank schon mal für eure Hilfe!
slowboarder
Im Profil kannst Du frei den Rang ändern


Verfasst am:
12. Feb 2014, 18:11
Rufname:


AW: Autoausfüllen: Laufrahmen jede 5. Zeile ohne Abstand - AW: Autoausfüllen: Laufrahmen jede 5. Zeile ohne Abstand

Nach oben
       Version: Office 2010

Hi

wenns konsequent jede 5. Zeile beginnen mit Zeile 10 ist, könntest du mit berechneten Zellbezügen arbeiten:

=Index('Blatt 1'!B:B;Zeile(A2)*5)

Formel dann einfach nach unten ziehen.

gruß Daniel
DomSta
Im Profil kannst Du frei den Rang ändern


Verfasst am:
12. Feb 2014, 18:20
Rufname:
Wohnort: Augsburg

Re: AW: Autoausfüllen: Laufrahmen jede 5. Zeile ohne Abstand - Re: AW: Autoausfüllen: Laufrahmen jede 5. Zeile ohne Abstand

Nach oben
       Version: Office 2010

slowboarder - 12. Feb 2014, 17:11 hat folgendes geschrieben:
Hi

wenns konsequent jede 5. Zeile beginnen mit Zeile 10 ist, könntest du mit berechneten Zellbezügen arbeiten:

=Index('Blatt 1'!B:B;Zeile(A2)*5)

Formel dann einfach nach unten ziehen.

gruß Daniel


Vielen Dank für deine schnelle Antwort.

Bei meinem aktuellen Problem bezieht es sich auf jede 5. Zeile. Da ich dieses Problem jedoch noch öfter haben werde und es sich dabei immer um andere Abstände handeln wird, wäre es klasse wenn du mir eine kleine Erklärung zu deiner Formel geben könntest damit ich mir in Zukunft selber weiter helfen kann.

Grüße
DomSta
Im Profil kannst Du frei den Rang ändern


Verfasst am:
17. Feb 2014, 19:48
Rufname:
Wohnort: Augsburg

AW: Autoausfüllen: Laufrahmen jede 5. Zeile ohne Abstand - AW: Autoausfüllen: Laufrahmen jede 5. Zeile ohne Abstand

Nach oben
       Version: Office 2010

Hallo zusammen,

nachdem ich keine Antwort mehr bekommen habe stelle ich die Frage um da sie evtl. nicht verständlich genug gestellt war.

Ich habe auf "Blatt 1" in folgenden Zellen Werte:
A26
A46
A66
A86
usw.
Diese Zellen wiederholen sich alle 20 Zeilen.

Jetzt möchte ich in "Blatt 2" durch das Ziehen eines Laufrahmens in jeder Folgenden Zelle diese Information einfügen:
"Blatt 1" (A26) soll jetzt in "Blatt 2" (B40)
"Blatt 1" (A46) soll jetzt in "Blatt 2" (B41)
"Blatt 1" (A66) soll jetzt in "Blatt 2" (B42)
usw.
erscheinen.

Weiter geht es mit "Blatt 3"
Auf diesem Blatt sollen die Informationen von "Blatt 1" wie in Blatt 2 erscheinen, allerdings nur alle 2 Zeilen.
"Blatt 1" (A26) soll jetzt in "Blatt 3" (E32)
"Blatt 1" (A46) soll jetzt in "Blatt 3" (E34)
"Blatt 1" (A66) soll jetzt in "Blatt 3" (E36)
usw.
erscheinen.

Wie kann ich das bewerkstelligen?

Wäre klasse wenn ihr mir weiter helfen könnt.

Grüße
HermannZ
Excel-Kenner


Verfasst am:
17. Feb 2014, 20:25
Rufname: Hermann

AW: Autoausfüllen: Laufrahmen jede 5. Zeile ohne Abstand - AW: Autoausfüllen: Laufrahmen jede 5. Zeile ohne Abstand

Nach oben
       Version: Office 2010

Hi;

für die erste Variante sollte gehen;

=INDEX(Blatt1!A:A;(ZEILE(A1)-1)*20+26)

diese Formel in Blatt2 Zelle B40 und nachunten kopieren.

für das zweite Beispiel sollte gehen;

=WENN(REST(ZEILE();2)=0;INDEX(Blatt1!A:A;(ZEILE(A1)-1)*10+26);"")

diese Formel in Blatt3 E32 und nach unten kopieren
hier wird dann jeweils in die zwischen Zeile "" gesetzt.

ich hoffe ich habe das jetzt auch richtig verstanden.

_________________
Gruss Hermann
DomSta
Im Profil kannst Du frei den Rang ändern


Verfasst am:
18. Feb 2014, 15:45
Rufname:
Wohnort: Augsburg

Re: AW: Autoausfüllen: Laufrahmen jede 5. Zeile ohne Abstand - Re: AW: Autoausfüllen: Laufrahmen jede 5. Zeile ohne Abstand

Nach oben
       Version: Office 2010

HermannZ - 17. Feb 2014, 19:25 hat folgendes geschrieben:
Hi;

für die erste Variante sollte gehen;

=INDEX(Blatt1!A:A;(ZEILE(A1)-1)*20+26)

diese Formel in Blatt2 Zelle B40 und nachunten kopieren.



Das funktioniert sehr gut. Danke

HermannZ - 17. Feb 2014, 19:25 hat folgendes geschrieben:


für das zweite Beispiel sollte gehen;

=WENN(REST(ZEILE();2)=0;INDEX(Blatt1!A:A;(ZEILE(A1)-1)*10+26);"")

diese Formel in Blatt3 E32 und nach unten kopieren
hier wird dann jeweils in die zwischen Zeile "" gesetzt.

ich hoffe ich habe das jetzt auch richtig verstanden.


Da erscheint bei mir 0 in der Tabelle.
Ich denke es könnte daran liegen dass an der Stelle ...Blatt1!A:A;(Zeile(A1)-1)...
sich "(A1)" auf "A1" auf "Blatt3" anstelle von "Blatt1" bezieht.
Ich habe das mit meinen geringen Excel Kenntnissen versucht zu ändern aber es hat leider nicht funktioniert.
Wäre klasse wenn du mir da noch einmal weiterhelfen könntest.

Grüße
HermannZ
Excel-Kenner


Verfasst am:
19. Feb 2014, 20:07
Rufname: Hermann

AW: Autoausfüllen: Laufrahmen jede 5. Zeile ohne Abstand - AW: Autoausfüllen: Laufrahmen jede 5. Zeile ohne Abstand

Nach oben
       Version: Office 2010

Hi;

da kann ich dir jetzt nicht folgen,habe interessehalber dié Formel einmal in
einbe Tabelle eingebaut, sie geht einwandfrei.

zur Erklärung:

hier zuerst einmal ein Beispiel damit du sehen kannst das das geht;

 A
32150
33 
34250
35 
36350
37 
38450

Formeln der Tabelle
ZelleFormel
A32=WENN(REST(ZEILE();2)=0;INDEX(Tabelle1!A:A;(ZEILE(A1)-1)*10+26);"")
A34=WENN(REST(ZEILE();2)=0;INDEX(Tabelle1!A:A;(ZEILE(A3)-1)*10+26);"")
A36=WENN(REST(ZEILE();2)=0;INDEX(Tabelle1!A:A;(ZEILE(A5)-1)*10+26);"")
A38=WENN(REST(ZEILE();2)=0;INDEX(Tabelle1!A:A;(ZEILE(A7)-1)*10+26);"")


Excel Jeanie Html

die Formel ist eigend ganz einfach zu verstehen;

Der erste Teil der Formel;

=WENN(REST(ZEILE();2)=0;

dient ja nur dazu die Zeile zu überbrücken damit dort nichts angezeigt wird.

Beginnend mit der Zeile 32 mit der Rest Funktion wird hier 0 ermittelt also
wird die Formel ausgelöst.
für die Zeile 33 wird 1 ermittelt und somit "" ausgegeben, usw.

Der zeite Teil der formel;

INDEX(Tabelle1!A:A;(ZEILE(A1)-1)*10+26)

ist der eigendlich relevante teil, mit (ZEILE(A1)-1)*10+26 wird die Zeile
bestimmt aus der in Tabelle1 A:A der Wert übernommen werden soll.
für diese erste Zeile ergibt sich (ZEILE(A1)-1) = 0 *10 + 26 = 26
also wird der Wert aus Tabelle1 A26 übernommen
für die Zweite Zeile wäre das (ZEILE(A2)-1) = 1 * 10 + 26 = 36
für diese Zeile findet aber keine Berechnung statt da sie ja von der WENN
Funktion unterdrückt wurde

usw:

Ich hoffe du kannst damit was anfangen.

_________________
Gruss Hermann
DomSta
Im Profil kannst Du frei den Rang ändern


Verfasst am:
19. Feb 2014, 20:23
Rufname:
Wohnort: Augsburg


Re: AW: Autoausfüllen: Laufrahmen jede 5. Zeile ohne Abstand - Re: AW: Autoausfüllen: Laufrahmen jede 5. Zeile ohne Abstand

Nach oben
       Version: Office 2010

HermannZ - 19. Feb 2014, 19:07 hat folgendes geschrieben:
Hi;

da kann ich dir jetzt nicht folgen,habe interessehalber dié Formel einmal in
einbe Tabelle eingebaut, sie geht einwandfrei.

zur Erklärung:

hier zuerst einmal ein Beispiel damit du sehen kannst das das geht;

<table border="1" cellspacing="0" cellpadding="0" style="font-family:Times New Roman,Arial; font-size:12pt; background-color:#ffffff; padding-left:2pt; padding-right:2pt; "> <colgroup><col style="font-weight:bold; width:30px; "><col style="width:72px;"></colgroup><tr style="background-color:#cacaca; text-align:center; font-weight:bold; font-size:8pt; "><td> </td><td>A</td></tr><tr style="height:14px ;"><td style="font-size:8pt; background-color:#cacaca; text-align:center; ">32</td><td style="color:#333333; font-size:10pt; text-align:right; ">150</td></tr><tr style="height:14px ;"><td style="font-size:8pt; background-color:#cacaca; text-align:center; ">33</td><td style="color:#333333; font-size:10pt; "> </td></tr><tr style="height:14px ;"><td style="font-size:8pt; background-color:#cacaca; text-align:center; ">34</td><td style="color:#333333; font-size:10pt; text-align:right; ">250</td></tr><tr style="height:14px ;"><td style="font-size:8pt; background-color:#cacaca; text-align:center; ">35</td><td style="color:#333333; font-size:10pt; "> </td></tr><tr style="height:14px ;"><td style="font-size:8pt; background-color:#cacaca; text-align:center; ">36</td><td style="color:#333333; font-size:10pt; text-align:right; ">350</td></tr><tr style="height:14px ;"><td style="font-size:8pt; background-color:#cacaca; text-align:center; ">37</td><td style="color:#333333; font-size:10pt; "> </td></tr><tr style="height:14px ;"><td style="font-size:8pt; background-color:#cacaca; text-align:center; ">38</td><td style="color:#333333; font-size:10pt; text-align:right; ">450</td></tr></table><br><table style="font-family:Arial; font-size:10pt; border-style: groove ;border-color:#00ff00;background-color:#fffcf9; color:#000000; "><tr><td><b>Formeln der Tabelle</b></td></tr><tr><td><table border="1" cellspacing="0" cellpadding="2" style="font-family:Arial; font-size:9pt;"><tr style="background-color:#cacaca; font-size:10pt;"><td>Zelle</td><td>Formel</td></tr><tr><td>A32</td><td>=WENN(REST<span style=' color:008000; '>(ZEILE<span style=' color:#0000ff; '>()</span>;2)</span>=0;INDEX<span style=' color:008000; '>(Tabelle1!A:A;<span style=' color:#0000ff; '>(ZEILE<span style=' color:#ff0000; '>(A1)</span>-1)</span>*10+26)</span>;"")</td></tr><tr><td>A34</td><td>=WENN(REST<span style=' color:008000; '>(ZEILE<span style=' color:#0000ff; '>()</span>;2)</span>=0;INDEX<span style=' color:008000; '>(Tabelle1!A:A;<span style=' color:#0000ff; '>(ZEILE<span style=' color:#ff0000; '>(A3)</span>-1)</span>*10+26)</span>;"")</td></tr><tr><td>A36</td><td>=WENN(REST<span style=' color:008000; '>(ZEILE<span style=' color:#0000ff; '>()</span>;2)</span>=0;INDEX<span style=' color:008000; '>(Tabelle1!A:A;<span style=' color:#0000ff; '>(ZEILE<span style=' color:#ff0000; '>(A5)</span>-1)</span>*10+26)</span>;"")</td></tr><tr><td>A38</td><td>=WENN(REST<span style=' color:008000; '>(ZEILE<span style=' color:#0000ff; '>()</span>;2)</span>=0;INDEX<span style=' color:008000; '>(Tabelle1!A:A;<span style=' color:#0000ff; '>(ZEILE<span style=' color:#ff0000; '>(A7)</span>-1)</span>*10+26)</span>;"")</td></tr></table></td></tr></table> <br><br>Excel Jeanie Html

die Formel ist eigend ganz einfach zu verstehen;

Der erste Teil der Formel;

=WENN(REST(ZEILE();2)=0;

dient ja nur dazu die Zeile zu überbrücken damit dort nichts angezeigt wird.

Beginnend mit der Zeile 32 mit der Rest Funktion wird hier 0 ermittelt also
wird die Formel ausgelöst.
für die Zeile 33 wird 1 ermittelt und somit "" ausgegeben, usw.

Der zeite Teil der formel;

INDEX(Tabelle1!A:A;(ZEILE(A1)-1)*10+26)

ist der eigendlich relevante teil, mit (ZEILE(A1)-1)*10+26 wird die Zeile
bestimmt aus der in Tabelle1 A:A der Wert übernommen werden soll.
für diese erste Zeile ergibt sich (ZEILE(A1)-1) = 0 *10 + 26 = 26
also wird der Wert aus Tabelle1 A26 übernommen
für die Zweite Zeile wäre das (ZEILE(A2)-1) = 1 * 10 + 26 = 36
für diese Zeile findet aber keine Berechnung statt da sie ja von der WENN
Funktion unterdrückt wurde

usw:

Ich hoffe du kannst damit was anfangen.


Vielen Dank Hermann,
ich hatte das Blatt falsch verlinkt. Der Fehler ist mir leider erst heute aufgefallen als ich bemerkt habe dass bei der verlinkung von Blättern Leerzeichen innerhalb der "Blätter Titel nicht funktionieren.
Jetzt klappt alles.

Danke dir für deine ausführliche Erklärung.

Grüße
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Farben einer Zeile per Wenn-Funktion ändern??? 2 disposible 4951 14. März 2006, 09:07
disposible Farben einer Zeile per Wenn-Funktion ändern???
Keine neuen Beiträge Excel Formeln: Formeln automatisch in neu eingefügte Zeile übertragen 3 Ferencz 1727 27. Feb 2006, 15:22
Klaus-Dieter Formeln automatisch in neu eingefügte Zeile übertragen
Keine neuen Beiträge Excel Formeln: Wenn Bedingung erfüllt Zeile markieren 2 Moredread 2880 16. Feb 2006, 14:28
Moredread Wenn Bedingung erfüllt Zeile markieren
Keine neuen Beiträge Excel Formeln: Bestimmte Zeile summieren 2 Enkel Abrahams 678 09. Dez 2005, 11:37
Enkel Abrahams Bestimmte Zeile summieren
Keine neuen Beiträge Excel Formeln: in Zeile aus Spalten schreiben??? 6 robert_de 2318 25. Nov 2005, 12:10
robert_de in Zeile aus Spalten schreiben???
Keine neuen Beiträge Excel Formeln: Formel für letzte gefüllte Zeile in Spalte 1 börse 9538 16. Nov 2005, 09:24
fridgenep Formel für letzte gefüllte Zeile in Spalte
Keine neuen Beiträge Excel Formeln: Zahlen in einer Zeile auswerten nach den Größtwerten 11 Nicole-Fun 908 26. Okt 2005, 09:44
ransi Zahlen in einer Zeile auswerten nach den Größtwerten
Keine neuen Beiträge Excel Formeln: SUMMEWENN mit Suchkriterium Datum;Datum nach jeder Zeile +1? 4 homer_134 3721 20. Sep 2005, 23:48
homer_134 SUMMEWENN mit Suchkriterium Datum;Datum nach jeder Zeile +1?
Keine neuen Beiträge Excel Formeln: Wenn Bedingung Zeile kopieren 1 marco1 1634 28. Jul 2005, 14:04
Günni Wenn Bedingung Zeile kopieren
Keine neuen Beiträge Excel Formeln: automatisch eine zeile einfügen... 4 nichtswisser 2156 17. Mai 2005, 10:36
fl618 automatisch eine zeile einfügen...
Keine neuen Beiträge Excel Formeln: Wenn Bedingung ganze Zeile in endere Arbeitsmappe kopieren 2 Unregistered7 1556 05. Mai 2005, 22:32
Gast Wenn Bedingung ganze Zeile in endere Arbeitsmappe kopieren
Keine neuen Beiträge Excel Formeln: Formel für Zusammenzählen jeder zweiten Zelle einer Zeile 2 toto_225 814 11. März 2005, 12:04
toto_225 Formel für Zusammenzählen jeder zweiten Zelle einer Zeile
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Access Tabellen