Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Sicherheitshinweis ---> für registrierte Mitglieder <-
Formel für: bis ein Wert erreicht ist
Gehe zu Seite Zurück  1, 2, 3  Weiter
zurück: Erfassen-Auswertung verschiedener Zellen weiter: Werte nach Datum sortieren Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Heinz Schweigert
.


Verfasst am:
22. Jan 2014, 22:35
Rufname: Heinz

AW: Formel für: bis ein Wert erreicht ist - AW: Formel für: bis ein Wert erreicht ist

Nach oben
       Version: Office 2010

... das kommt auf deinen Rechner an, und was noch alles in der Datei berechnet wird.

Aber das merkst du schon, einfach ausprobieren, und wenn die Datei träge ist danach dann ist der Bereich zu groß Laughing

Aber für einen herkömmlichen Rechner heutiger Tage sollte das schon gehen. Meiner würde murren, aber der ist auch von vorvor...gestern Laughing

Grüße Heinz
lupo1
Tüftler und {}-Sympathisant


Verfasst am:
23. Jan 2014, 09:34
Rufname:


AW: Formel für: bis ein Wert erreicht ist - AW: Formel für: bis ein Wert erreicht ist

Nach oben
       Version: Office 2010

Das sind Dimensionen, bei denen das Charles-Williams-Credo eindeutig greift. Bitte also aus SUMME(D$2:D2) unbedingt Hilfsspalte E2: =E1+D2 machen, damit nur das 4fache der Wurzel der Zeit benötigt wird:
 DEF
15  
2-1-1-1
3-2-3-2
4-3-5-2
5-2-50
6-2-50
7   
8AusgangHilfsspalteZiel

ZelleFormel
E2=MAX(-D$1;E1+D2)
F2=E2-E1

Spalte C sollte trotzdem geordnet sein, da sonst wieder jeweils der ganze Datenbestand durchsucht werden muss. Tipp für eine VBA-Aufzeichnung:
1. Vor Deiner Reihenfolge von C eine lfd. Nr. B schreiben
2. Nach C sortieren
3. Die sich so ergebenden Formeln F als Werte G kopieren
4. Zurück gemäß B sortieren
5. G ergibt nun den gewünschten modifiziert-gekappten Verlauf von D bei "Unordnung" von C.

_________________
MfG Lupo - 11.10.2012-> {MSO 2000 SP3;Win 7} - 28.02.2013-> {MSO 2010;Win 8.1} (beide vorhanden)
Natalie232
Gast


Verfasst am:
23. Jan 2014, 12:43
Rufname:

AW: Formel für: bis ein Wert erreicht ist - AW: Formel für: bis ein Wert erreicht ist

Nach oben
       Version: Office 2010

Hallo,

kann ich mit Hilfe einer Wenn(Oder()) funtkion, die auschließen die nicht geändert werden dürfen?

Also zum Beispiel wenn der Rang A,B oder O ist, dann soll das aufjedenfallübernommen werden, bei den anderen wird dann das kürzen begonnen.


Das wäre Super, wenn das klappt.


Danke Euch
Heinz Schweigert
.


Verfasst am:
23. Jan 2014, 17:23
Rufname: Heinz

AW: Formel für: bis ein Wert erreicht ist - AW: Formel für: bis ein Wert erreicht ist

Nach oben
       Version: Office 2010

Hallo nochmal Razz

@lupo1
Was bitteschön ist denn das Charles-Williams-Credo? Rolling Eyes
"Das 4fache der Wurzel der Zeit" - ok, das muss man sich wohl auf der Zunge zergehen lassen...

@Natalie
Da hast du aber Glück, dass Excel Buchstaben größer als Zahlen wertet, diese kleine "Detailänderung" kann ganz schnell Lösungen übern Haufen werfen.

Aber so, ja, du kannst die Sonderfälle vorneweg mit einer WENN(ODER-Abfrage abfangen. Kommst damit klar, oder?

Grüße Heinz
lupo1
Tüftler und {}-Sympathisant


Verfasst am:
23. Jan 2014, 18:30
Rufname:


AW: Formel für: bis ein Wert erreicht ist - AW: Formel für: bis ein Wert erreicht ist

Nach oben
       Version: Office 2010

http://msdn.microsoft.com/en-us/library/ff700515(v=office.14).aspx (ca. ab der Mitte der Seite)
_________________
MfG Lupo - 11.10.2012-> {MSO 2000 SP3;Win 7} - 28.02.2013-> {MSO 2010;Win 8.1} (beide vorhanden)
Natalie232
Gast


Verfasst am:
23. Jan 2014, 22:10
Rufname:

AW: Formel für: bis ein Wert erreicht ist - AW: Formel für: bis ein Wert erreicht ist

Nach oben
       Version: Office 2010

Hi,


Zitat:
Aber so, ja, du kannst die Sonderfälle vorneweg mit einer WENN(ODER-Abfrage abfangen. Kommst damit klar, oder?



Scheinbar nicht. Ich habe ein Denkfehler drin. Es soll mir zwar wo Buchstaben eingetragen sind, die Werte unverändert übertragen, aber sobald keine Buchstaben mehr Vorhanden sind, bzw die Ausnahmen zu ende, soll es wieder Vergleichen, ob mein Höchst-Level (also die 5) erreicht wurde oder ob ich es noch befüllen kann.



 BCDEF
17  5was raus kommen solltewas ich durch Formel erhalte
18PersonRangWerte  
19P1X-2-2-2
20P1Y-1-1-1
21P1Z-2-2-2
22P13-20-2
23P17-30-3
24P1 Summe-5   
25P21-5-5-5
26P22-100
27P23-200
28P2 Summe-3   

ZelleFormel
F19=WENN(ODER(C19="X";C19="Y";C19="z";C19="0");D19;MAX(D19;D19+MIN(ABS(D19);SUMMENPRODUKT(($B$19:$B$27=B19)*($C$19:$C$27<=C19)*ABS($D$19:$D$27))-$D$17)))
F20=WENN(ODER(C20="X";C20="Y";C20="z";C20="0");D20;MAX(D20;D20+MIN(ABS(D20);SUMMENPRODUKT(($B$19:$B$27=B20)*($C$19:$C$27<=C20)*ABS($D$19:$D$27))-$D$17)))
F21=WENN(ODER(C21="X";C21="Y";C21="z";C21="0");D21;MAX(D21;D21+MIN(ABS(D21);SUMMENPRODUKT(($B$19:$B$27=B21)*($C$19:$C$27<=C21)*ABS($D$19:$D$27))-$D$17)))
F22=WENN(ODER(C22="X";C22="Y";C22="z";C22="0");D22;MAX(D22;D22+MIN(ABS(D22);SUMMENPRODUKT(($B$19:$B$27=B22)*($C$19:$C$27<=C22)*ABS($D$19:$D$27))-$D$17)))
F23=WENN(ODER(C23="A";C23="R";C23="o";C23="0");D23;MAX(D23;D23+MIN(ABS(D23);SUMMENPRODUKT(($B$19:$B$27=B23)*($C$19:$C$27<=C23)*ABS($D$19:$D$27))-$D$17)))
E25=MAX(D25;D25+MIN(ABS(D25);SUMMENPRODUKT(($B$3:$B$11=B25)*($C$3:$C$11<=C25)*ABS($D$3:$D$11))-$D$1))
F25=WENN(ODER(C25="A";C25="R";C25="o";C25="0");D25;MAX(D25;D25+MIN(ABS(D25);SUMMENPRODUKT(($B$19:$B$27=B25)*($C$19:$C$27<=C25)*ABS($D$19:$D$27))-$D$17)))
E26=MAX(D26;D26+MIN(ABS(D26);SUMMENPRODUKT(($B$3:$B$11=B26)*($C$3:$C$11<=C26)*ABS($D$3:$D$11))-$D$1))
F26=WENN(ODER(C26="A";C26="R";C26="o";C26="0");D26;MAX(D26;D26+MIN(ABS(D26);SUMMENPRODUKT(($B$19:$B$27=B26)*($C$19:$C$27<=C26)*ABS($D$19:$D$27))-$D$17)))
E27=MAX(D27;D27+MIN(ABS(D27);SUMMENPRODUKT(($B$3:$B$11=B27)*($C$3:$C$11<=C27)*ABS($D$3:$D$11))-$D$1))
F27=WENN(ODER(C27="A";C27="R";C27="o";C27="0");D27;MAX(D27;D27+MIN(ABS(D27);SUMMENPRODUKT(($B$19:$B$27=B27)*($C$19:$C$27<=C27)*ABS($D$19:$D$27))-$D$17)))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Natalie232
Gast


Verfasst am:
23. Jan 2014, 22:41
Rufname:

AW: Formel für: bis ein Wert erreicht ist - AW: Formel für: bis ein Wert erreicht ist

Nach oben
       Version: Office 2010

Mit der anderen Formel klappt es gut... Bis auf die Kleinigkeit, dass sie die Werte der Zelle über ihr benötigt. Es ist ok, solange die erste diese Zelle Leer ist. Dort stehen aber Informationen ... Wie kann ich diese Problematik umgehen?


Ich danke Euch

 BCDEF
1PersonRang5  
2P1x-1-1-1
3P1y-1-2-1
4P11-1-3-1
5P120-30
6P13-2-5-2
7 Abschnitt1 EndeAbschnitt1 EndeAbschnitt1 EndeAbschnitt1 Ende
8P21-1  
9P22-2  
10P230  
11  AusgangHilfsspalteZiel

ZelleFormel
E2=MAX(-D$1;E1+D2)
F2=E2-E1
E3=MAX(-D$1;E2+D3)
F3=E3-E2
E4=MAX(-D$1;E3+D4)
F4=E4-E3
E5=MAX(-D$1;E4+D5)
F5=E5-E4
E6=MAX(-D$1;E5+D6)
F6=E6-E5
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Heinz Schweigert
.


Verfasst am:
23. Jan 2014, 22:53
Rufname: Heinz

AW: Formel für: bis ein Wert erreicht ist - AW: Formel für: bis ein Wert erreicht ist

Nach oben
       Version: Office 2010

Hallo Natalie

Da hatte ich einen Denkfehler drin: Excel müßte Buchstaben kleiner als Zahlen werten, damit es funktioniert.

Somit bleibt nur, diese Text-Geschichte explicit in die Formel aufzunehmen (jetzt für
F19):
=WENN(ODER(C19="X";C19="Y";C19="z";C19="0");D19;MAX(D19;D19+MIN(ABS(D19);SUMMENPRODUKT(($B$19:$B$27=B19)*(($C$19:$C$27<=C19)+ISTTEXT($C$19:$C$27))*ABS($D$19:$D$27))-$D$17)))

Musste mal gucken, bin mir nicht sicher ob im Deutschen die Funktion ISTTEXT mit doppeltem T geschrieben wird - gehts schon los Rolling Eyes

Grüße Heinz
Heinz Schweigert
.


Verfasst am:
23. Jan 2014, 23:16
Rufname: Heinz

AW: Formel für: bis ein Wert erreicht ist - AW: Formel für: bis ein Wert erreicht ist

Nach oben
       Version: Office 2010

...nochmal ich

Zitat:
Wie kann ich diese Problematik umgehen?

Indem Du die Formel für jeden Blockbeginn anpasst, und dort nicht die Zelle oberhalb summierst
oder
Falls die Art der Information nur Text ist, die Funktion SUMME zum addieren nimmst:
E2 =MAX(-D$1;SUMME(E1;D2))
F2 =E2-WENN(ISTTEXT(E1);0;E1)

Grüße Heinz
Gast



Verfasst am:
24. Jan 2014, 10:30
Rufname:

AW: Formel für: bis ein Wert erreicht ist - AW: Formel für: bis ein Wert erreicht ist

Nach oben
       Version: Office 2010

Zitat:

Indem Du die Formel für jeden Blockbeginn anpasst, und dort nicht die Zelle oberhalb summierst
oder
Falls die Art der Information nur Text ist, die Funktion SUMME zum addieren nimmst:
E2 =MAX(-D$1;SUMME(E1;D2))
F2 =E2-WENN(ISTTEXT(E1);0;E1)



Hallo Smile

kann ich statt "ISTTEXT" prüfen ob es eine Formel ist? Tatsächlich endet jeder block mit der Summe von dem über ihn liegende Zahlen...

Oder

andere Idee: Kann ich stattdessen eine Bedingung einfügen, zum Beispiel falls Spalte B nicht mehr P1 ist sondern bei Summe angekommen ist, dann beginne von vorn.

Danke euch
Heinz Schweigert
.


Verfasst am:
24. Jan 2014, 19:39
Rufname: Heinz

AW: Formel für: bis ein Wert erreicht ist - AW: Formel für: bis ein Wert erreicht ist

Nach oben
       Version: Office 2010

Auch Hallo Surprised

Eine Funktion auf Formel á la ISTFORMEL() gibts meines Wissens nicht, Hab aber nicht Version 2010.

Der oder-Fall ist denkbar, vorausgesetzt, dass die Syntax was in der Zelle immer die gleiche ist, bzw. das Wort "Summe" immer an der gleichen Position steht. Bezogen auf die Syntax deines Beispiels:

P1 Summe

kannst mit RECHTS() dies überprüfen:
E2 =WENN(RECHTS(B1;5)="Summe";MAX(-D$1;D2);MAX(-D$1;E1+D2))

Grüße Heinz
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
24. Jan 2014, 19:47
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände

AW: Formel für: bis ein Wert erreicht ist - AW: Formel für: bis ein Wert erreicht ist

Nach oben
       Version: Office 2010

Hallo Heinz

Zitat:
Eine Funktion auf Formel á la ISTFORMEL() gibts meines Wissens nicht, Hab aber nicht Version 2010.

Dann wird es Zeit upzudaten.
http://de.excel-wiki.de/istformel/

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
< Peter >
Excel-Moderator, der immer noch dazu lernt


Verfasst am:
24. Jan 2014, 19:49
Rufname: Kommt darauf an wer ruft
Wohnort: Das schönste Land in Deutschlands Gaun

AW: Formel für: bis ein Wert erreicht ist - AW: Formel für: bis ein Wert erreicht ist

Nach oben
       Version: Office 2010

Hallo,

naja, nur deswegen muss man noch nicht updaten:

Code:
 Public Function Is_Formula(rng as range) as boolean
'Quelle: Frank Kabel
    Is_Formula = rng.hasformula
end function


Und im Tabellenblatt dann einfach

=IS_FORMULA(A1)

_________________
Gruß
Peter
Heinz Schweigert
.


Verfasst am:
24. Jan 2014, 20:10
Rufname: Heinz

AW: Formel für: bis ein Wert erreicht ist - AW: Formel für: bis ein Wert erreicht ist

Nach oben
       Version: Office 2010

Hallo Ihr

@Detlef
Ist zwar n bisschen off topic, aber:
Wirst lachen ich hab 2010 seit 2 Jahren in der Schublade liegen - aber sag mal ehrlich, hast du schon irgendwas Brauchbares an den neuen Versionen (nach 2003) entdeckt, was sich nicht mit den alten Versionen (wie Peter zeigt) realisieren läßt. Nur wer wirklich mehr als 65000 Zeilen und 256 Spalten braucht, dem mögen die neuen Versionen nützlich sein. Wobei, sorry, leider kann excel nur schwer die neuen großen Tabellenblätter verkraften, das hat man nämlich vergessen, dass man die arbeitsweise der Funktionen ebenfalls verbessert. Sad

Ansonsten ist alles nur noch bunter geworden, mit noch mehr schnickschnack - wie ne Funktion ISTFORMEL() die es zudem, deinem link nach, erst in Version 2013 gibt, die wg. sowas dann nicht mehr 100% kompatibel mit älteren Versionen wird. Was soll das also?

Grüße Heinz
Natalie232
Gast


Verfasst am:
27. Jan 2014, 10:49
Rufname:


AW: Formel für: bis ein Wert erreicht ist - AW: Formel für: bis ein Wert erreicht ist

Nach oben
       Version: Office 2010

erstmal ein großes Dankeschön für eure Hilfe.

Zitat:
Indem Du die Formel für jeden Blockbeginn anpasst, und dort nicht die Zelle oberhalb summierst
oder
Falls die Art der Information nur Text ist, die Funktion SUMME zum addieren nimmst:
E2 =MAX(-D$1;SUMME(E1;D2))
F2 =E2-WENN(ISTTEXT(E1);0;E1)


Leider beginnt es dann nicht von vorn mit den Berechnungen, sondern gibt nur noch nuller aus. Oder gehe ich falsch vor?
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Gehe zu Seite Zurück  1, 2, 3  Weiter
Diese Seite Freunden empfehlen

Seite 2 von 3
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Suche Formel für meinen Urlaubsplaner 1 carlos 2875 11. Apr 2004, 22:23
Klaus-Dieter Suche Formel für meinen Urlaubsplaner
Keine neuen Beiträge Excel Formeln: Formel für Leerzeilen 2 Ursula 2167 24. März 2004, 12:31
steve1da Formel für Leerzeilen
Keine neuen Beiträge Excel Formeln: Formel 1 posti 636 20. März 2004, 15:51
Dick Formel
Keine neuen Beiträge Excel Formeln: SVERWEIS - Hilfe die Formel klappt nicht !!! 3 sabine99 2359 15. März 2004, 16:19
sabine99 SVERWEIS - Hilfe die Formel klappt nicht !!!
Keine neuen Beiträge Excel Formeln: Zahlenvergleichen nud grössten Wert mit Namen anzeigen 3 [WN]Ultima 1537 15. März 2004, 14:26
xpecidy Zahlenvergleichen nud grössten Wert  mit Namen anzeigen
Keine neuen Beiträge Excel Formeln: Brauche Hilfe: SVerweis + Wenn Formel Beispiel 10 Gast 7507 08. März 2004, 18:25
Gast Brauche Hilfe: SVerweis + Wenn Formel Beispiel
Keine neuen Beiträge Excel Formeln: Mathematische Formel gesucht! 2 Gast 1367 05. März 2004, 01:18
lala Mathematische Formel gesucht!
Keine neuen Beiträge Excel Formeln: Platzhalter in deiner SUMMEPRODUKT formel 5 seraph 3464 03. März 2004, 18:26
seraph Platzhalter in deiner SUMMEPRODUKT formel
Keine neuen Beiträge Excel Formeln: Suche ein Formel 4 Unwissender 2147 20. Feb 2004, 09:45
xpecidy Suche ein Formel
Keine neuen Beiträge Excel Formeln: formel für 2 Arbeitsmappen 2 Diana 1135 18. Feb 2004, 18:17
peb formel für 2 Arbeitsmappen
Keine neuen Beiträge Excel Formeln: WENN bzw. SUMMEWENN Formel (Provisionsberechnung) 4 Uli 6094 17. Feb 2004, 09:58
Manfred Bartak WENN bzw. SUMMEWENN Formel (Provisionsberechnung)
Keine neuen Beiträge Excel Formeln: Wenn;Oder, Nichtgleich Formel verschachtelt? 2 nebbio 18743 02. Feb 2004, 17:21
nebbio Wenn;Oder, Nichtgleich Formel verschachtelt?
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML CSS