Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
wenn funktion
zurück: ein monat vor aktuellem datum warnen weiter: markierfelder und hacken Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Tazer
Gast


Verfasst am:
08. Jan 2014, 10:32
Rufname:

wenn funktion - wenn funktion

Nach oben
       

hi leute,
also ich habe eine übersichtstabelle bei der wenn ein teil projekt fertig ist "finished" ausgegeben wird (ansonsten "in progress") nun wollte ich über eine Wenn funktion anzeigen wann das komplette projekt fertig ist.
das ganze sieht bei mir so aus: =WENN((D20="finished")=(E20="finished")=(F20="finished")=(G20="finished")=(H20="finished");'finished';"in progress")
wenn einer der teilprojekte nicht "finished" hat steht da auch so wie es soll "in progress" allerdings wenn alle auf "finished" sind gibt excel mir anstatt des finished eine 0 aus... jemand eine idee?
Hierzu noch: bei der wenn funktion kann ich einfach keine buchstaben gleichsetzten also wenn in den zellen E61-E73 immer ein x steht und ich die wie in der funktion über = vergleichen will geht das nur mit zahlen (anstatt x)
=WENN(E61=E62=E63=E64=E65=E66=E67=E68=E69=E70=E71=E72=E73;"finished";"in progress")
---->E61-E73 zahlen funktion geht, E61-E73 buchstabe funktion geht nicht
hoffe mein problem ist nicht zu kompliziert beschrieben
Mfg HG
steve1da
Moderator


Verfasst am:
08. Jan 2014, 10:35
Rufname:


AW: wenn funktion - AW: wenn funktion

Nach oben
       

Hola,

so etwas wird entweder mit einer Wenn/Und Funktion gemacht:
Code:
=wenn(und(D20="finished";E20="finished";......);"finished";"in progress")
oder aber z.B. so:
Code:
=WENN(ZÄHLENWENN(E20:H20;"finished")=4;"finished";"in progress")

Gruß,
steve1da
Tazer
Gast


Verfasst am:
08. Jan 2014, 10:46
Rufname:

AW: wenn funktion - AW: wenn funktion

Nach oben
       

hey danke für die fixe antwort ;)
also das =WENN(UND..... hatte ich schonmal ausprobiert gestern aber fürs ergebnis machts leider keinen unterschied immer noch 0 und in progress hier meine funktion zum checken ob ich doch zu blöd war deine vorlage zu kopieren aber ich glaube nicht.
Code:
=WENN(UND(D20="finished";E20="finished";F20="finished";G20="finished";H20="finished");'finished';"in progress")
das zählewenn würde ich ungern benutzen weil ich noch nicht weiß wie viele teilprojekte es geben wird und man dann (glaube ich ) die funktion jedes mal ändern müsste
steve1da
Moderator


Verfasst am:
08. Jan 2014, 10:51
Rufname:

AW: wenn funktion - AW: wenn funktion

Nach oben
       

So sieht das bei mir aus:

Arbeitsblatt mit dem Namen 'Tabelle1'
 DEFGHIJ
20finishedfinishedfinishedfinished  in progress
21finishedfinishedfinishedfinishedfinished finished

ZelleFormel
J20=WENN(UND(D20="finished";E20="finished";F20="finished";G20="finished";H20="finished");"finished";"in progress")
J21=WENN(UND(D21="finished";E21="finished";F21="finished";G21="finished";H21="finished");"finished";"in progress")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Wenn noch mehr Projekte hinzukommen, musst du die Wenn-Formel doch auch erweitern!
Tazer
Gast


Verfasst am:
08. Jan 2014, 11:03
Rufname:


AW: wenn funktion - AW: wenn funktion

Nach oben
       

klein aber fein mein fehler >,> anführungszeichen hatten nur 1 strich , funktioniert jetzt ;) ja hast du recht mit zählewenn , aber ich schreibe auf deutsch(deutsches OOo) für türken in englisch und da geht sonst zuviel flöten wenn ich denn alles erklären muss später, ist ne riesen excel tabelle die ich erstelle und naja die sind nicht ganz so bewandert in excel (noch weniger als ich wenn das überhaupt geht) ^^ lange rede gar kein sinn, vielen dank für die hilfe

hast du noch ne idee zu meinem zweiten problem? also dass ich buchstaben mit = überprüfe? also wenn in jeder zelle ein x steht= finished wenn was andres steht "in progress" , momentan habe ich das mit 0 und 1 , sieht aber nicht so schön aus wie ich das gerne hätte
steve1da
Moderator


Verfasst am:
08. Jan 2014, 11:06
Rufname:

AW: wenn funktion - AW: wenn funktion

Nach oben
       

Zitat:
also wenn in jeder zelle ein x steht= finished wenn was andres steht "in progress"
Ist doch das gleiche wie die obrige Formel, nur mit "x" anstatt "finished".
Tazer
Gast


Verfasst am:
08. Jan 2014, 11:09
Rufname:

AW: wenn funktion - AW: wenn funktion

Nach oben
       

sorry hab ich grade falsch gedacht, ich meine das er sich aussuchen kann was er einfüllt also egal welcher buchstabe oder zeichen , wenn alle gleich dann=finished wenn einer aus der reihe tanzt=in progress ist nicht sooooo wichtig aber da die hier für teilprjojekte alphabetisch geordnete kleinteile haben währe das recht praktisch weil ich dann noch eine spalte verlinken kann die nicht von hand ausgefüllt werden muss
steve1da
Moderator


Verfasst am:
08. Jan 2014, 11:18
Rufname:

AW: wenn funktion - AW: wenn funktion

Nach oben
       

Das würde man so abfragen:

Arbeitsblatt mit dem Namen 'Tabelle1'
 DEFGHIJ
22xxxxx finished
23xgxxx in progress

ZelleFormel
J22=WENN(ZÄHLENWENN(D22:H22;D22)=5;"finished";"in progress")
J23=WENN(UND(D23=E23;E23=F23;F23=G23;G23=H23);"finished";"in progress")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Tazer
Gast


Verfasst am:
08. Jan 2014, 11:28
Rufname:


AW: wenn funktion - AW: wenn funktion

Nach oben
       

bester mann ;) funktioniert alles dank dir!
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Forum für LibreOffice, OpenOffice und Staroffice : WENN ... DANN Funktion (IF ... THEN Function) in Tabelle 0 DiscoDenis 1016 08. Sep 2012, 17:44
DiscoDenis WENN ... DANN Funktion (IF ... THEN Function) in Tabelle
Keine neuen Beiträge Office 2010 Forum: Wenn Funktion in Access 2010 0 m-coupe 1077 29. Apr 2012, 23:35
m-coupe Wenn Funktion in Access 2010
Keine neuen Beiträge Office 2010 Forum: excel Funktion ..... ich bekomme das nicht hin 0 subuku 466 01. März 2012, 10:14
subuku excel Funktion ..... ich bekomme das nicht hin
Keine neuen Beiträge Office 2010 Forum: Excel verschachtelte Wenn Funktion 2 Albatros2 2622 23. Jan 2012, 18:26
Albatros2 Excel verschachtelte Wenn Funktion
Keine neuen Beiträge Office 2010 Forum: Funktion "Berechtigung nach Person einschränken" f 0 bingolo 1204 02. Okt 2011, 18:13
bingolo Funktion "Berechtigung nach Person einschränken" f
Keine neuen Beiträge Office 2010 Forum: wie in excel auf benutzerdefinierte funktion zugreifen? 3 xlsx38 2012 04. Aug 2011, 17:43
banman wie in excel auf benutzerdefinierte funktion zugreifen?
Keine neuen Beiträge Office 2010 Forum: Excel - Häckchen setzen und wenn funktion 1 Helpo 3843 10. Jul 2011, 15:21
Ute-S Excel - Häckchen setzen und wenn funktion
Keine neuen Beiträge Office 2010 Forum: Outlook 2010 Problem bei der Funktion "Allen Antworten& 0 whiterabbit 964 10. März 2011, 13:01
whiterabbit Outlook 2010 Problem bei der Funktion "Allen Antworten&
Keine neuen Beiträge Office 2010 Forum: Wenn Funktion in Summewenns einbauen 1 Mondo 448 16. Dez 2010, 13:27
Wolfgang 1958 Wenn Funktion in Summewenns einbauen
Keine neuen Beiträge Office 2010 Forum: Chat Funktion in Office 2010? 1 pcmauserl 3038 23. Sep 2010, 17:13
Ute-S Chat Funktion in Office 2010?
Keine neuen Beiträge Office 2007 Forum: Nützliche Funktion abgeschafft / Einstellungen speichern 6 Tummy 6283 20. Dez 2009, 14:25
mumpel Nützliche Funktion abgeschafft / Einstellungen speichern
Keine neuen Beiträge Office 2007 Forum: pdf funktion in symbolleiste anzeigen 2 cattgrisu 2798 29. Nov 2009, 14:25
iso pdf funktion in symbolleiste anzeigen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: CSS Forum