Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Sverweis mit mehereren Ergebnissen
zurück: Verlinkung auf Tabellenblatt weiter: Kalenderwoche Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
calbat
Im Profil kannst Du frei den Rang ändern


Verfasst am:
10. Dez 2013, 16:20
Rufname:

Sverweis mit mehereren Ergebnissen - Sverweis mit mehereren Ergebnissen

Nach oben
       Version: Office 2007

Hallo,

ich hätte eine kurze Frage bezüglich des SVerweis.

Ich habe hier eine Tabelle mit verschiedenen Produktnummern. Zu diesen Nummern gibt es dann noch weitere Liefernummern. Eine Produktnummer hat mehrerere Liefernummern, aber eine Liefernummer gehört nur zu einer Produktnummer (hoffe das ist verständlich)

Nun will ich wissen, welche Liefernummern zu den jeweiligen Produktnummern gehören. Wenn ich das jetzt mit dem Sverweis mache, dann bekomme ich leider nur den ersten Treffer und nicht die anderen 2-4 Stück, die es bei manchen Produktnummern gibt. Wie kann ich mir die nun noch ausgeben lassen?

Habe es schon mit der Pivottabelle versucht, allerdings werden die jeweiligen Liefernummern dann untereinander ausgegeben, ich bräuchte sie allerdings neben-/hintereinander. Kann mir da jemand dabei helfen?
steve1da
Moderator


Verfasst am:
10. Dez 2013, 16:24
Rufname:

AW: Sverweis mit mehereren Ergebnissen - AW: Sverweis mit mehereren Ergebnissen

Nach oben
       Version: Office 2007

Hola,

schau mal hier:

Arbeitsblatt mit dem Namen 'Tabelle3'
 ABCDEFGH
11123456   ProduktnummerLiefernummer
22222    1123
33333335   1456
44     2222
5      3333
6      3335
7      4777

ZelleFormel
B1{=WENNFEHLER(INDEX($H$1:$H$7;KKLEINSTE(WENN($G$1:$G$99=$A1;ZEILE($1:$99));SPALTE(A1)));"")}
C1{=WENNFEHLER(INDEX($H$1:$H$7;KKLEINSTE(WENN($G$1:$G$99=$A1;ZEILE($1:$99));SPALTE(B1)));"")}
D1{=WENNFEHLER(INDEX($H$1:$H$7;KKLEINSTE(WENN($G$1:$G$99=$A1;ZEILE($1:$99));SPALTE(C1)));"")}
E1{=WENNFEHLER(INDEX($H$1:$H$7;KKLEINSTE(WENN($G$1:$G$99=$A1;ZEILE($1:$99));SPALTE(D1)));"")}
F1{=WENNFEHLER(INDEX($H$1:$H$7;KKLEINSTE(WENN($G$1:$G$99=$A1;ZEILE($1:$99));SPALTE(E1)));"")}
B2{=WENNFEHLER(INDEX($H$1:$H$7;KKLEINSTE(WENN($G$1:$G$99=$A2;ZEILE($1:$99));SPALTE(A2)));"")}
C2{=WENNFEHLER(INDEX($H$1:$H$7;KKLEINSTE(WENN($G$1:$G$99=$A2;ZEILE($1:$99));SPALTE(B2)));"")}
D2{=WENNFEHLER(INDEX($H$1:$H$7;KKLEINSTE(WENN($G$1:$G$99=$A2;ZEILE($1:$99));SPALTE(C2)));"")}
E2{=WENNFEHLER(INDEX($H$1:$H$7;KKLEINSTE(WENN($G$1:$G$99=$A2;ZEILE($1:$99));SPALTE(D2)));"")}
F2{=WENNFEHLER(INDEX($H$1:$H$7;KKLEINSTE(WENN($G$1:$G$99=$A2;ZEILE($1:$99));SPALTE(E2)));"")}
B3{=WENNFEHLER(INDEX($H$1:$H$7;KKLEINSTE(WENN($G$1:$G$99=$A3;ZEILE($1:$99));SPALTE(A3)));"")}
C3{=WENNFEHLER(INDEX($H$1:$H$7;KKLEINSTE(WENN($G$1:$G$99=$A3;ZEILE($1:$99));SPALTE(B3)));"")}
D3{=WENNFEHLER(INDEX($H$1:$H$7;KKLEINSTE(WENN($G$1:$G$99=$A3;ZEILE($1:$99));SPALTE(C3)));"")}
E3{=WENNFEHLER(INDEX($H$1:$H$7;KKLEINSTE(WENN($G$1:$G$99=$A3;ZEILE($1:$99));SPALTE(D3)));"")}
F3{=WENNFEHLER(INDEX($H$1:$H$7;KKLEINSTE(WENN($G$1:$G$99=$A3;ZEILE($1:$99));SPALTE(E3)));"")}
B5{=WENN(ZEILEN($1:5)>ZÄHLENWENN($G$1:$G$7;$A$1);"";INDEX($H$1:$H$7;KKLEINSTE(WENN(G$1:G$99=$A$1;ZEILE($1:$99));ZEILE(A5))))}
B6{=WENN(ZEILEN($1:6)>ZÄHLENWENN($G$1:$G$7;$A$1);"";INDEX($H$1:$H$7;KKLEINSTE(WENN(G$1:G$99=$A$1;ZEILE($1:$99));ZEILE(A6))))}
B7{=WENN(ZEILEN($1:7)>ZÄHLENWENN($G$1:$G$7;$A$1);"";INDEX($H$1:$H$7;KKLEINSTE(WENN(G$1:G$99=$A$1;ZEILE($1:$99));ZEILE(A7))))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Die Formel in B1 einfach nach rechts und nach unten kopieren.

Gruß,
steve1da
calbat
Im Profil kannst Du frei den Rang ändern


Verfasst am:
11. Dez 2013, 10:51
Rufname:


AW: Sverweis mit mehereren Ergebnissen - AW: Sverweis mit mehereren Ergebnissen

Nach oben
       Version: Office 2007

Vielen, vielen Dank Smile
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: SVERWEIS 5 Julia 1607 18. Jan 2005, 14:46
Julia SVERWEIS
Keine neuen Beiträge Excel Formeln: Probleme mit Sverweis und Wochentag 1 Bluntman 573 29. Dez 2004, 01:45
Bluntman Probleme mit Sverweis und Wochentag
Keine neuen Beiträge Excel Formeln: SVERWEIS - Problem (Suchkriterium = Formelergebnis) 2 intellijens 3624 25. Dez 2004, 15:26
intellijens SVERWEIS - Problem (Suchkriterium = Formelergebnis)
Keine neuen Beiträge Excel Formeln: bei sverweis #nv unterdrücken? wie? 5 Mister Minit 2201 22. Nov 2004, 12:29
fridgenep bei sverweis #nv unterdrücken? wie?
Keine neuen Beiträge Excel Formeln: Ich habe ein Problem mit Sverweis 12 Lol 2401 19. Nov 2004, 11:15
Arnim Ich habe ein Problem mit Sverweis
Keine neuen Beiträge Excel Formeln: "=TEIL" mit "SVERWEIS" 3 fredi! 1211 10. Nov 2004, 13:01
fredi! "=TEIL" mit "SVERWEIS"
Keine neuen Beiträge Excel Formeln: fehlerhafter SVERWEIS 15 Gast 2219 08. Nov 2004, 15:09
Gast fehlerhafter SVERWEIS
Keine neuen Beiträge Excel Formeln: SVERWEIS, Wert aus der nächsten zelle 9 Dave 5483 11. Okt 2004, 13:50
Dave SVERWEIS, Wert aus der nächsten zelle
Keine neuen Beiträge Excel Formeln: Vergleich mit SVERWEIS und WENN 4 Marc 3124 27. Sep 2004, 12:44
Marc Vergleich mit SVERWEIS und WENN
Keine neuen Beiträge Excel Formeln: Fehler in Formel mit "WENN" und "SVERWEIS&quo 1 Peter VBA 885 14. Sep 2004, 17:21
fl618 Fehler in Formel mit "WENN" und "SVERWEIS&quo
Keine neuen Beiträge Excel Formeln: Probleme mit sverweis und vergleich 4 Gast 1891 07. Sep 2004, 15:08
fl618 Probleme mit sverweis und vergleich
Keine neuen Beiträge Excel Formeln: Bei SVERWEIS wird die Matrix mit hochgezählt, beim kopieren. 1 MariaMagda 1606 28. Jul 2004, 14:14
Thomas Ramel Bei SVERWEIS wird die Matrix mit hochgezählt, beim kopieren.
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Word Serienbriefe