Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Buchstaben Suchen Addieren Auswerten!
Gehe zu Seite Zurück  1, 2, 3, 4  Weiter
zurück: Dropdown Funktion öffnen bei eingabe eines textes weiter: Verlinkung auf Tabellenblatt Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Gast



Verfasst am:
26. Nov 2013, 13:38
Rufname:

AW: Buchstaben Suchen Addieren Auswerten! - AW: Buchstaben Suchen Addieren Auswerten!

Nach oben
       Version: Office 2011 (Mac)

Bin jetzt bis 23 Uhr arbeiten.
steve1da
Moderator


Verfasst am:
26. Nov 2013, 13:39
Rufname:


AW: Buchstaben Suchen Addieren Auswerten! - AW: Buchstaben Suchen Addieren Auswerten!

Nach oben
       Version: Office 2011 (Mac)

Genau die meine ich.

So sieht das bei mir aus:

Arbeitsblatt mit dem Namen 'Stundenausgabe'
 ABCDEF
5  SchichtUhrzeitWEPUT
606:0007:00106:00-07:001,700,57
707:0008:00 07:00-08:001,250,25
808:0009:00 08:00-09:000,750,00
909:0010:00 09:00-10:000,750,25
1010:0011:00 10:00-11:000,001,00
1111:0012:00 11:00-12:000,000,25
1212:0013:00 12:00-13:000,500,25
1313:0014:00 13:00-14:000,000,00
1414:0015:00 14:00-14:300,000,00
1515:0016:00 14:30-15:000,000,00
1616:0017:00 15:00-16:000,000,00

ZelleFormel
C6=Mitarbeiterzeiten!C7
E6=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A6)*(Mitarbeiterzeiten!$D$7:$AL$7<$B6)*(Mitarbeiterzeiten!$C$100:$C$102=E$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
F6=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A6)*(Mitarbeiterzeiten!$D$7:$AL$7<$B6)*(Mitarbeiterzeiten!$C$100:$C$102=F$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
E7=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A7)*(Mitarbeiterzeiten!$D$7:$AL$7<$B7)*(Mitarbeiterzeiten!$C$100:$C$102=E$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
F7=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A7)*(Mitarbeiterzeiten!$D$7:$AL$7<$B7)*(Mitarbeiterzeiten!$C$100:$C$102=F$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
E8=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A8)*(Mitarbeiterzeiten!$D$7:$AL$7<$B8)*(Mitarbeiterzeiten!$C$100:$C$102=E$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
F8=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A8)*(Mitarbeiterzeiten!$D$7:$AL$7<$B8)*(Mitarbeiterzeiten!$C$100:$C$102=F$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
E9=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A9)*(Mitarbeiterzeiten!$D$7:$AL$7<$B9)*(Mitarbeiterzeiten!$C$100:$C$102=E$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
F9=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A9)*(Mitarbeiterzeiten!$D$7:$AL$7<$B9)*(Mitarbeiterzeiten!$C$100:$C$102=F$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
E10=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A10)*(Mitarbeiterzeiten!$D$7:$AL$7<$B10)*(Mitarbeiterzeiten!$C$100:$C$102=E$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
F10=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A10)*(Mitarbeiterzeiten!$D$7:$AL$7<$B10)*(Mitarbeiterzeiten!$C$100:$C$102=F$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
E11=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A11)*(Mitarbeiterzeiten!$D$7:$AL$7<$B11)*(Mitarbeiterzeiten!$C$100:$C$102=E$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
F11=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A11)*(Mitarbeiterzeiten!$D$7:$AL$7<$B11)*(Mitarbeiterzeiten!$C$100:$C$102=F$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
E12=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A12)*(Mitarbeiterzeiten!$D$7:$AL$7<$B12)*(Mitarbeiterzeiten!$C$100:$C$102=E$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
F12=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A12)*(Mitarbeiterzeiten!$D$7:$AL$7<$B12)*(Mitarbeiterzeiten!$C$100:$C$102=F$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
E13=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A13)*(Mitarbeiterzeiten!$D$7:$AL$7<$B13)*(Mitarbeiterzeiten!$C$100:$C$102=E$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
F13=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A13)*(Mitarbeiterzeiten!$D$7:$AL$7<$B13)*(Mitarbeiterzeiten!$C$100:$C$102=F$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
E14=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A14)*(Mitarbeiterzeiten!$D$7:$AL$7<$B14)*(Mitarbeiterzeiten!$C$100:$C$102=E$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
F14=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A14)*(Mitarbeiterzeiten!$D$7:$AL$7<$B14)*(Mitarbeiterzeiten!$C$100:$C$102=F$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
E15=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A15)*(Mitarbeiterzeiten!$D$7:$AL$7<$B15)*(Mitarbeiterzeiten!$C$100:$C$102=E$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
F15=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A15)*(Mitarbeiterzeiten!$D$7:$AL$7<$B15)*(Mitarbeiterzeiten!$C$100:$C$102=F$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
E16=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A16)*(Mitarbeiterzeiten!$D$7:$AL$7<$B16)*(Mitarbeiterzeiten!$C$100:$C$102=E$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
F16=SUMMENPRODUKT((Mitarbeiterzeiten!$D$7:$AL$7>=$A16)*(Mitarbeiterzeiten!$D$7:$AL$7<$B16)*(Mitarbeiterzeiten!$C$100:$C$102=F$5)*(Mitarbeiterzeiten!$D$100:$AL$102))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gast



Verfasst am:
27. Nov 2013, 01:05
Rufname:

AW: Buchstaben Suchen Addieren Auswerten! - AW: Buchstaben Suchen Addieren Auswerten!

Nach oben
       Version: Office 2011 (Mac)

Ok, jetzt geht´s!
Gast



Verfasst am:
27. Nov 2013, 01:17
Rufname:

AW: Buchstaben Suchen Addieren Auswerten! - AW: Buchstaben Suchen Addieren Auswerten!

Nach oben
       Version: Office 2011 (Mac)

Hab wieder ne Frage Smile

wie kann ich denn Excel sagen das von 8-8:15 und von 11:00-11:30 Pause ist damit diese Zeit nicht berechnet wird ?
Gast



Verfasst am:
28. Nov 2013, 10:27
Rufname:


AW: Buchstaben Suchen Addieren Auswerten! - AW: Buchstaben Suchen Addieren Auswerten!

Nach oben
       Version: Office 2011 (Mac)

Steve?
steve1da
Moderator


Verfasst am:
28. Nov 2013, 10:32
Rufname:

AW: Buchstaben Suchen Addieren Auswerten! - AW: Buchstaben Suchen Addieren Auswerten!

Nach oben
       Version: Office 2011 (Mac)

Hier gibts zwar noch andere, aber ohne aktuelle Tabelle werden auch die nicht helfen können Wink
Gast



Verfasst am:
28. Nov 2013, 10:48
Rufname:

AW: Buchstaben Suchen Addieren Auswerten! - AW: Buchstaben Suchen Addieren Auswerten!

Nach oben
       Version: Office 2011 (Mac)

ach ja mein fehler Smile mom www.eftn.de/Zeiterfassung-1.xlsx
Gast



Verfasst am:
28. Nov 2013, 10:49
Rufname:

AW: Buchstaben Suchen Addieren Auswerten! - AW: Buchstaben Suchen Addieren Auswerten!

Nach oben
       Version: Office 2011 (Mac)

Die Pausen in der Frühsicht funktionieren jetzt aber warum geht es bei der Spätsicht nicht? :/
steve1da
Moderator


Verfasst am:
28. Nov 2013, 11:02
Rufname:

AW: Buchstaben Suchen Addieren Auswerten! - AW: Buchstaben Suchen Addieren Auswerten!

Nach oben
       Version: Office 2011 (Mac)

Zum ersten Problem mit den Pausen.

Schreibe in Tabellenblatt Mitarbeiterzeiten in A105 8:00, in B105 8:15, in A106 11:00 und in B106 11:30

In D105 jetzt folgende Formel:

Code:
=WENN(((D$7>=$A105)*(D$7<=$B105)+(D$7>=$A106)*(D$7<=$B106))=0;1;0)


Die Formel in D100 wie folgt schreiben und nach links und nach unten ziehen:

Code:
=ZÄHLENWENN(D$9:D$99;$C100)*D$8*D$105


Deine Summenprodukt Formeln im Blatt Stundenausgabe haben übrigens als Bereiche immer noch 100 bis 102, der Bereich geht aber von 100 bis 105, also anpassen!

Und wenn ich von 1 Frühschicht auf 2 Spätschicht umschalte, so werden dort auch Werte ermittelt.
Gast



Verfasst am:
28. Nov 2013, 11:10
Rufname:

AW: Buchstaben Suchen Addieren Auswerten! - AW: Buchstaben Suchen Addieren Auswerten!

Nach oben
       Version: Office 2011 (Mac)

Wenn ich doch oben C8 z.B. Sicht 1 eingebe werde alle Pause D8-am8 ausgegeben nur eben bei der Spätsicht nicht?!?!?!?!
Es würde mir reichen wenn wir das dort ans laufen bekommen
steve1da
Moderator


Verfasst am:
28. Nov 2013, 11:15
Rufname:

AW: Buchstaben Suchen Addieren Auswerten! - AW: Buchstaben Suchen Addieren Auswerten!

Nach oben
       Version: Office 2011 (Mac)

Zitat:
Wenn ich doch oben C8 z.B. Sicht 1 eingebe werde alle Pause D8-am8 ausgegeben nur eben bei der Spätsicht nicht?!?!?!?!


Ganz ehrlich, keine Ahnung was du meinst.

Zitat:
Es würde mir reichen wenn wir das dort ans laufen bekommen


Wo?
Gast



Verfasst am:
28. Nov 2013, 12:19
Rufname:

AW: Buchstaben Suchen Addieren Auswerten! - AW: Buchstaben Suchen Addieren Auswerten!

Nach oben
       Version: Office 2011 (Mac)

Mitarbeiterzeiten D5 bis AK8 habe ich ja immer die Dezimalzahl der Zeit stehen.


unter 8:00 wird durch eine Wennformel ja automatisch die Zeit bzw. die Pause generiert, allerdings funktioniert es in der Spätsicht nicht.
steve1da
Moderator


Verfasst am:
28. Nov 2013, 12:26
Rufname:

AW: Buchstaben Suchen Addieren Auswerten! - AW: Buchstaben Suchen Addieren Auswerten!

Nach oben
       Version: Office 2011 (Mac)

Schade das du mit keinem Wort auf meinen Vorschlag eingegangen bist. Dort kann man noch mehrere Pausenzeiten definieren und in die Formel einbauen.

Ich bin dann mal raus.
Gast



Verfasst am:
28. Nov 2013, 12:33
Rufname:

AW: Buchstaben Suchen Addieren Auswerten! - AW: Buchstaben Suchen Addieren Auswerten!

Nach oben
       Version: Office 2011 (Mac)

Nein, jetzt haben wir uns missverstanden ich habe deine Vorschlag schon eingebaut, wollte nur wissen wo oben mein Fehler liegt.

Denn ich verstehe nicht warum die Pausen der Frühschicht funktionieren, aber die in der Spätschicht nicht ?


Bei deinem Vorschlag habe ich aber das Problem das er mir z.B. von 8:00 - 8:15 zu jeder Zeit 0,25 Stunden abzieht also aus 0,25 Stunden werden 0,5 Stunden Pause.
steve1da
Moderator


Verfasst am:
28. Nov 2013, 12:41
Rufname:


AW: Buchstaben Suchen Addieren Auswerten! - AW: Buchstaben Suchen Addieren Auswerten!

Nach oben
       Version: Office 2011 (Mac)

Deine Formel in AA8 bezieht sich auf ganz andere Werte als die in AA7, daran wirds liegen.

Außerdem wird z.B. die Zeit in Arbeitszeiten AC8 nicht als identisch mit Arbeitszeiten D5 angesehen. Erst wenn man die Zeit in AC8 manuell erneut eingibt funktioniert es.
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Gehe zu Seite Zurück  1, 2, 3, 4  Weiter
Diese Seite Freunden empfehlen

Seite 3 von 4
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: werte aus verschiedenen tabellen addieren 3 Actiongreg 2518 06. Jul 2005, 17:23
actiongreg werte aus verschiedenen tabellen addieren
Keine neuen Beiträge Excel Formeln: Addieren von Werten grösser 0 10 GAST06.06.05 4200 17. Jun 2005, 09:38
Gast17.06.05 Addieren von Werten grösser 0
Keine neuen Beiträge Excel Formeln: Mehrere Formelergebnisse addieren ohne Hilfsspalte? 14 Detlef 42 1915 27. Apr 2005, 20:24
Hübi Mehrere Formelergebnisse addieren ohne Hilfsspalte?
Keine neuen Beiträge Excel Formeln: Buchstaben zaehlen ueber mehrere Sheets 2 Budinger 597 30. März 2005, 20:04
Budinger Buchstaben zaehlen ueber mehrere Sheets
Keine neuen Beiträge Excel Formeln: Funktion 'Summenprodukt' mit Buchstaben 2 cschaden 2356 05. März 2005, 20:58
cschaden Funktion 'Summenprodukt' mit Buchstaben
Keine neuen Beiträge Excel Formeln: SVERWEIS-Werte addieren 2 Hiasl 3402 19. Jan 2005, 19:47
Hiasl SVERWEIS-Werte addieren
Keine neuen Beiträge Excel Formeln: Will Werte addieren in Bezug zu einer anderen Spalte 8 MrMr 2236 08. Jan 2005, 14:50
xyzdef Will Werte addieren in Bezug zu einer anderen Spalte
Keine neuen Beiträge Excel Formeln: Erst Spalte dann wert suchen zeile ausgeben 2 Kai2k 3055 07. Jan 2005, 12:10
Kai2k Erst Spalte dann wert suchen zeile ausgeben
Keine neuen Beiträge Excel Formeln: Suchen eines Wertes in einer Zeile 1 AxelChris 1731 25. Nov 2004, 17:25
Patrick0705 Suchen eines Wertes in einer Zeile
Keine neuen Beiträge Excel Formeln: Problem mit Suchen/Ersetzen 1 Benni 730 24. Nov 2004, 23:04
Reinhard Problem mit Suchen/Ersetzen
Keine neuen Beiträge Excel Formeln: Nur addieren wenn ein bestimmter Wert in einer Bereich 4 Aloha 2956 18. Nov 2004, 22:44
Aloha Nur addieren wenn ein bestimmter Wert in einer Bereich
Keine neuen Beiträge Excel Formeln: Zellen auswerten 4 Cat 1526 11. Nov 2004, 01:20
Gast Zellen auswerten
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Excel Tipps