Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Wenn Formel und suchen in einer Matrix
zurück: Wie lasse ich in eine Zelle automatisch einen Text schreiben weiter: Dropdown Feld wenn Zelle nicht leer Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
killa21
Gast


Verfasst am:
24. Jul 2013, 16:35
Rufname:

Wenn Formel und suchen in einer Matrix - Wenn Formel und suchen in einer Matrix

Nach oben
       Version: Office 2013

Hallo,

ich benötige bitte eure Hilfe zu folgendem Problem. Ich möchte in einer Matrix jede Zelle nach dem Zeichen ":" durchsuchen. Wenn es vorhanden ist soll die Ausgabe "i" erfolgen wenn nicht dann ein Leerzeichen.

Matrix = C5:C5223 (z.B. "i= 1:235" oder "for this one")
Suchbegriff = „:“
Wenn in der Zelle vorhanden dann als Ausgabe „i“
Wenn nicht in der Zelle vorhanden dann als Ausgabe „Leerzeichen“

Danke und viele Grüße,
steve1da
Moderator


Verfasst am:
24. Jul 2013, 16:37
Rufname:


AW: Wenn Formel und suchen in einer Matrix - AW: Wenn Formel und suchen in einer Matrix

Nach oben
       Version: Office 2013

Hola,

so?

Code:
=WENN(ZÄHLENWENN(C5;"*:*");"i";"Leerzeichen")


Diese Formel runterziehen.

Gruß,
steve1da
Gast



Verfasst am:
24. Jul 2013, 16:47
Rufname:

AW: Wenn Formel und suchen in einer Matrix - AW: Wenn Formel und suchen in einer Matrix

Nach oben
       Version: Office 2013

Danke für die schnelle Antwort.
Kann die Formel leider nicht runterziehen soll in folgende Formel integriert werden.

=WENN(B4="";"";SVERWEIS($B$4;'Preisliste2013'!$A$4:$AD$7992;2;FALSCH)&gesuchte Formel&SVERWEIS($B$4;'Preisliste!$A$4:$AD$7992;3;FALSCH))

Ausgabe: Bezeichnung & "i"oder"Leerzeichen" & Zusatzbezeichnung
Niko2890
Gast


Verfasst am:
24. Jul 2013, 16:56
Rufname:

AW: Wenn Formel und suchen in einer Matrix - AW: Wenn Formel und suchen in einer Matrix

Nach oben
       Version: Office 2013

Hi probier es mal mit der Formel:

=WENN(ISTFEHLER(FINDEN(":";C5;1));" ";"i")
hiob
armer wissbegieriger user


Verfasst am:
24. Jul 2013, 17:16
Rufname: losmo


Re: AW: Wenn Formel und suchen in einer Matrix - Re: AW: Wenn Formel und suchen in einer Matrix

Nach oben
       Version: Office 2013

Anonymous - 24. Jul 2013, 16:47 hat folgendes geschrieben:
Danke für die schnelle Antwort.
Kann die Formel leider nicht runterziehen soll in folgende Formel integriert werden.

=WENN(B4="";"";SVERWEIS($B$4;'Preisliste2013'!$A$4:$AD$7992;2;FALSCH)&gesuchte Formel&SVERWEIS($B$4;'Preisliste!$A$4:$AD$7992;3;FALSCH))

Ausgabe: Bezeichnung & "i"oder"Leerzeichen" & Zusatzbezeichnung


aber dann stimmen doch die bereiche nicht mehr oder..?

Code:
=WENN(B4="";"";SVERWEIS($B$4;Preisliste2013!$A$4:$AD$7992;2;0)&WENN(ISTZAHL(FINDEN(":";C5;1));"i";"Leer")&SVERWEIS($B$4;Preisliste2013!$A$4:$AD$7992;3;0))

_________________
hiobs botschaft gespickt mit
halbgarem hintergrundwissen
Gast



Verfasst am:
24. Jul 2013, 17:26
Rufname:

AW: Wenn Formel und suchen in einer Matrix - AW: Wenn Formel und suchen in einer Matrix

Nach oben
       Version: Office 2013

Das mit dem "leer" funktioniert er zeigt mir nur kein "i" an wenn ein ":" da ist.
hiob
armer wissbegieriger user


Verfasst am:
24. Jul 2013, 17:28
Rufname: losmo

Re: AW: Wenn Formel und suchen in einer Matrix - Re: AW: Wenn Formel und suchen in einer Matrix

Nach oben
       Version: Office 2013

Anonymous - 24. Jul 2013, 17:26 hat folgendes geschrieben:
Das mit dem "leer" funktioniert er zeigt mir nur kein "i" an wenn ein ":" da ist.


wo zeigt wer was an..? was hast du wo wie eingesetzt..?

_________________
hiobs botschaft gespickt mit
halbgarem hintergrundwissen
Gast



Verfasst am:
24. Jul 2013, 18:44
Rufname:

AW: Wenn Formel und suchen in einer Matrix - AW: Wenn Formel und suchen in einer Matrix

Nach oben
       Version: Office 2013

Habe die Formen wie folgt eingesetzt.

=WENN(B4="";"";SVERWEIS($B$4;Preisliste2013!$A$4:$AD$7992;2;0)&WENN(ISTZAHL(FINDEN(":";Preisliste2013!C35:C7992;1));"i";"Leer")&SVERWEIS($B$4;Preisliste2013!$A$4:$AD$7992;3;0))

Und zeigt an.

Zelle leer
"Bezeichnung" "Leer" "Zusatz"

Zelle mit ":"
"Bezeichnung" "Leer" "Zusatz"

Danke. Hoffe ich habe es verständlich erklärt was gar nicht so einfach ist. Surprised
killa21
Gast


Verfasst am:
25. Jul 2013, 08:26
Rufname:

AW: Wenn Formel und suchen in einer Matrix - AW: Wenn Formel und suchen in einer Matrix

Nach oben
       Version: Office 2013

Es kann so ja gar nicht funtionieren.

=WENN(B4="";"";SVERWEIS($B$4;Preisliste2013!$A$4:$AD$7992;2;0)&WENN(ISTZAHL(FINDEN(":";Preisliste2013!C35:C7992;1));"i";"Leer")&SVERWEIS($B$4;Preisliste2013!$A$4:$AD$7992;3;0))

Er bringt immer eine Leerzeile da er nicht unterscheiden kann in welcher Zeile
sich der SVERWEIS befindet.

z.B. Art.-Nr. 12345 ist ein 1 : 122
z.B. Art.-Nr. 12346 ist ein Zelle leer
steve1da
Moderator


Verfasst am:
25. Jul 2013, 08:42
Rufname:


AW: Wenn Formel und suchen in einer Matrix - AW: Wenn Formel und suchen in einer Matrix

Nach oben
       Version: Office 2013

Hola,

ich denke mal es wird Zeit für eine Beispieltabelle (z.B. bei file-upload.net).

Gruß,
steve1da
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: suche ne formel mit bestimmten abhängigkeiten 6 pipi 3131 26. Apr 2004, 13:39
pipi suche ne formel mit bestimmten abhängigkeiten
Keine neuen Beiträge Excel Formeln: Problem mit WENN Formel 1 Hubert 2799 17. Apr 2004, 23:00
Robsl Problem mit WENN Formel
Keine neuen Beiträge Excel Formeln: Suche Formel für meinen chef! 6 Gast 2434 14. Apr 2004, 10:50
Search Suche Formel für meinen chef!
Keine neuen Beiträge Excel Formeln: Formel für Leerzeilen 2 Ursula 2167 24. März 2004, 12:31
steve1da Formel für Leerzeilen
Keine neuen Beiträge Excel Formeln: Formel 1 posti 636 20. März 2004, 15:51
Dick Formel
Keine neuen Beiträge Excel Formeln: Formel? 1 MantaC24NE 1378 16. März 2004, 19:29
Klaus-Dieter Formel?
Keine neuen Beiträge Excel Formeln: wenn formel mit ODER 4 Equilibrium 1654 16. März 2004, 00:09
Gast wenn formel mit ODER
Keine neuen Beiträge Excel Formeln: Hilfe finde keine geeignete Formel 4 faby22 1682 14. März 2004, 16:07
Faby22 Hilfe finde keine geeignete Formel
Keine neuen Beiträge Excel Formeln: indirekte Matrix 2 Tom64 618 05. März 2004, 12:31
Tom64 indirekte Matrix
Keine neuen Beiträge Excel Formeln: Mathematische Formel gesucht! 2 Gast 1367 05. März 2004, 01:18
lala Mathematische Formel gesucht!
Keine neuen Beiträge Excel Formeln: formel gesucht wenn/dann/sverweis 1 robert305 3159 01. März 2004, 16:45
xpecidy formel gesucht wenn/dann/sverweis
Keine neuen Beiträge Excel Formeln: Suche ein Formel 4 Unwissender 2147 20. Feb 2004, 09:45
xpecidy Suche ein Formel
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML Editor Forum