Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Gleiche Kombinationen summieren.
zurück: div/0 weiter: Formel gibt #Wert! zurück?! Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
AndreasGast
Gast


Verfasst am:
23. Jul 2013, 20:40
Rufname:

Gleiche Kombinationen summieren. - Gleiche Kombinationen summieren.

Nach oben
       Version: Office 2010

Hallo,

folgendes Prob.

Ich habe eine Liste, in A stehen Kostenstellen. in B Kostenträger und in C Sachkonten.
Wenn ich nun A Filtere und nur eine Kostenstelle anziege lasse, hat diese vllt 40-50 Datensätze. auch B und C sind ab un an gleich aber auch unterschiedlich. ich möchte dass nun gleiche Kombinationen summiert

gibt es ne möglichkeit, notfalls ueber VBA. kombinationen von A B C die gleich sind.

bspw. A: 1234 B: 567 C: 89
nun Soll er jedes Feld nach dieser kombination suchen uns summieren. und mit den weiteren kombinationen das selbe.

ueber die ausgabe habe ich mir aber auch noch keine gedanken gemacht. müsste ja dann wohl ne ausgabezelle für jede denkbare kombination haben.
Thomas Ramel
Microsoft Excel-MVP


Verfasst am:
23. Jul 2013, 21:22
Rufname: Thom
Wohnort: Glashütten - CH


AW: Gleiche Kombinationen summieren. - AW: Gleiche Kombinationen summieren.

Nach oben
       Version: Office 2010

Grüezi Andreas

Was genau verstehst Du bei diesen Kombinationen unter 'summieren'?

Willst Du wissen wie oft jede Kombination in deinen Daten enthalten ist?

Oder gibt es noch eine andere Spalte, deren Inhalt aufgrund der Kombination der ersten drei dann summiert werden soll?


Anyway - auf jeden Fall kannst Du das Ganze am einfachsten mit einer Pivot-Tabelle 'erschlagen'.
Lege die drei Felder deren Kombinationen Du haben möchtest in den Zeilenbereich und z.B. die weitere Spalte in den Wertebereich - damit werden die Daten der weiteren Spalte dann summiert (ggf. noch Summe als Aggregierungsfunktion festlegen).

Oder ziehe eine der drei Spalten zusätzlich in den Wertebereich und wähle 'Anzahl' als Aggregierungsfunktion, dann wird die Anzahl der Kombinationen ausgegeben.

_________________
Mit freundlichen Grüssen

Thomas Ramel
[Vista Ultimate SP-1 / xl2007 SP-2]
Simon177_a
Gast


Verfasst am:
23. Jul 2013, 22:07
Rufname:

AW: Gleiche Kombinationen summieren. - AW: Gleiche Kombinationen summieren.

Nach oben
       Version: Office 2010

Hi,

schau dir mal die Funtkion SUMMEWENNS an. Für eine feste Kombination macht die genau das, was du beschrieben hast.


Schwieriger wird es, wenn es darum geht, sämtliche Kombinationen zu finden.
Da wirst in der Tat Hilfsspalten benötigen. Nehmen wir an, deine Einträge beginnen in Zeile 1.
Dann kommt in Zelle G1:
{=WENN(SUMME(WENN(A1=A$1:A1;1;0)*WENN(B1=B$1:B1;1;0)*WENN(C1=C$1:C1;1;0))>1;"war schon dran";"neue Kombination")}

Die { } stehen für Arrayformel. Wenn du weißt, was das ist, kannst du das runterkopieren.
Damit kannst du dir anzeigen lassen, welche Kombinationen schon mal dran waren.
Simon177_a
Gast


Verfasst am:
23. Jul 2013, 22:14
Rufname:


AW: Gleiche Kombinationen summieren. - AW: Gleiche Kombinationen summieren.

Nach oben
       Version: Office 2010

Ach, natürlich kannst du die Arrayformel auch
durch eine Konstruktion mit ZÄHLENWENNS ersetzen:

=WENN(ZÄHLENWENNS(A$1:A1;A1;B$1:B1;B1;C$1:C1;C1)>1;"war schon dran";"neue Kombination")

(Ich rede von SUMMEWENNS und benutze dann Arrayformeln. Dzdzdz..)
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Gleiche Worte in Spalte zählen und Zahl einmal ausgeben 4 Gast 1194 02. Apr 2007, 13:03
Gast Gleiche Worte in Spalte zählen und Zahl einmal ausgeben
Keine neuen Beiträge Excel Formeln: gleiche Werte abfragen 3 Gastt 803 07. März 2007, 00:02
Gast gleiche Werte abfragen
Keine neuen Beiträge Excel Formeln: Summieren! 2 Testperson 386 05. März 2007, 11:28
myfake Summieren!
Keine neuen Beiträge Excel Formeln: Dezimalzahl als Stunden summieren 4 Wishmaster 5485 16. Feb 2007, 14:32
Kaischi Dezimalzahl als Stunden summieren
Keine neuen Beiträge Excel Formeln: Formel für Summieren? 4 Gast 587 05. Feb 2007, 13:34
urs Formel für Summieren?
Keine neuen Beiträge Excel Formeln: SUMMPRODUKT: Summieren von Beträgen innerhalb von-bis Datum 2 RobiX 893 19. Nov 2006, 12:34
RobiX SUMMPRODUKT: Summieren von Beträgen innerhalb von-bis Datum
Keine neuen Beiträge Excel Formeln: Formel 3 Zellen sortieren ohne zwei gleiche oder mehrere???? 2 vr6-tuning 594 16. Nov 2006, 20:38
vr6-tuning Formel 3 Zellen sortieren ohne zwei gleiche oder mehrere????
Keine neuen Beiträge Excel Formeln: Zelle grün gefärbt, dann X in Hilfsspalte oder summieren 11 Nenilix 1402 04. Sep 2006, 16:30
< Peter > Zelle grün gefärbt, dann X in Hilfsspalte oder summieren
Keine neuen Beiträge Excel Formeln: Werte in abhängigkeit summieren 2 Frankie 3445 27. Apr 2006, 19:15
rainberg Werte in abhängigkeit summieren
Keine neuen Beiträge Excel Formeln: Verschiedene Tabellen, gleiche Zelle 3 schwingler 1813 29. März 2006, 07:26
schwingler Verschiedene Tabellen, gleiche Zelle
Keine neuen Beiträge Excel Formeln: Plus- und Minuswerte aufteilen und summieren 5 Klaus D. 3595 25. Feb 2006, 21:55
Klaus D. Plus- und Minuswerte aufteilen und summieren
Keine neuen Beiträge Excel Formeln: werte nach suchkriterien summieren 5 xub 1005 05. Feb 2006, 16:07
xub werte nach suchkriterien summieren
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft-Excel Diagramme