Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Erste nicht leere Zelle in der Spalte UND 3 Bedingungen
zurück: Wert suchen und Spalte daneben wiedergeben weiter: Excel x-Wert der Trendkurve berechnen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
sheryfraser
Im Profil kannst Du frei den Rang ändern


Verfasst am:
23. Apr 2013, 13:40
Rufname:

Erste nicht leere Zelle in der Spalte UND 3 Bedingungen - Erste nicht leere Zelle in der Spalte UND 3 Bedingungen

Nach oben
       Version: Office 2010

Hallo!

Ich habe folgendes Problem:

in einer Tabelle werden Bedarfsmeldenummern chronologisch erfasst.
In Spalte A wird die Nummer der Bedarfsmeldung (Sachgemeinkosten) vergeben (Jahr + fortlaufende Nr.)
In Spalte B werden die von SAP vergebenen Nummern (MANF für Investitionen) erfasst.
In Spalte C steht die Kostenart.

Ich möchte nun, dass...
- wenn ein Eintrag in Spalte B vorgenommen wurde, die Zelle links daneben in Spalte A leer bleibt
- wenn ein Eintrag in Spalte C erfolgt (Kostenart) UND kein Eintrag in Spalte B vorhanden ist, die Bedarfsmeldenummer in Spalte A automatisch erscheint.
- die Bedarfsmeldenummer immer +1 der letzten Eintragung ist

Ich bekomme das noch gelöst, wenn nur 1 leere Zelle in Spalte A wegen Eintrag in Spalte B. Sobald es 2 oder mehr werden funktioniert meine Fomel natürlich nicht mehr....

=WENN(C3="";"";WENN(B3="";WENN(A2="";A1+1;A2+1);""))

Wie könnte ich das Problem lösen, wenn er die Bedarfsmeldenummer der letzten nicht leeren zelle nimmt und um 1 erhöht?



BANF-Liste.jpg
 Beschreibung:
Beispiel
 Dateigröße:  34.66 KB
 Angeschaut:  130 mal

BANF-Liste.jpg


Gast



Verfasst am:
23. Apr 2013, 14:01
Rufname:

AW: Erste nicht leere Zelle in der Spalte UND 3 Bedingungen - AW: Erste nicht leere Zelle in der Spalte UND 3 Bedingungen

Nach oben
       Version: Office 2010

Hallo,

Tabelle1

 ABC
1BANFMANFKostenart
22013001 123
32013002 456
42013003 789
52013004 123
6 4711456
72013005 789
82013006 123
9 678 
102013007 789
11 815123
122013008 456

Formeln der Tabelle
ZelleFormel
A2=WENN(UND(B2="";C2<>"");MAX(2013000;$A$1:A1)+1;"")


Excel Jeanie Html

Formel in A2 nach unten ausfüllen lassen.

viele Grüße

Axel
sheryfraser
Im Profil kannst Du frei den Rang ändern


Verfasst am:
23. Apr 2013, 14:19
Rufname:


AW: Erste nicht leere Zelle in der Spalte UND 3 Bedingungen - AW: Erste nicht leere Zelle in der Spalte UND 3 Bedingungen

Nach oben
       Version: Office 2010

Asche auf mein Haupt...das war ja gar nicht so schwer....

Am Besten macht man mal ne Stunde die Datei zu und fängt von vorne an, wenn man nimmer weiter kommt *lach

aber 1000 Dank!!!!!

Gruß

Michael
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Problem mit WENN-Formel - ich bräuchte zu viele Bedingungen 6 Florian 1187 05. Okt 2004, 12:37
Florian Problem mit WENN-Formel - ich bräuchte zu viele Bedingungen
Keine neuen Beiträge Excel Formeln: Leerzeichen in Zelle löschen 3 pkegelking 1807 01. Okt 2004, 11:57
pkegelking Leerzeichen in Zelle löschen
Keine neuen Beiträge Excel Formeln: inhalt einer zelle suchen und wiedergeben 2 winni 5568 23. Sep 2004, 16:47
winni inhalt einer zelle suchen und wiedergeben
Keine neuen Beiträge Excel Formeln: Formatieren in Abhängigkeit von Zelle 'links'? 9 abidmon 2819 06. Sep 2004, 10:03
abidmon Formatieren in Abhängigkeit von Zelle 'links'?
Keine neuen Beiträge Excel Formeln: Autom. Farbänderung einer Zelle. 1 Stefan 66 5197 19. Aug 2004, 14:51
fl618 Autom. Farbänderung einer Zelle.
Keine neuen Beiträge Excel Formeln: Einfärben einer Spalte bei bestimmten Vorzeichen 3 itmeli 813 16. Aug 2004, 13:25
itmeli Einfärben einer Spalte bei bestimmten Vorzeichen
Keine neuen Beiträge Excel Formeln: Suche Zelle nach einem ähnlichem Wert ab... (wildcart) 2 Ranzi 2538 09. Aug 2004, 18:22
icke Suche Zelle nach einem ähnlichem Wert ab... (wildcart)
Keine neuen Beiträge Excel Formeln: Text und fortlaufende Nr. in eine Zelle 2 Strebe nach Können 1013 16. Jul 2004, 19:19
Strebe nach Können Text und fortlaufende Nr. in eine Zelle
Keine neuen Beiträge Excel Formeln: Wenn in Spalte A der Wert .... dann die Felder in Spalte B 3 mucky 2520 16. Jul 2004, 08:06
mucky Wenn in Spalte A der Wert .... dann die Felder in Spalte B
Keine neuen Beiträge Excel Formeln: punkt am ende der zelle? 3 marKUSS 1815 08. Jul 2004, 14:26
Gast punkt am ende der zelle?
Keine neuen Beiträge Excel Formeln: Wort in Zelle immer mit Großbuchstaben beginnen 6 QWERT 2522 24. Jun 2004, 15:56
steve1da Wort in Zelle immer mit Großbuchstaben beginnen
Keine neuen Beiträge Excel Formeln: Zahlen die links in einer Zelle stehen addieren 9 Red Hair 1611 09. Jun 2004, 07:41
steve1da Zahlen die links in einer Zelle stehen addieren
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Frontpage Forum