Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Sverweis und Wenn Abfrage
zurück: Minuten addieren weiter: Formel mit Wenn(und(.... Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Offen Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Tobstar55
Gast


Verfasst am:
23. Apr 2013, 12:16
Rufname:

Sverweis und Wenn Abfrage - Sverweis und Wenn Abfrage

Nach oben
       Version: Office 2007

Hallo,

hoffe hier kann mir jemand helfen da ich schon länger über dem Problem brüte und leider nicht drauf komme:

Möchte über einen sverweis Daten aus dem einen Tabellenreiter in den anderen Tabellenreiter übernehmen, funktioniert fürs erste schon mal ganz gut (hier: sverweis in Zelle B12):

=SVERWEIS(A12;Tabelle1!$A$24:$G$69947;2;FALSCH)

Mit diesem sverweis überschreibe ich also immer wieder die aktuelle Zelle A12 sobald ich entsprechende Zellen in meiner Matrix ändere.
Fehlt nun in meiner Matrix z.B. die Artikelnummer nach der ich suche (da sich die Matrix ständig ändert) würde sich nun der "Wert" in der Zelle mit dem sverweis in "#NV" ändern.

Mein Ziel wäre nun falls mir der sverweis ein #NV ausspuckt den ursprünglichen Wert der Zelle B12 beizubehalten und nicht mit #NV zu überschreiben. Mein Ansatz wäre nun folgender gewesen:

=WENN(SVERWEIS(A12;Tabelle1!$A$24:$G$69947;2;FALSCH)="#NV";B12;SVERWEIS(A10;Tabelle1!$A$24:$G$69947;2;FALSCH))

Doch leider ist weiterhin #NV das "Ergebnis". Liegt es an der falschen Formatierung oder falschen Anwendung der Formel oder gibt es noch einen anderen Weg zum Ziel? Aber wenn möglich nicht über VBA sondern nur über die typischen Excel-Formeln.

Dank und Gruß,
Tobstar
steve1da
Moderator


Verfasst am:
23. Apr 2013, 12:32
Rufname:

AW: Sverweis und Wenn Abfrage - AW: Sverweis und Wenn Abfrage

Nach oben
       Version: Office 2007

Hola,

der Sverweis steht also in B12? Dann wirst du um VBA nicht herum kommen, denn entweder steht in einer Zelle eine Formel, oder Text - beides geht ohne VBA nicht.

Gruß,
steve1da
Tobstar55
Gast


Verfasst am:
23. Apr 2013, 12:40
Rufname:


AW: Sverweis und Wenn Abfrage - AW: Sverweis und Wenn Abfrage

Nach oben
       Version: Office 2007

Arrrr,

Danke für die schnelle Antwort. Aber das hab ich mir fast gedacht.

Hättest du einen Tip/Ansatz wie ich das am einfachsten löse. Habe mich jetzt so auf den sverweis eingeschoßen...
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Rechnungsformular erstellen (SVerweis, WVerweis) 1 Susan 2997 14. Nov 2004, 19:42
ae Rechnungsformular erstellen (SVerweis, WVerweis)
Keine neuen Beiträge Excel Formeln: sverweis + darunterliegende Zeilen 7 L*R 3701 12. Nov 2004, 13:55
Arnim sverweis + darunterliegende Zeilen
Keine neuen Beiträge Excel Formeln: Problem mit sverweis 6 Yvi 648 11. Nov 2004, 16:38
ae Problem mit sverweis
Keine neuen Beiträge Excel Formeln: Koennte ein Sverweis sein *{=SUMME((MONAT(A1:A7)=E1)*(C1:C7) 2 Gast 1362 25. Okt 2004, 20:15
Gast Koennte ein Sverweis sein *{=SUMME((MONAT(A1:A7)=E1)*(C1:C7)
Keine neuen Beiträge Excel Formeln: Sverweis 4 Bernett22 1867 20. Okt 2004, 16:32
Bernett22 Sverweis
Keine neuen Beiträge Excel Formeln: Summe verschiedener Zellen mit Suchkreterium (sverweis) 3 Ralli 11135 13. Okt 2004, 23:12
ae Summe verschiedener Zellen mit  Suchkreterium (sverweis)
Keine neuen Beiträge Excel Formeln: Sverweis HELP!!!!!! 2 Black_Samurai 1773 30. Sep 2004, 18:12
Black_Samurai Sverweis HELP!!!!!!
Keine neuen Beiträge Excel Formeln: Verschachtelte WENN-Formel, VERGLEICH oder SVERWEIS? 14 Zokanta 4788 27. Sep 2004, 22:34
Zokanta Verschachtelte WENN-Formel, VERGLEICH oder SVERWEIS?
Keine neuen Beiträge Excel Formeln: Vergleich mit SVERWEIS und WENN 4 Marc 3124 27. Sep 2004, 12:44
Marc Vergleich mit SVERWEIS und WENN
Keine neuen Beiträge Excel Formeln: SVERWEIS (VLOOKUP) und sortierte Liste 2 Aloha 2080 07. Sep 2004, 18:55
Aloha SVERWEIS (VLOOKUP) und sortierte Liste
Keine neuen Beiträge Excel Formeln: SVERWEIS Problem 2 lyrics 1777 09. Aug 2004, 11:14
lyrics SVERWEIS Problem
Keine neuen Beiträge Excel Formeln: SVerweis über mehrere Tabellenblätter 1 Andy_beginner 2084 16. Jul 2004, 08:19
icke SVerweis über mehrere Tabellenblätter
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML CSS