Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Doppelte Zeilen zusammenführen
zurück: Variabel in Formel weiter: Formatproblem bei Datum Differnz Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Steph1982
Im Profil kannst Du frei den Rang ändern


Verfasst am:
22. Apr 2013, 17:05
Rufname:

Doppelte Zeilen zusammenführen - Doppelte Zeilen zusammenführen

Nach oben
       Version: Office 2010

Hallo Zusammen,

folgendes Problem habe ich:
Nehmen wir an es existieren 4 Spalten:
A: Personalnummer B: Name C: Qualifikationen

Jetzt würde in der Spalte A die Personalnummer 2 oder auch 3 mal vorkommen,
allerding mit den unterschiedlichsten Qualifikationen.
Wie bekomme ich es hin, dass er zum einen erkennt, dass die Personalnummer identisch sind, er mir aber die unterschiedlichsten Qualifikation in einer Zeile darstellt bzw zusammenführt (sodass in der Spalte D bis F die Qualifikationen stehen)?????

Als Bsp.

1234 Mustermann, Daniel, Realschule, Abitur, Ausbildung

Vielen Lieben Dank für Eure Unterstützung!
slowboarder
Im Profil kannst Du frei den Rang ändern


Verfasst am:
22. Apr 2013, 17:25
Rufname:


AW: Doppelte Zeilen zusammenführen - AW: Doppelte Zeilen zusammenführen

Nach oben
       Version: Office 2010

Hi

führe folgende Schritte aus:

1. Tabelle nach Personalnummer sortieren

2. in D2 folgende Formel einfügen und nach rechts und nach unten bis zum Datenende kopieren:
=WENN(SPALTE()-3>=ZÄHLENWENN($A:$A;$A2);"";INDEX($C:$C;ZEILE()+SPALTE()-3))

3. Spalte D-F kopieren und an gleicher Stelle als Wert einfügen.

4. ganze Tabelle markieren und die Funktion: DATEN - DATENTOOLS - DUPLIKATE ENTFERNEN ausführen mit den Personalnummern als Referenzspalte.

Gruß Daniel
Steph1982
Im Profil kannst Du frei den Rang ändern


Verfasst am:
22. Apr 2013, 23:26
Rufname:

AW: Doppelte Zeilen zusammenführen - AW: Doppelte Zeilen zusammenführen

Nach oben
       Version: Office 2010

Hey Daniel,

zunächst einmal Danke, für den schnellen Beitrag,

vllt. war es ein wenig blöd von mir ausgedrückt.
Ich habe folgende Ausgangstabelle:

Tabelle1

 ABCDEF
1PernrNameVornameQualifikationQualifikationQualifikation
21234MusterStephanRealschule  
31234MusterStephan HauptschuleStudium
42345MüllerBjörnStudium  
57634FransecoHilde  Berufsschule
66789GalenTorben Gymnasium 
76789GalenTorben  Studium
86790GalenTorbenAusbildung  
96791GalenTorben  Studium


[url=http://www.office-loesung.de/ftopic91422_0_0_asc.php]Excel Jeanie Html[/url]

und anschließend soll die Tabelle wie folgt aussehen:

Tabelle2

 ABCDEFG
1PernrNameVornameQualifikationQualifikationQualifikation 
21234MusterStephanRealschuleHauptschuleStudium 
32345MüllerBjörnStudium   
47634FransecoHilde  Berufsschule 
56789GalenTorbenAusbildungGymnasiumStudiumStudium


[url=http://www.office-loesung.de/ftopic91422_0_0_asc.php]Excel Jeanie Html[/url]



wie kann ich das hinbekommen?????

Hilfe!!!
slowboarder
Im Profil kannst Du frei den Rang ändern


Verfasst am:
23. Apr 2013, 00:11
Rufname:

AW: Doppelte Zeilen zusammenführen - AW: Doppelte Zeilen zusammenführen

Nach oben
       Version: Office 2010

das sieht ziemlich chaotisch aus.
wenn ich da weiter machen soll, hätte ich gerne die Echtdaten als Datei.(Namen kannst du ja durch "xxx" ersetzen,, die spielen keine Rolle)
aber ohne VBA sehe ich da kaum Möglichkeiten.
Gruß Daniel
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
23. Apr 2013, 05:55
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände


AW: Doppelte Zeilen zusammenführen - AW: Doppelte Zeilen zusammenführen

Nach oben
       Version: Office 2010

Hallo Steph

Dann mußt du mal erklären warum du die Zeilen 6 bis 9 zusammenfaßt obwohl es drei verschiedene Personennummern sind.

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Doppelte Einträge herausfiltern 3 Jericho2000 6004 21. Okt 2005, 08:46
< Peter > Doppelte Einträge herausfiltern
Keine neuen Beiträge Excel Formeln: "Doppelte" Summewenn-Funktion? 3 bobi 7145 19. Okt 2005, 09:28
rainberg "Doppelte" Summewenn-Funktion?
Keine neuen Beiträge Excel Formeln: 2 Spalten mit Telefonnummern zusammenführen 2 Nicola1969 2184 28. Sep 2005, 14:51
Nicola1969 2 Spalten mit Telefonnummern zusammenführen
Keine neuen Beiträge Excel Formeln: Bei dreifachen Werten Zeilen löschen 14 Kosich 823 01. Sep 2005, 14:23
Kosich Bei dreifachen Werten Zeilen löschen
Keine neuen Beiträge Excel Formeln: Daten in Spalten zusammenführen 5 krabbelkrabbel 1470 30. Aug 2005, 14:14
krabbelkrabbel Daten in Spalten zusammenführen
Keine neuen Beiträge Excel Formeln: doppelte daten suchen 2 chrispx 1428 26. Aug 2005, 09:27
chrispx doppelte daten suchen
Keine neuen Beiträge Excel Formeln: Zählen von Einträgen in Zeilen oder Spalten 3 ggaribaldi 1657 27. Jul 2005, 09:23
steve1da Zählen von Einträgen in Zeilen oder Spalten
Keine neuen Beiträge Excel Formeln: Zeilen zusammenfügen 8 nasi 1050 14. Jul 2005, 15:26
tom_r Zeilen zusammenfügen
Keine neuen Beiträge Excel Formeln: Zeilen mit Wert 0 ausblenden 2 MartinJungwirth 1448 24. Jun 2005, 13:53
MartinJungwirth Zeilen mit Wert 0 ausblenden
Keine neuen Beiträge Excel Formeln: Farbige Zeilen bei verschiedenen Kriterien 10 Nixweis 1254 09. Jun 2005, 13:59
Nixweiß Farbige Zeilen bei verschiedenen Kriterien
Keine neuen Beiträge Excel Formeln: Leere Zeilen vom Kombinationsfeld löschen 5 sifak 1332 19. Apr 2005, 17:11
Hübi Leere Zeilen vom Kombinationsfeld löschen
Keine neuen Beiträge Excel Formeln: Doppelte Daten entfernen 1 Sabine1980 2206 08. Feb 2005, 18:19
Thomas Ramel Doppelte Daten entfernen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML CSS