Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Daten aus Tabelle mittels Auswahl aus Combobox einlesen
zurück: Hilfe für Projekt zur Materialdisposition gesucht weiter: Mein Excel spinnt - Formel kopieren und cut+paste geht nicht Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Miky86
Gast


Verfasst am:
05. Jan 2013, 01:17
Rufname:

Daten aus Tabelle mittels Auswahl aus Combobox einlesen - Daten aus Tabelle mittels Auswahl aus Combobox einlesen

Nach oben
       Version: Office 2010

Hallo Experten,

ich bin leider absoluter Neuling auf dem Gebiet der VBA-Programmierung und habe dementsprechend kaum Kenntnisse darin Embarassed Ich hoffe ihr könnt mir weiterhelfen!?

Also zu meinem Problem.
Ich möchte Daten aus einer Tabelle (Blatt "Tabelle2") per Auswahl aus einer Combobox, welche im Blatt zuvor (Blatt "Tabelle1") sein soll , einfügen.
Im Tabellenblatt "Tabelle2" sind dabei in Spalte A drei Länder (Belgien, Portugal und Italien) mit jeweils 12 Monatsumsatzzahlen vermerkt.
Code:
Belgien         1  3  1  4  5  7  5  4  6  7  8  9
Portugal        3  3  6  4  5  7 10  8  6  7  1  1
Italien           2  4  3  7  8  6  1  1  1  1  2  2
In Tabellenblatt "Tabelle1" soll nun über die Auswahl eines der 3 Länder mit Hilfe einer Combobox die dazugehörigen Umsatzzahlen in eine neue Tabelle (welche direkt unterhalb der Combobox aufgelistet sein soll) eingelesen bzw. eingefügt werden. Die Umsatzzahlen sollen dabei senkrecht untereinander ohne leere Zelle aufgeführt werden.
Wichtig ist dabei, dass wenn man ein anderes Land auswählt eben die "neuen" Umsatzzahlen automatisch angeglichen werden (z.B. zuerst für Auswahl Belgien 1 3 1 4 usw. und dann für die Auswahl Italien die Umsatzzahlen 2 4 3 7 usw.).

Ja ich weiß, eigentlich ganz einfach...aber dennoch Sad

Ich weiß leider überhaupt nicht wie ich dies machen soll. Ich hoffe wirklich sehr dass mir jemand weiterhelfen kann. Schon mal herzlichsten Dank im Voraus!!!!!!!!

PS: Verwende Excel 2010
RPP63
ambitionierter Spätanfänger


Verfasst am:
05. Jan 2013, 10:30
Rufname:
Wohnort: mitten im Pott

AW: Daten aus Tabelle mittels Auswahl aus Combobox einlesen - AW: Daten aus Tabelle mittels Auswahl aus Combobox einlesen

Nach oben
       Version: Office 2010

Hallo!

Mal eine Lösung ohne VBA:
In Spalte A der Tabelle1 Daten, Gültigkeit, Liste
Hier entweder Hilfszellen (wie bei mir) für die Länder einfügen,
oder den Ländern in Tabelle2 einen Namen zuweisen und diesen in die Gültigkeit übernehmen.

Die Zuweisung erfolgt dann über SVERWEIS:

 ABCDEFGHIJKLMNO
1              Länder
2Land123456789101112 Belgien
3Belgien159421564218267261463427 Portugal
4Italien49128559076526010695806861 Italien
5Portugal3211138735935438978635144  
ZelleFormel
B3=WENN($A3="";"";SVERWEIS($A3;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
C3=WENN($A3="";"";SVERWEIS($A3;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
D3=WENN($A3="";"";SVERWEIS($A3;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
E3=WENN($A3="";"";SVERWEIS($A3;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
F3=WENN($A3="";"";SVERWEIS($A3;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
G3=WENN($A3="";"";SVERWEIS($A3;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
H3=WENN($A3="";"";SVERWEIS($A3;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
I3=WENN($A3="";"";SVERWEIS($A3;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
J3=WENN($A3="";"";SVERWEIS($A3;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
K3=WENN($A3="";"";SVERWEIS($A3;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
L3=WENN($A3="";"";SVERWEIS($A3;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
M3=WENN($A3="";"";SVERWEIS($A3;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
B4=WENN($A4="";"";SVERWEIS($A4;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
C4=WENN($A4="";"";SVERWEIS($A4;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
D4=WENN($A4="";"";SVERWEIS($A4;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
E4=WENN($A4="";"";SVERWEIS($A4;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
F4=WENN($A4="";"";SVERWEIS($A4;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
G4=WENN($A4="";"";SVERWEIS($A4;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
H4=WENN($A4="";"";SVERWEIS($A4;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
I4=WENN($A4="";"";SVERWEIS($A4;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
J4=WENN($A4="";"";SVERWEIS($A4;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
K4=WENN($A4="";"";SVERWEIS($A4;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
L4=WENN($A4="";"";SVERWEIS($A4;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
M4=WENN($A4="";"";SVERWEIS($A4;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
B5=WENN($A5="";"";SVERWEIS($A5;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
C5=WENN($A5="";"";SVERWEIS($A5;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
D5=WENN($A5="";"";SVERWEIS($A5;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
E5=WENN($A5="";"";SVERWEIS($A5;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
F5=WENN($A5="";"";SVERWEIS($A5;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
G5=WENN($A5="";"";SVERWEIS($A5;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
H5=WENN($A5="";"";SVERWEIS($A5;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
I5=WENN($A5="";"";SVERWEIS($A5;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
J5=WENN($A5="";"";SVERWEIS($A5;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
K5=WENN($A5="";"";SVERWEIS($A5;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
L5=WENN($A5="";"";SVERWEIS($A5;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
M5=WENN($A5="";"";SVERWEIS($A5;Tabelle2!$A$2:$M$4;SPALTE();FALSCH))
ZelleGültigkeitstypOperatorWert1Wert2
A3Liste =$O$2:$O$4 
A4Liste =$O$2:$O$4 
A5Liste =$O$2:$O$4 


Gruß, Ralf

_________________
besser spät als nie ...
Miky86
Gast


Verfasst am:
05. Jan 2013, 20:21
Rufname:


AW: Daten aus Tabelle mittels Auswahl aus Combobox einlesen - AW: Daten aus Tabelle mittels Auswahl aus Combobox einlesen

Nach oben
       Version: Office 2010

Hallo Ralf,

hab vielen, vielen lieben Dank für deine schnelle Antwort. Hat mir jetzt echt super weitergeholfen Razz

Habs jetzt mit der Variante mit dem SVERWEIS gemacht, allerdings hab ich noch ein bisschen was abgeändert bzw. angepasst...z.B. anstatt M$4 => M$5, damit ich das letzte Land auch noch mit in die Auswahl reinbekomme.

Ich hoffe, dass es so meinem AG passt...(ich sollte es eigentlich mit Combobox über VBA machen).

Nochmals VIELEN LIEBEN DANK!!!!!!!!!!! Very Happy

viele Grüße (aus dem leider heute verregneten Bayern)
Michael
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Daten Gültigkeit 4 wuselmann 575 27. Jan 2005, 18:26
Thomas Ramel Daten Gültigkeit
Keine neuen Beiträge Excel Formeln: Dateinamen für zu öffnende Tabelle in Zelle vorgeben, wie? 4 excessor 1698 24. Jan 2005, 22:52
A.Knecht Dateinamen für zu öffnende Tabelle in Zelle vorgeben, wie?
Keine neuen Beiträge Excel Formeln: Verknüpfung Access Tabelle 1 DB_User 1788 17. Jan 2005, 11:54
ZeroCool Verknüpfung Access Tabelle
Keine neuen Beiträge Excel Formeln: Werte aus Projekttabelle 1 automatisch in Tabelle 2 + 3 ? 7 DerDoktor 3771 15. Jan 2005, 14:41
DerDoktor Werte aus Projekttabelle 1 automatisch in Tabelle 2 + 3 ?
Keine neuen Beiträge Excel Formeln: Daten aus Spalte in Zeile 2 ckahlert 1126 06. Jan 2005, 17:56
ckahlert Daten aus Spalte in Zeile
Keine neuen Beiträge Excel Formeln: Excel Tabelle Formel? 2 herberte 1948 31. Dez 2004, 00:57
Arnim Excel Tabelle Formel?
Keine neuen Beiträge Excel Formeln: 2 Daten miteinander vergleichen, wenn gleich dann Text 1 BennyII 4347 11. Dez 2004, 12:00
ae 2 Daten miteinander vergleichen, wenn gleich dann Text
Keine neuen Beiträge Excel Formeln: Werte aus Tabelle zurückgebn 1 Spoonler 2266 22. Nov 2004, 15:54
ae Werte aus Tabelle zurückgebn
Keine neuen Beiträge Excel Formeln: Anzahl bei 2 Bedingungen aus Tabelle berechnen 6 Satanico 1723 21. Okt 2004, 14:48
Satanico Anzahl bei 2 Bedingungen aus Tabelle berechnen
Keine neuen Beiträge Excel Formeln: Funktion: Identische Inhalt einer Zelle in Tabelle 1 und 2 4 luki 4202 09. Sep 2004, 18:20
Gast Funktion: Identische Inhalt einer Zelle in Tabelle 1 und 2
Keine neuen Beiträge Excel Formeln: Gleiche Einträge in Tabelle nummerich aufzählen 1 sauer 483 02. Sep 2004, 09:11
ae Gleiche Einträge in Tabelle nummerich aufzählen
Keine neuen Beiträge Excel Formeln: Tabelle einer Internetseite auslesen 1 Andy_beginner 1931 14. Jul 2004, 23:19
Manfred Bartak Tabelle einer Internetseite auslesen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Excel Tricks