Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Datentausch: A=B und B=A
zurück: Formel schreiben in letzte Spalte (+3) bis zur letzten Zeile weiter: Eigenschaften von Textbox variabel Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Tom9000
Gast


Verfasst am:
28. Nov 2012, 11:37
Rufname:

Datentausch: A=B und B=A - Datentausch: A=B und B=A

Nach oben
       Version: Office 2007

Hallo Community,

nach vergeblicher Suche und Ahnungslosikeit (blutiger VBA-Anfänger), wende ich mich an Euch und hoffe, dass Ihr mir mit meinem Problem weiterhelfen könnt.

Bei dem errechneten Wert "0" oder "", sollt keine Aktion erfolgen.
Bei dem errechneten Wert "1" soll folgende Aktion erfolgen:

A1 = B1
B1 = A1
A2 = B2
B2 = A2
A3 = B3
B3 = A3

Die Daten sollen also miteinander getauscht werden. Hinzu kommt, dass die Werte in A1-A3 den errechneten Wert ergeben:

=Wenn(Summe(A1:A3)>=Summe(B1:B3);0;1)

Hintergrund ist, dass somit die Eingabedaten (A1:A3; B1:B3) optimiert werden können.
Tom9000
Gast


Verfasst am:
28. Nov 2012, 14:49
Rufname:


AW: Datentausch: A=B und B=A - AW: Datentausch: A=B und B=A

Nach oben
       Version: Office 2007

Es ist wirklich wichtig und ich bin für jede Antwort sehr dankbar.

Viele Grüße
Tom
Alex.°°
Im Profil kannst Du frei den Rang ändern


Verfasst am:
28. Nov 2012, 15:30
Rufname:

AW: Datentausch: A=B und B=A - AW: Datentausch: A=B und B=A

Nach oben
       Version: Office 2007

So müsste es klappen...
VG
Alex

Code:
Option Explicit
Sub Zellentausch()
Dim a, b
a = Range("A1:A3")
b = Range("B1:B3")
Range("A4").FormulaLocal = "=SUMME(A1:A3)"
Range("B4").FormulaLocal = "=SUMME(B1:B3)"
If Range("A4").Value > Range("B4").Value Or Range("A4").Value = Range("B4").Value Then
Range("A1:A3") = b
Range("B1:B3") = a
End If
End Sub
Tom9000
Gast


Verfasst am:
28. Nov 2012, 16:15
Rufname:

AW: Datentausch: A=B und B=A - AW: Datentausch: A=B und B=A

Nach oben
       Version: Office 2007

Hallo Alex,

läuft super: vielen, vielen DANK. Kann man das auch in Worksheet.Change einbauen?

Vielen Dank für eine weitere Rückmeldung und die aufgebrachte Zeit.

Viele Grüße
Tom
Alex.°°
Im Profil kannst Du frei den Rang ändern


Verfasst am:
28. Nov 2012, 17:00
Rufname:

AW: Datentausch: A=B und B=A - AW: Datentausch: A=B und B=A

Nach oben
       Version: Office 2007

HI Tom,

so kann man das machen.
Die Target.Address kann man aber bestimmt noch eleganter ansprechen...

vg
Alex

Code:
Option Explicit
Private Sub Worksheet_Change(ByVal Target As Range)
   If Target.Address = "$A$1" Or Target.Address = "$A$2" Or Target.Address = "$A$3" _
   Or Target.Address = "$B$1" Or Target.Address = "$B$2" Or Target.Address = "$B$3" Then
    Call alles
End If
End Sub
Alex.°°
Im Profil kannst Du frei den Rang ändern


Verfasst am:
28. Nov 2012, 17:03
Rufname:

AW: Datentausch: A=B und B=A - AW: Datentausch: A=B und B=A

Nach oben
       Version: Office 2007

Falscher Call.
so stimmt es...


Code:
Option Explicit
Private Sub Worksheet_Change(ByVal Target As Range)
   If Target.Address = "$A$1" Or Target.Address = "$A$2" Or Target.Address = "$A$3" _
   Or Target.Address = "$B$1" Or Target.Address = "$B$2" Or Target.Address = "$B$3" Then
    Call zellentausch
End If
End Sub
Tom9000
Gast


Verfasst am:
28. Nov 2012, 20:20
Rufname:


AW: Datentausch: A=B und B=A - AW: Datentausch: A=B und B=A

Nach oben
       Version: Office 2007

Hallo Alex,

passt PERFECT!

Vielen, vielen Dank dafür und eine gute Woche.
Viele Grüße
Tom
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Verweis über mehrere Tabellenblätter (#N/A bzw. #REF! error) 2 Travellin 1783 13. Okt 2010, 08:50
Travellin Verweis über mehrere Tabellenblätter (#N/A bzw. #REF! error)
Keine neuen Beiträge Excel Formeln: Summenbildung nach sverweis mit #N/A 4 Andrea89 350 14. Jul 2010, 15:47
Andrea89 Summenbildung nach sverweis mit #N/A
Keine neuen Beiträge Excel Formeln: WENN n.A. dann n.A. Sonst Summe 7 loomer 664 29. Apr 2010, 16:27
Gast WENN n.A. dann n.A. Sonst Summe
Keine neuen Beiträge Excel Formeln: Zahl/Wert in Uhrzeit bestimmen und berechnen z.B. 1 = 8:00 4 AlexGast 1485 25. Apr 2010, 14:56
AlexGast Zahl/Wert in Uhrzeit bestimmen und berechnen z.B. 1 = 8:00
Keine neuen Beiträge Excel Formeln: Stundenzettel Ausgabewert begrenzen u.a. "Probleme" 7 derbrausepaul 1173 03. Jan 2010, 16:24
derbrausepaul Stundenzettel Ausgabewert begrenzen u.a. "Probleme"
Keine neuen Beiträge Excel Formeln: Mit "=ZÄHLENWENNS" Objektgrößen (z.B. 200x300cm) Z 3 Gast 327 10. Dez 2009, 11:42
Gast Mit "=ZÄHLENWENNS" Objektgrößen (z.B. 200x300cm) Z
Keine neuen Beiträge Excel Formeln: Bezug in feld a1 über kürzel wie z.b. S.P. verknüpfen 3 Gast 325 13. Sep 2009, 21:17
{Boris} Bezug in feld a1 über kürzel wie z.b. S.P. verknüpfen
Keine neuen Beiträge Excel Formeln: Excel: Verknüpfung Teilergebnis und Auswahl (z.B. Wenn) 0 Krebserl 931 15. Jun 2009, 12:58
Krebserl Excel: Verknüpfung Teilergebnis und Auswahl (z.B. Wenn)
Keine neuen Beiträge Excel Formeln: Wieviele verschiedene z.B. Donnerstage in einem Bereich? 7 Bani 427 15. Mai 2009, 09:06
Bani Wieviele verschiedene z.B. Donnerstage in einem Bereich?
Keine neuen Beiträge Excel Formeln: Permanenter Bezug einer Formel auf eine Zelle (z.B L4) 6 mck_BS 330 13. Mai 2009, 21:02
mck_BS Permanenter Bezug einer Formel auf eine Zelle (z.B L4)
Keine neuen Beiträge Excel Formeln: A B C ... automatisch erweitern wie 1 2 3 ... usw. 4 Mario H 5542 08. Mai 2009, 11:17
Mario H A B C ... automatisch erweitern wie 1 2 3 ... usw.
Keine neuen Beiträge Excel Formeln: Excel Datum z.B 10.05.2008 auswerten und dann Mai in Spalt 2 MaWo80 2080 08. Mai 2008, 09:53
Gast Excel Datum z.B 10.05.2008   auswerten und dann Mai in Spalt
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Web Editor Forum