Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Liste ohne leere Zellen und Nullen darstellen
zurück: wenn in a1 wert zb. m, und in b1 zb. 1 dann in c1 =m1 weiter: In A1 =Heute() in b1 soll der Monat und C1 das Jahr Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Thilo131
Im Profil kannst Du frei den Rang ändern


Verfasst am:
13. Sep 2012, 23:59
Rufname:

Liste ohne leere Zellen und Nullen darstellen - Liste ohne leere Zellen und Nullen darstellen

Nach oben
       Version: Office 2010

Hallo,

ich habe folgendes Problem:
Ich möchte aus einer Liste, die Namen, Nullen und leere Zellen enthält, eine Liste erzeugen, die nur noch die Namen direkt untereinander aufzählt.
Es gibt viele Beiträge hierzu, die mich jedoch alle zu einer Fehlermeldung führen. Folgende Formel habe ich z.B. verwendet:

=WENN(ZEILE()>SUMME(N(C$61:C$100)<>0);"";INDEX(C$61:C$100;KKLEINSTE(WENN(C$61:C$100<>0;ZEILE($61:$100));ZEILE())))

C$61:C$100 ist die Liste mit Namen, Nullen und leeren Zellen

Wo könnte der Fehler liegen?
Vielen Dank
Thilo
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
14. Sep 2012, 05:31
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände


AW: Liste ohne leere Zellen und Nullen darstellen - AW: Liste ohne leere Zellen und Nullen darstellen

Nach oben
       Version: Office 2010

Hallo Thilo

Zitat:
Es gibt viele Beiträge hierzu, die mich jedoch alle zu einer Fehlermeldung führen.

Welche der zillion Fehlermeldungen könnte das wohl sein?

Arbeitsblatt mit dem Namen 'Tabelle1'
 F
70gggg

ZelleFormel
F70{=WENNFEHLER(INDEX(C:C;KKLEINSTE(WENN(C$61:C$70<>0;ZEILE($61:$70));ZEILEN(F$70:F70)));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Thilo131
Im Profil kannst Du frei den Rang ändern


Verfasst am:
15. Sep 2012, 00:44
Rufname:

AW: Liste ohne leere Zellen und Nullen darstellen - AW: Liste ohne leere Zellen und Nullen darstellen

Nach oben
       Version: Office 2010

Hallo shift-del,
die Fehlermeldung ist WERT. Mit deiner Formel bin ich schon eine großen Schritt weiter! Alle Felder mit einer Null werden aus der neuen Liste herausgenommen. Allerdings fehlen noch die Felder, die keine Daten erhalten. Die werden leider noch mit aufgeführt! Gibt es noch eine mögliche Anpassung?

Vielen Dank und Gruß
Thilo
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
15. Sep 2012, 08:19
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände

AW: Liste ohne leere Zellen und Nullen darstellen - AW: Liste ohne leere Zellen und Nullen darstellen

Nach oben
       Version: Office 2010

Hallo Thilo

Zitat:
Allerdings fehlen noch die Felder, die keine Daten erhalten. Die werden leider noch mit aufgeführt! Gibt es noch eine mögliche Anpassung?

Dann sind deine Zellen nicht leer.
Arbeitsblatt mit dem Namen 'Tabelle1'
 CDE
61aaa aaa
62ssss ssss
63   
64ddd ddd
65fff fff
66   
670  
680  

ZelleFormel
C63=""
E61{=WENNFEHLER(INDEX(C:C;KKLEINSTE(WENN(C$61:C$70<>0;ZEILE($61:$70));ZEILEN(E$61:E61)));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Arbeitsblatt mit dem Namen 'Tabelle2'
 CDE
61aaa aaa
62ssss ssss
63  ddd
64ddd fff
65fff  
66   
670  
680  

ZelleFormel
C63=""
E61{=WENNFEHLER(INDEX(C:C;KKLEINSTE(WENN((C$61:C$70<>0)*(C$61:C$70<>"");ZEILE($61:$70));ZEILEN(E$61:E61)));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Thilo131
Im Profil kannst Du frei den Rang ändern


Verfasst am:
15. Sep 2012, 11:28
Rufname:


AW: Liste ohne leere Zellen und Nullen darstellen - AW: Liste ohne leere Zellen und Nullen darstellen

Nach oben
       Version: Office 2010

Vielen Dank, shift-del. Die zweite Formel hat funktioniert. Du hast recht, die Zellen waren nicht ganz leer, sie enthielten Formeln.
Viele Grüße
Thilo
Tino H.
Gast


Verfasst am:
25. Jan 2013, 20:48
Rufname:

AW: Liste ohne leere Zellen und Nullen darstellen - AW: Liste ohne leere Zellen und Nullen darstellen

Nach oben
       Version: Office 2003

Liebe Foren-Mitglieder,

ich saß heute bis eben im Büro und habe stundenlang über die Lösung eines Problems gegrübelt und so langsam bekomme ich es noch mit den Nerven. Sad
Deshalb möchte ich meine Frage an euch adressieren und hoffe ihr könnt mir den entscheidenden Tipp geben, damit ich über das Wochenende weiter an meiner Anwendung basteln kann.

Ich habe genau das im Betreff genannte Problem, dass ich aus einer verformelten Spalte (Tabelle1), die mir Werte ausgibt (Buchstaben, Leerzellen und Nullen), eine zweite sortierte Spalte erstellen will. Wobei - der Vollständigkeit halber - gesagt sei, dass die Nullen in einem Zwischenschritt mittels Matrixfunktion aus der Originalliste (Tabelle0) (mittels WENN(ISTNV(FEHLER.TYP) generiert wurden. Der relevante Spaltenbereich der Tabelle1 mit den Buchstaben, Nullen und Leerzeichen ist Tabelle1!B7:B418.

In der Zielspalte (Tabelle2) will ich nun mittels der hier dankenswerter Weise vorgestellten Funktion

{=WENN((Tabelle1!B$7:B$418<>0)*(Tabelle1!B$7:B$418<>"");KKLEINSTE((WENN((Tabelle1!B$7:B$418<>0)*(Tabelle1!B$7:B$418<>"");ZEILE(Tabelle1!B$7:B$418)));ZEILEN(B$7:B7));"")}

die Werte ohne Leerzeichen und Nullen aus der Spalte Tabelle1! in aufgelisteter Form ausgeben, so dass nur Buchstaben aufgelistet werden.

Leider gibt mir die Zielliste, nachdem ich die Matrixfunktion ausgehend von Tabelle2!B7 bis B418 runterkopiert habe, keine Werte wieder (also Leerzellen). D.h. auch die erwarteten sortierten Werte (ergo Buchstaben) werden nicht ausgegeben.

Ich habe versucht der Sache etwas auf den Grund zu gehen und habe über die Formelauswertung festgestellt, dass bspw. bei 6 erwarteten Ergebnissen im Spaltenbereich Tabelle2!B7:B12 auch entsprechend, ein Ergebnis ausgegeben werden könnte.
Beim vorletzten Schritt der Auswertung wird dann bspw. für Zelle Tabelle2!B7 folgende Rechenoperation wiedergegeben:

=WENN({0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;1;0;0;usw.;0;0};27;"")

Das passt insofern, als dass das erste erwartete Ergebnis in Tabelle1!B7:B418 in Tabelle1!B27 zu finden ist. Gleiches ist bei der Formelauswertung in den Zellen Tabelle2!B8 bis Tabelle2!B12 der Fall; also dort wo die erwarteten sortierten Werte ausgegeben werden sollten. In gleicher Weise gibt mir die Auswertung hier immer jeweils eine eindeutige Zahl aus, die mit der Spaltenzahl der erwarteten Ergebnisse der in Tabelle1! befindlichen Werte korrespondiert.
Bei Tabelle2!B13 wird im vorletzten Schritt der Formelauswertung folgende Rechenoperation ausgegeben:

=WENN({0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;1;0;0usw.;0;0};#ZAHL!;"")

Die ist aus meiner Sicht logisch, da die Matrixfunktion keinen 7. Wert in Tabelle1!B7:B418 mehr findet, den sie ausgeben kann. Es gibt ja auch tatsächlich keinen 7. erwarteten Wert mehr!

Dies zeigt mir, dass meine Matrixfunktion eigentlich die erwarteten Werte in Tabelle1! findet und sie auch in sortierter Reihenfolge in Tabelle2! ordnet. Jedoch wird in Tabelle2! wie gesagt kein Wert ausgegeben...

Liegt es ggf. daran, dass ich die Matrixfunktion in einem bereits verformelten Bereich (Tabelle1!B7:B418) anwende?

Wisst ihr Rat?

Vielen Dank für eure Befassung mit meinem Problem,

Tino
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
25. Jan 2013, 21:40
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände

AW: Liste ohne leere Zellen und Nullen darstellen - AW: Liste ohne leere Zellen und Nullen darstellen

Nach oben
       Version: Office 2010

Hallo Tino

ZEILE(Tabelle1!B$7:B$418) soll die Anzahl der Zeilen von 1..n wiedergeben.
Deine Formel ergibt aber 7..n+6.

Es mehrere Möglichkeiten das 1..n zu erreichen:
Code:
ZEILE($1:$412)

Code:
ZEILE(Tabelle1!B$7:B$418)-ZEILE(Tabelle1!B$7)+1

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Tino H.
Gast


Verfasst am:
26. Jan 2013, 01:33
Rufname:

AW: Liste ohne leere Zellen und Nullen darstellen - AW: Liste ohne leere Zellen und Nullen darstellen

Nach oben
       Version: Office 2003

Hallo shift-del,

vielen Dank für deinen Hinweis zum späten Freitag Abend. Hab' mich auch sogleich daran gemacht und dies eingebaut. Meine Matrixformel lautet jetzt entsprechend:

{=WENN((Tabelle1!B$7:B$418<>0)*(Tabelle1!B$7:B$418<>"");KKLEINSTE((WENN((Tabelle1!B$7:B$418<>0)*(Tabelle1!B$7:B$418<>"");ZEILE(Tabelle1!$1:$412)));ZEILEN(B$7:B7));"")}

Somit habe ich eine saubere Zuordnung hinbekommen von 1->n.

Leider bleibt mein Problem bestehen, dass in meiner Zielliste in Tabelle2!, nachdem ich die Matrixfunktion ausgehend von Tabelle2!B7 bis B418 runterkopiert habe, keine Werte ausgegeben, werden, die Zielliste also leer bleibt.

Analog zu meiner vorherigen Fehlersuche lautet jetzt die Rechenoperation beim vorletzte Schritt der Formelauswertung in Tabelle2!B7:

=WENN({0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;1;0;0;usw.;0;0};21;"")

Auch hier wieder analog zur vorherigen Funktion ist das erste erwartete Ergebnis im Matrixbereich Tabelle1!B7:B418 in Tabelle1!B21 zu finden. Gleiches ist bei der Formelauswertung in den Zellen Tabelle2!B8 bis Tabelle2!B12 auch hier der Fall (Ausgabe der Rechenoperation korrespondierend mit entsprechender Zeile im Matrixbereich).

Die 6 erwarteten Ergebnisse (Buchstaben) müssten also in der Reihenfolge sortiert in der Zielliste Tabelle2!B7:B12 ausgegeben werden.; zumal ab Tabelle2!B13 die Rechenoperation beim vorletzten Schritt der Formelauswertung analog zu meiner ersten Funktion lautet:

=WENN({0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;1;0;0;usw.;0;0};#ZAHL!;"")

Leider erhalte ich - führe ich den letzten Schritt der Formelauswertung aus - immer gar kein Ergebnis. Entsprechend wird in der Zielliste auch kein Ergebnis ausgegeben...

Gibt es eine Idee, wie ich die Ergebnisse entsprechend in meiner Zielliste in Tabelle2! ausgeben kann?
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
26. Jan 2013, 11:55
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände

AW: Liste ohne leere Zellen und Nullen darstellen - AW: Liste ohne leere Zellen und Nullen darstellen

Nach oben
       Version: Office 2010

Hallo

An deiner Formel scheint doch einiges reparaturbedürftig zu sein.
Code:
{=WENN(SUMME((Tabelle1!B$7:B$418<>0)*(Tabelle1!B$7:B$418<>""))<ZEILEN(B$7:B7);"";INDEX(Tabelle1!$B$7:$B$418;KKLEINSTE(WENN((Tabelle1!B$7:B$418<>0)*(Tabelle1!B$7:B$418<>"");ZEILE($1:$412));ZEILEN(B$7:B7))))}

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Tino H.
Gast


Verfasst am:
27. Jan 2013, 00:52
Rufname:

AW: Liste ohne leere Zellen und Nullen darstellen - AW: Liste ohne leere Zellen und Nullen darstellen

Nach oben
       Version: Office 2003

Hallo shift-del,

vielen, vielen Dank für deine Hilfe. Mit deiner Formel funktioniert alles wie gewünscht! Surprised

Meine Bewunderung hast du und die anderen Foren-Moderatoren, die scheinbar einen Formelsyntax lesen und verstehen können, wie andere Menschen Kochbücher.

Ich habe heute, damit ich auch wirklich einen Lerneffekt daraus ziehe, intensiv deine Formel studiert und mich mit der Index-Funktion beschäftigt. Jetzt verstehe ich sie auch wirklich und weiß (hoffentlich) wie sie funktioniert.

Auch wenn ich Hilfeforen wirklich nur nutze, wenn ich gar keine Lösungsoption mehr sehe, bin ich sehr froh, so kompetente und schnelle Unterstützung wie hier zu erhalten.

Wünsche dir noch ein schönes WE.

Beste Grüße

Tino
Tino H.
Gast


Verfasst am:
27. Jan 2013, 00:52
Rufname:


AW: Liste ohne leere Zellen und Nullen darstellen - AW: Liste ohne leere Zellen und Nullen darstellen

Nach oben
       Version: Office 2003

Hallo shift-del,

vielen, vielen Dank für deine Hilfe. Mit deiner Formel funktioniert alles wie gewünscht! Surprised

Meine Bewunderung hast du und die anderen Foren-Moderatoren, die scheinbar einen Formelsyntax lesen und verstehen können, wie andere Menschen Kochbücher.

Ich habe heute, damit ich auch wirklich einen Lerneffekt daraus ziehe, intensiv deine Formel studiert und mich mit der Index-Funktion beschäftigt. Jetzt verstehe ich sie auch wirklich und weiß (hoffentlich) wie sie funktioniert.

Auch wenn ich Hilfeforen wirklich nur nutze, wenn ich gar keine Lösungsoption mehr sehe, bin ich sehr froh, so kompetente und schnelle Unterstützung wie hier zu erhalten.

Wünsche dir noch ein schönes WE.

Beste Grüße

Tino
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Liste für Verleih erstellen - Verweis auf Kalenderwoche 2 Silbrunke 1924 02. Jan 2005, 22:00
Gast Liste für Verleih erstellen - Verweis auf Kalenderwoche
Keine neuen Beiträge Excel Formeln: Datum aus mehreren Zellen zusammensetzen. 9 gast2005 5086 25. Dez 2004, 22:33
Kuwe Datum aus mehreren Zellen zusammensetzen.
Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten. Excel Formeln: Bestimmten Zellen einen Wert zuteilen. 1 tomimmo 2544 03. Dez 2004, 20:35
ae Bestimmten Zellen einen Wert zuteilen.
Keine neuen Beiträge Excel Formeln: Berechnung mit ausgeblendeten Zellen 2 Urban 1123 11. Nov 2004, 08:25
Günni Berechnung mit ausgeblendeten Zellen
Keine neuen Beiträge Excel Formeln: Zellen auswerten 4 Cat 1526 11. Nov 2004, 01:20
Gast Zellen auswerten
Keine neuen Beiträge Excel Formeln: Excel Zellen verknüpfen! 1 Gast 2858 10. Nov 2004, 10:41
Gast Excel Zellen verknüpfen!
Keine neuen Beiträge Excel Formeln: Datum als Wochentag automatisch darstellen? 6 Gast 1432 05. Okt 2004, 17:11
gast Datum als Wochentag automatisch darstellen?
Keine neuen Beiträge Excel Formeln: Kopieren von Zellen, Problem mit Datumsformatierung 4 Mick 1431 08. Sep 2004, 18:59
Mick Kopieren von Zellen, Problem mit Datumsformatierung
Keine neuen Beiträge Excel Formeln: Zellen mit Formeln ausfüllen 22 akm1978 4502 26. Aug 2004, 17:33
akm1978 Zellen mit Formeln ausfüllen
Keine neuen Beiträge Excel Formeln: Projektkosten übersichtlich im Monatsauflauf darstellen 3 Miri 1817 24. Aug 2004, 10:40
Thomas Ramel Projektkosten übersichtlich im Monatsauflauf darstellen
Keine neuen Beiträge Excel Formeln: Auf Zellen einer Datei im Web verweisen. 1 kha 812 30. Jul 2004, 13:18
kha Auf Zellen einer Datei im Web verweisen.
Keine neuen Beiträge Excel Formeln: Zusammenhängende Zellen mit gleichem Text zählen 10 Red Hair 1522 09. Jul 2004, 15:22
Red Hair Zusammenhängende Zellen mit gleichem Text zählen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft-Excel Diagramme