Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Negativuhrzeit
zurück: Fehlerindikatoren im Punktdiagramm weiter: bei aktivem Filter zeilen einblenden? Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Supi111
Im Profil kannst Du frei den Rang ändern


Verfasst am:
21. Apr 2012, 19:05
Rufname:

Negativuhrzeit - Negativuhrzeit

Nach oben
       Version: Office 2010

Hallo Experten

Ich hab eine frage ich möchte Negativuhrzeit rot ausgeben in vba und weis nicht wie?
sldp es würde sich um -h:mm
währe für jede Hilfe Dankbar
bzw. wür mich noch interesieren einen Wert aus bestimter zelle auslesen und in eine andere eintragen.
l.g. Supi
KlausMz
Moderator Access


Verfasst am:
21. Apr 2012, 19:26
Rufname:
Wohnort: Irgendwo in der Pfalz


AW: Negativuhrzeit - AW: Negativuhrzeit

Nach oben
       Version: Office 2010

Hallo,
negative Uhrzeiten im Format -hh:nn kann man nicht darstellen, das heist, das negative Vorzeichen wird nicht angezeigt.
Mit der bedingten Formatierung kannst Du aber das Feld rot machen, wenn die der Uhrzeit zu Grunde liegende Zahl negativ ist.
Rein sachlich gibt es auch keine negative Uhrzeit. Wenn es ein Zeitsaldo ist, so ist das keine Uhrzeit, sondern eine Zeitmenge, die mit einem Zeitformat dargestellt werden kann. Aber auch nur wenn die Zeitmenge kleiner als 24 Stunden ist.
Wo kommt den die negative Zahl her, bzw. wie kommt diese zu Stande?

Zum 2. Problem. Du kannst einem Feld (in Access gibt es keine Zellen, die gibt es nur in Excel) den Wert eines anderen Feldes zuweisen.
Ganz allgemein in einem Formular:
Code:
    Me.Feld1 = Me.Feld2
Oder wolltest Du eventuell doch Excel?

PS:
Vieleicht schilderst Du ja Dein Anliegen etwas ausführlicher. Und den Text vor dem Senden noch mal zu prüfen, wäre auch nicht schlecht.
Zitat:
sldp
Was heist das?
_________________
Gruß
Klaus . . . . . Feedback wäre wünschenswert.
Ich möchte bitte keine unaufgeforderten PN. Fragen bitte im Forum.
Supi111
Im Profil kannst Du frei den Rang ändern


Verfasst am:
21. Apr 2012, 20:26
Rufname:

AW: Negativuhrzeit - AW: Negativuhrzeit

Nach oben
       Version: Office 2010

Sorry hatte das falsche Forum ausgewehlt
Ich meine Doch Excel.
Da ddu gesagt hast das es keien minuszeit gibt hast recht. Ich hab eine Monatliche Musleistung die ich bringen sollt und wenn ich die nicht erreiche dann Fehltmir die restlicheh Zeit, und die wird mit minus ausgegeben.
Das andere war ein Tipfehler.
l.g.Supi
Höttl Wilfried
Im Profil kannst Du frei den Rang ändern


Verfasst am:
21. Apr 2012, 20:58
Rufname: wilfried07
Wohnort: Antau Burgenland

AW: Negativuhrzeit - AW: Negativuhrzeit

Nach oben
       Version: Office 2010

Hallo!

Passt das so?

Arbeitsblatt mit dem Namen 'Tabelle6'
 ABCDEFGHI
1Negative Stundenanzahl Plusstunden, Minusstunden, Dezimal, Text in extra Spalte        
2         
3Textstunden werden nur dargestellt, weiter rechnen geht nicht        
4       IndustriezeitTextstunden
5kommengehenPauseSollIstPlusstundenMinusstundenDezimal +/-nicht rechnenbar
607:0013:0000:3008:0006:0000:0001:30-2,50-2:30
709:0514:1200:3008:0005:0700:0002:23-3,38-3:23
808:3016:0000:3008:0007:3000:0000:00-1,00-1:00
907:1016:0000:3006:0008:5002:2000:002,332:20
1010:0012:0000:3006:0002:0000:0003:30-4,50-4:30
11   36:0029:2702:2007:23-9,05-9:03

ZelleFormel
E6=B6-A6
F6=WENN(D6<E6;ABS(E6-D6-C6);0)
G6=WENN(D6>E6;ABS(D6-E6-C6);0)
H6=(E6-D6-C6)*24
I6=WENN(E6<D6;"-";" ")&TEXT(ABS(E6-D6-C6);"[h]:mm")
D11=SUMME(D6:D10)
E11=SUMME(E6:E10)
F11=SUMME(F6:F10)
G11=SUMME(G6:G10)
H11=SUMME(H6:H10)
I11{=WENN(SUMMENPRODUKT((TEIL(I6:I10;2;99))*WENN(LINKS(I6:I10)="-";-1;1))<=0;"-";" ")&TEXT(ABS(SUMMENPRODUKT((TEIL(I6:I10;2;99))*WENN(LINKS(I6:I10)="-";-1;1)));"[h]:mm")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Gruß
Wilfried
Zero
Formeln, Diagramme und ein bisschen VBA


Verfasst am:
21. Apr 2012, 20:58
Rufname: Dennis
Wohnort: NDS


AW: Negativuhrzeit - AW: Negativuhrzeit

Nach oben
       Version: Office 2010

Hallo

Am einfachsten wäre es, wenn du 2 Spalten benutzen würdest. (+|-)
Ansonsten findest du in der Boardsuche sicher genügend zu diesem Thema.

_________________
Gruß zero
Supi111
Im Profil kannst Du frei den Rang ändern


Verfasst am:
21. Apr 2012, 21:08
Rufname:

AW: Negativuhrzeit - AW: Negativuhrzeit

Nach oben
       Version: Office 2010

Danke für eure Hilfe
ich dachte dass ich nur die ZAhlen eifach rot unterlegen kann da es Über vba die Zelle einzeln Formatiert einmal mit -h:mm und h:mm
Gast



Verfasst am:
22. Apr 2012, 00:08
Rufname:

AW: MinusStunden - AW: MinusStunden

Nach oben
       Version: Office 2010

Hallo.

Zitat:
Textstunden werden nur dargestellt, weiter rechnen geht nicht

So ganz bin ich damit nicht einverstanden:

 ABCDEF
1KommenGehenSollIstPlusMinusBilanz
28:0013:308:005:30-2:30-03:30
38:0017:008:009:001:00 
48:0014:458:006:45-1:15 
58:0015:158:007:15-0:45 

Formeln der Tabelle
ZelleFormel
D2=B2-A2
E2=WENN(D2-C2<0;TEXT(C2-D2;"-[h]:mm");D2-C2)
F2{=TEXT(ABS(SUMME(WENN(LINKS(E2:E10)="-";TEIL(E2:E10;2;99)*-1;E2:E10*1)));WENN(SUMME(WENN(LINKS(E2:E10)="-";TEIL(E2:E10;2;99)*-1;E2:E10*1))<0;"-";)&"[hh]:mm")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+STIFT+RETURN abschließen!
Matrix verstehen


Excel Jeanie Html

Aber wahrscheinlich gibts wieder ganz viele Gründe warum man das nicht machen sollte.

Gruß Kurt
< Peter >
Excel-Moderator, der immer noch dazu lernt


Verfasst am:
22. Apr 2012, 09:06
Rufname: Kommt darauf an wer ruft
Wohnort: Das schönste Land in Deutschlands Gaun

AW: Negativuhrzeit - AW: Negativuhrzeit

Nach oben
       Version: Office 2010

Hallo,

und mit welcher Formel würdest du die Summen der Spalte E und F berechnen?

_________________
Gruß
Peter
Gast



Verfasst am:
22. Apr 2012, 10:26
Rufname:

AW: Negativuhrzeit - AW: Negativuhrzeit

Nach oben
       Version: Office 2010

Hallo.

F2 ist die Summe von E2:E5
Gruß Kurt
< Peter >
Excel-Moderator, der immer noch dazu lernt


Verfasst am:
22. Apr 2012, 10:56
Rufname: Kommt darauf an wer ruft
Wohnort: Das schönste Land in Deutschlands Gaun

AW: Negativuhrzeit - AW: Negativuhrzeit

Nach oben
       Version: Office 2010

Hallo,

stimmt, da war ich heute morgen noch nicht richtig wach.

_________________
Gruß
Peter
Supi111
Im Profil kannst Du frei den Rang ändern


Verfasst am:
22. Apr 2012, 15:18
Rufname:

AW: Negativuhrzeit - AW: Negativuhrzeit

Nach oben
       Version: Office 2010

Hallo jetzt währe noch schön wenn mir jemand sagen würde wie ich den Wert F2 in Rot bekomme und wenn die Normalzeit ist in SCHWARZ.
l.g. Supi
Zero
Formeln, Diagramme und ein bisschen VBA


Verfasst am:
22. Apr 2012, 15:22
Rufname: Dennis
Wohnort: NDS


AW: Negativuhrzeit - AW: Negativuhrzeit

Nach oben
       Version: Office 2010

Hallo

Bed. Formatierung
=Links(F2)="-"

_________________
Gruß zero
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Word VBA