Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Array auf Wertdifferenz prüfen
zurück: Bearbeitungsleiste mit Hilfe weiter: Excel 2000 Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
MartinBerlin
Neuling


Verfasst am:
21. März 2012, 21:53
Rufname:

Array auf Wertdifferenz prüfen - Array auf Wertdifferenz prüfen

Nach oben
       Version: Office 2007

Hi,

ich bräuchte kurz Eure Hilfe, bei einer Fragestellung, die ich mal nicht per SVERWEIS lösen möchte.

Nehmen wir an, ich habe in A1:A100 eine Reihe von Werten und in C1 einen einzelnen anderen Wert. Was ich nun machen möchte, ist zu überprüfen, ob C1 nah an einem der Werte aus A1:A100 dran liegt. Genauer gesagt, ich möchte wissen, ob die Differenz kleiner/gleich 1 ist. Und es geht dabei immer um die Differenz A*-C1, d.h. es geht nur darum, ob C1 von unten kommend an einen der A-Werte heran reicht.

Das hier scheint fast zu funktionieren:
Code:
{=WENN(ODER(ABS((A1:A100)-C1)<1);1;0)}


Aber das ist halt nur für die absoluten Abstände. Wie bekomme ich das hin, dass es nur für positive Werte aus A*-C1 funktioniert?

Viele Grüße

Martin
BoskoBiati
Im Profil kannst Du frei den Rang ändern


Verfasst am:
21. März 2012, 22:40
Rufname: Bosko

AW: Array auf Wertdifferenz prüfen - AW: Array auf Wertdifferenz prüfen

Nach oben
       Version: Office 2007

Hallo,

als Ansatz:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
34 12,8
43 1
56  
62  
78  
815  
913  

ZelleFormel
C4=SUMMENPRODUKT((A3:A9-C3<1)*(A3:A9-C3>0))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

_________________
Gruß

Bosko

Ich würde mich freuen zu erfahren, ob ich helfen konnte.
MartinBerlin
Neuling


Verfasst am:
21. März 2012, 23:27
Rufname:


AW: Array auf Wertdifferenz prüfen - AW: Array auf Wertdifferenz prüfen

Nach oben
       Version: Office 2007

Funktioniert wunderbar. Vielen Dank!
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Excel: Wenn-dann-Funktion über eine ganze zeile prüfen? 4 SkiLitschi 3861 09. Apr 2009, 10:52
EtoPHG Excel: Wenn-dann-Funktion über eine ganze zeile prüfen?
Keine neuen Beiträge Excel Formeln: Zeichenkette auf nichtvorhandenes Zeichen prüfen 2 Nightstorm 1217 09. Apr 2009, 08:59
Nightstorm Zeichenkette auf nichtvorhandenes Zeichen prüfen
Keine neuen Beiträge Excel Formeln: Spalte durchsuchen und auf neue Einträge prüfen 6 jagromir 410 19. März 2009, 16:07
jagromir Spalte durchsuchen und auf neue Einträge prüfen
Keine neuen Beiträge Excel Formeln: Prüfen ob Wert in Matrix vorhanden 2 chcb 13592 14. März 2009, 17:01
chcb Prüfen ob Wert in Matrix vorhanden
Keine neuen Beiträge Excel Formeln: Felder prüfen welche einen Wert haben 3 rdggsdgsdgs 310 24. Sep 2008, 16:02
Anja Hermann Felder prüfen welche einen Wert haben
Keine neuen Beiträge Excel Formeln: Prüfen welche Zahen zwischen +0,500 und -0,500 liegen 6 Rayn 397 14. Aug 2008, 17:24
silex1 Prüfen welche Zahen zwischen +0,500 und -0,500 liegen
Keine neuen Beiträge Excel Formeln: Mit Sverweis mehrere Zellen Prüfen 1 Gast 391 08. Aug 2008, 09:20
Lucy77 Mit Sverweis mehrere Zellen Prüfen
Keine neuen Beiträge Excel Formeln: Mit WENN_ODER_Funktion 3 Bedingungen prüfen bzw. erstellen 2 Germann 486 23. Jun 2008, 21:42
Germann Mit WENN_ODER_Funktion 3 Bedingungen prüfen bzw. erstellen
Keine neuen Beiträge Excel Formeln: wenn verschachtelt mit indirekt und listen, 2 felder prüfen 5 excelrookie 1409 19. Jun 2008, 10:21
Gast wenn verschachtelt mit indirekt und listen, 2 felder prüfen
Keine neuen Beiträge Excel Formeln: Prüfen ob Zelle sichtbar? 2 Magixter 3365 08. Mai 2008, 11:02
Magixter Prüfen ob Zelle sichtbar?
Keine neuen Beiträge Excel Formeln: Bereich auf Übereinstimmung prüfen.... 3 Excelhorst 4060 10. Feb 2008, 19:22
Gast Bereich auf Übereinstimmung prüfen....
Keine neuen Beiträge Excel Formeln: Probleme mit Array Formeln und Datenmenge 2 Gast 495 10. Jan 2008, 15:33
Gast Probleme mit Array Formeln und Datenmenge
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: PHP JavaScript