Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Wenn Formel größer gleich
Gehe zu Seite 1, 2  Weiter
zurück: Daten übernehmen weiter: Diagramm-Trendlinie, Formel kann nicht stimmen... Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Gast



Verfasst am:
21. März 2012, 12:55
Rufname:

Wenn Formel größer gleich - Wenn Formel größer gleich

Nach oben
       Version: Office 2010

Hallo

habe ein Problem mit der WENN Formel:

Zelle A1: hier werden Werte von - bis + eingegeben
Zelle B1: =WENN(A1<"";"";WENN(A1<"-10000";"SEHR SCHLECHT";WENN("-10000"<A1<"-1";"Schlecht";WENN("1"<A1<"10000";"GUT";WENN("10000"<A1<"20000";"Besser";WENN(A1>"20000";"Sehr gut";))))))

Diese Formel in B1 reagiert aber leider nicht.
Ich möchte in A1 zb. die Zahl - 15 eingeben und in B1 steht dann "SEHR SCHLECHT" Confused

Die Formel muss folgendes umsetzten:
Wenn A1 = leer; dann: B1 leer
Wenn A1 < -10000 ; dann: SEHR SCHLECHT
Wenn -10000 < A1 < -1 ; dann: SCHLECHT
Wenn 1 < A1 < 10000 ; dann: GUT
Wenn 10000 < A1 <20000> 20000 ; dann: SEHR GUT

Kann mir hier jemand helfen?
Danke.

LG
Armin
Supertyp62
Funktionswustling


Verfasst am:
21. März 2012, 13:08
Rufname: Jan
Wohnort: Gießen


AW: Wenn Formel größer gleich - AW: Wenn Formel größer gleich

Nach oben
       Version: Office 2010

Hallo Armin,

was passiert zwischen -1 und +1?

_________________
Questions are a burden to others. So burden away!
Gast



Verfasst am:
21. März 2012, 13:14
Rufname:

AW: Wenn Formel größer gleich - AW: Wenn Formel größer gleich

Nach oben
       Version: Office 2010

Ja hier kann man statt -1 und 1 auch 0 schreiben Smile
Gast



Verfasst am:
21. März 2012, 13:21
Rufname:

AW: Wenn Formel größer gleich - AW: Wenn Formel größer gleich

Nach oben
       Version: Office 2010

Hallo,

1. ergeben Zahlen in "" einen Text, der mit Vergleichen nicht abgefragt werden kann.
2. Sind Deine Bedingungen nicht logisch, es fehlt z.B. der Bereich zwischen -1 und +1
3. Ist die Syntax ziemlich daneben, -1000<A1<-1 ist keine gültige Form.

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
120001sehr gut

ZelleFormel
B1=WENN(A1="";"";WENN((A1>20000)+(A1<-10000);"sehr ";"")&VERWEIS(A1+1%%%;{-999999;-1;1};{"schlecht";"";"gut"}))


Gruß

Bosko
Guenter_Steiner
Im Profil kannst Du frei den Rang ändern


Verfasst am:
21. März 2012, 13:25
Rufname: Günter


AW: Wenn Formel größer gleich - AW: Wenn Formel größer gleich

Nach oben
       Version: Office 2010

Hallo,

könnte das hinkommen ? (hoffe alle Bedingungen richtig interpretiert zu haben):

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
1-15000sehr schlecht
2-1schlecht
32gut
410001sehr gut

ZelleFormel
B1=WENN(A1<>"";WAHL((A1<0)+(A1<-10000)+(A1>0)*3+(A1>10000);"schlecht";"sehr schlecht";"gut";"sehr gut");"")


Zum anderen: Du kannst TEXT als Zahlen ( also Zahlen mit "" ) nicht berechnen oder bewerten.

_________________
mfG
Günter
werni
Solala


Verfasst am:
21. März 2012, 13:28
Rufname: werni
Wohnort: Ennenda GL

AW: Wenn Formel größer gleich - AW: Wenn Formel größer gleich

Nach oben
       Version: Office 2010

Hallo Armin

Und ein Versuch mal so?

 ABCDE
19999Gut -100000Sehr Schlecht
2   -1Schlecht
3   1Gut
4   10000Besser
5   100000Sehr Gut

ZelleFormel
B1=WENN(A1="";"";SVERWEIS(A1;D1:E5;2;1))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Gruss werni

_________________
"Die Summe aller Intelligenz auf Erden ist konstant, aber die Anzahl Individuen steigt."
. EINSTEIN
Gast



Verfasst am:
21. März 2012, 13:39
Rufname:

AW: Wenn Formel größer gleich - AW: Wenn Formel größer gleich

Nach oben
       Version: Office 2010

Hallo Werni,

was passiert bei -200000?


Gruß

Bosko
Gast



Verfasst am:
21. März 2012, 13:39
Rufname:

AW: Wenn Formel größer gleich - AW: Wenn Formel größer gleich

Nach oben
       Version: Office 2010

Hallo Günther,

vielen Dank es passt fast Smile

Wenn A1 = leer; dann: B1 leer
Wenn A1 < -10000 ; dann: SEHR SCHLECHT
Wenn -10000 < A1 < 0 ; dann: SCHLECHT
Wenn 0 < A1 < 10000 ; dann: GUT
Wenn 10000 < A1 <20000> 20000 ; dann: SEHR GUT

A1 > -10000 SEHR SCHLECHT
-10000 A1 > 0 SCHLECHT
0 < A1 < 10000 GUT
10000 < A1 < 20000 BESSER
20000 < A1 SEHR GUT

Ist das so verstaendlich was ich meine?
[/list]
werni
Solala


Verfasst am:
21. März 2012, 13:46
Rufname: werni
Wohnort: Ennenda GL

AW: Wenn Formel größer gleich - AW: Wenn Formel größer gleich

Nach oben
       Version: Office 2010

Hallo Bosko

So kleine Zahlen kennt Armin vielleicht nicht.
Man könnte den Sverweis mit ISTFEHLER abfangen, oder eine viel, viel kleinere Zahl angeben.

Gruss werni

_________________
"Die Summe aller Intelligenz auf Erden ist konstant, aber die Anzahl Individuen steigt."
. EINSTEIN
Guenter_Steiner
Im Profil kannst Du frei den Rang ändern


Verfasst am:
21. März 2012, 13:51
Rufname: Günter

AW: Wenn Formel größer gleich - AW: Wenn Formel größer gleich

Nach oben
       Version: Office 2010

Hallo,

dann so?

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
1-15000sehr schlecht
2-1schlecht
32gut
410001sehr gut
520001sehr gut

ZelleFormel
B1=WENN(A1<>"";WAHL((A1<0)+(A1<-10000)+(A1>0)*3+(A1>10000);"schlecht";"sehr schlecht";"gut";"sehr gut");"")

_________________
mfG
Günter
Gast



Verfasst am:
21. März 2012, 13:54
Rufname:

AW: Wenn Formel größer gleich - AW: Wenn Formel größer gleich

Nach oben
       Version: Office 2010

Hallo Bosko, hallo werni,

A1 ist mein Eingabefeld, ich kann hier alle Zahlen
zb: gebe ich in A1 -20199 dann ist A1 <10000> -10000 SEHR SCHLECHT
-10000 A1 > 0 SCHLECHT
0 < A1 < 10000 GUT
10000 < A1 < 20000 BESSER
20000 < A1 SEHR GUT

Wisst ihr was ich meine?
Gast



Verfasst am:
21. März 2012, 14:04
Rufname:

AW: Wenn Formel größer gleich - AW: Wenn Formel größer gleich

Nach oben
       Version: Office 2010

Hallo,

z.B. so:

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
1-99999sehr schlecht
2-9999schlecht
3-1schlecht
40gut
51gut
610000besser
720000sehr gut

ZelleFormel
B1=WENN(A1="";"";VERWEIS(A1+1%%%;{-999999;-10000;0;10000;20000};{"sehr schlecht";"schlecht";"gut";"besser";"sehr gut"}))
B2=WENN(A2="";"";VERWEIS(A2+1%%%;{-999999;-10000;0;10000;20000};{"sehr schlecht";"schlecht";"gut";"besser";"sehr gut"}))
B3=WENN(A3="";"";VERWEIS(A3+1%%%;{-999999;-10000;0;10000;20000};{"sehr schlecht";"schlecht";"gut";"besser";"sehr gut"}))
B4=WENN(A4="";"";VERWEIS(A4+1%%%;{-999999;-10000;0;10000;20000};{"sehr schlecht";"schlecht";"gut";"besser";"sehr gut"}))
B5=WENN(A5="";"";VERWEIS(A5+1%%%;{-999999;-10000;0;10000;20000};{"sehr schlecht";"schlecht";"gut";"besser";"sehr gut"}))
B6=WENN(A6="";"";VERWEIS(A6+1%%%;{-999999;-10000;0;10000;20000};{"sehr schlecht";"schlecht";"gut";"besser";"sehr gut"}))
B7=WENN(A7="";"";VERWEIS(A7+1%%%;{-999999;-10000;0;10000;20000};{"sehr schlecht";"schlecht";"gut";"besser";"sehr gut"}))


Gruß

Bosko
Guenter_Steiner
Im Profil kannst Du frei den Rang ändern


Verfasst am:
21. März 2012, 14:09
Rufname: Günter

AW: Wenn Formel größer gleich - AW: Wenn Formel größer gleich

Nach oben
       Version: Office 2010

Hallo,

sorry, meine Formel enthielt einen Fehler (Fehlübermittlung):

=WENN(A1<>"";WAHL((A1<0)+(A1<-10000)+(A1>0)*3+(A1>10000)+(A1>20000);"schlecht";"sehr schlecht";"gut";"besser";"sehr gut");"")

wäre korrekt.

_________________
mfG
Günter
Armin42
Im Profil kannst Du frei den Rang ändern


Verfasst am:
21. März 2012, 14:09
Rufname: Armin

AW: Wenn Formel größer gleich - AW: Wenn Formel größer gleich

Nach oben
       Version: Office 2010

Nochmal vielleicht wirds so klarer>



- Ich habe eigentlich 3 Eingabefelder in denen beliebige Zahlen eingegeben werden; in A1, B1, und C1

- in D1 wird die Summe der Eingabefelder A1, B1, C1 berechnet

- in E1 möchte ich die WENN Formel einbauen, sodass WENN die SUMME in
D1 < -10000, dann soll "sehr schlecht" in E1 stehen
-10000 < D1 < 0, dann soll "schlecht" in E1 stehen
0 < D1 < 10000, dann soll "gut" in E1 stehen
10000 < D1 < 20000, dann soll "besser" in E1 stehen
20000 < D1 , dann soll "sehr gut" in E1 stehen


Wisst ihr jetzt was ich meine?
Gast



Verfasst am:
21. März 2012, 14:13
Rufname:


AW: Wenn Formel größer gleich - AW: Wenn Formel größer gleich

Nach oben
       Version: Office 2010

Hallo,

hast Du überhaupt schon mal eine der Formeln ausprobiert?

Gruß

Bosko
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Gehe zu Seite 1, 2  Weiter
Diese Seite Freunden empfehlen

Seite 1 von 2
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: ...und ich flippe gleich aus. 2 pets 606 12. Mai 2004, 12:21
Nik ...und ich flippe gleich aus.
Keine neuen Beiträge Excel Formeln: Formel gesucht!!! Part II 1 Kimbolaysen 596 10. Mai 2004, 13:23
xyzdef Formel gesucht!!! Part II
Keine neuen Beiträge Excel Formeln: Formel mit Variable die jede Zeile um eins höher wird??! 2 Gast 917 09. Mai 2004, 09:10
Gast Formel mit Variable die jede Zeile um eins höher wird??!
Keine neuen Beiträge Excel Formeln: Formel anzeigen und gleichzeitig Ergebnis 1 Achim 2435 03. Mai 2004, 10:36
xpec Formel anzeigen und gleichzeitig Ergebnis
Keine neuen Beiträge Excel Formeln: suche ne formel mit bestimmten abhängigkeiten 6 pipi 3131 26. Apr 2004, 13:39
pipi suche ne formel mit bestimmten abhängigkeiten
Keine neuen Beiträge Excel Formeln: In einer Formel die Matrix flexsiebel machen 1 merdin75 2158 22. Apr 2004, 19:59
peb In einer Formel die Matrix flexsiebel machen
Keine neuen Beiträge Excel Formeln: Suche Formel für meinen chef! 6 Gast 2434 14. Apr 2004, 10:50
Search Suche Formel für meinen chef!
Keine neuen Beiträge Excel Formeln: BRAUCHE DRINGEND EINE FORMEL 2 Susanne 1947 03. März 2004, 17:45
Susanne BRAUCHE DRINGEND EINE FORMEL
Keine neuen Beiträge Excel Formeln: formel gesucht wenn/dann/sverweis 1 robert305 3159 01. März 2004, 16:45
xpecidy formel gesucht wenn/dann/sverweis
Keine neuen Beiträge Excel Formeln: Suche ein Formel 4 Unwissender 2147 20. Feb 2004, 09:45
xpecidy Suche ein Formel
Keine neuen Beiträge Excel Formeln: formel für 2 Arbeitsmappen 2 Diana 1135 18. Feb 2004, 18:17
peb formel für 2 Arbeitsmappen
Keine neuen Beiträge Excel Formeln: Suche eine Formel für die Nachtschicht-Arbeitszeit 2 charlie77 4981 13. Feb 2004, 00:01
charlie77 Suche eine Formel für die Nachtschicht-Arbeitszeit
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML Editor Forum