Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
nur Zellen mit Inhalt
zurück: VBA oder Formeln. Hilfe mir raucht der Kopf !!! weiter: doppelte Auftragsnummer in Liste Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Duinne
Gast


Verfasst am:
21. März 2012, 11:54
Rufname:

nur Zellen mit Inhalt - nur Zellen mit Inhalt

Nach oben
       Version: Office 2003

Hallo Leute,

ich habe eine Problem mit einer Wenn-Funktion.
Folgende Situation:

Ich habe drei Spalten, die unterschiedlich gefüllt sind. In der vierten Spalte möchte ich Folgendes auslesen:

=WENN(ODER(Y15="";AA15="";AD15="");0;"1")

In der Zeile 15 soll geprüft werden, ob in den Spalten Y, AA oder AD etwas drin steht. Wenn ja, dann die 0, wenn nicht dann die 1.

Das Problem dabei ist, dass alle Zellen mit einer Formel hinterlegt sind, das heißt der Inhalt wird "generiert". In dem Moment ist die Zeile natürlich nicht leer und ich erhalte stets den Wert 0.

Kann man dieser Problem in der Formel umgehen?

Vielen Dank für die Hilfe!
Guenter_Steiner
Im Profil kannst Du frei den Rang ändern


Verfasst am:
21. März 2012, 12:17
Rufname: Günter


AW: nur Zellen mit Inhalt - AW: nur Zellen mit Inhalt

Nach oben
       Version: Office 2003

Hallo,

wenn die Formeln ein "" generieren, muss ja WAHR rauskommen.

Was erwartest du denn sonst in der Zelle? eine Zahl?

Dann kannst du mit ISTZAHL(Y15) statt mit ="" abfragen:

=WENN(ODER(ISTZAHL(Y15);ISTZAHL(AA15);ISTZAHL(AD15));0;"1")

_________________
mfG
Günter
Duinne
Gast


Verfasst am:
21. März 2012, 12:26
Rufname:

AW: nur Zellen mit Inhalt - AW: nur Zellen mit Inhalt

Nach oben
       Version: Office 2003

Danke für die schnelle Antwort!

Ich hatte erwartet, dass nur Zellen mit dem Inhalt, der auch angezeigt wird, ausgewertet werden.

Die Lösung mit ISTZAHL funktioniert bei mir auch nicht. Ich bekomme wieder für eine Zeile, in der lediglich Formeln hinterlegt sind aber die Zellen keinen berechneten Wert anzeigen, den Wert 1.
Supertyp62
Funktionswustling


Verfasst am:
21. März 2012, 12:46
Rufname: Jan
Wohnort: Gießen

AW: nur Zellen mit Inhalt - AW: nur Zellen mit Inhalt

Nach oben
       Version: Office 2003

Hallo Duinne,

so wie du das beschreibst, ist es eher:

=WENN(ODER(Y15<>"";AA15<>"";AD15<>"");0;"1")

_________________
Questions are a burden to others. So burden away!
Gast



Verfasst am:
21. März 2012, 13:47
Rufname:

AW: nur Zellen mit Inhalt - AW: nur Zellen mit Inhalt

Nach oben
       Version: Office 2003

Wundervoll, jetzt klappt es!

Vielen Dank für die Hilfe und noch einen schönen Tag =)

Grüße
Duinne
Hydronaut
#NV


Verfasst am:
21. März 2012, 14:21
Rufname:


AW: nur Zellen mit Inhalt - AW: nur Zellen mit Inhalt

Nach oben
       Version: Office 2003

Hallo

Oder so:
Code:
=WENN(ANZAHL2(Y15;AA15;AD15);0;1)

_________________
Grüsse
Detlef

Bitte keine PN!
Seit Nikolaus 2012 mit Excel 2010
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Zellen miteinander verlinken 2 holfloser Gast 1527 07. Feb 2005, 10:50
holfloser Gast Zellen miteinander verlinken
Keine neuen Beiträge Excel Formeln: zellen verbinden 1 Gast 1414 22. Jan 2005, 01:11
jochenj zellen verbinden
Keine neuen Beiträge Excel Formeln: Einzelne Zellen miteinander vergleichen. 8 breid 1726 14. Jan 2005, 17:54
breid Einzelne Zellen miteinander vergleichen.
Keine neuen Beiträge Excel Formeln: Worte aus einer Zelle in 2 Zellen schreiben 2 Sven79 1322 12. Jan 2005, 01:20
Sven79 Worte aus einer Zelle in 2 Zellen schreiben
Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten. Excel Formeln: Bestimmten Zellen einen Wert zuteilen. 1 tomimmo 2544 03. Dez 2004, 20:35
ae Bestimmten Zellen einen Wert zuteilen.
Keine neuen Beiträge Excel Formeln: Berechnung mit ausgeblendeten Zellen 2 Urban 1123 11. Nov 2004, 08:25
Günni Berechnung mit ausgeblendeten Zellen
Keine neuen Beiträge Excel Formeln: Zellen auswerten 4 Cat 1526 11. Nov 2004, 01:20
Gast Zellen auswerten
Keine neuen Beiträge Excel Formeln: Excel Zellen verknüpfen! 1 Gast 2858 10. Nov 2004, 10:41
Gast Excel Zellen verknüpfen!
Keine neuen Beiträge Excel Formeln: Bestimmen einer Zellenposition durch ihren Inhalt 1 FMPO 1607 22. Sep 2004, 13:35
fl618 Bestimmen einer Zellenposition durch ihren Inhalt
Keine neuen Beiträge Excel Formeln: Funktion: Identische Inhalt einer Zelle in Tabelle 1 und 2 4 luki 4202 09. Sep 2004, 18:20
Gast Funktion: Identische Inhalt einer Zelle in Tabelle 1 und 2
Keine neuen Beiträge Excel Formeln: Kopieren von Zellen, Problem mit Datumsformatierung 4 Mick 1431 08. Sep 2004, 18:59
Mick Kopieren von Zellen, Problem mit Datumsformatierung
Keine neuen Beiträge Excel Formeln: Zellen mit Formeln ausfüllen 22 akm1978 4502 26. Aug 2004, 17:33
akm1978 Zellen mit Formeln ausfüllen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Excel Tricks