Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Umwandeln von Uhrzeit in Benutzerdefiniert
zurück: Sverweis und Wenn verknüpfen? weiter: Zählen bis 60% Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Rainer1010
Im Profil kannst Du frei den Rang ändern


Verfasst am:
20. März 2012, 01:09
Rufname:

Umwandeln von Uhrzeit in Benutzerdefiniert - Umwandeln von Uhrzeit in Benutzerdefiniert

Nach oben
       Version: Office 2007

Hallo Leute!

Ich habe alle Spalten bis auf Spalte I mit Benutzerdeffiniert (standard;standard) formatiert um die zahlen so zu bekommen wie wie erscheinen. Nur leider geht das in Spalte I nicht. Wie kann ich das umwandeln das ich mit der Spalte I für weitere jetzt nicht sichbare Spalten weiterrechnen kann.

Danke für eure hilfe


VORLAGE

 BCDEFGHI
602.04.2012107:0022:00153  
703.04.2012208:0013:004,5 3,501:00
804.04.2012307:0023:00164 00:00

Formeln der Tabelle
ZelleFormel
F6=WENN((REST(E6-D6;1)*24)>=8;REST(E6-D6;1)*24;MAX(0;(REST(E6-D6;1)*24)-0,5))
G6=MAX(;F6-12)
H6=WENN(UND(F6>G6;F6<8);(8-F6);"")
F7=WENN((REST(E7-D7;1)*24)>=8;REST(E7-D7;1)*24;MAX(0;(REST(E7-D7;1)*24)-0,5))
G7=MAX(;F7-12)
H7=WENN(UND(F7>G7;F7<8);(8-F7);"")
I7=WENN(D7*E6;MAX(0;11/24-REST(D7-E6;1));"")
F8=WENN((REST(E8-D8;1)*24)>=8;REST(E8-D8;1)*24;MAX(0;(REST(E8-D8;1)*24)-0,5))
G8=MAX(;F8-12)
H8=WENN(UND(F8>G8;F8<8);(8-F8);"")
I8=WENN(D8*E7;MAX(0;11/24-REST(D8-E7;1));"")


Excel Jeanie Html
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
20. März 2012, 06:13
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände


AW: Umwandeln von Uhrzeit in Benutzerdefiniert - AW: Umwandeln von Uhrzeit in Benutzerdefiniert

Nach oben
       Version: Office 2007

Hallo Rainer

Ich verstehe die Frage nicht.
Wenn alles mit Standard formatiert wäre, dann würde die Tabelle so aussehen:
Arbeitsblatt mit dem Namen 'Tabelle1'
 BCDEFGHI
64100110,291666670,91666667153  
74100220,333333330,541666674,5 3,50,04166667
84100330,291666670,95833333164 0
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Und was die Formatierung mit Formeln in weiteren Spalten zu tun hat, erschließt sich mir auch nicht.

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Thomas Ramel
Microsoft Excel-MVP


Verfasst am:
20. März 2012, 07:21
Rufname: Thom
Wohnort: Glashütten - CH

AW: Umwandeln von Uhrzeit in Benutzerdefiniert - AW: Umwandeln von Uhrzeit in Benutzerdefiniert

Nach oben
       Version: Office 2007

Grüezi Rainer

Wie man Uhzeitwerte in dezimale Werte umwandelt weisst Du ja (nehme ich aufgrund der anderen Formeln jedenfalls an) - tu doch in Spalte I genau dasselbe und formatiere die Zellen als 'Stadard':

Arbeitsblatt mit dem Namen 'Tabelle1'
 BCDEFGHI
602.04.2012107:0022:00153  
703.04.2012208:0013:004.503.51
804.04.2012307:0023:00164 0

ZelleFormel
I7=WENN(D7*E6;MAX(0;11/24-REST(D7-E6;1));"")*24
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

_________________
Mit freundlichen Grüssen

Thomas Ramel
[Vista Ultimate SP-1 / xl2007 SP-2]
BoskoBiati
Im Profil kannst Du frei den Rang ändern


Verfasst am:
20. März 2012, 08:12
Rufname: Bosko

AW: Umwandeln von Uhrzeit in Benutzerdefiniert - AW: Umwandeln von Uhrzeit in Benutzerdefiniert

Nach oben
       Version: Office 2007

Hallo zusammen,

wenn die Null sowieso nicht auftauchen soll, dann wäre es so einfacher:

Code:
==(E6*D7>0)*MAX(0;11/24-REST(D7-E6;1))*24

Es entsteht dann auch kein Fehler, wenn der Sonst-Teil aktiv wird mit ""*24

_________________
Gruß

Bosko

Ich würde mich freuen zu erfahren, ob ich helfen konnte.
Rainer1010
Im Profil kannst Du frei den Rang ändern


Verfasst am:
20. März 2012, 23:34
Rufname:


AW: Umwandeln von Uhrzeit in Benutzerdefiniert - AW: Umwandeln von Uhrzeit in Benutzerdefiniert

Nach oben
       Version: Office 2007

hallo und danke für die Hilfe.

Es scheint alles zu klappen, bis auf das, wenn kein Wert eingetragen wurde immer noch 0 dortsteht statt einem leeren feld.
könnt ihr mir da noch helfen danke

VORLAGE

 DEFGHI
607:0022:00153  
708:0013:004,5 3,51
807:0023:00164 0
906:0023:00175 4
1007:0023:00164 3
11     0
12     0

Formeln der Tabelle
ZelleFormel
F6=WENN((REST(E6-D6;1)*24)>=8;REST(E6-D6;1)*24;MAX(0;(REST(E6-D6;1)*24)-0,5))
G6=MAX(;F6-12)
H6=WENN(UND(F6>G6;F6<8);(8-F6);"")
F7=WENN((REST(E7-D7;1)*24)>=8;REST(E7-D7;1)*24;MAX(0;(REST(E7-D7;1)*24)-0,5))
G7=MAX(;F7-12)
H7=WENN(UND(F7>G7;F7<8);(8-F7);"")
I7=(E6*D7>0)*MAX(0;11/24-REST(D7-E6;1))*24
F8=WENN((REST(E8-D8;1)*24)>=8;REST(E8-D8;1)*24;MAX(0;(REST(E8-D8;1)*24)-0,5))
G8=MAX(;F8-12)
H8=WENN(UND(F8>G8;F8<8);(8-F8);"")
I8=(E7*D8>0)*MAX(0;11/24-REST(D8-E7;1))*24
F9=WENN((REST(E9-D9;1)*24)>=8;REST(E9-D9;1)*24;MAX(0;(REST(E9-D9;1)*24)-0,5))
G9=MAX(;F9-12)
H9=WENN(UND(F9>G9;F9<8);(8-F9);"")
I9=(E8*D9>0)*MAX(0;11/24-REST(D9-E8;1))*24
F10=WENN((REST(E10-D10;1)*24)>=8;REST(E10-D10;1)*24;MAX(0;(REST(E10-D10;1)*24)-0,5))
G10=MAX(;F10-12)
H10=WENN(UND(F10>G10;F10<8);(8-F10);"")
I10=(E9*D10>0)*MAX(0;11/24-REST(D10-E9;1))*24
F11=WENN((REST(E11-D11;1)*24)>=8;REST(E11-D11;1)*24;MAX(0;(REST(E11-D11;1)*24)-0,5))
G11=MAX(;F11-12)
H11=WENN(UND(F11>G11;F11<8);(8-F11);"")
I11=(E10*D11>0)*MAX(0;11/24-REST(D11-E10;1))*24
F12=WENN((REST(E12-D12;1)*24)>=8;REST(E12-D12;1)*24;MAX(0;(REST(E12-D12;1)*24)-0,5))
G12=MAX(;F12-12)
H12=WENN(UND(F12>G12;F12<8);(8-F12);"")
I12=(E11*D12>0)*MAX(0;11/24-REST(D12-E11;1))*24


Excel Jeanie Html
Rainer1010
Im Profil kannst Du frei den Rang ändern


Verfasst am:
20. März 2012, 23:51
Rufname:

AW: Umwandeln von Uhrzeit in Benutzerdefiniert - AW: Umwandeln von Uhrzeit in Benutzerdefiniert

Nach oben
       Version: Office 2007

und noch ein problem ist gerade entstanden in I7. Weiss nicht warum das als einzige Zeile so passiert.

VORLAGE

 DEFGHI
708:0013:004,5 3,51,33227E-15
807:0018:0011  0
906:0023:00175 0
1007:0023:00164 3

Formeln der Tabelle
ZelleFormel
F7=WENN((REST(E7-D7;1)*24)>=8;REST(E7-D7;1)*24;MAX(0;(REST(E7-D7;1)*24)-0,5))
G7=MAX(;F7-12)
H7=WENN(UND(F7>G7;F7<8);(8-F7);"")
I7=(E6*D7>0)*MAX(0;11/24-REST(D7-E6;1))*24
F8=WENN((REST(E8-D8;1)*24)>=8;REST(E8-D8;1)*24;MAX(0;(REST(E8-D8;1)*24)-0,5))
G8=MAX(;F8-12)
H8=WENN(UND(F8>G8;F8<8);(8-F8);"")
I8=(E7*D8>0)*MAX(0;11/24-REST(D8-E7;1))*24
F9=WENN((REST(E9-D9;1)*24)>=8;REST(E9-D9;1)*24;MAX(0;(REST(E9-D9;1)*24)-0,5))
G9=MAX(;F9-12)
H9=WENN(UND(F9>G9;F9<8);(8-F9);"")
I9=(E8*D9>0)*MAX(0;11/24-REST(D9-E8;1))*24
F10=WENN((REST(E10-D10;1)*24)>=8;REST(E10-D10;1)*24;MAX(0;(REST(E10-D10;1)*24)-0,5))
G10=MAX(;F10-12)
H10=WENN(UND(F10>G10;F10<8);(8-F10);"")
I10=(E9*D10>0)*MAX(0;11/24-REST(D10-E9;1))*24


Excel Jeanie Html
Thomas Ramel
Microsoft Excel-MVP


Verfasst am:
21. März 2012, 00:20
Rufname: Thom
Wohnort: Glashütten - CH

AW: Umwandeln von Uhrzeit in Benutzerdefiniert - AW: Umwandeln von Uhrzeit in Benutzerdefiniert

Nach oben
       Version: Office 2007

Grüezi Rainer

Wer hat denn die Formeln eigentlich entwickelt - wenn du das warst solltest Du doch wissen was sie tun.....


Deine Formel in I7 bezieht sich auf Zeile 6, die aber leer ist - darum steht dann in I7 ein ungewöhnlicher Wert.

_________________
Mit freundlichen Grüssen

Thomas Ramel
[Vista Ultimate SP-1 / xl2007 SP-2]
Rainer1010
Im Profil kannst Du frei den Rang ändern


Verfasst am:
21. März 2012, 21:35
Rufname:

AW: Umwandeln von Uhrzeit in Benutzerdefiniert - AW: Umwandeln von Uhrzeit in Benutzerdefiniert

Nach oben
       Version: Office 2007

hallo thomas

hab die Zeile 6 nicht hochgeladen mein fehler. Jedoch hab ich eine eingabe in Zelle 6 gemacht. In den anderen Zeilen funktioniert es.

VORLAGE

 DEFGHI
607:0021:00142  
708:0013:004,5 3,51,33227E-15
807:0018:0011  0
906:0023:00175 0
1007:0023:00164 3

Formeln der Tabelle
ZelleFormel
F6=WENN((REST(E6-D6;1)*24)>=8;REST(E6-D6;1)*24;MAX(0;(REST(E6-D6;1)*24)-0,5))
G6=MAX(;F6-12)
H6=WENN(UND(F6>G6;F6<8);(8-F6);"")
F7=WENN((REST(E7-D7;1)*24)>=8;REST(E7-D7;1)*24;MAX(0;(REST(E7-D7;1)*24)-0,5))
G7=MAX(;F7-12)
H7=WENN(UND(F7>G7;F7<8);(8-F7);"")
I7=(E6*D7>0)*MAX(0;11/24-REST(D7-E6;1))*24
F8=WENN((REST(E8-D8;1)*24)>=8;REST(E8-D8;1)*24;MAX(0;(REST(E8-D8;1)*24)-0,5))
G8=MAX(;F8-12)
H8=WENN(UND(F8>G8;F8<8);(8-F8);"")
I8=(E7*D8>0)*MAX(0;11/24-REST(D8-E7;1))*24
F9=WENN((REST(E9-D9;1)*24)>=8;REST(E9-D9;1)*24;MAX(0;(REST(E9-D9;1)*24)-0,5))
G9=MAX(;F9-12)
H9=WENN(UND(F9>G9;F9<8);(8-F9);"")
I9=(E8*D9>0)*MAX(0;11/24-REST(D9-E8;1))*24
F10=WENN((REST(E10-D10;1)*24)>=8;REST(E10-D10;1)*24;MAX(0;(REST(E10-D10;1)*24)-0,5))
G10=MAX(;F10-12)
H10=WENN(UND(F10>G10;F10<8);(8-F10);"")
I10=(E9*D10>0)*MAX(0;11/24-REST(D10-E9;1))*24


Excel Jeanie Html
BoskoBiati
Im Profil kannst Du frei den Rang ändern


Verfasst am:
21. März 2012, 21:40
Rufname: Bosko


AW: Umwandeln von Uhrzeit in Benutzerdefiniert - AW: Umwandeln von Uhrzeit in Benutzerdefiniert

Nach oben
       Version: Office 2007

Hallo,

versuche es mal so:

Code:
=runden((E6*D7>0)*MAX(0;11/24-REST(D7-E6;1))*24;2)

_________________
Gruß

Bosko

Ich würde mich freuen zu erfahren, ob ich helfen konnte.
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Schicht anhand der Uhrzeit ermitteln 5 Schnuffe 3590 18. Sep 2006, 08:37
Schnuffe Schicht anhand der Uhrzeit ermitteln
Keine neuen Beiträge Excel Formeln: Zeit umwandeln 13 Cörmi 3888 05. Sep 2006, 23:51
Hübi Zeit umwandeln
Keine neuen Beiträge Excel Formeln: Uhrzeit mit Dezimalzahlen multiplizieren 2 GastMitNervenAmEnde 8039 14. Jul 2006, 09:35
Gast Uhrzeit mit Dezimalzahlen multiplizieren
Keine neuen Beiträge Excel Formeln: aus Uhrzeit wird Zahl !!! Wieso? 5 Mario79 852 06. Jun 2006, 23:22
Mario79 aus Uhrzeit wird Zahl !!! Wieso?
Keine neuen Beiträge Excel Formeln: Umwandeln text von gross in klein + batchdownload?? 3 Timburton 1131 18. Mai 2006, 19:09
Solaiman Umwandeln text von gross in klein + batchdownload??
Keine neuen Beiträge Excel Formeln: tt:hh:mm in Minuten umwandeln 1 Gerald Stiebel 1780 27. März 2006, 09:02
c0bRa tt:hh:mm in Minuten umwandeln
Keine neuen Beiträge Excel Formeln: Rechnen mit Uhrzeit 2 Bernd S 1989 28. Feb 2006, 20:11
Gast Rechnen mit Uhrzeit
Keine neuen Beiträge Excel Formeln: JULIANISCHES Datum umwandeln 2 Gast 5610 24. Jan 2006, 18:51
ae JULIANISCHES Datum umwandeln
Keine neuen Beiträge Excel Formeln: Aktuelle Uhrzeit? 3 JimmyT 842 19. Jan 2006, 14:40
c0bRa Aktuelle Uhrzeit?
Keine neuen Beiträge Excel Formeln: Erzielte Zeit in Sekunden umwandeln 2 waterjoe 11886 23. Nov 2005, 18:06
waterjoe Erzielte Zeit in Sekunden umwandeln
Keine neuen Beiträge Excel Formeln: Formelwert in Text umwandeln ! 8 uslr795 8933 06. Okt 2005, 10:55
uslr795 Formelwert in Text umwandeln !
Keine neuen Beiträge Excel Formeln: Uhrzeit 5 Wilfried 981 25. Aug 2005, 14:44
fridgenep Uhrzeit
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Dreamweaver Forum