Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Dynamischer Zellbereich,definiert von einem anderen Zellwert
zurück: Microsoft Date and Time Picker Control weiter: Worddatei autom. im Quellordner als Pdf u. Word speichern Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
watergateory
Neuling


Verfasst am:
25. Aug 2011, 14:19
Rufname: John

Dynamischer Zellbereich,definiert von einem anderen Zellwert - Dynamischer Zellbereich,definiert von einem anderen Zellwert

Nach oben
       Version: Office 2010

Hallo zusammen,

hab folgendes Problem:

A B C

1 93 0,8... Ergebnis: =mittelwert(B1:B(wert(A1))
2 105 0,5...
... ...

Also ich hätte gerne als Ergebnis C1=mittelwert(B1:B(wert(A1)), nur der Endwert des Bereichs B kann ich nicht mit dem Wert von A1 versehen d.h. in dem Fall sollte der Bereich (b1:b93) sein. Für C2 soll der Bereich (b1:b105) sein usw.

Kann mir jemand dabei helfen?

Vielen Dank!
Christoph
Ute-S
PowerPoint-Profi


Verfasst am:
26. Aug 2011, 13:21
Rufname:
Wohnort: Nähe Frankfurt


AW: Dynamischer Zellbereich,definiert von einem anderen Zell - AW: Dynamischer Zellbereich,definiert von einem anderen Zell

Nach oben
       Version: Office 2010

Verwende nicht WERT, sondern INDIREKT:

=MITTELWERT(B1:INDIREKT("B"&A1))

Die Verkettung in der Klammer nach INDIREKT setzt die Zelladresse aus B und der Zahl in A1 zusammen.

Viele Grüße
Ute
watergateory
Neuling


Verfasst am:
29. Aug 2011, 10:05
Rufname: John

AW: Dynamischer Zellbereich,definiert von einem anderen Zell - AW: Dynamischer Zellbereich,definiert von einem anderen Zell

Nach oben
       Version: Office 2010

Hi Ute,

Vielen Dank für die Hilfe! Leider, beim ausfüllen nach unten kriege ich einen Fehler, womit ich nicht zurechtkomme. Hättest Du eine Idee, woran es liegen könnte? Danke!

LG
Christoph
Code:
P   Q   S
   93   -1,925324403 (=MITTELWERT(P3:INDIREKT("P"&Q3)))
   93   -1,925324403
   93   -1,925324403
   93   -1,925324403
   93   -1,925324403
   93   -1,925324403
   93   -1,925324403
   93   -1,925324403
   93   -1,925324403
   93   -1,925324403
   93   -1,925324403
   93   -1,925324403
   93   -1,925324403
   93   -1,925324403
   93   -1,925324403
   93   -1,925324403
   93   -1,925324403
   93   -1,925324403
   93   -1,925324403
-1,925324   93   -1,925324403
   93   #DIV/0!
   93   #DIV/0!
   93   #DIV/0!
   93   #DIV/0!
   93   #DIV/0!
...              ...                ...
Ute-S
PowerPoint-Profi


Verfasst am:
29. Aug 2011, 13:25
Rufname:
Wohnort: Nähe Frankfurt


AW: Dynamischer Zellbereich,definiert von einem anderen Zell - AW: Dynamischer Zellbereich,definiert von einem anderen Zell

Nach oben
       Version: Office 2010

Ehrlich gesagt: Deine Tabelle verstehe ich nicht. Die Spalte "P" enthält ganze Zahlen (im Beispiel "93") und die Dezimalzahlen in Spalte "Q" willst Du zur Zelladresse verketten? Das kann nicht funktionieren, Du brauchst eine ganze Zahl als Zeilennummer für die Zelladresse.

Falls ich Dein Beispiel falsch verstanden habe: Lad mal eine kleine Excel-Beispieltabelle hoch.

Viele Grüße
Ute
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Office 2010 Forum: Excel Dynamischer Fragebogen 0 BorisT 739 07. Feb 2012, 15:04
BorisT Excel Dynamischer Fragebogen
Keine neuen Beiträge Office 2010 Forum: Dynamischer Verbinder in Visio mit mehreren Ecken 1 hacori 6525 12. Dez 2011, 12:14
Sven001 Dynamischer Verbinder in Visio mit mehreren Ecken
Keine neuen Beiträge Forum für LibreOffice, OpenOffice und Staroffice : dynamischer diagramm titel 0 gast1234567 1037 22. Sep 2011, 07:33
gast1234567 dynamischer diagramm titel
Keine neuen Beiträge Forum für LibreOffice, OpenOffice und Staroffice : zellwert ändern während sverweis 1 Ey-Ko 1074 23. Dez 2010, 10:11
Ey-Ko zellwert ändern während sverweis
Keine neuen Beiträge Office 2007 Forum: excel: scrollbar für bestimmten zellbereich?! 0 phi88 699 24. Okt 2010, 12:21
phi88 excel: scrollbar für bestimmten zellbereich?!
Keine neuen Beiträge Anwendungsübergreifende Fragen: dynamischer Vertragstext - welches Programm von Office 3 frageausdemhochhaus 513 12. Mai 2010, 09:04
pjruiz dynamischer Vertragstext - welches Programm von Office
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Expression Web