Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
#WERT! soll nicht erscheinen
zurück: Entweder ist Excel doof oder Ich bins!!! (Wenn Formel) weiter: ZF Berechnen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Hilfebedürftiger
Gast


Verfasst am:
05. Jul 2011, 12:12
Rufname:

#WERT! soll nicht erscheinen - #WERT! soll nicht erscheinen

Nach oben
       Version: Office 2007

Brauche dringend Hilfe, bin schon ganz blöd vom überlegen:

In E21 schreibe ich ein Datum.

I 21 ergibt sich aus folgender Formel:

=WENN(E21=0;"";DATUM(JAHR(E21);MONAT(E21)+6;TAG(E21)))

(also rechnet E21 + 6 Monate)

J 21 wird bedingt durch ein Steuerelement = WAHR oder FALSCH (je nachdem, ob das Kästchen angeklickt ist oder nicht)

F 21 ergibt sich aus folgender Formel:

=WENN(J21=WAHR;I21;"")

(wenn in J 21 Wahr steht, dann schreibe I 21)

Und G 21 aus dieser Formel:

=WENN(NICHT(E21="TEXT");(WENN(F21=0;100;TAGE360($E$3;F21)));"")

(das heißt, das Datum von Heute (=E3) wird von dem Datum was in F 21 steht abgezogen, so dass eine Ablaufzahl entsteht.

Das ganze funktioniert, solange ein Datum von mir eingegeben wird. Steht die Zelle E 21 leer (ohne Datum) dann steht in G 21: #WERT!
Ich möchte aber, dass er dort dann auch nichts reinschreibt, also die Zelle leer läßt. Was muß ich ändern????
Gast



Verfasst am:
05. Jul 2011, 12:21
Rufname:


AW: #WERT! soll nicht erscheinen - AW: #WERT! soll nicht erscheinen

Nach oben
       Version: Office 2007

Hallo,

Was bezweckst Du damit:

Zitat:
=NICHT(E21="TEXT")


Das bedeutet, wenn in E21 nicht das Wort Text steht, dann rechne!


Probiere es mal so:

Code:
=WENN(e21<>"";WENN(F21=0;100;TAGE360($E$3;F21));"")


Gruß

Bosko
Hilfebedürftiger
Gast


Verfasst am:
05. Jul 2011, 12:47
Rufname:

AW: #WERT! soll nicht erscheinen - AW: #WERT! soll nicht erscheinen

Nach oben
       Version: Office 2007

Der Fehler bleibt aber trotzdem weiterhin bestehen:

sobald in E21 kein datum steht, schreibt er in G23 #WERT!

Ich möchte dann aber die Zelle leer haben.
Gast



Verfasst am:
05. Jul 2011, 13:35
Rufname:

AW: #WERT! soll nicht erscheinen - AW: #WERT! soll nicht erscheinen

Nach oben
       Version: Office 2007

Hallo,

dann stelle mal einen Tabellenauszug vor.

Gruß

Bosko
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
05. Jul 2011, 19:14
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände


AW: #WERT! soll nicht erscheinen - AW: #WERT! soll nicht erscheinen

Nach oben
       Version: Office 2007

Hallo

Probiere mal das:
Code:
=WENN(E21<>"";WENN(F21="";100;TAGE360($E$3;F21));"")

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: #WERT bei Funktion Finden 2 stpimi 891 20. Apr 2005, 13:53
stpimi #WERT bei Funktion Finden
Keine neuen Beiträge Excel Formeln: Wie bekomme ich die null und den minus wert weg???? 5 Dennis81 1191 20. Feb 2005, 06:04
Dennis81 Wie bekomme ich die null und den minus wert weg????
Keine neuen Beiträge Excel Formeln: Text in Zelle ergibt #WERT beim Additionieren 2 Aloha 2091 19. Feb 2005, 10:36
Aloha Text in Zelle ergibt #WERT beim Additionieren
Keine neuen Beiträge Excel Formeln: vergleich mit Wert vor 10min 2 Norbert_B 585 11. Feb 2005, 15:19
Norbert_B vergleich mit Wert vor 10min
Keine neuen Beiträge Excel Formeln: Wert nur einmal anzeigen 3 User001 21427 04. Feb 2005, 15:18
rainberg Wert nur einmal anzeigen
Keine neuen Beiträge Excel Formeln: Wert *-1 = ########## 4 acki-bm 689 04. Feb 2005, 09:40
Thomas Ramel Wert *-1  = ##########
Keine neuen Beiträge Excel Formeln: Wert suchen 2 Foxy 583 29. Jan 2005, 18:04
Gast Wert suchen
Keine neuen Beiträge Excel Formeln: Wert aus Verkettung wird nicht angezeigt 8 Mike28 2412 28. Jan 2005, 11:52
Mike28 Wert aus Verkettung  wird nicht angezeigt
Keine neuen Beiträge Excel Formeln: Wert und Datum verknüpfen 3 Helle67 3021 11. Jan 2005, 18:23
Helle67 Wert und Datum verknüpfen
Keine neuen Beiträge Excel Formeln: Feld contains Wert 1 Gast.... 887 03. Jan 2005, 19:22
Arnim Feld contains Wert
Keine neuen Beiträge Excel Formeln: Erster Wert aus mehreren Spalten 4 Gast 1922 03. Dez 2004, 10:52
Arnim Erster Wert aus mehreren Spalten
Keine neuen Beiträge Excel Formeln: gegeben 2 Spalten/ ges. wie oft Wert aus Spalte 1 mit Wert a 4 Stefan B. 1310 21. Okt 2004, 08:06
Stefan B. gegeben 2 Spalten/ ges. wie oft Wert aus Spalte 1 mit Wert a
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Macromedia Dreamweaver