Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
WENN und Checkbox
zurück: Musik weiter: Frage bezueglich der CELL-Formel Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
MikeMike
Gast


Verfasst am:
30. Jun 2011, 23:14
Rufname:

WENN und Checkbox - WENN und Checkbox

Nach oben
       Version: Office 2010

Hallo,

ich habe eine Checkbox auf Höhe von B7 plaziert und mit dem Feld B23 verknüpft (siehe Bild).
In B7 wird geprüft, ob B23=WAHR ist. Trifft dies zu, nimmt er den Wert aus C2. Falls nicht, gibt er 0 zurück:
Code:
=WENN(B23=WAHR; C2; "0")

usw ...
B8:
Code:
=WENN(B24=WAHR; C2; "0")

...

Soweit funktioniert auch alles und die Werte stimmen immer.




Dann kommt es zu folgender Situation:
Mein Excel setzt meine Bedingung in H7 nicht komplett um:
Ich habe diese Bedingung in der Zelle H7 definiert:
Code:
=WENN(B7>0;(B7*F7);(C7*E7))

Ich habe diese Bedingung in der Zelle H8 definiert:
Code:
=WENN(B8>0;(B8*F8);(C8*E8))


In B7 wird automatisch der in C2 festgelegte Wert genutzt, sobald man die Checkbox aktiviert (siehe Beschreibung oben & Bild).
In B8 wird automatisch der Wert 0 genutzt, sobald man die Checkbox deaktiviert (siehe Beschreibung oben & Bild).


Die ganze Zeile 7 stimmt also.
In Zeile 8 wird in H8 aber nicht die SONST-Bedingung ausgeführt. In diesem Fall müsste nämlich, da B8=0 ist, C8*E8 gerechnet werden. Es wird aber komischerweise irgendetwas mit 0 gerechnet, da 0 rauskommt. Es kommt also nur das Feld B8 in Frage, welches einen falschen Wert liefert?


Wo könnte da der Logikfehler liegen?


Zero
Formeln, Diagramme und ein bisschen VBA


Verfasst am:
01. Jul 2011, 16:47
Rufname: Dennis
Wohnort: NDS


AW: WENN und Checkbox - AW: WENN und Checkbox

Nach oben
       Version: Office 2010

Hallo

"0" in ungleich 0

=WENN(B23=WAHR; C2; 0)
oder
=WENN(B23; C2; 0)

_________________
Gruß zero
MikeMike
Gast


Verfasst am:
05. Jul 2011, 21:57
Rufname:

AW: WENN und Checkbox - AW: WENN und Checkbox

Nach oben
       Version: Office 2010

Nochmal eine Frage:

Wie kann ich eine Provision ausrechnen lassen?

Gegeben sei der Betrag 20€ (incl. Provision).
Ich würde gerne ausrechnen lassen, wie der Betrag ohne Provision wäre.

Also ist der gesuchte Betrag X.

Die Rechnung lautet dann:
X PLUS 10% von X = 20


Ich verstehe den Excel-Solver nicht ganz. Geht das damit? Wenn ja, wie genau?
Zero
Formeln, Diagramme und ein bisschen VBA


Verfasst am:
05. Jul 2011, 23:21
Rufname: Dennis
Wohnort: NDS

AW: WENN und Checkbox - AW: WENN und Checkbox

Nach oben
       Version: Office 2010

Hallo

Wozu den Solver? 7. Klasse! Dreisatz!

20/1,1
20 / (100% + 10%)

_________________
Gruß zero
MikeMike
Gast


Verfasst am:
06. Jul 2011, 00:20
Rufname:


AW: WENN und Checkbox - AW: WENN und Checkbox

Nach oben
       Version: Office 2010

Ich wusste doch, dass ich irgendwo auf dem Schlauch stehe.

Embarassed



Danke vielmals Smile
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Inhalt mehrerer Zellen durch Checkbox in eine Zelle kopieren 6 kollimator 103 14. Feb 2013, 09:57
Hydronaut Inhalt mehrerer Zellen durch Checkbox in eine Zelle kopieren
Keine neuen Beiträge Excel Formeln: Tabelle mit Checkbox ein- und ausblenden 0 Nadine12342 191 29. März 2012, 16:42
Nadine12342 Tabelle mit Checkbox ein- und ausblenden
Keine neuen Beiträge Excel Formeln: Checkbox/Kontrollkästchen (Wenn, dann....) 3 Hazel85 816 01. März 2012, 14:56
Gast Checkbox/Kontrollkästchen (Wenn, dann....)
Keine neuen Beiträge Excel Formate: Checkbox, die einen Wert zählt 17 mikeyboy 931 30. Jan 2012, 09:14
mikeyboy Checkbox, die einen Wert zählt
Keine neuen Beiträge Excel Formeln: muss ich jede checkbox einzeln verknüpfen??? 5 Gast 686 01. Okt 2010, 12:56
Gast muss ich jede checkbox einzeln verknüpfen???
Keine neuen Beiträge Excel Formate: Checkbox Textformatierung 4 Newstart 2138 26. Jul 2010, 13:10
Newstart Checkbox Textformatierung
Keine neuen Beiträge Excel Formeln: Checkbox in Formel 1 Moonlight_driver 184 12. Jul 2010, 13:40
Moonlight_driver Checkbox in Formel
Keine neuen Beiträge Excel Formate: Checkbox einblenden bei bestimmter Dropdown-Auswahl 1 zoliboy 1301 09. Jun 2010, 17:27
gandalf149 Checkbox einblenden bei bestimmter Dropdown-Auswahl
Keine neuen Beiträge Excel Formate: Checkbox 1 MiFraNe 395 04. Feb 2010, 13:51
Alterweg Checkbox
Keine neuen Beiträge Excel Formate: Transparent Checkbox 1 Silly14 3043 09. Nov 2007, 02:40
Hübi Transparent Checkbox
Keine neuen Beiträge Excel Formate: Steuerelemente Toolbox - Checkbox Hintergrund 0 BigALe 2717 22. Mai 2007, 11:43
BigALe Steuerelemente Toolbox - Checkbox Hintergrund
Keine neuen Beiträge Excel Formeln: Checkbox in Dokument einfügen 1 RickyDean 1439 30. Jul 2006, 21:07
Hermie Checkbox in Dokument einfügen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: PHP JavaScript