Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
leeres UFO beim Öffnen
zurück: Variablen in andere Formulare übergeben weiter: Einbinden von Hintergrundbild im Formular Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
11.auflage
dank des Forums schon sehr viel dazugelernt


Verfasst am:
11. Aug 2005, 11:11
Rufname:

leeres UFO beim Öffnen - leeres UFO beim Öffnen

Nach oben
       

Hallo!

Habe ein Suchformular, in dem sich u.a. ein Unterformular befindet. Wenn ich nun das Formular öffne, dann werden mir immer noch die Daten vom letzten Mal in dem Unterformular angezeigt. Ich möchte aber, dass das Unterformular leer ist, wenn ich das Formular öffne. Das geht bestimmt ganz einfach, ich weiß nur gerade nicht, wie...

Für Tipps bin ich sehr dankbar!!
iionic am 11. Aug 2005 um 11:44 hat folgendes geschrieben:
Habe das gleich Problem ...
Wäre super wenn uns jemand schreiben könnte wie dies geht ... Smile
Flame
Pisa Verantwortlicher


Verfasst am:
12. Aug 2005, 09:36
Rufname:
Wohnort: Bremen


AW: leeres UFO beim Öffnen - AW: leeres UFO beim Öffnen

Nach oben
       

Beim Öffnen des Formulars:
Code:
    Me!unterformular.RecordSource = ""
so koennte es gehen.
_________________
Wenn ich groß bin möchte ich mal Mod werden
11.auflage
dank des Forums schon sehr viel dazugelernt


Verfasst am:
12. Aug 2005, 10:41
Rufname:

AW: leeres UFO beim Öffnen - AW: leeres UFO beim Öffnen

Nach oben
       

Hallo Flame!

erst einmal danke für die Antwort!

habe das ausgetestet, aber es kommt "Methode oder Datenobjekt nicht gefunden"....mein Code sieht so aus:
Code:
    Me!tbl_5000UFO.RecordSource = ""
und tbl_5000UFO ist halt mein Unterformular...hast du vielleicht noch eine Idee?
Flame
Pisa Verantwortlicher


Verfasst am:
12. Aug 2005, 10:46
Rufname:
Wohnort: Bremen

AW: leeres UFO beim Öffnen - AW: leeres UFO beim Öffnen

Nach oben
       

hast du das jetzt beim öffnen des unterforms oder des Hauptforms eingefügt, allerdings sollte der RS des unterforms dem haupt - und unterformular bekannt sein ... werde mal eben deine Situation nachbasteln.
_________________
Wenn ich groß bin möchte ich mal Mod werden
11.auflage
dank des Forums schon sehr viel dazugelernt


Verfasst am:
12. Aug 2005, 11:01
Rufname:


AW: leeres UFO beim Öffnen - AW: leeres UFO beim Öffnen

Nach oben
       

beim hauptformular
Flame
Pisa Verantwortlicher


Verfasst am:
12. Aug 2005, 11:01
Rufname:
Wohnort: Bremen

AW: leeres UFO beim Öffnen - AW: leeres UFO beim Öffnen

Nach oben
       

probier das mal beim unterfomular, da gibt es auch ein "beim Öffnen"

Im Formularentwurf mit rechtsklick auf das unterformular, da dann auf daten/datensatzherkunft. Hier kannst du in jedes feld klicken und dann F1 dann wird dir ausführlich erläutert wie du diese Funktion ansprechen kannst (wenn die hilfe installiert ist).

_________________
Wenn ich groß bin möchte ich mal Mod werden
jens05
Moderator


Verfasst am:
12. Aug 2005, 11:17
Rufname:
Wohnort: ~~~~~

AW: leeres UFO beim Öffnen - AW: leeres UFO beim Öffnen

Nach oben
       

Hallo Julie,
Code:
    Me!tbl_5000UFO.Form.RecordSource = ""
Allerdings wird dir das Ufo in den Textfelder dann ein #Fehler anzeigen.

Was ist eigentlich das konkrete Ziel, was meinst mit "Daten vom letzten mal"?

_________________
mfg jens05 Wink
11.auflage
dank des Forums schon sehr viel dazugelernt


Verfasst am:
12. Aug 2005, 11:52
Rufname:

AW: leeres UFO beim Öffnen - AW: leeres UFO beim Öffnen

Nach oben
       

@flame: also wenn ich das jetzt beim UFo eingeben, zeigt er mir statt dem UFo nur noch eine weiße Fläche an...und das mit der Datensatzherkunft hab ich leider nicht so ganz verstanden.Was kann ich damit denn bezwecken, wenn ich mir die Abfrage dann noch einmal anschauen kann?

@jens: also es handelt sich hier um ein Suchformular ( das von Dalmatinchen) und ich möchte halt ganz gerne, dass das UFO, in dem die Ergebnisse angezeigt werden, beim Öffnen des Hauptformulares keine Daten enthält, sondern dann erst Daten anzeigt, wenn ich z.B. einen bestimmten Suchbegriff eingebe. ich möchte halt nicht, dass man immer sieht, was derjenige vor einem gesucht hat, ist ja auch eventuell ein bisschen verwirrend...
Flame
Pisa Verantwortlicher


Verfasst am:
12. Aug 2005, 11:56
Rufname:
Wohnort: Bremen

AW: leeres UFO beim Öffnen - AW: leeres UFO beim Öffnen

Nach oben
       

ja, beim öffnen ist alles weiß, das wolltest du doch auch so oder möchtest du alle datensätze anzeigen?

Sobald du die suchkriterien aber veränderst sollten wieder Datensätze angezeigt werden.


Also beim öffnen
Code:
    Me!unterform.Form.RecordSource = ""
dann nach eingabe in suchfeld
Code:
    Me!unterform.Form.RecordSource = "SELECT * FROM tbl " & _
                                     "WHERE suchkriterium =" & Me!eingabefeld
oder nicht???
_________________
Wenn ich groß bin möchte ich mal Mod werden
11.auflage
dank des Forums schon sehr viel dazugelernt


Verfasst am:
12. Aug 2005, 12:43
Rufname:


AW: leeres UFO beim Öffnen - AW: leeres UFO beim Öffnen

Nach oben
       

danke für die Tipps!Jetzt klappt alles:)
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Access Tabellen & Abfragen: N:M - Beziehung in UFO darstellen 29 Palmsbeach 721 23. Nov 2012, 19:45
MissPh! N:M - Beziehung in UFO darstellen
Keine neuen Beiträge Access Tabellen & Abfragen: Abfrage -> Ufo -> Eintrag wählen -> Editieren 6 seym 173 10. Sep 2012, 23:18
seym Abfrage -> Ufo -> Eintrag wählen -> Editieren
Keine neuen Beiträge Access Tabellen & Abfragen: Hauptformular nach Datum im Ufo filtern 10 Nils13 516 08. Mai 2012, 11:22
KlausMz Hauptformular nach Datum im Ufo filtern
Keine neuen Beiträge Access Tabellen & Abfragen: Ein leeres Datum/Uhrzeit-Feld erfragen 3 Summerial 2416 14. Okt 2008, 13:08
Gast Ein leeres Datum/Uhrzeit-Feld erfragen
Keine neuen Beiträge Access Tabellen & Abfragen: Daten aus Tabelle in UFO anzeigen lassen 3 Jondalar 586 25. Feb 2008, 09:37
Marmeladenglas Daten aus Tabelle in UFO anzeigen lassen
Keine neuen Beiträge Access Tabellen & Abfragen: Tabelle/Abfrage beim Öffnen fast so groß wie Bildschirm 3 Der_Andi1984 791 23. Feb 2008, 20:26
KlausMz Tabelle/Abfrage beim Öffnen fast so groß wie Bildschirm
Keine neuen Beiträge Access Tabellen & Abfragen: Leeres Datenblatt 1 Manuel18 582 27. Aug 2007, 16:13
rita2008 Leeres Datenblatt
Keine neuen Beiträge Access Tabellen & Abfragen: Passwort zum Öffnen der Datenbank 2 awgoelle 481 16. Aug 2007, 16:52
awgoelle Passwort zum Öffnen der Datenbank
Keine neuen Beiträge Access Tabellen & Abfragen: Probleme beim Öffnen verlinkter Tabellen 1 Stay 477 18. Apr 2007, 19:40
steffen0815 Probleme beim Öffnen verlinkter Tabellen
Keine neuen Beiträge Access Tabellen & Abfragen: Tabelle hat beim Öffnen immer gleiche Größe?! 4 ladau66 910 10. Mai 2006, 10:37
Gast Tabelle hat beim Öffnen immer gleiche Größe?!
Keine neuen Beiträge Access Tabellen & Abfragen: Leeres Datumfeld abfragen 1 Gast 1182 16. Apr 2006, 20:28
Gast Leeres Datumfeld abfragen
Keine neuen Beiträge Access Tabellen & Abfragen: Fehlermeldung beim Öffnen der Berichte 3 Freund 584 02. März 2006, 21:08
jens05 Fehlermeldung beim Öffnen der Berichte
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Expression Web