Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Doppelte Einträge Prüfung mit Bedingung
zurück: Trendlinie verbessern weiter: Achsenbeschriftung Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
steffenhb
Im Profil kannst Du frei den Rang ändern


Verfasst am:
22. Feb 2011, 18:11
Rufname:
Wohnort: Bremen

Doppelte Einträge Prüfung mit Bedingung - Doppelte Einträge Prüfung mit Bedingung

Nach oben
       Version: Office 2003

Hallo,
ich bastel an diesem Problem nun 1 Woche und habe vieles im Internet dazu gefunden, aber nichts was auf meinen Fall 100% funktioniert.

Meine Tabelle sieht vereinfacht dargestellt so aus:

1__100__ FALSCH
2__ 200__ FALSCH
1__ 200__ WAHR
2__ 100__ WAHR
3__ 200__ FALSCH



Geprüft werden soll nun, welche Werte aus A in Spalte B nur mit 200, aber nicht mit 100 vertreten sind.

Versucht habe ich das:
=ZÄHLENWENN(A$1:A1;A1)>1

Excel wirft nun FALSCH oder WAHR aus. Falsch bedeutet, dass der Artikel nicht doppelt vorkommt. Mehr sagt das aber nicht aus.
Problem ist ja aber, dass diese Formel z.B. in Zeile 2 prüft, ob Wert 2 in Zelle A1:A2 mehr als einmal vorkommt, Ergebnis: FALSCH
In Zeile 4 prüft die Formel dann, ob Wert 2 in Zelle A1:A4 mehr als einmal vorkommt, Ergebnis: WAHR
Selektiere ich jetzt nach Wert 200 in Spalte B und Ergebnis FALSCH, dann taucht Wert 2 hier auf, obwohl er ja weiter unten doch noch mit Wert 100 in Spalte B vertreten ist.

Tja, und dieses Problem bekomme ich nicht gelöst.

Ich hoffe jemand hat eine Hilfestellung parat.

Vielen Dank schon mal.

Gruss,

Steffen
kurochan
angelesenes Halbwissen


Verfasst am:
22. Feb 2011, 19:21
Rufname:
Wohnort: bei Heidelberg

AW: Doppelte Einträge Prüfung mit Bedingung - AW: Doppelte Einträge Prüfung mit Bedingung

Nach oben
       Version: Office 2003

Hallo Steffen,

parat nicht. aber...

 ABCDEFG
11100  100200 
22200 111 
31200 211 
42100 301 
53200     
6       
7       
8       
9       
10       

ZelleFormel
E2=SUMMENPRODUKT((A$1:A$5=$D2)*(B$1:B$5=E$1))
F2=SUMMENPRODUKT((A$1:A$5=$D2)*(B$1:B$5=F$1))
E3=SUMMENPRODUKT((A$1:A$5=$D3)*(B$1:B$5=E$1))
F3=SUMMENPRODUKT((A$1:A$5=$D3)*(B$1:B$5=F$1))
E4=SUMMENPRODUKT((A$1:A$5=$D4)*(B$1:B$5=E$1))
F4=SUMMENPRODUKT((A$1:A$5=$D4)*(B$1:B$5=F$1))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Null in den Spalten E oder F bedeutet, die 100 oder 200 kommt für den WErt in Spalte D nicht vor.

_________________
Gruss
Eberhard / XL2000
steffenhb
Im Profil kannst Du frei den Rang ändern


Verfasst am:
23. Feb 2011, 10:31
Rufname:
Wohnort: Bremen


AW: Doppelte Einträge Prüfung mit Bedingung - AW: Doppelte Einträge Prüfung mit Bedingung

Nach oben
       Version: Office 2003

Ich glaube ich habe meine Frage gerade selbst gelöst...

Wenn ich zunächst nach Spalte B aufsteigend sortiere, dann erscheinen ja erst alle Werte mit 100 und dann die mit 200.
Somit gibt es keine Probleme mehr mit der Prüfung.

Trozdem danke. Manchmal muss man das Problem einfach mal vereinfacht formulieren, um selbst auf die Lösung zu kommen.
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Zählen ohne doppelte Werte 1 Holger42 18309 21. Feb 2006, 14:52
Alto Zählen ohne doppelte Werte
Keine neuen Beiträge Excel Formeln: doppelte wenn abfrage 5 unbelievable 7484 12. Feb 2006, 18:06
unbelievable doppelte wenn abfrage
Keine neuen Beiträge Excel Formeln: Bei erfüllter Bedingung Rückgabe von Nummern der größe nach 1 eberhard 700 14. Jan 2006, 02:16
fridgenep Bei erfüllter Bedingung Rückgabe von Nummern der größe nach
Keine neuen Beiträge Excel Formeln: hintergrundfarbe ändern wenn "wenn-dann" bedingung 3 danbert 2125 11. Dez 2005, 15:24
danbert hintergrundfarbe ändern wenn "wenn-dann" bedingung
Keine neuen Beiträge Excel Formeln: Bedingung für "Feld xy leer" bewirkt Eintrag in Fe 7 joker874 799 02. Dez 2005, 13:35
joker765 Bedingung für "Feld xy leer" bewirkt Eintrag in Fe
Keine neuen Beiträge Excel Formeln: doppelte Einträge löschen 10 neelix2001 996 18. Nov 2005, 14:34
Blaze doppelte Einträge löschen
Keine neuen Beiträge Excel Formeln: mehrfach bedingung mit formel in bedingter formatierung 3 tRiBUN 2526 23. Okt 2005, 19:41
ae mehrfach bedingung mit formel in bedingter formatierung
Keine neuen Beiträge Excel Formeln: Wenn Bedingung Zeile kopieren 1 marco1 1634 28. Jul 2005, 14:04
Günni Wenn Bedingung Zeile kopieren
Keine neuen Beiträge Excel Formeln: zellfarbe bei erfüllter bedingung ändern, aber in der formel 2 jode333999aa 5328 21. Jul 2005, 14:55
jode333999aa zellfarbe bei erfüllter bedingung ändern, aber in der formel
Keine neuen Beiträge Excel Formeln: Wenn Bedingung mit Datumsfelder 4 maristein 684 05. Jul 2005, 06:16
maristein Wenn Bedingung mit Datumsfelder
Keine neuen Beiträge Excel Formeln: Prüfung, ob Zelleninhalt numerisch ist?! 1 JimmyT 2630 22. Apr 2005, 11:55
Günni Prüfung, ob Zelleninhalt numerisch ist?!
Keine neuen Beiträge Excel Formeln: Aus Liste A nur jene Einträge anzeigen, die nicht in Liste B 8 landau666 687 30. März 2005, 15:16
fridgenep Aus Liste A nur jene Einträge anzeigen, die nicht in Liste B
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML Forum