Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Excel Datumsberechnungen
Gehe zu Seite 1, 2, 3  Weiter
zurück: Mehrseitige Rechnung in Excel weiter: Datensätze sortieren Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
baben
Gast


Verfasst am:
07. Jul 2005, 20:16
Rufname:

Excel Datumsberechnungen - Excel Datumsberechnungen

Nach oben
       

Hi@all,
ich stehe mal wieder wor einem Excel Problem!

Situation:
Schritt 1
Ich habe ein Anfagsdatum und ein Enddatum und möchte die Tage wissen!
So gelöst: =MITTELWERT(TAGE360(C8;D) Richtig?

Jetz möchte ich aber das Excel mir ausrechnet wie viele Tage in welchen Monat fallen. Es sind max. 6 Wochen, d.H. es können max. 3 Monate betroffen sein.

Also her mit den Tipps!

Vielen Dank im Vorraus!

ciao baben
ae
Mein Name ist Ente


Verfasst am:
07. Jul 2005, 20:29
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg


AW: Excel Datumsberechnungen - AW: Excel Datumsberechnungen

Nach oben
       

Hallo,

also zu deiner Differenzberechnung reicht auch aus zu sagen =Enddatum-Anfangsdatum

ggfs. +1 falls der erste tag mit gerechnet werden soll

Tabelle4
 ABC
1Anfangsdatum12.06.2005 
2Enddatum11.08.2005 
3   
4Tage60,00 
5   
6Davon  
7618 
8811 
9731 
10Gesamt60 
11   
12   
Formeln der Tabelle
B4 : =B2-B1
A7 : =MONAT(B1)
B7 : =MONATSENDE(B1;0)-B1
A8 : =MONAT(B2)
B8 : =TAG(B2)
A9 : =WENN(A8-A7&gt;1;A7+1;"")
B9 : =TAG(MONATSENDE(B2;-1))
B10 : =SUMME(B7:B9)
 


Code:
Formeln der Tabelle
B4 : =B2-B1
A7 : =MONAT(B1)
B7 : =MONATSENDE(B1;0)-B1
A8 : =MONAT(B2)
B8 : =TAG(B2)
A9 : =WENN(A8-A7>1;A7+1;"")
B9 : =TAG(MONATSENDE(B2;-1))
B10 : =SUMME(B7:B9)
 

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
Gast



Verfasst am:
07. Jul 2005, 21:03
Rufname:

AW: Excel Datumsberechnungen - AW: Excel Datumsberechnungen

Nach oben
       

Hallo, danke für die schnelle Antwort! Das Problem gut erkannt aber leider noch nicht endgültig beseitigt. Das ist eine Nummer zu groß für mich.

Trotzdem respekt vor der schnellen und guten Antwort!!!!

Leider bin ich zu doof um die Tabelle hier einzufügen, deshalb der Versuch das per Hand zu erklären.

Tabelle:

Name Anreise Abreise Tage Juni Juli August
Anton 27.06.05 18.08.05
Berta 02.07.05 30.08.05
Cesar 01.07.05 15.07.05
Dussel 27.06.05 15.07.05

So sieht die Tabelle in etwa aus, wenn du mir da vielleicht nochmal helfen könntest! Wink

Vielen Dank im Vorraus
ae
Mein Name ist Ente


Verfasst am:
07. Jul 2005, 21:11
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Excel Datumsberechnungen - AW: Excel Datumsberechnungen

Nach oben
       

Hallo,

machs mal so:

Tabelle4
 ABCDEF
14   Monat AMonat BMonat C
15Anton27.06.200518.08.200531831
16Berta02.07.200530.08.20052930 
17Cesar01.07.200515.07.20053015 
18Dussel27.06.200515.07.2005315 
Formeln der Tabelle
D15 : =MONATSENDE(B15;0)-B15
E15 : =TAG(C15)
F15 : =WENN(MONAT(C15)-MONAT(B15)&gt;1;TAG(MONATSENDE(C15;-1));"")
D16 : =MONATSENDE(B16;0)-B16
E16 : =TAG(C16)
F16 : =WENN(MONAT(C16)-MONAT(B16)&gt;1;TAG(MONATSENDE(C16;-1));"")
D17 : =MONATSENDE(B17;0)-B17
E17 : =TAG(C17)
F17 : =WENN(MONAT(C17)-MONAT(B17)&gt;1;TAG(MONATSENDE(C17;-1));"")
D18 : =MONATSENDE(B18;0)-B18
E18 : =TAG(C18)
F18 : =WENN(MONAT(C18)-MONAT(B18)&gt;1;TAG(MONATSENDE(C18;-1));"")
 


Code:
Formeln der Tabelle
D15 : =MONATSENDE(B15;0)-B15
E15 : =TAG(C15)
F15 : =WENN(MONAT(C15)-MONAT(B15)>1;TAG(MONATSENDE(C15;-1));"")
D16 : =MONATSENDE(B16;0)-B16
E16 : =TAG(C16)
F16 : =WENN(MONAT(C16)-MONAT(B16)>1;TAG(MONATSENDE(C16;-1));"")
D17 : =MONATSENDE(B17;0)-B17
E17 : =TAG(C17)
F17 : =WENN(MONAT(C17)-MONAT(B17)>1;TAG(MONATSENDE(C17;-1));"")
D18 : =MONATSENDE(B18;0)-B18
E18 : =TAG(C18)
F18 : =WENN(MONAT(C18)-MONAT(B18)>1;TAG(MONATSENDE(C18;-1));"")
 

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
baben
Gast


Verfasst am:
08. Jul 2005, 08:36
Rufname:


AW: Excel Datumsberechnungen - AW: Excel Datumsberechnungen

Nach oben
       

Hallo Andreas, dachte zuerst Perfekt jetzt funktioniert es! Aber, in deinem Beispiel ist in Zeile 15 der Monat B=August, in Zeile 17 ist der Monat B=Juli. Wenn du oder irgenwer sonst noch einen Tipp hätte, so wäre ich sehr dankbar!

ciao baben
ae
Mein Name ist Ente


Verfasst am:
08. Jul 2005, 08:43
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Excel Datumsberechnungen - AW: Excel Datumsberechnungen

Nach oben
       

Hallo baben,
darum habe ich bei deinem Tabellenaufbau bewusst Monat A B und C gewählt -
Mein A Abgriff ist immer der laufende Monat von Start ausgesehen
B ist immer der Monat des Enddatum und C falls es über mehr als 2 Monate geht
Wie konkret willst du denn das die Auswertung aussehen soll ?
Ich hab das eben so aufgemacht, weil es so mit recht einfachen Formeln zu bauen ist und easy nach unten kopiert wird
Wobei mir gerade aufgefallen ist, wenn alles in einem Monat ist hab ich nicht abgegriffen - das wäre aber leicht machbar

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
ae
Mein Name ist Ente


Verfasst am:
08. Jul 2005, 08:53
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Excel Datumsberechnungen - AW: Excel Datumsberechnungen

Nach oben
       

Hier mal die abgeänderte Version

Tabelle1
 ABCDEF
14 Monat AMonat BMonat C
15Anton27.06.200518.08.200531831
16Berta02.07.200530.08.20052930 
17Cesar01.07.200515.07.200514  
18Dussel27.06.200515.07.2005315 
Formeln der Tabelle
D15 : =WENN(MONAT(B15)=MONAT(C15);TAG(C15)-TAG(B15);MONATSENDE(B15;0)-B15)
E15 : =WENN(MONAT(C15)=MONAT(B15);"";TAG(C15))
F15 : =WENN(MONAT(C15)-MONAT(B15)&gt;1;TAG(MONATSENDE(C15;-1));"")
D16 : =WENN(MONAT(B16)=MONAT(C16);TAG(C16)-TAG(B16);MONATSENDE(B16;0)-B16)
E16 : =WENN(MONAT(C16)=MONAT(B16);"";TAG(C16))
F16 : =WENN(MONAT(C16)-MONAT(B16)&gt;1;TAG(MONATSENDE(C16;-1));"")
D17 : =WENN(MONAT(B17)=MONAT(C17);TAG(C17)-TAG(B17);MONATSENDE(B17;0)-B17)
E17 : =WENN(MONAT(C17)=MONAT(B17);"";TAG(C17))
F17 : =WENN(MONAT(C17)-MONAT(B17)&gt;1;TAG(MONATSENDE(C17;-1));"")
D18 : =WENN(MONAT(B18)=MONAT(C18);TAG(C18)-TAG(B18);MONATSENDE(B18;0)-B18)
E18 : =WENN(MONAT(C18)=MONAT(B18);"";TAG(C18))
F18 : =WENN(MONAT(C18)-MONAT(B18)&gt;1;TAG(MONATSENDE(C18;-1));"")
 



Code:
Formeln der Tabelle
D15 : =WENN(MONAT(B15)=MONAT(C15);TAG(C15)-TAG(B15);MONATSENDE(B15;0)-B15)
E15 : =WENN(MONAT(C15)=MONAT(B15);"";TAG(C15))
F15 : =WENN(MONAT(C15)-MONAT(B15)>1;TAG(MONATSENDE(C15;-1));"")
D16 : =WENN(MONAT(B16)=MONAT(C16);TAG(C16)-TAG(B16);MONATSENDE(B16;0)-B16)
E16 : =WENN(MONAT(C16)=MONAT(B16);"";TAG(C16))
F16 : =WENN(MONAT(C16)-MONAT(B16)>1;TAG(MONATSENDE(C16;-1));"")
D17 : =WENN(MONAT(B17)=MONAT(C17);TAG(C17)-TAG(B17);MONATSENDE(B17;0)-B17)
E17 : =WENN(MONAT(C17)=MONAT(B17);"";TAG(C17))
F17 : =WENN(MONAT(C17)-MONAT(B17)>1;TAG(MONATSENDE(C17;-1));"")
D18 : =WENN(MONAT(B18)=MONAT(C18);TAG(C18)-TAG(B18);MONATSENDE(B18;0)-B18)
E18 : =WENN(MONAT(C18)=MONAT(B18);"";TAG(C18))
F18 : =WENN(MONAT(C18)-MONAT(B18)>1;TAG(MONATSENDE(C18;-1));"")
 

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
baben
Gast


Verfasst am:
08. Jul 2005, 08:58
Rufname:

AW: Excel Datumsberechnungen - AW: Excel Datumsberechnungen

Nach oben
       

Werde das jetzt mal probieren, so ähnlich habe ich es schon versucht. Es soll halt am Ende rauskommen wie viele Tage im Juni, wie viele im Juli etc. angefallen sind.

Ich geb bescheid wie der zwischenstand ist.

ciao baben

P.S. Sitze derzeit in Thüringen, komme aber ursprünglich aus der Nähe von Lüneburg. Wie klein das Internet die Welt doch macht! Wink
ae
Mein Name ist Ente


Verfasst am:
08. Jul 2005, 09:03
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Excel Datumsberechnungen - AW: Excel Datumsberechnungen

Nach oben
       

Hallo,

Zitat:
P.S. Sitze derzeit in Thüringen, komme aber ursprünglich aus der Nähe von Lüneburg. Wie klein das Internet die Welt doch macht!


Siehste - und ich bin Schwabe und lebe seit ca 20 Jahren in Norddt. Exil - Twisted Evil

Wobei LG eine liebgewordene 2. Heimat ist


Zum Aufbau deiner Tabelle-
Das Problem ist, wenn in den Überschriften wo bei mir Monat A B C steht die Monate stehen müsste man die wohl fürs ganze Jahr rüber ziehen -
Ist das so geplant oder gewollt ?
Wenn ja müsste man den Formelaufbau nochmals komplett überdenken

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
ae
Mein Name ist Ente


Verfasst am:
08. Jul 2005, 09:11
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Excel Datumsberechnungen - AW: Excel Datumsberechnungen

Nach oben
       

Hallo,

wie wäre denn der Aufbau in dieser Art ?
Wobei ich noch keinen Schimmer habe wie dann der Lösungsansatz aussehen muss-
Wäre einfach wichtig bevor man losbastelt den konkreten Aufbau und die konkrete Problemstellung zu kennen
Bei diesem Aufbau ist natürlich der Jahreswechsel nicht mit abgegriffen

Tabelle2
 ABCDEFGHIJKLMNO
1   Monate           
2Namevonbis123456789101112
3Anton27.06.200518.08.2005            
4Berta02.07.200530.08.2005            
5Cesar01.07.200515.07.2005            
6Dussel27.06.200515.07.2005            
 

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
baben
Gast


Verfasst am:
08. Jul 2005, 09:14
Rufname:

AW: Excel Datumsberechnungen - AW: Excel Datumsberechnungen

Nach oben
       

Hi, pro Tabelle sind immer nur 3 Monate abzudecken, insofern sind die Überschriften egal.

Das Problem besteht aber leider immer noc.
In Zeile 15 ist Monat A=Juni, Monta B=Juli und Monat C=August.
In Zeile 16 ist Monat A=Juli, Monta B=August. usw.

Es muß halt so sein, dass Monat A= immer Juli, Monat B= immer Juli etc. ist.

So habe ich mir das mal überlegt, funktioniert nur leider nicht! ;-(

Wobei in E13 als Hilfe die Monatstage für Monat B eingetragen sind.

Für den Monat B
=WENN(MONAT(C15)-MONAT(B15)=1;TAG(MONATSENDE(C15;-1));WENN(MONAT(C15)-MONAT(B15)=2;E13;""))

Für den Monat C
=bin ich noch am überlegen

Was meinst du?
=
ae
Mein Name ist Ente


Verfasst am:
08. Jul 2005, 09:22
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Excel Datumsberechnungen - AW: Excel Datumsberechnungen

Nach oben
       

Hallo,
ist denn gewährleistet, daß in der Realität der Startmonat immer der selbe ist ?
In deinem geposteten Bsp. ist das ja nicht der Fall - siehe Anton und Dussel Beginn Juni die anderen Juli

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
Gast



Verfasst am:
08. Jul 2005, 09:28
Rufname:

AW: Excel Datumsberechnungen - AW: Excel Datumsberechnungen

Nach oben
       

Stimmt, so geht das nicht, der Startmonat ist nicht immer Monat A.

Für den Monat C habe ich das so versucht:

=WENN(MONAT(C15)=I1;TAG(C15);"")

Das klappt schonmal!
ae
Mein Name ist Ente


Verfasst am:
08. Jul 2005, 09:35
Rufname: Andreas
Wohnort: Reppenstedt bei Lüneburg

AW: Excel Datumsberechnungen - AW: Excel Datumsberechnungen

Nach oben
       

Hallo,
gilt das ganze denn immer nur für einen bestimmten Zeitraum des Jahres (also eine Eingrenzung der Monate) oder passiert das permanent im Laufe des Jahres -
also das zB nach Dussel irgendwann Emil im Oktober und November vorkommt?

_________________
Gruß
Andreas E
------
Oh Mann, ich fühl mich heute wie =DATEDIF(DATUM(1961;6;12);HEUTE();"y") Jahre alt
Gast



Verfasst am:
08. Jul 2005, 09:50
Rufname:


AW: Excel Datumsberechnungen - AW: Excel Datumsberechnungen

Nach oben
       

Immer eingegrenzt!

Es gibt jeden Monat eine neue Tabelle in der dann der laufende Monat, der vorherige Monat und der kommende Monat erfasst werden. Da die Abrechnung immer schon 2 bis 3 Tage vor dem Monatsende erfolgt muss es in der Tabelle möglich sein auch den Vormaonat einzutragen um diese Tage dann nachzumelden.

Derzeitiger Stand:
Monat A:=WENN(MONAT(B15)=$G$1;MONATSENDE(B15;0)-B15+1;"")

Das funktioniert glaube ich soweit!

Monat B:=WENN(MONAT(C15)-MONAT(B15)=1;TAG(MONATSENDE(c15;-1)-c15);WENN(MONAT(c15)-MONAT(c15)=2;E13;""))

Das funktioniert nicht! Wenn C15-B15=2 funktioniert es, sonst leider nicht!

Monat C:=WENN(MONAT(C15)=F12;TAG(C15);"")

Wobei in F 12 der jewilige Monat eingetragen wurde, hier die 8!

Das funktioniert solange die An und Abreise nicht in den August fallen! Wenn beides im August berechnet er immer die ganzen Tage im August!
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Gehe zu Seite 1, 2, 3  Weiter
Diese Seite Freunden empfehlen

Seite 1 von 3
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Hilfe: kniffelige Datumsberechnungen möglich? 7 Schimmelpelz 332 24. Jun 2011, 08:44
Schimmelpelz kniffelige Datumsberechnungen möglich?
Keine neuen Beiträge Excel Auswertungen: Excel Datumsberechnungen 1 Ronar 562 10. Jul 2008, 11:18
Klaus-Dieter Excel Datumsberechnungen
Keine neuen Beiträge Excel Formeln: fehlerhafte Datumsberechnungen bei Excel 2007 7 csaf2376 2201 21. Okt 2007, 15:08
Thomas Ramel fehlerhafte Datumsberechnungen bei Excel 2007
Keine neuen Beiträge Excel Formeln: Datumsberechnungen mit Excel 2003 6 Moulder 8232 19. Nov 2006, 21:48
12und20zig Datumsberechnungen mit Excel 2003
Keine neuen Beiträge Excel Hilfe: Formel für Datumsberechnungen ? 1 kati48268 994 07. Dez 2005, 22:02
etron795 Formel für Datumsberechnungen ?
Keine neuen Beiträge Excel Hilfe: Der 30. bei Datumsberechnungen wird ignoriert 6 Huski 551 25. Aug 2005, 16:39
Quatro-fritz Der 30. bei Datumsberechnungen wird ignoriert
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft Project