Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Hyperlink mit OnMouseOver funktioniert einfach nicht!
zurück: Farbverläufe im Hintergrund weiter: Frames nachbearbeiten? Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Gast



Verfasst am:
06. Sep 2010, 16:57
Rufname:

Hyperlink mit OnMouseOver funktioniert einfach nicht! - Hyperlink mit OnMouseOver funktioniert einfach nicht!

Nach oben
       

allo zusammen. Ich möchte zuerst mitteilen, dass ich wirklich keine Ahnung von HTML & CSS habe.
Okay, nun zu meiner Frage: Ich versuche eine Website mit Dreamweaver CS4 zusammenzustellen. Damit diese schlussendlich auch nach was aussieht, habe ich mich also entschieden mit div tags usw zu arbeiten. Die Codes und was weiss ich habe ich überal ein bisschen zusammen getragen. Eine erste Probe ist geglückt.
Die Hyperlinks wurden erstellt, ich habe diese mit einer CSS-Regel bearbeitet. Also Farbe, position usw.
Ich habe aber ein Problem. Die Hyperlinks in der Navileiste sollen, wie auf jeder Homepage, einen onmouseover-effekt bekommen. Ganz Simpel. Der Text soll lediglich die Farbe ändern, wenn man mit drüber Maus drüber fährt. Alles klar, dachte ich, ich kan die Regel ja jeder Zeit ändern. Doch da gibts keine Möglichkeiten CSS-Hyperlinks zu erstellen. Okay, nicht so schlimm, ich kann dja einfach die Seiteneigenschaft festlegen.
Falsch gedacht. Denn obwohl man dort tatsächlich die gewünschte Einstellung vornehmen kann, so bleibt diese nicht gespeichert. Ich öffne also die Seiteneigenschaften wieder und alle Einstellungen sind weg... Softwareproblem? Nö, denn in einem neuen, leeren Dokument ist das kein Problem, das funktioniert. Okay, gut, es liegt an der Codierung. Google stundenlang durchforstet, diverse Codes kopiert ausprobiert, nichts. Wie kann es sein, dass so was simples nicht funktioniert.

Könnt Ihr mir weiterhelfen? Habe ich was im Code falsch gemacht? Denn wie gesagt, ich habe keine Ahnung.... Ich habe den Code mal angefügt:
Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">

<style type="text/css"> a.Navi:link, a.Navi:visited { font-size: 8pt; font-family: Verdana; text-decoration: None; border: Solid 1px #0000F0; background: #041C3C; color: #FFFFFF; padding: 2px } a.Navi:hover { font-size: 8pt; color: #933; font-family: Verdana; text-decoration: None; border: Solid 1px #FFD700; background: #041C3C; color: #FFFFFF; padding: 2px } </style> <a href="#" class="Navi">Javascript</a>

<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
<title>tenize.ch :: official page</title>

<link rel="stylesheet" type="text/css" media="screen" href="min/f=champions/css/screen.css">

<style type="text/css">
<!--
#Top {
   position:absolute;
   left:203px;
   top:13px;
   width:448px;
   height:103px;
   z-index:1;
   background-color: #9999CC;
}
#navigation {
   position:absolute;
   left:0px;
   top:0px;
   width:247px;
   height:600px;
   z-index:2;
   background-color: #CCCCCC;
}
#content {
   position:absolute;
   left:245px;
   top:0px;
   width:757px;
   height:600px;
   z-index:3;
   background: #00CCFF url(IMG_0804.JPG) 100% 100%;
   overflow: scroll;
   text-align: center;
}
#hauptlayer {
   position:relative;
   top:34px;
   width:501px;
   height:600px;
   z-index:4;
   left: 0;
   top: 71px;
}
#hauptlayer #navigation p {
   left: 200px;
   border-top: 20px none #333;
   border-right-style: none;
   border-bottom-style: none;
   border-left-style: none;
   border-right-color: #333;
   border-bottom-color: #333;
   border-left-color: #333;
   color: #000;
   font: 12px Arial, Helvetica, sans-serif;
}
#hauptlayer #navigation .navigation {
   position: absolute;
   width: 30px;
   left: 20px;
   font: 18px Arial, Helvetica, sans-serif;
   color: #869FB2;
   text-decoration: none;
}
#hauptlayer #navigation p br {
   background: #CCC;
   font-size: 14px;
   font-style: italic;
}
onemouseover {
}
#hauptlayer #content p {
   font-size: 36px;
   color: #869FB2;
}
-->
</style></head>

<body>
<div id="hauptlayer" style="width:1000px; margin-left:auto; margin-right:auto">
  <div id="navigation">
    <p>&nbsp;</p>
    <p>&nbsp;</p>
    <p>&nbsp;</p>
    <p>&nbsp;</p>
    <p><a class="navigation" href="index.html">HOME</a></p>
    <p><br>
      <a class="navigation" href="news.html">NEWS</a><br>
      <a class="navigation" href="fotos">BAND</a><br>
      <a class="navigation" href="band">MUSIC</a><br>
      <a class="navigation" href="konzerte">GOODIES</a><br>
      <a class="navigation" href="musik">GUESTBOOK</a><br>
      <a class="navigation" href="videos">LINKS</a><br>
      <a class="navigation" href="guestbook">CONTACT</a><br>
    <a class="navigation" href="impressum">IMPRESSUM</a></p>
    <p>&nbsp;</p>
    <p><br>
    </p>
<p>&nbsp;</p>
    <p>&nbsp;</p>
    <p><a href="news.html">NEWS</a></p>
 
<p>&nbsp;</p>
    <p>&copy; by tenize media 2010</p>
    <p>&nbsp; </p>
  </div>

<div id="content">
  <p>&nbsp;</p>
  <p>&nbsp;</p>
  <p>&nbsp;</p>
  <p>WELCOME</p>
</div>
</div>

</body>
</html>
html, body {margin:0; padding:0; width:100%; height:100%;
overflow:hidden;}
#hintergrund {position:absolute; z-index:1; width:100%; height:100%;}
#fest {position:absolute; top:25px; left:10px; width:150px; z-index:10;
border:1px solid #000; padding:10px;}
#scrollbar {position:absolute; width:100%; height:100%; top:0; left:0;
overflow-x: hidden:auto; z-index:2;}
.your-class {overflow-x: hidden}
#inhalt {padding:5px 300px 20px 200px;}


<?xml version="1.0" encoding="ISO-8859-1"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title>www.tutorials.de</title>
<style type="text/css">
<!--
* { margin: 0;
padding: 0;}

/* Höhen- und Breitenanpassung zu 100%; Scrollbar ausblenden */
body, html{
   width: 100%;
   height: 100%;
   overflow: hidden;
   color: #869FB3;
}

/* BG-Image auf unterste Ebene anordnen */
#bgImg{ position: absolute;
top: 0;
left: 0;
border: 0;
z-index: 1;}
/* Body-Dummy absolut über BG-Image legen; Scrollbar bei Bedarf einblenden */
#bodyDiv{ position: absolute;
top: 0;
left: 0;
z-index: 2;
overflow: auto;
width: 100%;
height: 100%;
text-align: center;}

//#hauptlayer #content p {
   font-size: 24px;
}
-->
</style>
</head>
<body>
<img id="bgImg" src="fender amps.jpg" width="100%" height="100%">

</div>

</body>
</html>

{maninweb: Hinweis: Google Analytics Tracker Code aus dem Code entfernt.}
womaninweb
(X)HTML und CSS Junkie


Verfasst am:
07. Sep 2010, 12:09
Rufname:
Wohnort: Aachen

AW: Hyperlink mit OnMouseOver funktioniert einfach nicht! - AW: Hyperlink mit OnMouseOver funktioniert einfach nicht!

Nach oben
       

Hallo Gast,

Zitat:
Ich möchte zuerst mitteilen, dass ich wirklich keine Ahnung von HTML & CSS habe.
Bei dieser Aussage kann ich dir nur dringend empfehlen, dir Grundkenntnisse in diesem Bereich anzueignen. Das kannst du hier im Forum in dem Workshop "Webdesign für Einsteiger" oder auf ziehenders-welt.de. Kein noch so tolles Programm der Welt kann mangelndes Wissen ersetzen. Es ist auch wenig hilfreich für dich, wenn ich dir sage, wo du etwas ändern muss, um zu dem gewünschten Ergebnis zu kommen, weil eben die Grundkenntnisse fehlen. Zudem würde es deinen Code auch nur verschlimmbessern.
Zitat:
Habe ich was im Code falsch gemacht?

Ja, und zwar eine ganze Menge. Das erste wäre der Doctype, der in deinem Code zweimal vorkommt. Im ersten fehlt der eröffnende <head>-Bereich, die CSS-Angaben sind munter überall verteilt, einschliesslich eines externen Stylesheets, das die index.html wahrscheinlich nie wiederfinden wird: min/f=champions/css/screen.css (Shock). Außerdem hast deinen Code großzügig mit zwei <body>s ausgestattet und zweimal das <html> geschlossen. Einige der CSS-Angaben scheinen völlig überflüssig zu sein und sollten gelöscht werden. Also müsste erstmal der gesamte Code aufgeräumt und in die richtige Form gebracht werden, bevor du in die Feintuningrunde gehst.

Gruß,
womaninweb

_________________
Der Vorteil der Klugheit besteht darin, dass man sich dumm stellen kann. Das Gegenteil ist schon schwieriger.
Kurt Tucholsky
chrisse
Im Profil kannst Du frei den Rang ändern


Verfasst am:
07. Sep 2010, 23:52
Rufname:


AW: Hyperlink mit OnMouseOver funktioniert einfach nicht! - AW: Hyperlink mit OnMouseOver funktioniert einfach nicht!

Nach oben
       

Tja da muss ich womaninweb wirklich recht geben - schau dir mal ein gutes Tutorial an, das kostet dich zwar ein bisschen Zeit, wird dir in Zukunft aber STUNDEN ersparen. Trotzdem will ich dir mal verraten, dass CSS sowas grundsätzlich schon kann, unter a:hover sollte in guten Tutorials deine Frage gelöst sein. Trotzdem wird das wahrscheinlich so lange nicht funktionieren, bis du wirklich an der richtigen Stelle im - gesäuberten - Code diese Änderung vornimmst. Also ran ans Tutorial.
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Frontpage Forum: Hyperlink Schaltflächen (Menue) mit Mouseover in DHTML 2 Monacus 604 03. Okt 2013, 15:55
Monacus Hyperlink Schaltflächen (Menue) mit Mouseover in DHTML
Keine neuen Beiträge Macromedia Dreamweaver Forum: Hyperlink in einem Bild der relativen Größe anpassen 0 squeedlyspooch 1485 14. Apr 2011, 11:15
squeedlyspooch Hyperlink in einem Bild der relativen Größe anpassen
Keine neuen Beiträge Frontpage Forum: Hyperlink auf einem Foto anbringen? 3 HDT 1485 20. Jan 2011, 15:37
womaninweb Hyperlink auf einem Foto anbringen?
Keine neuen Beiträge Frontpage Forum: Hyperlink zurück zur vorherigen Seite 11 1234 17807 20. Jul 2010, 12:47
womaninweb Hyperlink zurück zur vorherigen Seite
Keine neuen Beiträge MS Expression Web Forum: Browser-Vorschau funktioniert nicht richtig 1 Phin 1794 24. Dez 2009, 16:42
maninweb Browser-Vorschau funktioniert nicht richtig
Keine neuen Beiträge HTML & CSS Forum: css-Formatierung für <hr> funktioniert nicht im IE...? 6 Tobi Berlin 2799 12. Sep 2009, 12:50
Tobi Berlin css-Formatierung für <hr> funktioniert nicht im IE...?
Keine neuen Beiträge Frontpage Forum: Funktion 'Hyperlink einfügen' bei Firefox-Browser 3 hocileju 2301 20. Mai 2008, 21:07
maninweb Funktion 'Hyperlink einfügen' bei Firefox-Browser
Keine neuen Beiträge PHP & JavaScript Forum: Datenbank: Ändern funktioniert nicht 2 hamstermann 1094 10. Nov 2007, 21:03
hamstermann Datenbank: Ändern funktioniert nicht
Keine neuen Beiträge Frontpage Forum: Tabellen umändern funktioniert nicht 3 Zwackmix 895 06. Nov 2007, 20:54
maninweb Tabellen umändern funktioniert nicht
Keine neuen Beiträge HTML & CSS Forum: Hyperlink 1 wolter 1711 09. Sep 2007, 00:59
maninweb Hyperlink
Keine neuen Beiträge MS Expression Web Forum: Anzeige in Firefox funktioniert nicht 2 svenruppelt 3098 26. März 2007, 09:55
svenruppelt Anzeige in Firefox funktioniert nicht
Keine neuen Beiträge Frontpage Forum: Warum funktioniert folgender Hyperlink nicht? 2 metro2001 2190 14. Feb 2007, 12:43
metro2001 Warum funktioniert folgender Hyperlink nicht?
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: MS Frontpage