Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
bed. Formatierung: Wenn in Zeile X mindestens 1mal Zeichen Y
zurück: Teilergebnis 2 mit Bedingung weiter: String aus String Filtern Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Lew
Neuling


Verfasst am:
14. Apr 2010, 14:58
Rufname:

bed. Formatierung: Wenn in Zeile X mindestens 1mal Zeichen Y - bed. Formatierung: Wenn in Zeile X mindestens 1mal Zeichen Y

Nach oben
       Version: Office 2008 (Mac)

Hallo zusammen,

die SuFu im Forum und auch google, haben mich einer Lösung zwar nahe gebracht, aber leider bin ich noch nicht angekommen. Folgendes Problem:

* Ich habe eine Tabelle mit Spalten von A bis AU
* 350 Zeilen
* Ich möchte eine bedingte Formatierung einfügen, die sinngemäß fortlaufend pro Zeile folgendes prüft:

Wenn in Zeile X eine beliebige Spalte von A bis AU den Eintrag ? (der Eintrag ist tatsächlich ein Fragezeichen) hat, dann hinterlege die Zeile im Bereich A bis AU mit einer Farbe.

Wenn das Fragezeichen als Bedingung auf Grund von Kollisionen mit internen Bezeichnern schwierig sein sollte, kann an Stelle des "?" auch ein anderer Zellinhalt als Bedingung genutzt werden. Die Schwierigkeit besteht allgemein eher darin, dass die Bedingung für die bedingte Formatierung keiner Zelle eindeutig zugeordnet ist sondern eine ganze Zeile geparst werden muss.

Kennt jemand eine Lösung für dieses Problem?

Herzlichen Dank und viele Grüße,
Lew


Zuletzt bearbeitet von Lew am 14. Apr 2010, 15:10, insgesamt einmal bearbeitet
neopa
(kleingeschrieben!) oder Werner .. ,- ...


Verfasst am:
14. Apr 2010, 15:10
Rufname: Werner
Wohnort: zu Hause


AW: bed. Formatierung: Wenn in Zeile X mindestens 1mal Zeich - AW: bed. Formatierung: Wenn in Zeile X mindestens 1mal Zeich

Nach oben
       Version: Office 2008 (Mac)

Hallo Lew,

so z.B. (Format einfach übertragen):

 ABCDE
163 5  
174Text_214?17
185Text_315abn17

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A161. / Formel ist =ZÄHLENWENN(16:16;"?")>0Abc


Excel Jeanie Html

_________________
Gruß Werner
.. , - ...
Schlabbe
Excel-Verdreher


Verfasst am:
14. Apr 2010, 15:13
Rufname:

AW: bed. Formatierung: Wenn in Zeile X mindestens 1mal Zeich - AW: bed. Formatierung: Wenn in Zeile X mindestens 1mal Zeich

Nach oben
       Version: Office 2008 (Mac)

Hallo,

mal im kleineren Maßstab anhand des unten stehenden Bsp.:

Markiere von A59 an den gesamten Bereich -> Format -> Bedingte Formatierung -> Formel ist -> unten stehende Formel eingeben (auf $ Zeichen achten) -> ok


Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEF
59abc?de
60abcfde
61abcfde
62a?cfde

Zellebedingte Formatierung...Format
A591: =SUMMENPRODUKT(($A59:$F59="?")*1)>0abc


Hoffe das hilft.

MfG

_________________
Außerdem mögen Ökonomen keine Menschen.
Lew
Neuling


Verfasst am:
14. Apr 2010, 16:02
Rufname:


Re: AW: bed. Formatierung: Wenn in Zeile X mindestens 1mal Z - Re: AW: bed. Formatierung: Wenn in Zeile X mindestens 1mal Z

Nach oben
       Version: Office 2008 (Mac)

Schlabbe - 14. Apr 2010, 15:13 hat folgendes geschrieben:

Hoffe das hilft.

MfG


Das tut es. Herzlichen Dank, auch dir neopa, leider habe ich es mit deinem Ansatz nicht hinbekommen.
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Bedingte Formatierung 2 Qwertzuiop 1929 27. Jun 2005, 09:38
Qwertzuiop Bedingte Formatierung
Keine neuen Beiträge Excel Formeln: Bedingte Formatierung 10 Carina 2 1615 22. Jun 2005, 14:01
rainberg Bedingte Formatierung
Keine neuen Beiträge Excel Formeln: Zeile automatisch einfügen (ab Excel 97) 1 frechmops6 1799 16. Apr 2005, 22:22
Kuwe Zeile automatisch einfügen (ab Excel 97)
Keine neuen Beiträge Excel Formeln: Bedingte Formatierung ... 4 Marcus_bb 877 15. Apr 2005, 14:39
Marcus_bb Bedingte Formatierung ...
Keine neuen Beiträge Excel Formeln: Die 6 höchsten Werte aus einer Zeile mit 12 Werten aufsummie 18 ThomasF 2087 04. Apr 2005, 10:31
Arnim Die 6 höchsten Werte aus einer Zeile mit 12 Werten aufsummie
Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten. Excel Formeln: Excel Wenn oder bedingte Formatierung 3 Unregistered 12359 22. März 2005, 15:50
fridgenep Excel Wenn oder bedingte Formatierung
Keine neuen Beiträge Excel Formeln: Beding. Formatierung 2 Susan 1396 23. Feb 2005, 16:22
Susan Beding. Formatierung
Keine neuen Beiträge Excel Formeln: Bedingte Formatierung, verknüpft mit Datum 2 MichaelP 2643 11. Jan 2005, 10:48
MichaP Bedingte Formatierung, verknüpft mit Datum
Keine neuen Beiträge Excel Formeln: Eine Zeile am Ende mit einem CommandButton einfügen 0 chico24 884 11. Jan 2005, 10:29
chico24 Eine Zeile am Ende mit einem CommandButton einfügen
Keine neuen Beiträge Excel Formeln: Formatierung einer Stechkarte 6 Charly2 2115 08. Dez 2004, 14:22
Charly2 Formatierung einer Stechkarte
Keine neuen Beiträge Excel Formeln: Suchen eines Wertes in einer Zeile 1 AxelChris 1731 25. Nov 2004, 17:25
Patrick0705 Suchen eines Wertes in einer Zeile
Keine neuen Beiträge Excel Formeln: Wenn-Bedingung mit mehreren Spalten und Zeile 6 Lusie 2819 02. Nov 2004, 15:57
Lusie Wenn-Bedingung mit mehreren Spalten und Zeile
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML Forum