Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfeld
zurück: Ergebnis einer Formularabfrage in Excel exportieren weiter: leere textfelder? Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
gerold1985
Im Profil kannst Du frei den Rang ändern


Verfasst am:
01. Apr 2010, 14:10
Rufname:

Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfeld - Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfeld

Nach oben
       Version: Office 2003

Hi Accessprofis,

ich hab ein ziemlich komisches Problem. Auf einem Formular habe ich ein OLE-Objekt, das eine Bilddatei enthalten soll. Über einen Button wird folgender Code ausgeführt: (Filedialog zur Dateiauswahl)
Code:
Private Sub button1_Click()
    Dim docpfad As String
    Dim dlg As FileDialog
   
    Set dlg = Application.FileDialog(msoFileDialogOpen)
    dlg.Title = "Bitte Datei auswählen"
    dlg.InitialFileName = "C:\"
    dlg.ButtonName = "speichern"
    If dlg.show Then
        docpfad = dlg.selecteditems(1)
        Me.OBJEKTFELD.SourceDoc = docpfad
        Me.OBJEKTFELD.Action = acOLECreateEmbed
    End If
End Sub
Auf meinem Pc funktioniert alles hervorragend. Ich habe auch schon herrausbekommen, das .tif oder .jpg dateien nicht in diesem Objetkfeld als Bild angezeigt werden können, von daher hab ich mich für .bmp Dateien entschieden.
Auf meinem Pc kann ich irgendeine bmp-Datei auswählen über den Filedialog, und diese wird, so wie es sein soll, sofort im Objektfeld angezeigt.

Wenn allerdings ein Arbeitskollege versucht das Objektfeld zu füllen, wird nur der Dateiname + Datei-icon angezeigt, und das Bild erst über das klicken auf das Objektfeld angezeigt.

Ich bin ratlos, weil bei mir alles klappt wie es soll und bei anderen nicht...

hat jemand eine Idee?

Vielen Dank im Vorraus und viele Grüße

gerold
Sinister
Access-Programmierer


Verfasst am:
01. Apr 2010, 16:13
Rufname:


AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel - AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel

Nach oben
       Version: Office 2003

Hallo,

Meine Idee: du brauchst kein OLE-Objekt. Nehme ein "Bild", das Ding kann auch JPEGs anzeigen.

_________________
Warum einfach, wenn es kompliziert geht!?
gerold1985
Im Profil kannst Du frei den Rang ändern


Verfasst am:
06. Apr 2010, 10:58
Rufname:

AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel - AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel

Nach oben
       Version: Office 2003

Danke für die schnelle Antwort!

Leider wird das Bild aber nachher in einer Tabelle gespeichert. Von daher muss das Feld gebunden sein, und das geht leider bei "Bild"-Objekten nicht...
Sinister
Access-Programmierer


Verfasst am:
06. Apr 2010, 12:42
Rufname:

AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel - AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel

Nach oben
       Version: Office 2003

Für die Benutzer ist es ziemlich egal, ob die Bilder in der .mdb-Datei gespeichert sind oder nicht. Es sei denn, du hast ausschlaggebende Gründe...
_________________
Warum einfach, wenn es kompliziert geht!?
Gast



Verfasst am:
06. Apr 2010, 12:48
Rufname:


AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel - AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel

Nach oben
       Version: Office 2003

Die Tabelle ist sogar ODBC-Verknüpft und die Bilder werden auf einen Oracle Server übertragen... doch ob die Bilder nun in der Access-DB, auf Oracle oder einfach nur verknüpft sind ändert leider nichts an dem Problem, das auf anderen PCs nur das Icon der Datei, und nicht das Bild selbst angezeigt wird.

Zitat:
Für die Benutzer ist es ziemlich egal, ob die Bilder in der .mdb-Datei gespeichert sind oder nicht. Es sei denn, du hast ausschlaggebende Gründe...


Ich denke die hab ich.
Bei einer Verknüpfung muss der User Zugriff auf den Pfad haben. Dies darf er aber nicht, da er sonst die Datei manipulieren könnte...
In der Datenbank darf die Bilddatei auch nur "gelesen" werden, und nicht verändert.(Mit einer Ausnahme, der Admin der für die Datenpflege zuständig ist)
gerold1985
Im Profil kannst Du frei den Rang ändern


Verfasst am:
06. Apr 2010, 12:50
Rufname:

AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel - AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel

Nach oben
       Version: Office 2003

sorry, war nicht eingeloggt.
Sinister
Access-Programmierer


Verfasst am:
06. Apr 2010, 15:15
Rufname:

AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel - AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel

Nach oben
       Version: Office 2003

Die Gründe hast du. Versuche weitere Vorschläge von MS.
Alternativ kannst du die Bilder als BLOBs speichern, dann könntest du die Bilder sowohl in einer Tabelle speichern, als auch mit dem Bild-Steuerelement anzeigen.

_________________
Warum einfach, wenn es kompliziert geht!?
gerold1985
Im Profil kannst Du frei den Rang ändern


Verfasst am:
06. Apr 2010, 15:46
Rufname:

AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel - AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel

Nach oben
       Version: Office 2003

die Bilder sind als BLOB gespeichert... ich kann sie ja auch problemlos als Bild sehen...
Wenn ich die Bilder (über meinen Pc) in der Tabelle gespeichert habe, kann der Kollege sie ja auch sehen...

das Problem ist nur, wenn der Kollege versucht sie zu speichern, wird nur der Dateiname angezeigt. (z.b Bild1.bmp) + Icon

ich hab keine Idee woran das liegen kann....
Sinister
Access-Programmierer


Verfasst am:
06. Apr 2010, 16:08
Rufname:

Re: AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objek - Re: AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objek

Nach oben
       Version: Office 2003

Anonymous - 06. Apr 2010, 12:48 hat folgendes geschrieben:
In der Datenbank darf die Bilddatei auch nur "gelesen" werden...

gerold1985 - 06. Apr 2010, 15:46 hat folgendes geschrieben:
...das Problem ist nur, wenn der Kollege versucht sie zu speichern...

Widerspruch, oder?
gerold1985 hat folgendes geschrieben:
ich hab keine Idee woran das liegen kann....

Ich dachte, das wäre unter dem Link im vorigen Post beschrieben. Ist zwar eine automatische Übersetzung, aber Originalsprache (Englisch) ist auch verfügbar.

_________________
Warum einfach, wenn es kompliziert geht!?
gerold1985
Im Profil kannst Du frei den Rang ändern


Verfasst am:
06. Apr 2010, 16:23
Rufname:

AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel - AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel

Nach oben
       Version: Office 2003

Danke für die schnelle Antwort.

Nein, kein Widerspruch... der Kollege ist jener, der für die Datenpflege verantwortlich ist. Dieser hat Berechtigung Bilder zu löschen und hinzuzufügen.

(Das Bilder von "normalen" Usern nur gelesen werden dürfen hatte ich nur erwähnt, um zu erklären wieso keine Bild-Verknüpfung benutzt werden darf)

Ich habe mir die Beispiel-Datenbank aus deinem Link angeschaut.
Ich habe es in meiner Datenbank genauso gelöst, es funktioniert alles bei mir...

doch auch hier, das gleiche Problem beim Kollegen.. anstatt Bild wird nur Dateiname angezeigt, beim einfügen eines neuen Bildes.
Ich hatte schonmal gedacht es hängt damit zusammen, das er ein anderes Bildvorschau Programm in Windows benutzt, doch das macht eig. auch keinen Sinn.
Sinister
Access-Programmierer


Verfasst am:
06. Apr 2010, 16:42
Rufname:

AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel - AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel

Nach oben
       Version: Office 2003

gerold1985 hat folgendes geschrieben:
Ich habe mir die Beispiel-Datenbank aus deinem Link angeschaut.
Ich habe es in meiner Datenbank genauso gelöst, es funktioniert alles bei mir...

Widerspruch, im BLOB-Beispiel wird "Bild" benutzt.

_________________
Warum einfach, wenn es kompliziert geht!?
gerold1985
Im Profil kannst Du frei den Rang ändern


Verfasst am:
07. Apr 2010, 09:55
Rufname:

AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel - AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel

Nach oben
       Version: Office 2003

Vielen Dank nochmal für deine Hilfe.
ich hab mir die beispiel DB jetzt nochmal genauer angeschaut.

Leider kann ich die BLOB Variante nicht verwenden, da das Bild immer lokal zwischengespeichert wird. Somit wäre es für den User möglich das Bild für andere Zwecke zu verwenden.
Da es sich hier um wichtige Unterschriften handelt, darf dies nicht passieren.

Das Problem an dieser Stelle ist, das das "Bild" Objekt immer nur Bilder von der HDD aus anzeigen kann, jedoch nicht aus einer Tabelle....

schade, sah eigentlich richtig gut aus diese Methode....

dann hätte ich mir auch BMP spaaren können, und jpgs nehmen können...

naja jetzt steh ich wieder am Anfang Sad
Sinister
Access-Programmierer


Verfasst am:
07. Apr 2010, 10:03
Rufname:

AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel - AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objektfel

Nach oben
       Version: Office 2003

Und wie hältst du die Benutzer davon ab, Screenshots zu machen?
_________________
Warum einfach, wenn es kompliziert geht!?
gerold1985
Im Profil kannst Du frei den Rang ändern


Verfasst am:
07. Apr 2010, 10:30
Rufname:


Re: AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objek - Re: AW: Datei-icon wird angezeigt, anstatt Bild im OLE-Objek

Nach oben
       Version: Office 2003

Sinister - 07. Apr 2010, 10:03 hat folgendes geschrieben:
Und wie hältst du die Benutzer davon ab, Screenshots zu machen?


daran hab ich auch schon gedacht...
evtl. gibt es die Möglichkeit die "Druck"-Taste zu sperren...

Aber ansich du hast schon Recht, wenn jemand die Absicht hat die Bilder zu kopieren, lässt sich das wohl kaum verhindern.

dann ist vielleicht die BLOB-Methode doch am besten.

Vielen Dank nochmal.

Ich werd das dann doch so lösen

Gruß Gerold
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Access Tabellen & Abfragen: Kreuztabelle Summe wird nicht korrekt angezeigt 10 Miniwatu 108 13. März 2014, 13:51
Miniwatu Kreuztabelle Summe wird nicht korrekt angezeigt
Keine neuen Beiträge Access Tabellen & Abfragen: Abfrage/Function - nur ein Satz wird angezeigt 1 95ole 89 10. Mai 2013, 20:57
jens05 Abfrage/Function - nur ein Satz wird angezeigt
Keine neuen Beiträge Access Tabellen & Abfragen: Eingaben werden in der Tabelle nicht angezeigt. WARUM? 6 aschdibaschdi 98 13. Jan 2013, 17:21
JMalberg Eingaben werden in der Tabelle nicht angezeigt. WARUM?
Keine neuen Beiträge Access Tabellen & Abfragen: Beziehungen werden nicht angezeigt 1 Düsentrieb 99 05. Okt 2012, 09:53
KlausMz Beziehungen werden nicht angezeigt
Keine neuen Beiträge Access Tabellen & Abfragen: Beziehungen von Tabellen werden nicht angezeigt 1 Gast 400 13. Sep 2010, 12:35
AS55 Beziehungen von Tabellen werden nicht angezeigt
Keine neuen Beiträge Access Tabellen & Abfragen: OLE Objekte werden auf bestimmtem PC nicht angezeigt. 1 jojolino 912 10. Jun 2010, 09:26
Marina_Arida OLE Objekte werden auf bestimmtem PC nicht angezeigt.
Keine neuen Beiträge Access Tabellen & Abfragen: Datenmodellierung, Tabelle aufteilen? <- Jetzt mit Bild 4 Downtown09 909 03. Dez 2009, 11:53
Downtown09 Datenmodellierung, Tabelle aufteilen? <- Jetzt mit Bild
Keine neuen Beiträge Access Tabellen & Abfragen: Abfrage: leere Felder werden nicht angezeigt 2 Gast 907 25. März 2009, 18:25
Gast Abfrage: leere Felder werden nicht angezeigt
Keine neuen Beiträge Access Tabellen & Abfragen: Grösserer Wert aus 2 Spalten soll angezeigt werden 2 fizlipuzli 912 26. Jun 2008, 21:19
fizlipuzli Grösserer Wert aus 2 Spalten soll angezeigt werden
Keine neuen Beiträge Access Tabellen & Abfragen: Beziehungen von verknüpften Tabellen wird nicht angezeigt. 2 webtom 2950 06. Jun 2008, 08:37
Gast Beziehungen von verknüpften Tabellen wird nicht angezeigt.
Keine neuen Beiträge Access Tabellen & Abfragen: Datensätze mit leeren Feldern werden nicht angezeigt! 2 Ingo Neuhaus 392 26. Apr 2008, 17:05
Ingo Neuhaus Datensätze mit leeren Feldern werden nicht angezeigt!
Keine neuen Beiträge Access Tabellen & Abfragen: Bild im Formular anzeigen/ Je Datensatz ein eigenes Bild 1 Gast 607 20. März 2008, 17:49
Master_Chief Bild im Formular anzeigen/ Je Datensatz ein eigenes Bild
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Microsoft-Excel Diagramme