Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Text abhängig von der Formatierung
zurück: Tabelle nach mehreren Kriterien sortieren weiter: Umfrage mit Auswertung verknüpfen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Bernd d.R.
Excel: Geht so; VBA: es fängt an mehr zu werd


Verfasst am:
27. Jan 2010, 07:01
Rufname: Bernd
Wohnort: Braderup bei Niebüll (Dänische Grenze)

Text abhängig von der Formatierung - Text abhängig von der Formatierung

Nach oben
       Version: Office 2007

Moin;

Ich brauche in meiner Zelle J7 folgende Formel:

Code:
wenn Zelle D7 das Format % hat, dann "Prozent"; sonst "Euro"


Ich habe gadacht, so etwas hätte ich schon mal gemacht und geucht, doch leider Fehlanzeige.
Ihr wisst dafür bestimmt eine einfache Lösung.
Danke.
Ich stelle eine vergleichbare Frage auch in den Bereich VBA, weil es eventuell auch dort gehe.

Bernd

_________________
Für den Pessimisten ist jede Aufgabe ein Problem.
Für einen Optimisten ist jedes Problem eine Aufgabe.
< Peter >
Excel-Moderator, der immer noch dazu lernt


Verfasst am:
27. Jan 2010, 07:49
Rufname: Kommt darauf an wer ruft
Wohnort: Das schönste Land in Deutschlands Gaun


AW: Text abhängig von der Formatierung - AW: Text abhängig von der Formatierung

Nach oben
       Version: Office 2007

Hallo,

schau dir mal diesen Thread an:

http://www.office-loesung.de/fpost1239565.php#1239565

Den Beitrag im VBA-Forum mache ich dicht damit wir uns nicht verzetteln.

_________________
Gruß
Peter
Thomas Ramel
Microsoft Excel-MVP


Verfasst am:
27. Jan 2010, 08:00
Rufname: Thom
Wohnort: Glashütten - CH

AW: Text abhängig von der Formatierung - AW: Text abhängig von der Formatierung

Nach oben
       Version: Office 2007

Grüezi zusammen

Ich könnte mir auch folgendes vorstellen - das Ganze aktualisiert sich aber nur bei einer Neuberechnung, ähnlich wie auch die anderen Methoden.
Arbeitsblatt mit dem Namen 'Tabelle1'
 DE
75,00 €Euro
85%Prozent

ZelleFormel
E7=WENN(LINKS(ZELLE("Format";D7);1)="P";"Prozent";"Euro")
E8=WENN(LINKS(ZELLE("Format";D8);1)="P";"Prozent";"Euro")

_________________
Mit freundlichen Grüssen

Thomas Ramel
[Vista Ultimate SP-1 / xl2007 SP-2]
Bernd d.R.
Excel: Geht so; VBA: es fängt an mehr zu werd


Verfasst am:
27. Jan 2010, 08:15
Rufname: Bernd
Wohnort: Braderup bei Niebüll (Dänische Grenze)


AW: Text abhängig von der Formatierung - AW: Text abhängig von der Formatierung

Nach oben
       Version: Office 2007

Moin Peter, moin Thomas;

Ich habe mich für die Variante von Thomas entscheiden, da sie für mich einfach und verständlich ist.
Dabei habe ich nur die oberste Zeile benötigt.
Mit dem VBA-Code verändert sich die Formatierung in D7.
Entweder in € oder eben in %.
Hintergrund ist, dass die eine Einrichtung die Zuschlage für Nachtarbeit in % vom Stundenlohn zahlt, die andere eben als festen Eurobetrag und damit das für beide Einrichtungen funktioniert, musste ich also die Formatierung ändern können.
Bei der jetzign Formel ging es mir nur darum, in der Zelle J7 anzuzeigen, welche Formatierung gerade eingestellt ist, da die Zelle D7 (und viele andere) ja zunächst völlig leer ist.

Danke an Euch beide.
Das hat mir sehr geholfen.

Gruß

Bernd

_________________
Für den Pessimisten ist jede Aufgabe ein Problem.
Für einen Optimisten ist jedes Problem eine Aufgabe.
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Verknüpfung Tabellen / Formatierung 3 MarMi 1982 27. Jul 2005, 11:16
MarMi Verknüpfung Tabellen / Formatierung
Keine neuen Beiträge Excel Formeln: Text multiplizieren 3 tschwarz 1567 20. Jul 2005, 22:10
mumpel Text multiplizieren
Keine neuen Beiträge Excel Formeln: Bedingte Formatierung Teilbar 2 Kiamolo 2679 08. Jul 2005, 11:28
Kiamolo Bedingte Formatierung Teilbar
Keine neuen Beiträge Excel Formeln: Bedingte Formatierung mit Oder 3 Qwertzuiop 1781 27. Jun 2005, 14:36
Charlie Bedingte Formatierung mit Oder
Keine neuen Beiträge Excel Formeln: Wenn Dann Funktion einer dritten (Text-)Spalte 6 Gucci 1814 19. Apr 2005, 16:19
Hübi Wenn Dann Funktion einer dritten (Text-)Spalte
Keine neuen Beiträge Excel Formeln: Definierte Text- bzw. Zahlenbereiche aus Zelle auslesen 2 Diskus12 1669 14. März 2005, 17:30
Diskus12 Definierte Text- bzw. Zahlenbereiche aus Zelle auslesen
Keine neuen Beiträge Excel Formeln: Text aus Zelle (Tabellenblattname) als Formelbestandteil ? 4 Sid 2003 03. März 2005, 17:28
Gast Text aus Zelle (Tabellenblattname) als Formelbestandteil ?
Keine neuen Beiträge Excel Formeln: Text in Zelle ergibt #WERT beim Additionieren 2 Aloha 2091 19. Feb 2005, 10:36
Aloha Text in Zelle ergibt #WERT beim Additionieren
Keine neuen Beiträge Excel Formeln: Ersetzen von Zellen mit neuem Text 8 Baba 1071 18. Feb 2005, 20:21
AnBo Ersetzen von Zellen mit neuem Text
Keine neuen Beiträge Excel Formeln: Platzhalter für Formel in der bedingten Formatierung 2 fisler0815 5900 27. Jan 2005, 14:36
fisler0815 Platzhalter für Formel in der bedingten Formatierung
Keine neuen Beiträge Excel Formeln: 2 Daten miteinander vergleichen, wenn gleich dann Text 1 BennyII 4347 11. Dez 2004, 12:00
ae 2 Daten miteinander vergleichen, wenn gleich dann Text
Keine neuen Beiträge Excel Formeln: wenn funktion mit text 1 klausi 1574 09. Dez 2004, 15:17
klausi wenn funktion mit text
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML Editoren Forum