Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
SVERWEIS hilft diesmal leider nicht - Matrixverweis
zurück: Hilfe bei Fragebogenauswertungen --> richtige Formeln??? weiter: Gerade/ungerade Zahlen in einer WENN-Formel Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
jopre0502
Excel-Kenner (ohne VBA)


Verfasst am:
25. Jan 2010, 18:00
Rufname:

SVERWEIS hilft diesmal leider nicht - Matrixverweis - SVERWEIS hilft diesmal leider nicht - Matrixverweis

Nach oben
       Version: Office 2003

Hallo,

ich möchte eine Liste zur Weiterverarbeitung modifizieren. Leider komme ich mit SVERWEIS bzw. Darstellung als Pivot-Tabelle nicht weiter. Für Ansätze von Euch wäre ich sehr dankbar.


Die Quell-Tabelle sieht wie folgt aus:


ABCDE
1WZ-NrAnzahlF-Schritt 1F-Schritt 2F-Schritt 3
2WZ-13Drehen
3WZ-24DrehenFräsen
4WZ-31FräsenHärtenSchleifen
5WZ-44Schleifen
6WZ-52Fräsen



Nun soll auf einem neuen Worksheet die Liste wie folgt aussehen:



ABCDEFGH
1DrehenAnzahlFräsenAnzahlHärtenAnzahlSchleifenAnzahl
2WZ-13WZ-24WZ-31WZ-31
3WZ-24WZ-31WZ-44
4WZ-52



Mit Index und Vergleich Funktion komme ich auch nicht weiter, da z.B. Drehen öfters in einer Spalte vorkommt und ich zusätzlich ja in einer mehrspaltigen Matrix suche.

Für jeden Ansatz bin ich dankbar.


Beste Grüße,

Jonas


Zuletzt bearbeitet von jopre0502 am 26. Jan 2010, 09:30, insgesamt 2-mal bearbeitet
silex1
User mit gefährlichem Halbwissen


Verfasst am:
25. Jan 2010, 19:00
Rufname: steht im Ausweis


AW: SVERWEIS hilft diesmal leider nicht - Matrixverweis - AW: SVERWEIS hilft diesmal leider nicht - Matrixverweis

Nach oben
       Version: Office 2003

Hallo Jonas,

nimm mal bitte aus Deinem Beitrag die Leerstellen raus.!

Und wenn es mit INDEX und VERGLEICH nicht geht, dann evtl. die erste Tabelle mal wie die Zweite bauen!

Oder so, jedoch bei großen Datenmengen seeeeehhhhhhrrrrrr Speicherlastig!

 ABCDEFGHIJKLM
1WZ-NrAnzahlF-Schritt 1F-Schritt 2F-Schritt 3DrehenAnzahlFräsen Härten Schleifen 
2WZ-13Drehen  WZ-13WZ-24WZ-31WZ-31
3WZ-24DrehenFräsen WZ-24WZ-31#ZAHL!#ZAHL!WZ-44
4WZ-31FräsenHärtenSchleifen  WZ-52#ZAHL!#ZAHL!#ZAHL!#ZAHL!
5WZ-44Schleifen      #ZAHL!#ZAHL!#ZAHL!#ZAHL!
6WZ-52Fräsen      #ZAHL!#ZAHL!#ZAHL!#ZAHL!

ZelleFormel
F2{=WENN(ISTFEHLER(INDEX($A:$A;KKLEINSTE(WENN($C$2:$E$6=$F$1;ZEILE($2:$6));ZEILE($A1))));"";INDEX($A:$A;KKLEINSTE(WENN($C$2:$E$6=$F$1;ZEILE($2:$6));ZEILE($A1))))}
G2=WENN(ISTNV(SVERWEIS(F2;$A$2:$B$6;2;));"";SVERWEIS(F2;$A$2:$B$6;2;))
H2{=WENN(ISTFEHLER(INDEX($A:$A;KKLEINSTE(WENN($C$2:$E$6=$H$1;ZEILE($2:$6));ZEILE($A1))));"";INDEX($A:$A;KKLEINSTE(WENN($C$2:$E$6=$H$1;ZEILE($2:$6));ZEILE($A1))))}
I2=WENN(ISTNV(SVERWEIS(H2;$A$2:$B$6;2;));"";SVERWEIS(H2;$A$2:$B$6;2;))
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.

_________________
LG, René und seine 3 Gehirnzellen
Es ist gut, dass wir nicht in die Zukunft blicken können! Wir hätten sonst keine!
BoskoBiati
Im Profil kannst Du frei den Rang ändern


Verfasst am:
25. Jan 2010, 20:56
Rufname: Bosko

AW: SVERWEIS hilft diesmal leider nicht - Matrixverweis - AW: SVERWEIS hilft diesmal leider nicht - Matrixverweis

Nach oben
       Version: Office 2003

Hallo,

im Prinzip die gleiche Lösung, außer der Anzahl, die mit Summenprodukt lösbar wäre:
Tabelle3

 ABCDEFGH
1Drehen Anzahl Fräsen Anzahl Härten Anzahl Schleifen Anzahl
2WZ-1 3WZ-2 4WZ-3 1WZ-3 1
3WZ-2 4WZ-3 1  WZ-4 4
4  WZ-5 2    

Formeln der Tabelle
ZelleFormel
A2{=WENN(ISTFEHLER(INDEX(Tabelle2!$A$2:$A$6;KKLEINSTE(WENN(Tabelle2!$C$2:$E$6=Tabelle3!A$1;ZEILE(Tabelle2!$C$2:$E$6)-1);ZEILE($A1))));"";INDEX(Tabelle2!$A$2:$A$6;KKLEINSTE(WENN(Tabelle2!$C$2:$E$6=Tabelle3!A$1;ZEILE(Tabelle2!$C$2:$E$6)-1);ZEILE($A1))))}
B2=WENN(A2="";"";SUMMENPRODUKT((Tabelle2!$A$2:$A$6=Tabelle3!A2)*(Tabelle2!$B$2:$B$6)))
A3{=WENN(ISTFEHLER(INDEX(Tabelle2!$A$2:$A$6;KKLEINSTE(WENN(Tabelle2!$C$2:$E$6=Tabelle3!A$1;ZEILE(Tabelle2!$C$2:$E$6)-1);ZEILE($A2))));"";INDEX(Tabelle2!$A$2:$A$6;KKLEINSTE(WENN(Tabelle2!$C$2:$E$6=Tabelle3!A$1;ZEILE(Tabelle2!$C$2:$E$6)-1);ZEILE($A2))))}
B3=WENN(A3="";"";SUMMENPRODUKT((Tabelle2!$A$2:$A$6=Tabelle3!A3)*(Tabelle2!$B$2:$B$6)))
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Jeanie Html

Tabelle2

 ABCDE
1WZ-Nr Anzahl F-Schritt 1 F-Schritt 2 F-Schritt 3
2WZ-1 3Drehen   
3WZ-2 4Drehen Fräsen  
4WZ-3 1Fräsen Härten Schleifen
5WZ-4 4Schleifen   
6WZ-5 2Fräsen   


Excel Jeanie Html

_________________
Gruß

Bosko

Ich würde mich freuen zu erfahren, ob ich helfen konnte.
jopre0502
Excel-Kenner (ohne VBA)


Verfasst am:
26. Jan 2010, 16:37
Rufname:

AW: SVERWEIS hilft diesmal leider nicht - Matrixverweis - AW: SVERWEIS hilft diesmal leider nicht - Matrixverweis

Nach oben
       Version: Office 2003

Hallo ihr beiden,

das war ja schon mehr als ein Ansatz. Vielen Dank dafür.

Später werde ich eine Quelltabelle haben, in der ich nicht weiß, wieviel Zeilen belegt sind bzw. Einträge existieren. Allein bei der Index-Funktion komme ich dabei nicht mit A:A weiter.
Kann ich hier eine Liste erstellen, in der die Matrix gerade in einer Spalte bis zum letzten Eintrag in der definierten Liste geht? Oder wie müsste dann der Ansatz aussehen?

Beste Grüße,

Jonas
silex1
User mit gefährlichem Halbwissen


Verfasst am:
26. Jan 2010, 17:07
Rufname: steht im Ausweis


AW: SVERWEIS hilft diesmal leider nicht - Matrixverweis - AW: SVERWEIS hilft diesmal leider nicht - Matrixverweis

Nach oben
       Version: Office 2003

Hallo Jonas,

Also INDEX(A:A) besagt, dass es von Zeile 1 bis 65500 geht. Reicht nicht aus?

Die Formel arbeitet bis Zeile 500 zuverlässig. Berechnung dauert zwar etwas (1Min), je nach Computer, aber alles bestens. Im Normalfall kann diese auch bis Zeile 65500 erweitert werden, nur dann kannst Du erst mal ne Woche Urlaub machen. Very Happy

Wenn die Rechenzeit zu massiv wird, MUSS die Datentabelle angepasst werden. s.o.

_________________
LG, René und seine 3 Gehirnzellen
Es ist gut, dass wir nicht in die Zukunft blicken können! Wir hätten sonst keine!
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: NEU Bitte letzten Beitrag lesen... SVERWEIS 11 Kiamolo 1014 15. Feb 2010, 13:09
Kiamolo NEU Bitte letzten Beitrag lesen... SVERWEIS
Keine neuen Beiträge Excel Formeln: Rechnungsformular erstellen (SVerweis, WVerweis) 1 Susan 2997 14. Nov 2004, 19:42
ae Rechnungsformular erstellen (SVerweis, WVerweis)
Keine neuen Beiträge Excel Formeln: sverweis + darunterliegende Zeilen 7 L*R 3701 12. Nov 2004, 13:55
Arnim sverweis + darunterliegende Zeilen
Keine neuen Beiträge Excel Formeln: Problem mit sverweis 6 Yvi 648 11. Nov 2004, 16:38
ae Problem mit sverweis
Keine neuen Beiträge Excel Formeln: hat leider net funktioniert 6 bluesunkat 401 04. Nov 2004, 10:38
bluesunkat hat leider net funktioniert
Keine neuen Beiträge Excel Formeln: problem mit sverweis 7 alex81 1258 28. Okt 2004, 21:51
ae problem mit sverweis
Keine neuen Beiträge Excel Formeln: Koennte ein Sverweis sein *{=SUMME((MONAT(A1:A7)=E1)*(C1:C7) 2 Gast 1362 25. Okt 2004, 20:15
Gast Koennte ein Sverweis sein *{=SUMME((MONAT(A1:A7)=E1)*(C1:C7)
Keine neuen Beiträge Excel Formeln: Sverweis - nicht alphabetisch 5 Gast 2597 21. Okt 2004, 06:32
Andre1977 Sverweis - nicht alphabetisch
Keine neuen Beiträge Excel Formeln: Sverweis 4 Bernett22 1867 20. Okt 2004, 16:32
Bernett22 Sverweis
Keine neuen Beiträge Excel Formeln: Problem mit Sverweis 1 Bernett22 1868 19. Okt 2004, 09:32
tom_r Problem mit Sverweis
Keine neuen Beiträge Excel Formeln: Sverweis HELP!!!!!! 2 Black_Samurai 1773 30. Sep 2004, 18:12
Black_Samurai Sverweis HELP!!!!!!
Keine neuen Beiträge Excel Formeln: Verschachtelte WENN-Formel, VERGLEICH oder SVERWEIS? 14 Zokanta 4788 27. Sep 2004, 22:34
Zokanta Verschachtelte WENN-Formel, VERGLEICH oder SVERWEIS?
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: MS Frontpage