Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Wenn Dann Funktion einer dritten (Text-)Spalte
zurück: Auswertung der Häufigkeit von Werten in einer Spalte weiter: Leere Zeilen vom Kombinationsfeld löschen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Gucci
Excel Anfänger


Verfasst am:
18. Apr 2005, 23:14
Rufname:

Wenn Dann Funktion einer dritten (Text-)Spalte - Wenn Dann Funktion einer dritten (Text-)Spalte

Nach oben
       

Hallo Allerseits! Vorweg erstmal gesagt, dass ich ein Anfaenger bin und ueber jede Hilfe Dankbar!
Die Excel 2003

Mein Problem ist vielleicht gar nicht so schlimm wie es mir scheint, also:
In einer Art Arbeitsbuch-Tabelle habe ich eine Spalte die die Summe der Arbeitsstunden in den vorherhigen Spalten mit einem Stundenlohn zusammenrechnet. Davor habe ich eine Spalte angelegt wo man mit Hilfe einer Dropdown Liste (=Gueltigkeitspruefung) einzelne Mitarbeiter auswaehlen kann, die die nachstenenden Stunden abgearbeitet haben. Das Problem ist, dass es auch die Moeglichkeit gibt, das 2 bestimmte Mitarbeiter an der gleichen Sache im Team arbeiten, die Arbeitsstundenzahl also eigentlich dann x 2 genommen werden muss! In der Formel fuer die Summe der Arbeitsstunden sollte also irgendeine Verknuepfung/Vergleich mit der Dropdown Spalte der Mitarbeiter stehen, damit die Summe der Arbeitsstunden automatisch x 2 genommen wird sobald ich in der Dropdownliste die Auswahl "Teamarbeit (Person x und y)" treffe!... und genau daran scheitert es, weil ich nicht weiss mit welchen Funktionen ich das hinkriege bzw. es gibt schon Probleme bei der Erkennung des Textinhaltes und dem Einbinden in einer Formel!

Vielen Herzlichen Dank schon mal im Voraus
Hübi
Es gibt immer bessere Lösungen, als meine.


Verfasst am:
19. Apr 2005, 00:16
Rufname: Hübi (selten Herbert)
Wohnort: Strausberg


AW: Wenn Dann Funktion einer dritten (Text-)Spalte - AW: Wenn Dann Funktion einer dritten (Text-)Spalte

Nach oben
       

Hi Gucci,

aus deiner Schilderung leite ich mal diesen Vorschlag ab
 
 ABCD
1MitarbeiterProjektZeitZeit Total
2MüllerA02:0002:00
3MeierB14:0014:00
4Teamarbeit Müller und MeierC06:0012:00
Formeln der Tabelle
D2 : =WENN(ISTFEHLER(FINDEN("Teamarbeit";A2));C2;C2*2)
D3 : =WENN(ISTFEHLER(FINDEN("Teamarbeit";A3));C3;C3*2)
D4 : =WENN(ISTFEHLER(FINDEN("Teamarbeit";A4));C4;C4*2)
 

_________________
Gruß Hübi
[Tipps getestet mit Win XP Prof. SP-2, Office 2000 Premium SP3 / Office 2003 Prof. SP3 / Office Professional 2007 SP1]
Gucci
Excel Anfänger


Verfasst am:
19. Apr 2005, 10:01
Rufname:

AW: Wenn Dann Funktion einer dritten (Text-)Spalte - AW: Wenn Dann Funktion einer dritten (Text-)Spalte

Nach oben
       

Hallo Hübi!
Vielen Dank schon mal für die schnelle Antwort! Das hat mich schon sehr viel weiter gebracht! Ich hab deine Formel in die Tabelle eingesetzt und es klappt eigentlich ganz gut, bis darauf dass ich in der Tabelle nur eine Zeit Spalte haben darf nähmlich die "Zeit Total" Spalte! Ich hab versucht etwas an der Formel rumzufummeln um sie auf die endgültige Zeitspalte zu beziehen aber es gibt nur die Meldung "Formel Bezieht sich auf das Ergebnis". Gibt es eine Möglichkeit diesen kleinen Schönheitsfehler auch noch in den Griff zu kriegen? Ansonsten würde ich die 2. Zeitspalte irgendwo am A. der Welt verstecken so dass man sie gar nicht sieht und sie ausserhalb des Druckbereiches ist!

Vielen Dank nochmals, Grüße
fridgenep
Gast


Verfasst am:
19. Apr 2005, 10:03
Rufname:

AW: Wenn Dann Funktion einer dritten (Text-)Spalte - AW: Wenn Dann Funktion einer dritten (Text-)Spalte

Nach oben
       

Hallo,

rechter Mausklick auf den Spaltenkopf (Buchstabe), dann ausblenden. Reicht das?
Hübi
Es gibt immer bessere Lösungen, als meine.


Verfasst am:
19. Apr 2005, 10:31
Rufname: Hübi (selten Herbert)
Wohnort: Strausberg

AW: Wenn Dann Funktion einer dritten (Text-)Spalte - AW: Wenn Dann Funktion einer dritten (Text-)Spalte

Nach oben
       

Hi Gucci,

Zitat:
In der Formel fuer die Summe der Arbeitsstunden sollte also irgendeine Verknuepfung/Vergleich mit der Dropdown ...

Dann mach es so
 
 ABCDE
1MitarbeiterProjektZeit 1Zeit 2Zeit Total
2MüllerA02:0001:0003:00
3MeierB14:0001:0015:00
4Teamarbeit Müller und MeierC06:0002:0016:00
Formeln der Tabelle
E2 : =WENN(ISTFEHLER(FINDEN("Teamarbeit";A2));SUMME(C2:D2);SUMME(C2:D2)*2)
E3 : =WENN(ISTFEHLER(FINDEN("Teamarbeit";A3));SUMME(C3:D3);SUMME(C3:D3)*2)
E4 : =WENN(ISTFEHLER(FINDEN("Teamarbeit";A4));SUMME(C4:D4);SUMME(C4:D4)*2)
 

_________________
Gruß Hübi
[Tipps getestet mit Win XP Prof. SP-2, Office 2000 Premium SP3 / Office 2003 Prof. SP3 / Office Professional 2007 SP1]
Gucci
Excel Anfänger


Verfasst am:
19. Apr 2005, 14:47
Rufname:

AW: Wenn Dann Funktion einer dritten (Text-)Spalte - AW: Wenn Dann Funktion einer dritten (Text-)Spalte

Nach oben
       

Juchuu!!! Vielen Dank! Ist der Hammer, Funktioniert perfekt!!!
Vielen vielen Dank, das war mir echt eine riesen Hilfe...obwohl es für euch vielleicht totaler Kindergarten war!

Grüße

Gucci
Hübi
Es gibt immer bessere Lösungen, als meine.


Verfasst am:
19. Apr 2005, 16:19
Rufname: Hübi (selten Herbert)
Wohnort: Strausberg


AW: Wenn Dann Funktion einer dritten (Text-)Spalte - AW: Wenn Dann Funktion einer dritten (Text-)Spalte

Nach oben
       

Hi Gucci,

freut mich, wenn du dich freust und ich helfen konnte.
Wenn die Summe größer 24 Std. werden kann, musst du noch die Zellen mit Benutzerdefiniertem Format [hh]:mm formatieren.

_________________
Gruß Hübi
[Tipps getestet mit Win XP Prof. SP-2, Office 2000 Premium SP3 / Office 2003 Prof. SP3 / Office Professional 2007 SP1]
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Text einer Zelle aufteilen 2 Gast Chris 2786 28. Okt 2004, 12:32
Gast Chris Text einer Zelle aufteilen
Keine neuen Beiträge Excel Formeln: Formel als Text in Nachbarzelle kopieren 6 blauvogel 1129 19. Okt 2004, 16:54
blauvogel Formel als Text in Nachbarzelle kopieren
Keine neuen Beiträge Excel Formeln: WENN(ODER)-Funktion... 2 Karin K. 733 13. Okt 2004, 15:51
Arnim WENN(ODER)-Funktion...
Keine neuen Beiträge Excel Formeln: Dynamisches Erweitern einer Spalte mit Formel 11 Case 1011 11. Okt 2004, 08:43
Case Dynamisches Erweitern einer Spalte mit Formel
Keine neuen Beiträge Excel Formeln: höchsten Wert a. e. Spalte und passenden Namen 6 Gast 1637 20. Sep 2004, 23:03
Fm höchsten Wert a. e. Spalte und passenden Namen
Keine neuen Beiträge Excel Formeln: Funktion: Identische Inhalt einer Zelle in Tabelle 1 und 2 4 luki 4202 09. Sep 2004, 18:20
Gast Funktion: Identische Inhalt einer Zelle in Tabelle 1 und 2
Keine neuen Beiträge Excel Formeln: Formatierung einer anderen Zelle wenn in der einen ein Text 2 Gast 5007 01. Sep 2004, 11:04
Gast Formatierung einer anderen Zelle wenn in der einen ein Text
Keine neuen Beiträge Excel Formeln: Einfärben einer Spalte bei bestimmten Vorzeichen 3 itmeli 813 16. Aug 2004, 13:25
itmeli Einfärben einer Spalte bei bestimmten Vorzeichen
Keine neuen Beiträge Excel Formeln: mal wieder: letzte ausgefüllte Zelle in Spalte 4 Gast 3785 14. Aug 2004, 11:57
Gast mal wieder: letzte ausgefüllte Zelle in Spalte
Keine neuen Beiträge Excel Formeln: Wenn Funktion 1 SF 402 02. Aug 2004, 16:27
icke Wenn Funktion
Keine neuen Beiträge Excel Formeln: Extrahieren von Text bis zum ersten Semikolon einer Zelle 8 Gast 2949 13. Jul 2004, 18:59
Arnim Extrahieren von Text bis zum ersten Semikolon einer Zelle
Keine neuen Beiträge Excel Formeln: Zusammenhängende Zellen mit gleichem Text zählen 10 Red Hair 1522 09. Jul 2004, 15:22
Red Hair Zusammenhängende Zellen mit gleichem Text zählen
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Word VBA