Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Verknüpfung/ Verweis etc. funktioniert nicht mehr
zurück: Summe wenn wenn wenn Formel weiter: x gleiche exceldateien -> überall neue Registerkarte einf Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Feedback Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
KruemelII
Im Profil kannst Du frei den Rang ändern


Verfasst am:
14. Dez 2009, 11:45
Rufname:

Verknüpfung/ Verweis etc. funktioniert nicht mehr - Verknüpfung/ Verweis etc. funktioniert nicht mehr

Nach oben
       Version: Office 2003

Hallo Ihr da draußen,

bitte, bitte helft. Ich sitze an einer Tabelle, die zig Querverweise hat und ein anderer angelegt hat. Ich habe nur geringe Kenntnisse über Formeln und der, der die Liste erstellt hat, steht nicht mehr zur Verfügung. Eigentlich sollten alle Zellen funktioniern, aber komischerweise funktionieren die Formeln nicht immer - anscheinend willkürlich?! Vielleicht könnt ihr helfen.
Es handelt sich um Datumsangaben und Restzeitberechnung etc.
Ich versuche es mal zu erläutern:

Der Vertrag beginnt zum Datum X, wird im Turnus Y abgerechnet und ist somit zum Datum Z fällig.

Ich gebe Datum X und die Turnusvariante ein, worauf die korrekte Zahl Turnus Y angezeigt wird, aber bei Datum Z nun #ZAHL! steht.

WARUM????
Mal rechnet er es richtig aus, mal nicht. Ich verstehe das nicht. Und hinter die ganzen Formeln blicke ich sowieso nicht.

Habt Ihr einen Rat? Ich sende auch gerne die Formeln, wenn das hilft:
Datum Beginn wird manuell eingetragen (Spalte D)
Formel Monat (Beginn des Vertrages - Spalte H): =WENN(D251="";"";MONAT(D251))
Formel Turnus (jährlich/ vierteljährlich/ monatlich - Spalte I): =WENN(D251="";"";SVERWEIS(G251;Turnus;2))
Formel Fälligkeit (Spalte J): =WENN(D251="";"";WENN(REST(DATEDIF(D251;DATUM($G$4;$G$2;1);"m");I251)<>0;"";DATUM($G$4;$G$2;1)))

Wenn ich darf, werde ich auch noch ein Bild der Tabelle hochladen.



excel_tabelle.jpg
 Beschreibung:
 Dateigröße:  24.79 KB
 Angeschaut:  625 mal

excel_tabelle.jpg




Zuletzt bearbeitet von KruemelII am 14. Dez 2009, 16:59, insgesamt einmal bearbeitet
neopa
(kleingeschrieben!) oder Werner .. ,- ...


Verfasst am:
14. Dez 2009, 11:52
Rufname: Werner
Wohnort: zu Hause


AW: Verknüpfung/ Verweis etc. funktioniert nicht mehr - AW: Verknüpfung/ Verweis etc. funktioniert nicht mehr

Nach oben
       Version: Office 2003

Hallo,

ohne Daten wirklich nicht eindeutig. Ich vermute, dass zumindest ein Datumswert nicht als korrketer Datumswert eingegeben wurde. (Evtl. falsches Trennzeichen etc.)

_________________
Gruß Werner
.. , - ...
KruemelII
Im Profil kannst Du frei den Rang ändern


Verfasst am:
14. Dez 2009, 12:29
Rufname:

AW: Verknüpfung/ Verweis etc. funktioniert nicht mehr - AW: Verknüpfung/ Verweis etc. funktioniert nicht mehr

Nach oben
       Version: Office 2003

Daten? Welche Daten? Was wird benötigt? Ich kann die Tabelle leider nicht kopieren (und dann separat in einem neuen Dokument anlegen), da noch mehrere Datenblätter daran verknüpft sind und dann irgendwie alles schief geht.
neopa
(kleingeschrieben!) oder Werner .. ,- ...


Verfasst am:
14. Dez 2009, 16:35
Rufname: Werner
Wohnort: zu Hause

AW: Verknüpfung/ Verweis etc. funktioniert nicht mehr - AW: Verknüpfung/ Verweis etc. funktioniert nicht mehr

Nach oben
       Version: Office 2003

Hallo,

ich stell den Thread auf offen. Vielleicht kann Dir dadurch ja jemand anders weiterhelfen.

_________________
Gruß Werner
.. , - ...
KruemelII
Im Profil kannst Du frei den Rang ändern


Verfasst am:
14. Dez 2009, 17:02
Rufname:


AW: Verknüpfung/ Verweis etc. funktioniert nicht mehr - AW: Verknüpfung/ Verweis etc. funktioniert nicht mehr

Nach oben
       Version: Office 2003

Danke. Bild ist jetzt auch vorhanden.
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
14. Dez 2009, 20:16
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände

AW: Verknüpfung/ Verweis etc. funktioniert nicht mehr - AW: Verknüpfung/ Verweis etc. funktioniert nicht mehr

Nach oben
       Version: Office 2007

Hallo

Mal wieder ein künstlerisch sehr wertvolles Bild.
Aber zur Problemlösung trägt es nichts bei.

Anleitung zum Hochladen von Dateien.

Tabellen im Forum darstellen:
Excel-Jeanie
Tab2Html
Tabellendarstellung in Foren

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
KruemelII
Im Profil kannst Du frei den Rang ändern


Verfasst am:
15. Dez 2009, 12:48
Rufname:

AW: Verknüpfung/ Verweis etc. funktioniert nicht mehr - AW: Verknüpfung/ Verweis etc. funktioniert nicht mehr

Nach oben
       Version: Office 2003

Tja, tut mir leid. Aber da ja niemand auf die Frage "Was benötigt ihr?" antwortet, weiß ich eben nicht, was ich reinstellen soll. Mir die Verlinkung zur Upload-Seite zu senden, ist auch nicht hilfreich.
Und ich erwähnte auch schon einmal, dass ich die Tabelle nicht kopieren kann (zwecks Datenabänderung), weill sie mit mehreren Datenblättern verknüpft ist und ich dann nur Grütze herausbekomme.
urs
Zahlenschubser, Excel ohne VBA


Verfasst am:
15. Dez 2009, 15:12
Rufname:
Wohnort: Oldenburg i.O.

AW: Verknüpfung/ Verweis etc. funktioniert nicht mehr - AW: Verknüpfung/ Verweis etc. funktioniert nicht mehr

Nach oben
       Version: Office 2003

Hi,

hier einmal nachgebildet, was oben im Bild zu sehen ist:

 DGHIJ
1 Monat   
2 12   
3 Jahr   
4 2009   
5     
250Beginn MonatTurnusFälligkeit
25101.12.2009jährlich121201.12.2009
25201.12.2009vierteljährlich12301.12.2009
25301.12.2009monatlich12101.12.2009

ZelleFormel
H251=WENN(D251="";"";MONAT(D251))
I251=WENN(D251="";"";SVERWEIS(G251;{"jährlich".12;"monatlich".1;"vierteljährlich".3};2))
J251=WENN(D251="";"";WENN(REST(DATEDIF(D251;DATUM($G$4;$G$2;1);"m");I251)<>0;"";DATUM($G$4;$G$2;1)))
H252=WENN(D252="";"";MONAT(D252))
I252=WENN(D252="";"";SVERWEIS(G252;{"jährlich".12;"monatlich".1;"vierteljährlich".3};2))
J252=WENN(D252="";"";WENN(REST(DATEDIF(D252;DATUM($G$4;$G$2;1);"m");I252)<>0;"";DATUM($G$4;$G$2;1)))
H253=WENN(D253="";"";MONAT(D253))
I253=WENN(D253="";"";SVERWEIS(G253;{"jährlich".12;"monatlich".1;"vierteljährlich".3};2))
J253=WENN(D253="";"";WENN(REST(DATEDIF(D253;DATUM($G$4;$G$2;1);"m");I253)<>0;"";DATUM($G$4;$G$2;1)))

ZelleGültigkeitstypOperatorWert1Wert2
G251Liste jährlich;monatlich;vierteljährlich 
G252Liste jährlich;monatlich;vierteljährlich 
G253Liste jährlich;monatlich;vierteljährlich 


Ich vermute das Problem in den Zellen G2 und/oder G4, die innerhalb DATEDIF genutzt werden.
Code:
=DATEDIF(D251;DATUM($G$4;$G$2;1);"m")
Steht in G4 beispielsweise das Jahr 2008, liefert die Formel einen Fehlerwert. Offenbar soll dort (G2 und G4) die Periode ausgewählt werden, für die die Auswertung erfolgt. (Ob das so sein muss, will ich nicht beurteilen.) DATEDIF stellt hier die Differenz in Monaten zwischen einem Startdatum (G2 + G4) und dem Datum je Datensatz (Spalte D) dar. Es kommt zu einem Fehlerwert, wenn das Startdatum kleiner ist als das je Datensatz...
_________________
urs grüßt
Gast



Verfasst am:
15. Dez 2009, 16:03
Rufname:


AW: Verknüpfung/ Verweis etc. funktioniert nicht mehr - AW: Verknüpfung/ Verweis etc. funktioniert nicht mehr

Nach oben
       Version: Office 2003

Oooooh man, das könnte stimmen! Die Tabelle hat tatsächlich 2 solche Felder. Und der Monat ist mit "11" betitelt. Embarassed Ich probiere es gleich aus...

Hahaha, es funktioniert! Vielen, vielen, vielen Dank! Very Happy Das so ein winziger Fehler so einen Stress verursachen kann. (Und natürlich wieder menschliches Versagen!) Rolling Eyes
Darauf hätte ich auch selbst kommen können, wenn man die Augen mal aufmacht. ;)

Vielen Dank auf jeden Fall nochmal! *verbeug* Der Fehler passiert garantiert nicht noch einmal.

LG
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Problem mit Verknüpfung 2 Gast 683 24. Jun 2005, 10:56
Gast Problem mit Verknüpfung
Keine neuen Beiträge Excel Formeln: Wieso funktioniert "suchen und ersetzten" nur bedi 1 landau666 490 08. Apr 2005, 01:05
landau666 Wieso funktioniert "suchen und ersetzten" nur bedi
Keine neuen Beiträge Excel Formeln: Verweis ??? - Verwaltung einer Namensliste 4 Moni40 803 25. Feb 2005, 23:29
Moni40 Verweis ??? - Verwaltung einer Namensliste
Keine neuen Beiträge Excel Formeln: Formel mit Verweis und automatischer Anordung 4 fofo2000 1832 25. Jan 2005, 10:04
Arnim Formel mit Verweis und automatischer Anordung
Keine neuen Beiträge Excel Formeln: Kann man in Excel Symbole (z.B. aus Windings etc.) einsetzen 1 Exelinchen 1990 21. Jan 2005, 11:09
ae Kann man in Excel Symbole (z.B. aus Windings etc.) einsetzen
Keine neuen Beiträge Excel Formeln: Verknüpfung auf bestimme Spalte, den letzten Wert zurückgebe 4 Thiemo 1531 17. Jan 2005, 19:32
KARL Verknüpfung auf bestimme Spalte, den letzten Wert zurückgebe
Keine neuen Beiträge Excel Formeln: Verknüpfung Access Tabelle 1 DB_User 1788 17. Jan 2005, 11:54
ZeroCool Verknüpfung Access Tabelle
Keine neuen Beiträge Excel Formeln: Liste für Verleih erstellen - Verweis auf Kalenderwoche 2 Silbrunke 1924 02. Jan 2005, 22:00
Gast Liste für Verleih erstellen - Verweis auf Kalenderwoche
Keine neuen Beiträge Excel Formeln: Verknüpfung zweier Tabellen 20 Stitti 4540 19. Dez 2004, 20:13
Arnim Verknüpfung zweier Tabellen
Keine neuen Beiträge Excel Formeln: Verknüpfung von 2 Tabellen 3 Olli-Holzfaeller 2499 21. Nov 2004, 12:19
ae Verknüpfung von 2 Tabellen
Keine neuen Beiträge Excel Formeln: Abfrageliste erstellen - Verknüpfung auf zweites Blat 7 ExcelFan 904 12. Nov 2004, 17:56
ExcelFan Abfrageliste erstellen - Verknüpfung auf zweites Blat
Keine neuen Beiträge Excel Formeln: Verknüpfung mit einer anderen Datei 1 Isa 1090 10. Nov 2004, 20:10
Reinhard Verknüpfung mit einer anderen Datei
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Macromedia Dreamweaver