Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Laufzeitfehler 7951 bei verwendung von Me.RecordsetClone
zurück: Datensätze zählen weiter: datensatz speichern Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Gast



Verfasst am:
07. Apr 2005, 22:36
Rufname:

Laufzeitfehler 7951 bei verwendung von  Me.RecordsetClone - Laufzeitfehler 7951 bei verwendung von Me.RecordsetClone

Nach oben
       

Tach zusammen,

ich komme mal wieder nicht weiter.

Ich habe einen Mustercode, mit dem in einem Serienbrief Word aufgemacht wird und die Datenquelle dann dort schon vorhanden ist.

D.h. der Anwender muss die Datenquelle nicht mehr zuordnen.

Die kritische Stelle ist:
Code:
        strSQL = "SELECT * FROM qrySB"       
        Set myRS = CurrentDb.OpenRecordset(strSQL, dbOpenSnapshot)                 
        Me.RecordsetClone.MoveFirst
Hier wird der Teil:
Code:
    Me.RecordsetClone.MoveFirst

mit der Meldung:
Zitat:
Laufzeitfehler 7951

Sie haben einen Ausdruck eingegeben, der einen unzulässigen Verweis auf die Recordclone-Eigenschaft enthält.
"angemeckert".

Leider ist die Access-Hilfe keine Hilfe, weil erst garnichts angezeigt wird.

Hier ist noch der SQL-String: möglicherweise hilft er bei der Antwort.
Code:
SELECT TORG_KRZL AS Absender_Z1,
       IIf([BEARB_ANREDE] Is Not Null,
           [bearb_anrede] & " " & [bearb_name],[bearb_name]) AS Absender_Z2,
       "Telefon (02 21) 178-" & IIf([BEARB_TELEFON] Is Not Null,
           Left([bearb_telefon],2) & " " & Right([bearb_telefon],2)) AS Absender_Z3,
       "Telefax (02 21) 178-" & IIf([BEARB_TELEFAX] Is Not Null,
           Left([BEARB_TELEFAX],2) & " " & Right([BEARB_TELEFAX],2)) AS Absender_Z4,
       BEARB_EMAIL AS Absender_Z5, Format(Now(),("d. mmmm yyyy")) AS akt_Datum
FROM   BEARBEITER;

Schon mal vorab vielen Dank für eine Hilfe

Hoffnungsvolle Grüße von

Hippolytus
PietPan
Access-VBA-Programmierer u.a.


Verfasst am:
07. Apr 2005, 23:44
Rufname:
Wohnort: Bayern


AW: Laufzeitfehler 7951 bei verwendung von  Me.RecordsetClon - AW: Laufzeitfehler 7951 bei verwendung von Me.RecordsetClon

Nach oben
       

N' Abend, Hippolytus,

wie sehen die Verweise aus. Hatte das gleiche Problem, wenn ADO in der Priorität vor DOA gestellt war. Kannste 'mal schauen?

_________________
Bye bye Piet (der sich über 'n Feedback freut)
-----------------------------------------------------
Wenn jeder den Platz, an dem er sich befindet ein wenig verbessert, wäre die Erde ein Paradies.
Hippolytus
Im Profil kannst Du frei den Rang ändern


Verfasst am:
08. Apr 2005, 08:18
Rufname:
Wohnort: Troisdorf

AW: Laufzeitfehler 7951 bei verwendung von  Me.RecordsetClon - AW: Laufzeitfehler 7951 bei verwendung von Me.RecordsetClon

Nach oben
       

Hallo Piet,

habe meinen PC gestern entnervt abgeschaltet, deshalb antworte ich erst jetzt.

Ich weiß nicht, wie man ein Bild hier einfügen kann, deshalb hier meine meine Verweise in Textform:

Visual Basic For Applications
Microsoft Access 10.0 Object Library
Microsoft DAO 3.6 Object Library
Microsoft Word 10.0 Object Library
Microsoft Excel 10.0 Object Library
OLE Automation
Microsoft Visual Basic for Applications Extensibility 5.3

Gruß Hippolytus
Willi Wipp
Moderator


Verfasst am:
08. Apr 2005, 12:17
Rufname:
Wohnort: Raum Wiesbaden

Re: Laufzeitfehler 7951 bei verwendung von  Me.RecordsetClon - Re: Laufzeitfehler 7951 bei verwendung von Me.RecordsetClon

Nach oben
       

Hi Gast,

ich bin mir zwar nicht sicher, der Code-Ausschnitt ist vielleicht etwas kurz, aber koennte es daran liegen
Code:
        Me.RecordsetClone.MoveFirst
' ersetzen durch
        myRS.MoveFirst

_________________
Eine kurze Rueckmeldung waere nett
SL Willi Wipp

(Anleitung fuer das Anhaengen von Dateien: Klicke links auf [www], Gaeste muessen sich dafuer anmelden)
Hippolytus
Im Profil kannst Du frei den Rang ändern


Verfasst am:
08. Apr 2005, 17:18
Rufname:
Wohnort: Troisdorf


AW: Laufzeitfehler 7951 bei verwendung von  Me.RecordsetClon - AW: Laufzeitfehler 7951 bei verwendung von Me.RecordsetClon

Nach oben
       

Hallo Willi,

ich muss nochmal alles überdenken, habe nicht richtig realisiert, dass sich
Code:
    Me.RecordsetClone
auf das aktuelle Formular bezieht.
Sorry!!

Gruß Hippolytus
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Access Tabellen & Abfragen: Unzulässige Verwendung von NULL 3 NicoB 90 23. Sep 2013, 09:47
NicoB Unzulässige Verwendung von NULL
Keine neuen Beiträge Access Tabellen & Abfragen: Laufzeitfehler 3211 9 diimex 299 19. Jun 2013, 22:27
derArb Laufzeitfehler 3211
Keine neuen Beiträge Access Tabellen & Abfragen: Verwendung von null unzulässig =S 3 leo01 201 10. Feb 2012, 11:47
leo01 Verwendung von null unzulässig =S
Keine neuen Beiträge Access Tabellen & Abfragen: Laufzeitfehler 3071 7 Ramon2012 198 30. Jan 2012, 19:51
KlausMz Laufzeitfehler 3071
Keine neuen Beiträge Access Tabellen & Abfragen: "Verwendung von Null unzulässig" Inner Join 4 madosch 716 10. Jul 2011, 14:12
Gast "Verwendung von Null unzulässig" Inner Join
Keine neuen Beiträge Access Tabellen & Abfragen: Laufzeitfehler 3109, Datensatz nicht zu löschen 0 Mitch26 408 31. Okt 2008, 18:45
Mitch26 Laufzeitfehler 3109, Datensatz nicht zu löschen
Keine neuen Beiträge Access Tabellen & Abfragen: Verwendung von NULL an Abfragekriterium 2 robert_ 604 24. Sep 2008, 07:51
Robert_ Verwendung von NULL an Abfragekriterium
Keine neuen Beiträge Access Tabellen & Abfragen: Verwendung von Null unzulässig 12 guest 3072 10. Okt 2007, 07:51
jasmine Verwendung von Null unzulässig
Keine neuen Beiträge Access Formulare: Access 2003 Laufzeitfehler 438 Objekt wird nicht gefunden 1 Arno Lesmeister 1310 15. Mai 2007, 17:31
rita2008 Access 2003 Laufzeitfehler 438 Objekt wird nicht gefunden
Keine neuen Beiträge Access Formulare: Laufzeitfehler 2164 2 rabie 2035 09. Feb 2007, 09:16
rabie Laufzeitfehler 2164
Keine neuen Beiträge Access Tabellen & Abfragen: Laufzeitfehler 3001 1 luckypunch 592 23. Jan 2007, 12:19
JörgG Laufzeitfehler 3001
Keine neuen Beiträge Access Formulare: Problem mit Filterlänge (Laufzeitfehler 7769) 5 maila 1516 11. Sep 2006, 19:50
Nouba Problem mit Filterlänge (Laufzeitfehler 7769)
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: PHP Forum