Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Werte aus Hauptformular werden in Ufo nicht gespeichert
zurück: Haupt Unterformulare Pflichtfelder weiter: Access speichert Formulareigenschaften nicht Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Gast



Verfasst am:
13. Okt 2009, 16:04
Rufname:

Werte aus Hauptformular werden in Ufo nicht gespeichert - Werte aus Hauptformular werden in Ufo nicht gespeichert

Nach oben
       Version: Office 2007

Hi,

folgendes Problem: Habe ein Hauptformular (Kommentareingabe 2) mit Eingabemaske. Das Unterformular (Kommentare Budget Unterformular) ist das Hauptformular in Tabellenform und soll alle bisher eingegebenen Datensätze anzeigen.
Ich habe einen "Speichern Button" mit dem Code:
Code:
Private Sub Befehl19_Click()
On Error GoTo Err_Befehl19_Click
    DoCmd.DoMenuItem acFormBar, acRecordsMenu, acSaveRecord, , acMenuVer70
    Forms![Kommentareingabe 2].[Kommentare Budget Unterformular].Requery
Exit_Befehl19_Click:
    Exit Sub
Err_Befehl19_Click:
    MsgBox Err.Description
    Resume Exit_Befehl19_Click
End Sub
Dieser soll nach Eingabe der Daten in den gebundenen Textfeldern aus dem Hauptformular die Einräge in der Tabelle im Unterformular anzeigen.
Nur ist es so: Sobald ich in die Textfelder was eintrage wird das auch schön in der Tabelle angezeigt, sobald ich aber auf meinen Speichern Button klicke wird der eingegebene Datensatz nicht mehr angezeigt. Die Zellen sind lediglich leer.
Öffne ich aber meine Tabelle, die Grundlage für das Unterformular ist, so sind die Werte drin. Und zwar alle die ich angegeben habe.
Was mache ich falsch? Ich möchte also, dass nach Eingabe meiner Daten im Hauptformular und nach klick des Speichern Button, der Datensatz in der Tabelle im Unterformular angezeigt und gespeichert wird, so dass ich immer wieder neue Datensätze einfügen kann und meine Tabelle immer größer wird.

Ich hoffe Ihr könnt mir helfen,

vielen Dank schonmal!
MissPh!
Office-VBA-Programmiererin


Verfasst am:
13. Okt 2009, 17:02
Rufname:
Wohnort: NRW


AW: Werte aus Hauptformular werden in Ufo nicht gespeichert - AW: Werte aus Hauptformular werden in Ufo nicht gespeichert

Nach oben
       Version: Office 2007

Welche "Zellen" sind leer, im Haupt- oder im Unterformular?

Schreibe doch mal anstelle dieser unsäglichen Menübefehle einen richtigen Speicherbefehl wie
Code:
    DoCmd.RunCommand acCmdSaveRecord
und sprich das Unterformular korrekt an mit
Code:
    Forms![Kommentareingabe 2]![Kommentare Budget Unterformular].Form.Requery
und berichte, ob sich was geändert hat.
_________________
Gruß MissPh!
Gast



Verfasst am:
14. Okt 2009, 09:54
Rufname:

AW: Werte aus Hauptformular werden in Ufo nicht gespeichert - AW: Werte aus Hauptformular werden in Ufo nicht gespeichert

Nach oben
       Version: Office 2007

Hi,

also meine Prozedur beim Speichern Button habe ich jetzt so abgeändert:
Code:
Private Sub Befehl2_Click()
    DoCmd.RunCommand acCmdSaveRecord
    Forms![Kommentareingabe 2]![Kommentare Budget Unterformular].Form.Requery
End Sub
Leider hat sich nichts geändert, die Werte werden zwar gespeichert, aber nicht im Unterformular angezeigt, diese Zellen sind nach Klick der Speicher Buttons leer.
Die Tabelle im Unterformular besteht quasi aus einer Zeile in die ich die Wert eintragen und abspeichern kann. Es werden bei Hinzufügen von Datensätzen bei Klick auf den Speicherbutton keine neuen Zeilen mit den neuen Datensätzen angefügt.
Diese neuen Datensätzen sind nur in der Originaltabelle, auf die sich das Ufo bezieht zu sehen nach separatem Öffnen.

Woran kann das denn nur liegen?
MissPh!
Office-VBA-Programmiererin


Verfasst am:
14. Okt 2009, 13:17
Rufname:
Wohnort: NRW

AW: Werte aus Hauptformular werden in Ufo nicht gespeichert - AW: Werte aus Hauptformular werden in Ufo nicht gespeichert

Nach oben
       Version: Office 2007

Überprüfe mal die Einstellungen der Formulareigenschaften des Unterformulars auf der Registerkarte "Daten": Steht dort Daten eingeben=Ja?
_________________
Gruß MissPh!
Gast



Verfasst am:
14. Okt 2009, 13:20
Rufname:

AW: Werte aus Hauptformular werden in Ufo nicht gespeichert - AW: Werte aus Hauptformular werden in Ufo nicht gespeichert

Nach oben
       Version: Office 2007

Ja das habe ich schon überprüft, steht auf Ja
MissPh!
Office-VBA-Programmiererin


Verfasst am:
14. Okt 2009, 13:48
Rufname:
Wohnort: NRW


AW: Werte aus Hauptformular werden in Ufo nicht gespeichert - AW: Werte aus Hauptformular werden in Ufo nicht gespeichert

Nach oben
       Version: Office 2007

Dann lies bitte auch noch, was dazu in der Access-Hilfe steht: reinklicken und F1 drücken!
_________________
Gruß MissPh!
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Access Tabellen & Abfragen: Aktuelle Summe der Werte einer Spalte 14 simsy 3001 15. März 2006, 16:56
simsy Aktuelle Summe der Werte einer Spalte
Keine neuen Beiträge Access Tabellen & Abfragen: Abfrage auf die Werte des Vorquartals beschränken 0 Reinhart B 604 09. März 2006, 11:39
Reinhart B Abfrage auf die Werte des Vorquartals beschränken
Keine neuen Beiträge Access Tabellen & Abfragen: SQL-Anweisung erhöht alle 4 Werte anstatt einem 2 Access-bastler 595 08. Feb 2006, 14:52
Access-bastler SQL-Anweisung erhöht alle 4 Werte anstatt einem
Keine neuen Beiträge Access Tabellen & Abfragen: Kreuztabellenabfrage Werte 2 Zoran 3025 22. Dez 2005, 18:27
Willi Wipp Kreuztabellenabfrage Werte
Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten. Access Tabellen & Abfragen: Werte summieren und mit x multiplizieren 3 heirnele 1187 20. Dez 2005, 19:32
Willi Wipp Werte summieren und mit x multiplizieren
Keine neuen Beiträge Access Tabellen & Abfragen: Werte übernehmen 2 ninamaria 566 31. Okt 2005, 21:24
stpimi Werte übernehmen
Keine neuen Beiträge Access Tabellen & Abfragen: Werte von Feld1 in Feld2 kopieren 2 cixz 896 30. Sep 2005, 11:50
Gast Werte von Feld1 in Feld2 kopieren
Keine neuen Beiträge Access Tabellen & Abfragen: Max. Werte über mehrere Datensätze ermitteln 1 Gast 1200 22. Aug 2005, 14:56
lothi Max. Werte über mehrere Datensätze ermitteln
Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten. Access Tabellen & Abfragen: Access Werte innerhalb einer Tabelle berechnen 1 Elmar9700 1684 21. Jun 2005, 16:26
Willi Wipp Access Werte innerhalb einer Tabelle berechnen
Keine neuen Beiträge Access Tabellen & Abfragen: Werte Zählen, aber bestimmte nicht dazu addieren 1 MrMarley 897 14. Jun 2005, 02:21
tobes Werte Zählen, aber bestimmte nicht dazu addieren
Keine neuen Beiträge Access Tabellen & Abfragen: Datensätze in 2 Tabellen vergleichen und Werte korrigieren 1 Keine Ahnung 1079 17. Mai 2005, 10:24
Gast Datensätze in 2 Tabellen vergleichen und Werte korrigieren
Keine neuen Beiträge Access Tabellen & Abfragen: Gleich bleibende Werte 2 adiag 565 12. Mai 2005, 20:00
adiag Gleich bleibende Werte
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Dreamweaver Forum