Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Navigate Methode des Webbrowser-Objektes funktioniert nicht
zurück: hilfe: tabelle in formular importieren ?! weiter: Ersten Wert des Listenfeldes nutzen Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Bitte Status wählen ! Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
oceanhawk
Access Einsteiger


Verfasst am:
23. März 2005, 16:54
Rufname:
Wohnort: Hannover

Navigate Methode des Webbrowser-Objektes funktioniert nicht - Navigate Methode des Webbrowser-Objektes funktioniert nicht

Nach oben
       

Hallo,
ich habe ein Formular mit einem 'Microsoft Webbrowser' OLE-Objekt (Klasse: Shell.Explorer.2 , Verb 0) mit der Bezeichnung 'browser'.
Wenn ich die Library SHDocVw einbinde, sollte mir doch die Navigate-Methode des Webbrowser-Objektes zur Verfügung stehen.
Aus für mich unerfindlichen Gründen ist diese Methode im CodeCompletion-Fenster nicht vorhanden. Meine Version ist Access 2003.
faßnacht(IT);
www.Office-Loesung.de Administrator


Verfasst am:
09. Apr 2005, 10:03
Rufname: Peter

AW: Navigate Methode des Webbrowser-Objektes funktioniert ni - AW: Navigate Methode des Webbrowser-Objektes funktioniert ni

Nach oben
       

Hi Ocean Smile
ich habe das mal recherchiert:
Der Datentyp ist SHDocVw.WebBrowser. Also ist die Variablendeklartaion
Code:
    Dim wbDeinBrowser As SHDocVw.WebBrowser
'oder
    Dim WithEvents wbDeinBrowser As SHDocVw.WebBrowser

Der Aufruf geht dann so:
Code:
    wbDeinBrowser.Navigate "http://www.Office-Loesung.de"
Alles ohne Gewähr, da ich es im Moment nicht ausprobieren kann.
_________________
na, hilft das weiter?
ciao Smile
Peter Faßnacht
oceanhawk
Access Einsteiger


Verfasst am:
10. Apr 2005, 12:59
Rufname:
Wohnort: Hannover


AW: Navigate Methode des Webbrowser-Objektes funktioniert ni - AW: Navigate Methode des Webbrowser-Objektes funktioniert ni

Nach oben
       

vielen Dank für Deine Recherche!
Wenn zunächst in der Programmierung ein Webbrowser-Objekt deklariert wird, wenn dann dieses deklarierte Webbrowser-Objekt mit dem 'sichtbaren' Browser-Objekt aus dem Formular instantiiert wird (set ..), so wird die Navigate-Methode im Code-Completion Fenster angezeigt. Tatsächlich funktioniert die Navigate-Methode auch mit einem nicht deklarierten Browserobjekt. Dann muß man '.Navigate' allerdings selber hintippen, wie ich gerade beim erneuten Probieren herausfand.

Danke für Deine Hilfe
Gruß
Oceanhawk
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Access Tabellen & Abfragen: Abfrage Sortierung funktioniert nicht richtig 14 Hans Helfer 376 29. Okt 2008, 20:25
Hans Helfer Abfrage Sortierung funktioniert nicht richtig
Keine neuen Beiträge Access Tabellen & Abfragen: Abfrage aus 2 Tabellen funktioniert nicht 0 niesel81 295 22. Okt 2008, 14:12
niesel81 Abfrage aus 2 Tabellen funktioniert nicht
Keine neuen Beiträge Access Tabellen & Abfragen: SQL Befehl funktioniert nicht -> DELETE 1 eiskalterengel 2304 02. Okt 2008, 12:40
Willi Wipp SQL Befehl funktioniert nicht -> DELETE
Keine neuen Beiträge Access Tabellen & Abfragen: Username unter AC 2003 auslesen - Environ funktioniert nicht 12 andreczogalla 3210 03. Sep 2008, 14:29
andreczogalla Username unter AC 2003 auslesen - Environ funktioniert nicht
Keine neuen Beiträge Access Tabellen & Abfragen: Löschweitergabe funktioniert nicht 4 Poke888 888 29. Mai 2008, 10:09
KlausMz Löschweitergabe funktioniert nicht
Keine neuen Beiträge Access Tabellen & Abfragen: Abfrage mit mehreren Kriterien funktioniert in Form nicht 14 StockMaster 782 06. Mai 2008, 13:24
Gast Abfrage mit mehreren Kriterien funktioniert in Form nicht
Keine neuen Beiträge Access Tabellen & Abfragen: Fehler in Update: Fehler beim Kompilieren -> Methode n. g 1 Mindjogger 590 14. März 2008, 17:51
Mindjogger Fehler in Update: Fehler beim Kompilieren -> Methode n. g
Keine neuen Beiträge Access Tabellen & Abfragen: Bound Column funktioniert nicht 6 Smmmile 1201 12. Jul 2007, 17:56
Smmmile Bound Column funktioniert nicht
Keine neuen Beiträge Access Tabellen & Abfragen: Warum funktioniert diese Abfrage nicht ? 6 Mirage 805 05. Jun 2007, 12:14
Mirage Warum funktioniert diese Abfrage nicht ?
Keine neuen Beiträge Access Tabellen & Abfragen: Aktualisierungsabfrage funktioniert nicht 7 BAD TOUCH 3024 30. Mai 2007, 13:13
Gast Aktualisierungsabfrage funktioniert nicht
Keine neuen Beiträge Access Tabellen & Abfragen: Wie kann ich 2 Abfragen in einer Methode ausführen! 8 Nega 584 19. Apr 2007, 09:13
Nega Wie kann ich 2 Abfragen in einer Methode ausführen!
Keine neuen Beiträge Access Tabellen & Abfragen: Abfrage funktioniert nicht...hilfe!!!!! 2 bennie103 604 22. März 2007, 21:14
Gast Abfrage funktioniert nicht...hilfe!!!!!
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: Frontpage Forum