Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Tabelle auswerten
zurück: Textstring wie kürzen?? weiter: Formel mit Zaehlenwenns und als Kriterium "kleiner-glei Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
Officestern
Im Profil kannst Du frei den Rang ändern


Verfasst am:
18. Aug 2009, 08:44
Rufname:

Tabelle auswerten - Tabelle auswerten

Nach oben
       Version: Office 2007

Hallo ich habe eine Tabelle, mit Namen in Spalte A und Namen in Spalte B
Die Liste soll sortiert werden und alle Namenkombinationen die nur einmal vorkommen ausgeblendet werden.

Hier ein Beispielbild:



Bisher habe ich dieses Problem mit diversen Nebenspalten gelöst, klappt recht gut ist aber auch sehr umständlich.

Beispiel für die bisherige Lösung:
Nebenspalte D
Code:
=WENN(A2=A3;1;0)

Nebenspalte E
Code:
=WENN(B2=B3;1;0)

Nebenspalte F
Code:
=D2+E2

Nebenspalte G
Code:
=WENN(B2=B1;1;0)

Nebenspalte H
Code:
=G2+H2

Nebenspalte I
Code:
=WENN(F2=2;"BEKANNT";WENN(I2=2;"BEKANNT";""))


Über eine Lösung würde ich mich freuen

Danke willi

Wenn erwünscht kann ich die Tabelle auch hochladen
urs
Zahlenschubser, Excel ohne VBA


Verfasst am:
18. Aug 2009, 10:04
Rufname:
Wohnort: Oldenburg i.O.

AW: Tabelle auswerten - AW: Tabelle auswerten

Nach oben
       Version: Office 2007

Hallo Willi,

passt Deine "bisherige Lösung" zu dem "Beispielbild"?

Wie wäre es mit einer Zählung?
Code:
{=SUMME(((A2&"#"&B2)=($A$2:$A$9&"#"&$B$2:$B$9))+((B2&"#"&A2)=($A$2:$A$9&"#"&$B$2:$B$9)))}

bzw. falls Leerzeilen vorsorglich unberücksichtigt bleiben sollen:
Code:
{=SUMME((($A$2:$A$20&"#"&$B$2:$B$20)<>"")*((A2&"#"&B2)=($A$2:$A$20&"#"&$B$2:$B$20))+((B2&"#"&A2)=($A$2:$A$20&"#"&$B$2:$B$20)))}

Matrixformel - {} nicht eingeben, Formel mit Strg+Shift+Enter abschließen

Danach kann z. B. mit Autofilter ausgeblendet werden, was weniger als zweimalig vorhanden ist...

_________________
urs grüßt
urs
Zahlenschubser, Excel ohne VBA


Verfasst am:
18. Aug 2009, 11:26
Rufname:
Wohnort: Oldenburg i.O.


AW: Tabelle auswerten - AW: Tabelle auswerten

Nach oben
       Version: Office 2007

Hallo Willi,

auch nach Deiner PN habe ich noch nicht vollständig begriffen.

Wichtig ist zunächst, dass Deine Datenbank 10.000 Datensätze enthält. Das drückt auf die Performance, weshalb manch Lösungsvorschlag (auch meine Matrixformel von oben) nicht wirklich geeignet ist. - Dennoch wird die Berechnung ein kleines Weilchen brauchen.

Ich bleibe bei meiner Grundidee von oben: Verkette die zwei Vereinsnamen in Hilfsspalte R mit
Code:
=D3&E3
sowie in Hilfsspalte S mit
Code:
=E3&D3
und zähle die Anzahl mit
Code:
=ZÄHLENWENN(R$3:R$10002;R3)+ZÄHLENWENN(S$3:S$10002;R3)

Diese Zählung bleibt nach Anwendung des Autofilters und einer Sortierung erhalten, so dass Du damit anstellen kannst, was auch immer damit nötig ist...

_________________
urs grüßt
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Eine Tabelle umdrehen 4 Aloha 1274 04. Apr 2005, 10:50
Aloha Eine Tabelle umdrehen
Keine neuen Beiträge Excel Formeln: Frontpage soll per link in eine excel tabelle verweisen 3 Darkspawn 1636 04. März 2005, 16:46
Hübi Frontpage soll per link in eine excel tabelle verweisen
Keine neuen Beiträge Excel Formeln: Übernahme eines Wertes in andere Tabelle 6 batigoal 859 18. Feb 2005, 13:02
bati Übernahme eines Wertes in andere Tabelle
Keine neuen Beiträge Excel Formeln: Werte aus Projekttabelle 1 automatisch in Tabelle 2 + 3 ? 7 DerDoktor 3771 15. Jan 2005, 14:41
DerDoktor Werte aus Projekttabelle 1 automatisch in Tabelle 2 + 3 ?
Keine neuen Beiträge Excel Formeln: Excel Tabelle Formel? 2 herberte 1948 31. Dez 2004, 00:57
Arnim Excel Tabelle Formel?
Keine neuen Beiträge Excel Formeln: Wert aus einer anderen Tabelle holen 2 =KB=Shorty 4867 17. Nov 2004, 21:22
=KB=Shorty Wert aus einer anderen Tabelle holen
Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten. Excel Formeln: Anzahl bei 2 Bedingungen aus Tabelle berechnen 1 Satanico 2570 20. Okt 2004, 13:31
steve1da Anzahl bei 2 Bedingungen aus Tabelle berechnen
Keine neuen Beiträge Excel Formeln: Daten/Tabelle tabellenübergreifend 0 markus.wilke 6170 15. Okt 2004, 16:45
markus.wilke Daten/Tabelle tabellenübergreifend
Keine neuen Beiträge Excel Formeln: Datenübernahme aus Tabelle 7 lut155 21997 05. Aug 2004, 15:12
Gast Datenübernahme aus Tabelle
Keine neuen Beiträge Excel Formeln: Unterschiedliche Anzahl einer Spalte auswerten 2 Sinai 928 29. Jul 2004, 18:13
Sinai Unterschiedliche Anzahl einer Spalte auswerten
Keine neuen Beiträge Excel Formeln: Tabelle einer Internetseite auslesen 1 Andy_beginner 1931 14. Jul 2004, 23:19
Manfred Bartak Tabelle einer Internetseite auslesen
Keine neuen Beiträge Excel Formeln: Tabelle Tippgemeinschaft 2 Hallenhandball 2259 30. Jun 2004, 15:37
BRU222 Tabelle Tippgemeinschaft
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: JavaScript