Office Forum
www.Office-Loesung.de
Access :: Excel :: Outlook :: PowerPoint :: Word :: Office :: Wieder Online ---> provisorisches Office Forum <-
Wenn Dann Wenn Dann Wenn Dann mit Datum ?!
zurück: wenn/dann/sonst weiter: Dropdown-Feld, dass ein anderes Dropdownfeld beeinflußt Unbeantwortete Beiträge anzeigen
Neues Thema eröffnen   Neue Antwort erstellen     Status: Antwort Facebook-Likes Diese Seite Freunden empfehlen
Zu Browser-Favoriten hinzufügen
Autor Nachricht
OhMyGod
Hilfesuchender


Verfasst am:
17. Aug 2009, 12:49
Rufname:
Wohnort: Potsdam

Wenn Dann Wenn Dann Wenn Dann mit Datum ?! - Wenn Dann Wenn Dann Wenn Dann mit Datum ?!

Nach oben
       Version: Office 2003

Hi, also ich habe eine Zelle in die folgende Daten geschrieben werden:
31.03.2008
30.06.2008
30.09.2008
31.12.2008

Nun hab ich eine andere Zelle, in der je nach Datum das Quartal automatisch stehen soll.
Beispiel: Zelle 1 = 31.03.2008
dann soll Zelle 2 = 1. Quartal sein.

=WENN(A4="31.03.2009";"1. Quartal";)
habe ich jetzt zum test versucht. Das funktioniert leider nicht. wenn ich statt 31.03.2009 zum Beispiel "test" eingebe funktioniert die formel damit.

Ausserdem brauch ich dann noch eine 2. Zelle die mir nur das Jahr hinten rausnimmt.
Im Endeffekt soll es dann so aussehen:
Bsp.1:
A1 31.03.2008
A2 1. Quartal
A3 2008

Bsp.2:
A1 30.06.2009
A2 2. Quartal
A3 2009

hoffe ich hab halbwegs verständlich erklärt was ich hier versuche. =/
Wenns so nicht funktioniert wäre ich auch bereit das irgendwie in einem Makro zu verpacken. Aber so wäre es mir lieber.

Hoffe auf schnelle Hilfe.

Vielen Dank =)
P.ter
Im Profil kannst Du frei den Rang ändern


Verfasst am:
17. Aug 2009, 12:53
Rufname:
Wohnort: Ortenau


AW: Wenn Dann Wenn Dann Wenn Dann mit Datum ?! - AW: Wenn Dann Wenn Dann Wenn Dann mit Datum ?!

Nach oben
       Version: Office 2003

Hallo,

suchst du sowas?

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABC
131.03.20081. Quartal2008
230.06.20082. Quartal2008
330.09.20083. Quartal2008
431.12.20084. Quartal2008

ZelleFormel
B1=AUFRUNDEN(MONAT(A1)/3;0)&". Quartal"
C1=JAHR(A1)


wobei man in der Spalte B auch mit einem benutzerdefinierten Format arbeiten könnte so das man auf den Zusatz &". Quartal" verzichten kann.

Als Alternative wenn in A1 auch Text steht könnte man das so abwandeln:

=WENN(ISTZAHL(A1);AUFRUNDEN(MONAT(A5)/3;0)&". Quartal";"")

_________________
Adee
P.ter
Gast



Verfasst am:
17. Aug 2009, 14:06
Rufname:

AW: Wenn Dann Wenn Dann Wenn Dann mit Datum ?! - AW: Wenn Dann Wenn Dann Wenn Dann mit Datum ?!

Nach oben
       Version: Office 2003

JA !
Funktioniert bestens
Super Very Happy

vielen vielen dank, auch für die schnelle Antwort ^^
Ist so eine deutlich bessere Lösung als das was ich versucht hatte Smile
shift-del
{Irrtum / Versuch * Glaskugel}


Verfasst am:
17. Aug 2009, 21:24
Rufname: Detlef
Wohnort: Ehemaliges Fabrikgelände


AW: Wenn Dann Wenn Dann Wenn Dann mit Datum ?! - AW: Wenn Dann Wenn Dann Wenn Dann mit Datum ?!

Nach oben
       Version: Office 2003

Hallo

Die Excelperten von excelformeln.de schlagen das vor:
Code:
=MONAT(MONAT(A1)&0)&". Quartal"


Mein Erklärungsversuch dazu:
http://clever-forum.de/read.php?11,188614,188695#msg-188695

_________________
Wir sehen uns!
... shift-del
Eine Mustertabelle hilft beim Helfen.
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Neues Thema eröffnen   Neue Antwort erstellen Alle Zeiten sind
GMT + 1 Stunde

Diese Seite Freunden empfehlen

Seite 1 von 1
Gehe zu:  
Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen

Verwandte Themen
Forum / Themen   Antworten   Autor   Aufrufe   Letzter Beitrag 
Keine neuen Beiträge Excel Formeln: Datum - Datum 2 bettyfcu 1049 13. Mai 2005, 10:32
fridgenep Datum - Datum
Keine neuen Beiträge Excel Formeln: restzeit bis zu einem bestimmten Datum 2 Jericho2000 1749 07. Apr 2005, 11:50
Jericho2000 restzeit bis zu einem bestimmten Datum
Keine neuen Beiträge Excel Formeln: Bei einer Wenn-Funktion mit Datum arbeiten!? 5 Neo[der Auserwählte] 2150 31. März 2005, 13:51
fl618 Bei einer Wenn-Funktion mit Datum arbeiten!?
Keine neuen Beiträge Excel Formeln: Datum in Excel Tabelle in Tagen darstellen 2 Unregistered 5101 22. März 2005, 20:49
Gast Datum in Excel Tabelle in Tagen darstellen
Keine neuen Beiträge Excel Formeln: Wenn Datum fast erreicht, Feld Rot 9 JörgK. 2957 21. März 2005, 16:29
JörgK. Wenn Datum fast erreicht, Feld Rot
Keine neuen Beiträge Excel Formeln: Datum in Zelle aktualisieren 2 Gast 1436 07. März 2005, 00:43
ae Datum in Zelle aktualisieren
Keine neuen Beiträge Excel Formeln: Datum rot anzeigen 2 Mimoss 2046 15. Feb 2005, 23:07
AnBo Datum rot anzeigen
Keine neuen Beiträge Excel Formeln: Wenn gleiches Datum... 6 Gekko 2258 06. Feb 2005, 14:07
Gast Wenn gleiches Datum...
Keine neuen Beiträge Excel Formeln: Datum aus mehreren Zellen zusammensetzen. 9 gast2005 5086 25. Dez 2004, 22:33
Kuwe Datum aus mehreren Zellen zusammensetzen.
Keine neuen Beiträge Excel Formeln: Vertragssumme ausr. bez. auf Datum heute und Datum Zukunft 7 Tristan68 1841 25. Nov 2004, 19:48
Arnim Vertragssumme ausr. bez. auf Datum heute und Datum Zukunft
Keine neuen Beiträge Excel Formeln: Datum automatisch berechnen 8 fisler0815 3392 21. Okt 2004, 14:41
icke Datum automatisch berechnen
Keine neuen Beiträge Excel Formeln: Datum 1 Peter3 2568 16. Okt 2004, 21:51
ae Datum
 

----> Diese Seite Freunden empfehlen <------ Impressum - Besuchen Sie auch: HTML CSS